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Introduction

th is Adobe InDesign, and what can it do for you? In its more than a
decade in existence, InDesign has become the most powerful publish-

ing application, one that lets you work the way you want to work. You can
use InDesign as a free-form but manual approach to layout, or as a structured
but easily revised approach. The fact that you can choose which way to
work is important for both novice and experienced users because there is no
single, correct way to lay out pages. Sometimes (for example, if your project
is a one-time publication, such as an ad), creating a layout from scratch —
almost as if you were doing it by hand on paper — is the best approach. And
sometimes using a highly formatted template that you can modify as needed
is the way to go: You don’t need to reinvent the wheel for documents that
have a structured and repeatable format, such as books and magazines.

InDesign can handle sophisticated tasks, such as glossy magazines and
high-impact ads, but its structured approach to publishing also makes it a
good choice for newspapers, newsletters, and books. InDesign is also a good
choice for corporate publishing tasks, such as proposals and annual reports.
In all cases, you can design for printing on paper or electronic distribution as
Adobe Acrobat Portable Document Format (PDF) files. Plug-in software from
other vendors adds extra capabilities.

Plus, you can use InDesign as the starting point for Web and Flash docu-
ments. These electronic documents can include interactive features, such as
page transitions, hyperlinks, and buttons to play sounds or a movie.

About This Book

After you get the hang of it, InDesign is quite easy to use. At the same time,
it’s a powerful publishing program with a strong following among the ranks
of professional publishers — and the latest InDesign CS4 version is certain to
reinforce that position. Part of its success is due to the fact that its interface
is like that of its sister applications, Adobe Illustrator and Adobe Photoshop,
which are also components of the Adobe Creative Suite.

If you're just getting started with InDesign, welcome! I hope you’ll find the
information in these pages to be helpful in getting you started.
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Conventions Used in This Book

<EATURE

This book covers InDesign on both Macintosh and Windows. Because the
application is almost identical on both platforms, I point out platform-
specific information only when it’s different — and that’s very rare. I've used
Macintosh screen shots throughout; Windows screen shots are usually iden-
tical, except for the dialog boxes to open, save, and export files — these are
arranged differently on Macs and PCs (for all programs, not just InDesign),
but the relevant options to InDesign are the same. If you're a Windows user,
a quick look at Adobe’s documentation, which shows Windows screens, can
show you how the interfaces are nearly identical. So don’t worry about them.

Here are some other conventions used in this book:

1 Menu commands: They're listed like this: Window=>Pages. That means
go to the Window menu and choose the Pages option from it. In almost
every case, the menu command sequences are the same for Mac and
Windows users; in a very few cases, they differ (such as the Preferences
menu option and the Configure Plug-ins menu option), so I note these
differences where they exist by putting the Mac menu sequence first and
then the Windows one.

InDesign CS4 has an annoying new feature of hiding menu options
from you. The goal is to be less intimidating, but it also means that if
you don’t know what InDesign can do, you won’t find out by looking
at the menus. Fortunately, you can tell InDesign to show you all the
menus all the time so that no features are hidden. Here’s how: Choose
Window=>Workspacer>Show Full Menus. This book assumes you’'ve
turned the menus all on.

1 Key combinations: If you’re supposed to press several keys together, |
indicate that by placing a plus sign (+) between them. Thus, Shift+3+A
means press and hold the Shift and 8 keys and then press A. After
you've pressed the A key, let go of all the keys. I also use the plus sign to
join keys to mouse movements. For example, Alt+drag means to hold the
Alt key when dragging the mouse.

Note that the Macintosh sequence comes first, followed by the Windows
equivalent.

v Pointer: The small graphic icon that moves on the screen as you move
your mouse is a pointer (also called a cursor). The pointer takes on dif-
ferent shapes depending on the tool you select, the current location of
the mouse, and the function you are performing.

v Click: This means to quickly press and release the mouse button once.
Many Mac mice have only one button, but some have two or more. All
PC mice have at least two buttons. If you have a multibutton mouse,
click the leftmost button when I say to click the mouse.
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v Double-click: This tells you to quickly press and release the mouse
button twice. On some multibutton mice, one of the buttons can func-
tion as a double-click. (You click it once, but the computer acts as if you
clicked twice.) If your mouse has this feature, use it; it saves strain on
your hand.

v Right-click: A feature first implemented on Windows, but present on
Macs since the late 1990s, this means to click the right-hand mouse
button. If your Mac has only one button, hold the Control key when
clicking the mouse button to do the equivalent of right-clicking in pro-
grams that support it. Mac OS X automatically assigns the right-hand
button on a multibutton mouse to the Control+click combination; if your
mouse came with its own System Preference, you can often further cus-
tomize the button actions.

v Dragging: Dragging is used for moving and sizing items in an InDesign
document. To drag an item, position the mouse pointer on the item,
press and hold down the mouse button, and then slide the mouse across
a flat surface.

What Vou're Not to Read

Q\Q’N' S To&

If you see any text in this book that has this icon next to it, feel free to skip
right over to the next paragraph. This icon alerts you to geeky information
that you don’t need to know to use InDesign. I just couldn’t help giving you a
little extra-credit information in case you were a budding geek like me.

Foolish Assumptions

Although this book has information that any level of layout artist or produc-
tion editor needs to know to use InDesign, this book is primarily for those of
you who are fairly new to the field, or who are just becoming familiar with the
program. | try to take the mystery out of InDesign and give you guidance on
how to create a bunch of different types of documents.

[ don’t assume that you've ever used InDesign (or any publishing program). But [
do assume that you have a basic knowledge of Macintosh or Windows — enough
to work with files and applications. And I assume that you have basic familiarity
with layout design, such as knowing what pages, margins, and fonts are. But [
don’t expect you to be an expert in any of these areas — nor do you have to be!

3
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How This Book Is Organized

This book contains eight parts. I also include some bonus content on the
InDesignCentral Web site (www.InDesignCentral .com).

Part I: Before You Begin

Designing a document is a combination of science and art. The science is in
setting up the structure of the page: How many places will hold text, and how
many will hold graphics? How wide will the margins be? Where will the page
numbers appear? You get the idea. The art is in coming up with creative ways
of filling the structure to please your eyes and the eyes of the people who will
be looking at your document.

In this part, I tell you how to navigate your way around InDesign using the
program’s menus, dialog boxes, panels, and panes. I also explain how to cus-
tomize the preferences to your needs.

Part II: Document Essentials

Good publishing technique is about more than just getting the words down
on paper. It’s also about opening, saving, adding, deleting, numbering, and
setting layout guidelines for documents. This part shows you how to do all
that and a lot more, including tips on setting up master pages that you can
use over and over again. You also find out how to create color swatches for
easy reuse in your documents.

Part I1I: Object Essentials

This part of the book shows you how to work with objects: the lines, text
frames, graphics frames, and other odds and ends that make up a publica-
tion. You also discover how to apply some really neat special effects to them.

Part 1U: Text Essentials

When you think about it, text is a big deal when it comes to publishing docu-
ments. After all, how many people would want to read a book with nothing
but pictures? In this part, [ show you how to create and manipulate text, in
more ways than you can even imagine.
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Part U: Graphics Essentials

Very few people would want to read a book with nothing but text, so this part
is where [ show you how to handle graphics in InDesign — both importing
them from the outside and creating your own within InDesign.

Part Vl: Getting Down to Business

InDesign is really good at handling the many kinds of documents that tend
to be used in businesses, such as manuals, annual reports, and catalogs.
This part shows you how to create tables, handle footnotes, create indexes,
manage page numbering across multiple chapters in a book, and use text
variables to make InDesign update text as needed based on the document’s
current context.

Part VII: Printing and
Multimedia Essentials

Whether you’re printing a publication or simply creating a PDF file for read-
ers to download from a Web site, you still need to understand the basics of
outputting an InDesign document. This part is where I show you how to set up
your output files, manage color, and work with service bureaus. You also find
out about creating multimedia documents — those with movies, sound, hyper-
links, and buttons — for distribution as PDF files, Flash files, and Web pages.

Part VIII: The Part of Tens

This part of the book is like the chips in the chocolate chip cookies; you can
eat the cookies without them, but you’d be missing a really good part. It’s a
part that shows you some important resources that can help you make the
most of InDesign.

Icons Used in This Book

So that you can pick out parts that you really need to pay attention to (or,

(AU depending on your taste, to avoid), [ use some symbols, or icons, in this book.
)

& When you see this icon, it means I am pointing out a feature that’s new to

InDesign CS4.
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If you see this icon, it means that 'm mentioning some really nifty point or
idea that you may want to keep in mind as you use the program.

This icon lets you know something you'’ll want to keep in mind. If you forget it
later, that’s fine, but if you remember it, it will make your InDesign life a little
easier.

If you skip all the other icons, pay attention to this one. Why? Because ignor-
ing it can cause something really, really bad or embarrassing to happen, like
when you were sitting in your second-grade classroom waiting for the teacher
to call on you to answer a question, and you noticed that you still had your
pajama shirt on. [ don’t want that to happen to you!

This icon tells you that I am about to pontificate on some remote technical bit
of information that may help explain a feature in InDesign. The technical info
will definitely make you sound impressive if you memorize it and recite it to
your friends.

Where to Go from Here

If you're a complete beginner, [ suggest you read the book’s parts in the
order I present them. If you haven’t used InDesign before but you have used
other layout programs, do read Part I first to get in the InDesign frame of
mind and then explore other parts in any order you want. If you have used
InDesign before, peruse them in any order you want, to see what’s changed.

As you gain comfort with InDesign, you’ll be surprised how much you can
do with it. And when you're ready to discover more, take advantage of the
wealth of resources out there to go the next level. The InDesignCentral Web
site (www. InDesignCentral.com) can help you do that.
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Before You Begin

The 5th Wave By Rich Tennant

A mm—
“Tt says, ‘Seth — Please see us about your idea
to wrap newsletter text around company logo.
Signed, the Production Department.”




In this part . . .

ou have your copy of InDesign, and you’d like some

basic information on how to get started, right? Well,
you’ve come to the right place. This part helps you sail
smoothly through InDesign and gives you a general idea of
what InDesign can do. I explain the layout approaches you
can take, as well as how to set up InDesign to work the
way you work.

Along the way, you find out how to navigate the plethora
of panels, menus, tools, and shortcuts that can seem over-
whelming at first, but which soon become second nature
as you gain experience using the program. Welcome
aboard!




Chapter 1

Understanding InDesign
Ingredients

In This Chapter
Getting acquainted with the InDesign approach
Figuring out global versus local control
Getting up to speed on the InDesign vocabulary
Exploring the document window
Surveying the top tools
Becoming familiar with tools and panels

Discovering what’s in the menus

Starting to use a new software application is not unlike meeting a new
friend for the first time. You take a long look at the person, maybe ask a
few questions, and begin the process of becoming acquainted. (If you're not
new to InDesign but are new to the CS4 version, it’s like seeing a friend you
haven’t seen in a while — you observe any changes and catch up on what’s
happened in the meantime.)

Just as it’s worthwhile to find out the likes and dislikes of a new friend, it’s
also worth your time to wrap your head around InDesign’s unique style
and approaches. When you do so, you'll find it much easier to start using
InDesign to get work done.

This chapter explains where to look in InDesign for the features and capabili-
ties you need to master. (For a quick look at what’s new to version CS4, check
out Chapter 25.) I introduce you to the process that InDesign assumes you
use when laying out documents, explain some of the terms you’ll encounter
throughout the book, describe the unique interface elements in the document
window, survey the most commonly used tools, and explain how InDesign
packages much of its functionality through an interface element called a panel.
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InDesign CS4 has an annoying new feature of hiding menu options from you.
The goal is to be less intimidating, but it also means if you don’t know what
InDesign can do, you won'’t find out by looking at the menus. Fortunately, you
can tell InDesign to show you all the menus all the time, so no features are
hidden. Here’s how: Choose Window=>Workspacer>Show Full Menus. This
book assumes that you’'ve turned the menus all on.

Understanding Global and Local Control

The power of desktop publishing in general, and InDesign in particular, is
that it lets you automate time-consuming layout and typesetting tasks while
at the same time letting you customize each step of the process according to
your needs.

What does that mean in practice? That you can use global controls to estab-
lish general settings for layout elements, and then use local controls to
modify those elements to meet specific requirements. The key to using global
and local tools effectively is to know when each is appropriate.

Global tools include

v General preferences and application preferences (see Chapter 2)

1 Master pages and libraries (see Chapter 5)

v Character and paragraph styles (see Chapter 13)

v Table and cell styles (see Chapter 19)

v Object styles (see Chapter 9)

» Sections and page numbers (see Chapter 4)

v Color definitions (see Chapter 6)

v Hyphenation and justification (see Chapter 14)
Styles and master pages are the two main global settings that you can expect
to override locally throughout a document. You shouldn’t be surprised to
make such changes often because although the layout and typographic
functions that styles and master pages automate are the fundamental com-

ponents of any document’s look, they don’t always work for all the specific
content within a publication. (If they did, who’d need human designers?!)

Local tools include

v Frame tools (see Part I, as well as Chapter 16)
v Character and paragraph tools (see Chapters 14 and 15)
v Graphics tools (see Part V)
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Keep your bearings straight

A powerful but confusing capability in InDesign
is something called a control point. InDesign
lets you work with objects from nine different
reference points — any of the four corners, the
middle of any of the four sides, or the center —
such as when positioning the object precisely
or rotating the object. You choose the active
reference point, or control point, in the Control
panel or Transform panel, using the grid of nine
points arranged in a square.

By default, InDesign uses the central reference
point as the control point, which is great for
rotating an object, but can lead to confusion

when you enter in the X and Y coordinates to
place it precisely. That's because most people
use the upper-left corner of an object when
specifying its coordinates, not the center of
the object. Be sure to change the control point
to the upper-left reference point whenever
entering X and Y coordinates in the Control or
Transform panels.

How do you change the control point? That's
easy: Just click the desired reference point
in that preview grid. The control point will be
black, whereas the other reference points will
be white.

Choosing the right tools for the job

Depending on what you're trying to do with InDesign at any given moment,

you may or may not immediately know which tool to use. If, for example, you

maintain fairly precise layout standards throughout a document, using master
pages is the way to keep your work in order. Using styles is the best solution if
you want to apply standard character and paragraph formatting throughout a

document. When you work with one-of-a-kind documents, on the other hand,

designing master pages and styles doesn’t make much sense — it’s easier just

to format elements as you create them.

For example, you can create drop caps (large initial letters set into a paragraph
of type, such as the drop cap that starts each chapter in this book) as a charac-
ter option in the Character panel, or you can create a paragraph style (format-
ting that you can apply to whole paragraphs, ensuring that the same formatting

is applied each time) that contains the drop-cap settings and then apply that
style to the paragraph containing the drop cap. Which method you choose
depends on the complexity of your document and how often you need to

perform the action. The more often you find yourself taking a set of steps, the
more often you should use a global tool (like character and paragraph styles)

to accomplish the task.

Fortunately, you don’t need to choose between global and local tools while
you're in the middle of designing a document. You can always create styles
from existing local formatting later. You can also add elements to a master
page if you start to notice that you need them to appear on every page.

11
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Specifying measurement values

Another situation in which you can choose between local or global controls is
specifying measurement values. Regardless of the default measurement unit you
set (that is, the measurement unit that appears in all dialog boxes and panels),
you can use any unit when entering measurements in an InDesign dialog box. For
example, if the default measurement is picas, but you're new to publishing and are
more comfortable working in inches, go ahead and enter measurements in inches.

InDesign accepts any of the following codes for measurement units. (Chapter
2 explains how to change the default measurements.) Note that the x in the
following items indicates where you specify the value, such as 2i for 2 inches.
It doesn’t matter whether you put a space between the value and the code:
Typing 2inch and typing 2 inch are the same as far as InDesign is concerned:

v xi or x inch or x" (for inches)

v xp (for picas)

v xpt or Opx (for points)

v xc (for ciceros, a European newspaper measurement

v xag (for agates, an American newspaper measurement)

v xcm (for centimeters)

v xmm (for millimeters)
You can enter fractional picas in two ways: in decimal format (as in 8.5p) and in

picas and points (as in 8p6). Either of these settings results in a measurement of
8% picas. (A pica contains12 points.)

What to do when you make a mistake

InDesign is a very forgiving program. If you
make a mistake, change your mind, or work
yourself into a complete mess, you don't have
to remain in your predicament or save your
work. InDesign offers several escape routes.
You can

order in which they were done by repeat-
edly choosing Edit=>Undo (38+Z or Ctrl+Z);
each time you undo, the previous action is
undone.

+* Redo an action you've undone by choosing
Edit->Redo (Shift+88+Z or Ctrl+Shift+Z).

v Undo your last action by choosing Alternatively, choosing Undo and Redo is a

Edit=>Undo (88+Z or Ctrl+Z). (You can't
undo some actions, particularly actions
such as scrolling that dont affect any items
or the underlying document structure.) You
can undo multiple actions in the reverse

handy way of seeing a before/after view of
a particular change. As with undo, you can
redo multiple undone actions in the reverse
of the order in which they were undone.
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Mastering Basic InDesign Vocabulary

All industries have their jargon to describe unique approaches, tools, attri-
butes, and specifications. Publishing is no different. Its vocabulary includes
pica, kRerning, crop, and color model. But because programs like InDesign
bring a once-specialized capability to the masses, the terms are sometimes
used incorrectly. Sometimes, they're replaced with general terms to make
nonprofessional users feel less threatened, but that substitution ends up
confusing professional printers, people who work in service bureaus, and
Internet service providers. Throughout this book, I define other publishing
terms as they come up.

In addition to using publishing-industry vocabulary, InDesign comes with its
own specific terminology, much of it adopted from other Adobe products.
Terms to know include the following:

v Frame: The container for an object. A frame can hold text, a graphic, or
a color fill.

v Link: The connection to a graphics or text file that you import, or place,
into an InDesign document. The link contains the file’s location and its
last modification date and time. A link can reference any graphics or text
file that you’'ve imported into a layout. InDesign can notify you when a
source text or graphics file has changed so that you can choose whether
to update the version in your layout.

1 Package: The collection of all files needed to deliver a layout for printing.

v PDF: The Adobe Portable Document Format, which has become the
standard for sharing electronic documents. No matter what kind of
computer it’s viewed on (Windows, Macintosh, Palm, or Unix), a PDF
document displays the original document’s typography, graphics repre-
sentation, and layout. With InDesign, you can place PDF files as if they
were graphics, and you can also export its InDesign pages to PDF format.

v Plug-in: A piece of software that loads into, and becomes part of,
InDesign to add capabilities to the program.

v Stroke: The outline of an object (whether a graphic, line, or individual
text characters) or frame.

v Thread: The connections between text frames that let a story flow from
one frame to another.
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Discovering the Document Window

|
Figure 1-1:
The
document
window is
where you
work on
documents.
|

In InDesign, you spend lots of time working in document windows — the
“containers” for your documents. Each document, regardless of its size, is
contained within its own document window.

The best way to get familiar with the InDesign document window is by
opening a blank document. Simply choosing File>Newr>Document (38+N or
Ctrl+N) and clicking OK opens a new document window. Don’t worry about
the settings for now — just explore.

Figure 1-1 shows all the standard elements of a new document window. I
won’t bore you by covering interface elements that are standard to all pro-
grams. Instead, the rest of this section focuses on InDesign-specific elements.
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The Version Cue pop-up menu lets you see the current status of a document
in a shared workgroup setup. You can ignore this expert feature. The new
Preflight pop-up menu helps deal with any issues that can affect printing, as
Chapter 23 explains. And the new Search menu lets you look for files on your
computer and in Adobe Bridge.

Rulers

Document windows display a horizontal ruler across the top and a vertical
ruler down the left side. As shown in Figure 1-1, the horizontal ruler measures
from the top-left corner of the page across the entire spread, and the vertical
ruler measures from the top to the bottom of the current page. These rulers
are handy for judging the size and placement of objects on a page. Even expe-
rienced designers often use the rulers while they experiment with a design.

Both rulers display increments in picas unless you change the measurement
system for each ruler in the Units & Increments pane of the Preferences
dialog box. Choose InDesign=>Preferences=>Units & Increments (88+K) or
Edite>Preferences=Units & Increments (Ctrl+K) to open the Preferences
dialog box. Your choices include inches, picas, points, decimal inches, cice-
ros, agates, millimeters, and centimeters.

If you change the ruler measurement system when no documents are open,
the rulers in all new documents will use the measurement system you
selected. If a document is open when you make the change, the rulers are
changed only in that document.

You can also create your own measurement system by choosing Custom.
Most people should ignore this option, but sometimes it can make sense, such
as setting the ruler to match the line spacing, so that you can measure number
of lines in your ruler.

If your computer has a small monitor and the rulers start to get in your way,
you can hide them by choosing ViewroHide Rulers (88+R or Ctrl+R).

Zero point

The point where the rulers intersect in the upper-left corner of the page is
called the zero point. (Some people call it the ruler origin.) The zero point is
the starting place for all horizontal and vertical measurements.

If you need to place items in relation to another spot on the page (for exam-
ple, from the center of a spread rather than from the left-hand page), you can
move the zero point by clicking and dragging it to a new location. Notice that

15
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the X: and Y: values in the Control panel update as you drag the zero point so
that you can place it precisely.

If you change the zero point, it changes for all pages or spreads in the docu-
ment. You can reset the zero point to the upper-left corner of the left-most
page by double-clicking the intersection of the rulers in the upper-left corner.

If you move the zero point, all the objects on the page display new X: and Y:

values even though they haven’t actually moved. Objects above or to the left
of the zero point will show negative X: and Y: values, and the X: and Y: values
of other objects will not relate to their actual position on the page or spread.

You can lock the zero point, making it more difficult to accidentally change it.
Control+click or right-click the ruler origin and choose Lock Zero Point from
the menu that appears. (The Unlock Zero Point command is right there as
well, so you can just as easily unlock it.) Locking the zero point is a good idea
because it will remind anyone working on your document that you prefer that
they not fiddle with the zero point.

Pasteboard

The white area that surrounds the page is called the pasteboard. It’s a work-
space for temporarily storing objects. The pasteboard above and below each
page or spread is an inch deep. The pasteboard at both left and right of a
page or spread is just as wide as the page. For example, a spread composed
of two 8-inch-wide pages has 8 inches of pasteboard to the left and 8 inches
of pasteboard to the right, plus 1 inch of pasteboard above and 1 inch below.

You can make the height of the pasteboard above and below pages something
other than the default of 1 inch. To do so, open the Guides & Pasteboard

pane of the Preferences dialog box and choose a new value for the Minimum
Vertical Offset field. (Choose InDesign=>Preferences=>Guides & Pasteboard
[88+K] or Edit=>Preferences~>Guides & Pasteboard [Ctrl+K] to open the
Preferences dialog box.)

Application frame and bar

InDesign CS4 introduces the application frame. Windows users will already
know what an application frame is, though it never had a name: All the elements
of InDesign — its panels, document windows, and so on — were confined into

a window with a gray background. By contrast, on a Mac, all these elements
floated freely, so folders, icons and other applications could be visible “under-
neath” InDesign’s elements — and that confused some users.



Chapter 1: Understanding InDesign Ingredients

<NTUR,
N

g,

With the application frame, Mac users can now put all the InDesign ele-
ments in their own container so that they dont float freely and other appli-
cations don’t peek through. You show the application frame by choosing
Window=>Application Frame — doing so makes InDesign for Mac behave
like InDesign for Windows. (By default, the application frame is turned off in
InDesign for Mac.)

Conversely, Windows users can choose Windowr>Application Frame to hide
the application frame so that InDesign for Windows looks like InDesign for
Mac. (By default, the application frame is turned on in InDesign for Windows.)

The Application Frame menu command is a foggle, hiding the application
frame if it’s visible and showing it if it’s hidden. You see a check mark next to
the menu option if the application frame is visible. (InDesign uses the same
toggling indicator in other menus.)

Above the Control panel is the new application bar, which offers easy access
to other Adobe applications, such as Bridge, and access to controls over vari-
ous view options. It appears by default if the application frame is enabled.
When the application frame is hidden, you can show or hide the application
bar by choosing Window=>Application Bar.

The application bar has several handy elements. From left to right:

v The first element is the set of quick-access buttons to Bridge and other
Adobe software.

v The second element is the Zoom Level field and pop-up menu, which
replaces the Zoom pop-up menu that used to be at the bottom of the
document window.

v The third element is the View Options pop-up menu, which lets you
hide and show frames boundaries, hidden characters, grids, and other
such visual aids from one handy location. These options previously
existed but only in a variety of scattered menu options (where they also
remain).

v The fourth element, the Screen Mode pop-up menu, duplicates the
Screen Mode feature at the bottom of the Tools panel (see Chapter 2).

v The fifth element, the new Arrange Documents pop-up menu, gives you
fast access to InDesign CS4’s new controls over how document windows
are arranged (covered later in this chapter).

v The sixth element, the Workspaces pop-up menu, gives you quick access
to the workspaces you've defined (as described in the “Working with
Panels, Docks, and Workspaces” section, later in this chapter).

v~ At the far right is the Search menu, which you can use to find files on
your computer or via the Adobe Bridge program.

17
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Pages and guides

Pages, which you can see on-screen surrounded by black outlines, reflect the
page size you set up in the New Document dialog box (Files>Newr>Document

[88+N or Ctrl+N]). If in your document window it looks like two or more pages
are touching, you're looking at a spread.

InDesign uses nonprinting guides, lines that show you the position of margins
and that help you position objects on the page. Margins are the spaces at the
outside of the page, whereas columns are vertical spaces where text is supposed
to go by default. Magenta lines across the top and bottom of each page show the
document’s top and bottom margins. Violet lines show left and right columns
(for single-page documents) or inside and outside columns (for spreads).

InDesign CS4 introduces a new set of guides, called smart guides, covered in
Chapter 10.

You can change the location of margin and column guides by choosing
Layout=>Margins and Columns. You can create additional guides — such as to
help you visually align objects — by holding down your mouse button on the
horizontal or vertical ruler and then dragging a guide into the position you want.

Page controls

If you feel like flipping through pages of the document you’re creating, InDesign
makes it easy with page-turning buttons and the Page field and pop-up menu.
Controls for entering prefixes for the page numbers of sections, and for indicat-
ing absolute page numbers in a document that contains multiple sections, are
also handy. (An absolute page number indicates a page’s position in the docu-
ment, such as +1 for the first page, +2 for the second page, and so on.)

At the bottom left of the document windows is a combined Page page-number
field and pop-up menu encased by two sets of arrows. These arrows are page-
turning buttons that take you to, from left to right, the first page, the previous
page, the next page, and the last page. Just click an arrow to get where you
want to go.

You can also jump directly to a specific document page or master page in
several ways:

v~ Highlight the current number in the page number field (by selecting it
with your cursor), enter a new page number or master-page name, and
press Return or Enter.

v Use the Go to Page dialog box (88+] or Ctrl+J), enter a new page number
or a master-page name, and press Return or Enter.

v Choose the desired page from the Page pop-up menu.
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» You can also use the Pages panel to navigate your document, as Chapter
4 explains.

Opening Multiple Document Windows

If you like to work on more than one project at once, you’'ve come to the right
program. InDesign lets you open several documents at once. It also lets you
open multiple windows simultaneously for individual documents. A large
monitor (or having multiple monitors connected) makes this multiwindow
feature even more useful. By opening multiple windows, you can

v Display two (or more) different pages or spreads at once. You still have
to work on the documents one at a time, but no navigation is required —
you have only to click within the appropriate window.

v Display multiple magnifications of the same page. For example, you
can work on a detail at high magnification in one window and display the
entire page — and see the results of your detail work — at actual size in
another window.

v Display a master page in one window and a document page based
on that master page in another window. When you change the master
page, the change is reflected in the window in which the associated
document page is displayed.

ATURe .

Document windows are now by default accessed through a set of tabs below
the Control panel, rather than as a series of cascaded windows as in previous
versions of InDesign.

When multiple windows are open, you activate a window by clicking on a win-
dow’s title tab or anywhere within its window. Also, the names of all open docu-
ments are displayed at the bottom of the Window menu. Choosing a document
name from the Window menu brings that document to the front. If multiple
windows are open for a particular document, each window is displayed (they're
displayed in the order in which you created them) in the Window menu.

To show multiple windows on-screen at once, choose
Windowr>Arranger>Tile. When you choose the Tile command, all open win-
dows are resized and displayed side by side. Or use one of the new window-
layout options in the new Arrange Documents pop-up menu’s options (in
the application bar). How they display will depend on the option you chose.
Either way, note that when you resize any individual document window, the
others will be resized accordingly so that they don’t overlap.

To put all these tiled windows back into their regular tabs so that
only one document window is visible on-screen at a time, choose
Window=Arrange=>Consolidate All Windows or choose the Consolidate All
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Windows option (single-window icon) in the Arrange Documents pop-up
menu in the application bar.

If you don'’t like the tabbed approach to windows and instead want to

use the old-style approach of stacked windows, you can. Just choose
Window=>Arranger>Float All in Windows. You can then move the indi-
vidual windows around the screen as desired; if they get too messy, choose
Windows=Arranger>Cascade to tell InDesign to make them all neat and
tidy in a cascaded stack. If you want to go back to tabbed windows, choose
Window=>Arrange=>Consolidate All Windows.

To close all windows for the currently displayed document, press Shift+38+W
or Ctrl+Shift+W. To close all windows for all open documents, press
Option+Shift+8+W or Ctrl+Alt+Shift+W.

Not only do you get separate document windows for each open document,
you can also create multiple windows for an individual document so that you
can see different parts of it at the same time. To open a new window for the
active document, choose Window=>Arrange=>New Window (or use the New
Window option in the new Arrange Documents pop-up menu in the applica-
tion bar). The new window is displayed in its own tab or window, depending
on whether you’ve enabled Open Documents as Tabs in the Interface pane

of the Preferences dialog box (InDesign=>Preferences=Interface [38+K] or
Edit>PreferencesrvInterface [Ctrl+K]).

You can tell that a document window shows a different view of an existing
document by looking at the name of the document in the window’s title.

At the end of the document name will be a colon () followed by a number.
Newsletter.indd:1 would be the document’s first window, Newsletter.indd:2
would be its second window, and so on.

Tooling around the Tools Panel
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You can move the InDesign Tools panel — the control center for 32 of
InDesign’s 33 tools, as well as for 13 additional functions — by clicking and
dragging it into position. The Tools panel usually appears to the left of a
document (see Figure 1-2).

The one tool not directly accessible from the Tools panel is the Marker tool.
But you can switch to it from the Eyedropper tool by holding Option or Alt.
(Chapter 6 explains its use.)

To discover each tool’s “official” name, hover the mouse pointer over a tool

for a few seconds, and a Tool Tip will appear, telling you the name of that tool.

If the Tool Tips don’t display, make sure that the Tool Tips pop-up menu is set

to Normal or Fast in the Interface pane of the Preferences dialog box (choose
InDesigne>Preferences~Interface [+K] or Edit=>Preferences=Interface [Ctrl+K]).
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Figure 1-2:
The
InDesign
Tools panel
(left) and

its pop-

out tools
(center). To
see pop-
out tools,
Control+
click or
right-click
any tool that
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triangle
appear-

ing in its
lower-right
corner
(right).
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InDesign gives you one — and only one — tool for each specific job. The
Tools panel includes tools for creating and manipulating the objects that
make up your designs. The tools in the Tools panel are similar to those in
other Adobe products (such as Photoshop, Illustrator, and Dreamweaver). |
cover what each tool does in the following sections.

The small arrow in the lower-right corner of some tools is a pop-out menu
indicator. A tool that displays this arrow is hiding one or more similar tools.
To access these “hidden” tools, click and hold a tool that has the pop-out
menu indicator, as shown in Figure 1-2. When the pop-out displays, click one
of the new tools.

You can now also Control+click or right-click a tool to see the “hidden” tools.

You don’t need to worry about all the tools, so I highlight just those that
you’ll need to know to start using InDesign. You'll likely come across the
others as you work on specific tasks, so I cover those in the chapters that
introduce those functions.
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Using the Selection tools

To work with objects, you have to select them. InDesign provides three tools
to do that, letting you select different aspects of objects.

Selection tool

The Selection tool is perhaps the most-used tool in InDesign. With the
Selection tool, you can select objects on the page and move or resize them.
You may want to think of this tool as the Mover tool because it’s the only tool
that lets you drag objects around on-screen.

After you've selected the Selection tool, here’s how it works:

v To select any object on a document page, click it. If you can’t seem to
select it, the object might be placed by a master page (a preformatted
page used to format pages automatically), or the object might be behind
another object.

+* To select an object placed by a master page, press Shift+8 or Ctrl+Shift
while you click.

1+ To select an object that is completely behind another object, 8 +click it
or Ctrl+click it.

Direct Selection tool

The Direct Selection tool is what you use to work on the contents of a frame,
not the frame itself. For example, you can use the Direct Selection tool to
select individual handles on objects to reshape them or to move graphics
within their frames.

Here’s how the Direct Selection tool works:

1 To select an object to reshape it, click the object to display anchor
points on the edges (the anchor points are hollow handles that you can
select individually, as shown in Figure 1-3). You can drag the anchor
points to reshape the object.

1+ To select objects placed by a master page, Shift+88+click or
Ctrl+Shift+click, as with the Selection tool. The Direct Selection tool lets
you easily select objects behind other objects and select items within
groups.

+* To move a graphic within its frame, click inside the frame and drag the
graphic.

+” To move a frame but leave the graphic in place, click an edge of the
frame and drag it.
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Figure 1-3:
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Position tool

Meant to mimic PageMaker’s Crop tool to help former PageMaker users
adjust to InDesign, the Position tool, which you access from the pop-out
menu in the Direct Selection tool, combines some aspects of the Selection
tool with some aspects of the Direct Selection tool:

1 As with the Selection tool, you can resize an object’s frame by dragging
its handles.

v As with the Direct Selection tool, you can click a graphic and reposition
it within the frame by dragging — and that has the effect of cropping the
graphic.

Using the Type tool

A very frequently used tool, the Type tool lets you enter, edit, and format
text. The Type tool also lets you create rectangular text frames.

Here’s how the Type tool works:

v To create a rectangular text frame, click and drag; hold the Shift key to
create a perfect square.

+* To begin typing or editing text, click in a text frame or in any empty
frame and type away.

I explain stories and threaded text frames in Chapter 11.
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Using the object-creation tools

InDesign has a bunch of tools for creating shapes. Part V covers them in
more depth, but you should know about a few of them now because they
create objects that can contain either text or graphics. Plus, you can also use
them to draw your own shapes that you then color or otherwise embellish in
your layout. Here’s what you need to know:

v Pen tool: With the Pen tool, you can create simple illustrations. You

use the Pen tool, which is modeled after the pen tools in Illustrator and
Photoshop, to create paths (both open, such as lines, and closed, such
as shapes) consisting of straight and curved segments. Give it a try —
it’s fun! (Chapter 7 explains how to use the tool.)

v Type tool: The Type tool lets you draw rectangular text frames, as well

as type text inside them.

v Line tool: The Line tool lets you draw freestanding lines (paths) on your

page. After selecting this tool, simply click and drag the mouse to draw
the line. Holding the Shift key while you click and drag constrains the
line angle to 45-degree increments, which is useful for creating straight
horizontal and vertical lines.

v Frame and shape tools: InDesign has three frame tools (Rectangle

Frame, Ellipse Frame, and Polygon Frame) and three shape tools
(Rectangle, Ellipse, and Polygon). The frame and shape tools are redun-
dant because both frames and shapes can hold text or graphics or be
empty.

Because the frame and shape tools really do the same thing, you might
use the frame tool when creating frames that will have their content
added later. Why? Because the frames appear with a big X through them,
making them easier to spot when looking for frames to fill. The shape
tools create frames without that X, so it’s easier to overlook them.

To create a rectangle or ellipse, choose the appropriate tool, click
somewhere in the document window, and drag the mouse to another
location. The rectangle or ellipse fills the area. But creating a polygon
works differently, as Chapter 7 explains.

Using the navigation tools

Several tools, described in the following list, help you navigate your docu-
ment so that you can move around your pages, move your pages around the
screen, and change the degree of magnification to see just part of a page or to
see several pages at once.
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+ Hand tool: The Hand tool lets you move a page around to view differ-

ent portions of it or another page entirely. After selecting the Hand tool,
click and drag in any direction. You can access the Hand tool temporar-
ily without actually switching tools by pressing Option+spacebar or
Alt+spacebar.

For a quick way to pan through your document, make sure that the
Hand tool is active. Then click and hold the mouse. InDesign will zoom
out and display a red rectangle. If you move the mouse, InDesign CS4
stops zooming and instead lets you move the rectangle to a new area of
focus. Let go to have InDesign display that part of the document back
at the original zoom setting. (This new zoom-and-pan navigator option
replaces previous versions’ Navigator panel and its features.) If the
autozoom is too fast, you can use the up and down arrow keys instead
to manually move through various zoom levels. And if you decide you've
navigated some place you didn’t mean to, just press Esc — as long as
the mouse is still pressed — to start over.

v Zoom tool: With the Zoom tool, you increase and decrease the docu-

ment view scale. You can highlight a specific area on a page to change
its view, or you can click on-screen to change the view scale within
InDesign’s preset increments, which is the same as pressing 3 += or
Ctrl+= to zoom in.

v View buttons: At the very bottom of the Tools panel is the Preview

Mode button. Its pop-out menu has four preview options: Bleed mode,
Slug mode, Preview mode, and Normal mode. Bleed mode shows any
objects that bleed (extend) beyond the page boundaries, whereas Slug
mode shows the space reserved for information such as crop marks and
color separation names used in final output. Preview mode shows you
the layout as if it were printed (no guides, bounding boxes, and so on.)
Normal mode shows you any interface elements in use, such as guides,
hidden characters, and story threads. You can read more about these in
Chapter 3. You set these options when you create new documents or by
choosing Filec>Document Setup.

If your Tools panel displays in two columns, you get two buttons at

the bottom of the panel: Normal Mode and Preview Mode. In that case,
Preview Mode has a pop-out menu that has the Preview, Bleed, and Slug
options. To toggle between single-column and two-column views of the
Tools panel, click the collapse icon (>> or <<, depending on how many
columns are displayed) at the top of the panel.
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Using contextual menus

InDesign’s contextual menu interface element options for modifying whatever it is you clicked.
is very useful. By Control+clicking or right- InDesign provides a lot of options this way, and
clicking the document, an object, elements using the contextual menusto access InDesign
listed in a panel (such as a list of files or styles), functions is often easier than hunting through
the rulers, and so on, you can display a menu of  the many regular menu options and panels.

Working with Panels, Docks,
and Workspaces

InDesign has so many controls and features that its designers have long ago
stopped relying on menu commands to access them all. Instead, most of
InDesign’s features are presented as sort of miniature dialog boxes, called
panels, that are “windows” of readily accessible options to consider when
working in InDesign.

Working with panels

Panels provide an interactive method of working with features, one that lets
you access the controls quickly. In many cases, panels offer the only method
for performing many tasks. Figure 1-1, earlier in this chapter, shows the panels
that appear on-screen by default. Note that you can access all panels — except
Quick Apply and Tabs — via the Window menu, whether or not the panel is
displayed on-screen at the moment.

Panels typically have three — but sometimes four — controls:

v~ All panels but the Attributes, Kuler, Pathfinder, Script Label, Story, and
Tools panels have a flyout menu, which provides a pop-up menu of con-
trols relevant to that panel.

v Any active panel — meaning it’s displayed in front of any others in its
panel group so that you can actually modify its settings — has a close
control to remove the panel from the panel group. This control isn’t a
way to switch to another panel in that panel group — to do that, just
click the tab of the panel you want to work with. (If you remove a panel
by mistake, go to the Window menu to open it again.)
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Figure 1-4:
An example
of a panel
collapsed
(left) and
expanded
(right).
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v Any active panel has a collapse control (the >> icon). For panels in the
dock, clicking that icon collapses it back into the dock. For panels not in
the dock (that is, for floating panels), collapsing them shrinks the panel
to a much smaller size to get them out of the way. When collapsed, these
panels will have a << icon to expand them again. (The Tools panel is an
exception: clicking the >> icon changes it to a two-column layout, while
clicking the << icon changes it to a one-column layout.)

v Some panels have an expand/collapse control. Click the control to show
more or fewer options. (If all options are displayed, clicking the control
will shorten the panel and hide some of the advanced options; if only
the basic options are displayed, clicking the control lengthens the panel
and shows all the options.) Figure 1-4 shows examples of collapsed and
expanded panels.
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InDesign CS4 adds several new panels: Conditional Text (see Chapter 21),
Connections (a quick way to go to Adobe’s online resources), Kuler (see
Chapter 6), and Preflight (see Chapter 23). The Buttons panel replaces the
old States panel (see Chapter 24). Gone are the Command Bar and Navigator
panels.

To better suit your working style, you can drag panels by their tabs to move
them from one panel group to another, drag them out of a dock so that
they’re free-floating, or drag them into a dock so that they’re no longer free-
floating. The dock feature lets you keep panel groups in one contained area,
which helps keep the interface from getting too cluttered. But you're not
forced to work this way: You can still drag panels outside the main dock so
that they’re free-floating on-screen.

Not all panels display in the main dock; less-used panels, such as Data Merge,
show up in a free-floating panel group when you open them via the Window
menu. Of course, you can always add such panels to the main dock if you use
them a lot.
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All but three panels have a tab, which contains its name, to help you select
the desired panel without having to go to the Window menu. The three special
panels (without tabs) are the Tools, Control, and Quick Apply panels. Unlike
the rest of InDesign’s panels, they can’t be grouped with other panels, so you
don’t need a tab to select them. Also, note that the Quick Apply panel is the
only one not available via the Window menu; instead, use the lightning-bolt
icon to open it from the Control panel and several other panels; you can also
choose Edit=>Quick Apply (88+Return or Ctrl+Enter).

To quickly select a panel, just click its tab from its open panel group. When a
panel is active, its controls have the following characteristics:

v To display and select an option, click a pop-up menu or an iconic
button; the changes take effect immediately.

v To place a new value in a field, highlight the value that’s already in
the field and enter the new value. Note that fields accept values in all
supported measurement systems, as described in the “Specifying mea-
surement values” section, earlier in this chapter. To implement the new
value, press Shift+Return or Shift+Enter. To get out of a field you've
modified, leaving the object unchanged, press Esc.

v+ To increase or decrease the value in the field, use the clickable up and
down arrows where available.

+* To use math to perform changes, enter calculations in the field. You can
add, subtract, multiply, and divide values in fields by using the following
operators: +, —, * (multiply), and / (divide). For example, to reduce the
width of a frame by half, type /2 after the current value in the Width field.
Or, to increase the length of a line by 6 points, you can type +6 next to the
current value in the Length field. You can also use percentages in fields,
such as 50%, which adjusts the current value by that percentage.

As with the tools, if you make sure that Tool Tips are enabled in the Interface
pane of the Preferences dialog box (choose InDesign=>Preferences=Interface
[38+K] or Edit~>PreferencesInterface [Ctrl+K]), you'll get some ideas as to
what the panel iconic buttons and fields do.

If panels are getting in your way, you can make them all disappear by press-
ing Tab — as long as the Type tool is not active and the text cursor is active
within a text frame, of course. Press Tab to get your panels back.

Working with docks

Docks have controls to collapse and expand them. Click the double-arrow
iconic button at a dock’s upper corner to collapse or expand the dock. You
can also resize the main dock by dragging its resize handle. Figure 1-5 shows
the dock controls and what they look like when expanded and collapsed.



Chapter 1: Understanding InDesign Ingredients 29

|
Figure 1-5:
The col-
lapsed dock
controls are
the default
display (left),
but you can
expand
them to see
their options
(right).
|
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Working with workspaces

Although you can rearrange InDesign’s panels to suit your needs, rearranging
again and again as you switch from one task to another can be a real chore.
For example, you may open several of the table- and text-oriented panels
when working on text, but then close them and open the graphics- and
positioning-oriented panels when refining layout placement.

That’s why InDesign lets you create workspaces, which are essentially
memorized panel collections. Display the panels you want, where you want
them, and create a new workspace by choosing Window=>Workspacer>New
Workspace. (Note that this menu option has been called Save

Workspace in previous versions.) Give the workspace a name that

makes sense, such as Text Panels. That workspace is now available via
Window=>Workspace=>workspace name, automatically displaying just those
saved panels in their saved locations.

Not only can you save workspaces, you can also tell InDesign C54 to save any
menu customizations made along with the currently opened selection panels
into that workspace. (Chapter 2 covers menu customization.)
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Surveying the Menus

Although InDesign relies heavily on its panels to present its rich capabilities,
it also uses traditional menus. In some cases, you can use menus instead of
panels; in others, you must use a menu command; in still others, you must
use a panel (such as for the data merge and object alignment features).

InDesign for Windows has nine menus, while InDesign for Macintosh has ten:

+ InDesign (Macintosh only): This menu contains the Preferences menu,
where you set much of InDesign’s behavioral defaults. You can also con-
figure plug-ins here. Other functions are standard for all Mac programs,
including hiding and quitting the program. Note that none of these menu
items’ functions are available in panels.

v~ File: This menu is where you open, create, close, save, export, and set
up documents and books; where you import text and graphics; where
you print documents and prepare them for commercial printing; and
where you set basic user information. Note that none of these menu
items’ functions are available in panels, except for the Preflight feature.

v Edit: This menu lets you cut, copy, and paste elements; edit, spell-check,
and do search-and-replace operations across entire stories and set up
story for the InCopy add-on program; adjust and manage color settings;
set up and change keyboard shortcuts and menu preferences; apply
various styles to selected objects and text; and undo and redo recent
actions. In Windows, you also set preferences and quit the program
from this menu. Note that these menu items’ functions, except for Quick
Apply, aren’t available in panels.

v Layout: With this menu, you add, delete, rearrange, and navigate pages;
change margins and guides; automatically resize a page and its objects;
set up page numbering and sections; and create and format tables of
contents. Note that these menu options’ functions — except for the
Pages, page-navigation, and Numbering & Section Options menus —
aren’t available in panels.

v Type: With this menu, you adjust typographic attributes such as size
and font, insert special characters, work with footnotes, add placeholder
text; and control the on-screen display of special characters such as
spaces. Note that the Find Font, Change Case, Type on a Path, Document
Footnote Options, Text Variables, Insert Character, Fill with Placeholder
text, and Show Hidden Characters menu items’ functions aren’t avail-
able though panels. Also note that the separate Notes menu found in
InDesign CS3 has moved into this menu as a new menu item.
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+* Object: You use this menu to change the shape, size, location, and other
attributes of objects, such as frames and lines; apply special effects to
objects; insert multimedia effects such as buttons; and control display
redraw speed. Note that the Text Frame Options, Anchored Object,
Corner Options, Clipping Path, and Convert Shape menu items’ functions
aren’t available through panels.

v~ Table: Use this menu to create, change, and format tables and cells.
Note that this menu’s functions are available through panels.

v View: This menu lets you control the display of your document, from
zoom level to whether guides, rulers, and frame edges appear. Note that
none of these menu items’ functions, except for Screen Mode and the
zoom controls, are available in panels.

v Window: This menu is where you manage the display of document
windows and panels, as well as where you set up and work with work-
spaces. The window display and workspace functions aren’t available
via panels.

v Help: Use this menu to access InDesign’s help system and manage
product activation and registration. In Windows, this menu also lets
you manage plug-ins. Note that none of these menu items’ functions are
available in panels.
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Chapter 2

Making InDesign Work Your Way

In This Chapter

Establishing document preferences
Working with stored preferences
Setting measurement standards
Changing text and object defaults
Working with view defaults

Setting color and style defaults

t’s safe to say that the nice people who created InDesign did their best:

They put their heads together and made educated guesses about how
most people would like to work and, in doing so, established defaults for vari-
ous settings in the program. When you’re just starting out, simply sticking
with the default settings and seeing how they work for you isn’t a bad idea.
But after you become more familiar with InDesign and start putting it through
its paces, you can change default preferences, views, and measurements,
making them better suited to your way of working.

Preferences are program settings that dictate how InDesign will act in certain
instances. InDesign provides extensive preference settings for everything
from how objects appear on-screen to how text is managed for spelling and
hyphenation.

Setting InDesign to work your way is easy, and this chapter explains how. I
promise not to numb you by covering every single option. Instead, I focus
on just those preferences you're likely to change. As for the rest, feel free to
explore their effects after you’re more comfortable using InDesign.
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Setting Document Preferences
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Figure 2-1:
The General
pane of the
Preferences
dialog box.
|

Preferences are settings that affect an entire document — such as what
measurement system you use on rulers, what color the guides are, and
whether substituted fonts are highlighted. To access these settings, open
the Preferences dialog box by choosing InDesign=>Preferences=>desired pane
name (88+K) or Edito>Preferences=desired pane name (Ctrl+K).

When you open the Preferences dialog box using the keyboard shortcut
(88+K or Ctrl+K), InDesign automatically opens the General pane, as shown
in Figure 2-1. To access one of the other 16 preferences panes, just click its
name from the list at the left of the dialog box.

InDesign has two methods for changing preferences: You can change prefer-
ences when no documents are open to create new settings for all future docu-
ments, or you can change preferences for the active document, which affects
only that document. Either way, after you've changed the desired preferences
settings, just click OK to save those settings.

You can’t reverse changes to preferences after the fact by using the Undo
command (Edit=>Undo [88+Z or Ctrl+Z]). If you change your mind about a
preference setting, reopen the Preferences dialog box and change the setting
again.
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Figure 2-2:
The Type
pane of the
Preferences
dialog box.
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Type preferences

The Type pane of the Preferences dialog box, shown in Figure 2-2, includes
settings that affect character formats, controls whether you use typogra-
pher’s quotes, and manages how text appears on-screen. You're likely to
adjust these settings, so here’s a quick review of the main ones:

Preferences
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Add Pages To: | End of Story 2]
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[ Delete Empty Pages

(_ Cancel \( 0K '\

v 1f Use Typographer’s Quotes is checked, InDesign inserts the correct
typographer’s quotes (often called curly quotes) for the current language
in use whenever you use quotation marks. For example, for U.S. English,
InDesign inserts typographic single quotes (" ") or double quotes (“ )
rather than straight quotes. For French, Catalan, Polish, and other
languages, InDesign inserts guillemets (« »).

v Check Triple Click to Select a Line if you want to be able to select an
entire line of text by triple-clicking it.

v When the Apply Leading to Entire Paragraph box is checked, changes
to leading (the space between lines) apply to the entire paragraph, as
opposed to the current line. In most cases, you want the leading to be
applied to all paragraphs, so checking this box is a good idea.

v Adjust Spacing Automatically When Cutting and Pasting Words, which
is checked by default, will add or delete spaces around words when you
cut and paste.
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v When Font Preview Size is checked, menus let you preview how your
font choice looks before you actually select it. The pop-up menu at the
right of the check box lets you select the size of the preview.

v The options in the Drag and Drop Text Editing section of the Type pane
control whether you can drag and drop text selections within a docu-
ment. By default, Enable in Story Editor is checked and Enable in Layout
View is unchecked, which means that you can drag and drop text in the
Story Editor but not when working on a layout. You’ll probably want to
check them both.

ATUR,
\\\6 ¢ v The new options in the Smart Text Reflow section of the Type pane tell

& InDesign how to create new pages if the text you are placing takes more
room than the number pages already in your document (see Chapter 11).

The Advanced Type pane includes additional typographic settings, shown in

Figure 2-3.
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In the Character Settings section of the Advanced Type pane, you control
precisely how superscript, subscript, and small-caps characters are placed
and sized:

v The Size fields let you specify the percentages to which superscript and
subscript characters are reduced (or even enlarged). The default is 58.3
percent, but you can enter a value between 1 and 200 percent. I prefer 60
or 65 percent, depending on the type size and font.
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Figure 2-4:
The Compo-
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v The Position fields let you specify how much to shift superscript charac-
ters up and subscript characters down. The default is 33.3 percent, but
you can enter a value between -500 and 500 percent. I prefer 30 percent
for subscripts and 35 percent for superscripts. Note that negative values
move text in the opposite directions: down for superscripts and up for
subscripts. The percentage is relative to the top of a lowercase letter
(the x height) for superscripts and to the baseline for subscripts.

v The Small Cap field lets you specify the scale of Small Caps characters in
relation to the actual capital letters in the font. The default is 70 percent,
but you can enter a value between 1 and 200 percent.

The Clipboard Handling pane includes one text-oriented preference: Use the
When Pasting Text and Tables from Other Applications setting to choose
how formatting is handled when you paste textual objects from other appli-
cations. The default is Text Only, which means that you want copied text to
look exactly like the existing text in your InDesign layout. The All Information
option retains the original formatting when you paste the text into InDesign.

Composition preferences

Preferences in the Composition pane, shown in Figure 2-4, do two things:
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v Highlight potential problems on-screen while you’re working

v Establish the behavior of text wrap in certain situations

Highlighting potential problems

The Highlight check boxes control whether InDesign calls attention to possi-
ble typesetting problems by drawing a highlighter pen effect behind the text.

All are unchecked by default unless indicated otherwise in the descriptions
that follow:

v Keep Violations highlights the last line in a text frame when it can’t
follow the rules specified in the Keep Options dialog box in the
Paragraph panel’s flyout menu (Type=>Paragraph [Option+3+T or
Ctrl+Alt+T]), as explained in Chapter 14. For example, if the Keep

Options settings require at least three lines of text in the text frame, but

only two lines fit and thus bump all the text in a frame to the next text

frame in the chain, the Keep Options rules are violated, and the last line

of text is highlighted.

+ When H&J Violations is checked, InDesign uses three shades of yellow
(the darker the shade, the worse the problem) to mark lines that may

be too loose or too tight due to the combination of spacing and hyphen-
ation settings. (H&J refers to hyphenation and justification.) Chapter 14

covers this topic, too.

v Custom Tracking/Kerning, if checked, highlights custom tracking and
kerning (essentially, anywhere you overrode the defaults) in a bluish
green. Chapter 15 covers kerning and tracking in more detail.

v Substituted Fonts, which is checked by default, uses pink highlights
to indicate characters in fonts that aren’t available and thus for which
InDesign has substituted a different font. For output purposes, it’s

important that you have the correct fonts, so you typically want to leave

this option checked.

v Substituted Glyphs highlights, in pink, any glyphs (special characters)
that were substituted. This substitution usually occurs when you have
multiple versions of the same font, with different special characters in

each version. For example, a file that uses the euro (€) currency symbol
may have been created in the newest version of a font, but a copy editor

working on the same file may have an older version of the font that is

missing the euro symbol. If uncorrected, the printed symbol may not be

what you expected, even if looks right on-screen.

Setting text-wrap rules

The three options in the Text Wrap area affect how text flows (wraps) around

images and other frames:
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v Selecting the Justify Text Next to an Object check box overrides any
local justification settings to make text wrapping around an object justi-
fied. The text will smoothly follow the object’s shape, rather than keep
any ragged margins that can make the wrap look strange. This option
comes into play when you wrap ragged (left-aligned or right-aligned) text
around objects.

v~ Skip by Leading, if checked, uses the text’s leading to determine how
much space follows an object around which text wraps. This effect is
used only if you choose the Jump Object text-wrap option in the Text
Wrap panel (Window=Text Wrap [Option+8+W or Ctrl+Alt+W]).

v Text Wrap Only Affects Text Beneath, if checked, causes only text below
(behind) an object to wrap around that object.

Chapter 16 covers text wrap in detail.

Measurement preferences

The Units & Increments pane, shown in Figure 2-5, is where you choose the
measurement systems for positioning items.
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Ruler Units area

The Ruler Units area affects three things: the zero point (by page, by spread,
or by the spine), the measurement system displayed on the horizontal and
vertical rulers in the document window, and the default values in fields used
for positioning objects.

The Origin pop-up menu determines the zero point (typically, the upper-left
corner of the page) for object positions. If you choose Page, the positions of
objects are relative to each page’s upper-left corner. If you choose Spread,
the positions of objects are relative to the current spread’s upper-left corner.
If you choose Spine, objects’ positions are relative to the binding spine of
each spread — the very top and center of where the two pages meet.

With the Vertical and Horizontal pop-up menus, you specify one measure-
ment system for the horizontal ruler and measurements, and the same or
different measurement system for the vertical ruler and measurements. For
example, you might use points for horizontal measurements and inches for
vertical measurements.

To specify the measurement systems you want to use, choose an option from
the Horizontal pop-up menu and from the Vertical pop-up menu. You have
the following options:

v+ Points: A typesetting measurement equal to /: of an inch (or /: of a
pica). To enter values in points, type a p before the value or pt after the
value (for example, p6 or 6 pt).

1~ Picas: A typesetting measurement equal to /% of an inch. To enter values
in picas, type a p after the value (for example, 6p).

You can combine measurements using both picas and points. Keeping
in mind that 1 pica is equal to 12 points, you can enter 1/ picas as either
1.5p or 1p6.

v Inches: An English measurement system that is divided into 16ths. To
enter values in inches, type i, in, inch, or " after the value. For example,
3i, 3in, 3 inch, and 3" are all read by InDesign as “3 inches.”

+* Inches decimal: Inches divided into 10ths on the ruler rather than
16ths. To enter values in inches decimal, include a decimal point as
appropriate and type i, in, inch, or " after the value.

v~ Agates: Typically used in newspapers, an agate is /i of an inch, usually the
depth of a line in the small type of classified ads, stock tables, and sports
statistics boxes. To enter values in agates, type ag after the value — for
example, 10ag.

v+ Millimeters: A metric measurement that is Y of a centimeter. To enter
values in millimeters, type mm after the value, such as 14mm.



1+~ Centimeters: A metric measurement that is about % of an inch. To enter
values in centimeters, type cm after the value, as in 2.3cm.

v Ciceros: A European typesetting measurement that is slightly larger than

a pica. To enter values in ciceros, type c after the value — for example, 2c.

v Custom: This option lets you set a customer number of points as your
measurement unit, placing a labeled tick mark at every point increment
you specify. You get to customize the number of tick marks between
the labeled marks by entering a value in the Points field. For example, if
you enter 12 in the field, you get a tick mark at each pica because a pica
contains 12 points. A good way to use this option is if you need to have
the rulers show tick marks at whole-line increments; in that case, if your
leading is 8 points, you’d set the Custom field to 8.

Keyboard Increments area

The Keyboard Increments area lets you customize the way the keyboard
arrow keys work. You can use the arrow keys to move selected objects right,
left, up, or down. You can also use the arrow keys and other keyboard short-
cuts to change some text formatting. The options are

v Cursor Key field: When you select an object with the Selection tool
or the Direct Selection tool, you can move it up, down, left, or right
by using the arrow keys on the keyboard. By default, the item moves
1 point with each key press. You can change the increment to a value
between 0.001 and 8p4 (1.3888 inches). If you use a document grid, you
can change the increment to match the grid lines.

v~ Size/Leading field: The value in this field specifies by how many points
the leading or font size is increased or decreased when done with key-
board commands. You can enter a value between 0.001 and 100 (the
default is 2).

+~ Baseline Shift field: To shift the baseline of highlighted text up or down,
you can click in the Baseline Shift field on the Character panel and then
click the up or down arrow on the keyboard. The default for the Baseline
Shift increment value is 2 points, which you can change to any value
between 0.001 and 100.

v Kerning field: To kern text with keyboard commands, you position
the cursor between two letters and then press Option+— or Alt+— to
increase kerning, and press Option+« or Alt+« to decrease kerning. By
default, each press changes kerning by /% of an em — shown on screen
as 2w em. You can change this value to anything between 1 and 100, in
increments of %o of an em. (An em is a space the width of a capital M, a
commonly used space in professional typography.)

Chapter 2: Making InDesign Work Your Way
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Typographic terminology 101

Publishing tools like InDesign use specialized to accommodate their specific shapes. For
terms, some of which appear in the Preferences example, you probably would use tighter
dialog box: kerning in the letter pair to than in oo

because fo looks better if the o fits partly

v~ Baseline: This term refers to the invisible under the cross of the ¢

line that text sits on in each line. Except
for a few characters like g and pthat poke ¢~ Leading: This term, also called line spac-
below it, all characters rest on this base- ing, refers to the space from one baseline
line. to another.

v~ Kerning: This refers to an adjustment of the 1~ Tracking: Tracking determines the overall
space between two letters. You kern letters space between letters within a word.

A\\S

Document defaults

InDesign also lets you change the default page size, margins, and columns

in new documents; the default attributes of guides; and the way layouts are
adjusted. You don’t modify these settings in the Preferences dialog box;
instead, to modify document defaults, first make sure that no documents are
open and then choose the following:

v Fileo>Document Setup (Option+3+P or Ctrl+Alt+P): The Document
Setup dialog box lets you change the default settings in the New
Document dialog box for the Number of Pages, Page Size, Facing Pages,
and Master Text Frame, as well as for bleeds and slugs if you click the
More Options button.

v Layout=>Margins and Columns: The Margins and Columns dialog box
lets you change the default settings in the New Document dialog box for
the Margins and Columns areas.

v Layout=>Ruler Guides: This command opens the Ruler Guides dialog
box where you adjust the View Threshold and Color for all new guides.

v Layout=>Layout Adjustment: The Layout Adjustment dialog box lets you
resize entire layouts and modify how they are resized.

If you're unhappy with the preferences and defaults you've established, you
can revert InDesign to all its default settings. To revert all preferences and
defaults, press Control+Option+Shift+8 or Ctrl+Alt+Shift when launching
InDesign.
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Working with stored preferences

Some preferences in InDesign are stored in
files that you can share with other users, so
the preferences can be consistently used in
a workgroup. These preferences include key-
board shortcut sets, color swatch libraries,
document setups, workspaces, and scripts.

Some of these stored preferences — such as
document setups and printing setups — are
called presets, and the files that store them
reside in the Presets folder within the InDesign
application folder. When you save a preset,
InDesign automatically updates the presets file.
You can then copy that preset file to another
user’s Presets folder.

To create presets, look for menu items with the
word preset in them — examples are Adobe
PDF Presets, Document Presets, and Print
Presets in the File menu; and Transparency
Flattener Presets in the Edit menu. Also look for
the Save Preset option in some dialog boxes.
To use a preset, look for a pop-up menu with
the word preset in them in dialog boxes; for
example, you would use the Document Preset
pop-up menu in the New Document dialog hox
to create a new document using a specific pre-
set's settings.

InDesign has other types of stored preferences
whose settings are also stored in separate files,
also stored in the Presets folder. But you won't
see options labeled Presetsin the InDesign user
interface to work with them. These stored pref-
erences include Keyboard Shortcuts, Menus,
and Color Profiles options in the Edit menu and
the Workspace option in the Window menu.
You can share these settings by copying them
to other users’ Presets folders.

Another kind of preference is typically stored
as part of a document: master pages, text vari-
able, color swatches, and the various types of
text, stroke, and object styles available through
a series of panels. These preferences can be
imported from other documents using the Load
command in the various panels’ flyout menus
and in some dialog boxes. Most presets —
such as document presets, print presets, trap
presets, and Adobe PDF presets — can also
be loaded and saved this same way. In addi-
tion, you can save color swatches to files to
be shared with other Adobe applications using
a Save Swatches command in the Swatches
panel’s flyout menu.

43

Modifying Defaults for Text and Objects

When you create a new document, start typing, or create a new object, your
work conforms to default settings. You can change these settings. For exam-
ple, by default, a new document is always letter-sized, but if you design only
posters, you can change the default.

You may need to work with InDesign for a while to figure out which settings
you prefer. When you identify a problem — for example, you realize that you
always end up changing the inset for text frames — jot down a note about it
or close all documents right then. When no documents are open, change the
setting for all future documents.
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Text defaults

When you start typing in a new text frame, the text is formatted with default
formats and attributes. You can also choose to show invisible characters
such as spaces and tabs by default; otherwise, you need to manually activate
character visibility in each text-heavy document. To modify text defaults:

v+ Choose default options for character formats such as Font Family, Font
Size, and Leading from the Character panel. Choose Type>Character
(88+T or Ctrl+T).

1 Choose defaults for paragraph formats, such as alignment, indents,
spacing, and so on, from the Paragraph panel. Choose Typer>Paragraph
(Option+8+T or Ctrl+Alt+T).

v Choose defaults for the [Basic Paragraph] style, which is what all
unstyled imported text, as well as text entered in a new text frame in
InDesign, will use. Choose Typer>Paragraph Styles (38+F11 or Ctrl+F11).

1 Activate Optical Margin Alignment. Choose Type=Story. This option
adjusts the left position of characters along the left margin to make the
left edges look more pleasing, by letting the top of a 7, for example, hang
slightly to the left of the margin, even if that means the characters aren’t
strictly aligned. (Because optical margin alignment works best for dis-
play type rather than body type, it’s unlikely that you’ll activate optical
margin alignment as your default setting.)

+* Show Hidden Characters is a good thing to activate if you always end
up turning on Show Hidden Characters when you're editing a document.
Choose Typem>Show Hidden Characters (8+Option+ or Ctrl+Alt+I), or
choose Hidden Characters from the View Options pop-up menu in the appli-
cation bar. Hidden characters are spaces, tabs, and so on that print “blank”
but that you may want to see on-screen to make sure that you have the
right character in use. InDesign has a unique on-screen symbol for every
kind of space, tab, indent-to-here, and other such “blank” characters.

Object defaults

When you create new objects, they’'re based on default settings. For example,
you can specify how text wraps around objects. To modify object defaults,
use the following commands:

v Specify the default Columns, Inset Spacing, First Baseline, and Ignore
Text Wrap settings for new text frames using the Text Frame Options
dialog box. Choose Object=>Text Frame Options (8+B or Ctrl+B).

1 Choose defaults for the [Normal Graphics Frame] and [Normal Text
Frame] styles, which are what all new frames created in InDesign will
use. Choose Window=>Object Styles (88+F7 or Ctrl+F7).
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v Specify how text will wrap around all new objects. Choose
Windowr>Text Wrap (88+Option+W or Ctrl+Alt+W).

1 Choose a style for the corners of all new frames except those created
with the Type tool. Choose Object=>Corner Options.

v Specify the default attributes of clipping paths imported into graphics
frames. Choose Object>Clipping Path=>Options (Option+Shift+3+K or
Ctrl+Alt+Shift+K).

1 Specify other default properties of objects. For example, if all objects
you create are stroked (framed), specify a weight in the Stroke panel.
Choose Window=>Stroke (88+F10 or Ctrl+F10), Window=Swatches (F5),
Window=>Gradient, or Window=>Attributes.

v~ Specify the default number of sides and the inset for the first new poly-
gon in a new document. Double-click the Polygon or Polygon Frame tool
to open the Polygon Settings dialog box (there is no menu command or
keyboard shortcut).

Modifying Defaults for Uiews
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InDesign provides controls for several view attributes, including zoom level,
frame boundaries, and grids.

The application bar contains the Zoom Level field, which shows the cur-
rent zoom percentage. You can type in a new value any time. Immediately
to its right is the Zoom Level pop-up menu, which also lets you change the
document’s view. The view can be between 5 percent and 4,000 percent in
0.01-percent increments.

If you use a MacBook Air or a 2008-or-newer-model MacBook Pro, you can
use gestures on its Multi-Touch trackpad (first introduced in the iPhone) to
zoom in or out. Use the pinch gesture (two fingers moving closer) to zoom
in and the expand gesture (two fingers moving apart) to zoom out. (If Apple
adds the Multi-Touch to other Macs in the future, they would support these
gestures in InDesign.)

The Zoom Level controls have moved from the bottom of the document
window in previous versions of InDesign to the new application bar in the CS4
version. Gone is the ability to change the view without taking your hands off
the keyboard by pressing Option+3+5 or Ctrl+Alt+5. Still, you can press 38+=
or Ctrl+= to zoom in, or 8+- or Ctrl+— to zoom out, in increments. Or, with the
Hand tool selected, just click and hold the mouse and let InDesign zoom
automatically; let go when you're at the desired zoom level.
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You can also control which layout visual aids display, using options in the
View menu.

For example, if you prefer not to view the edges of frames, you can hide
them. Similarly, you can hide the visual indicators for the threads indicating
which frames flow to and from the selected text frame.

If you want to start with a document-wide grid (see Chapter 10), you can.
Settings you can modify in the View menu include

+* Show the links between text frames. Choose ViewroShow Text Threads
(Option+8+Y or Ctrl+Alt+Y).

1+ Hide the edges of frames. Choose View=>Hide Frame Edges
(Control+8+H or Ctrl+H).

+* Hide the horizontal and vertical ruler. Choose Viewr>Hide Rulers
(88+R or Ctrl+R).

v+ Hide margin, column, and layout guides. Choose View=Grids &
Guides~Hide Guides (3 +; [semicolon] or Ctrl+; [semicolon]).

v Hide smart grids. Choose Viewr>Grids & Guides>Smart Guides
(88+U or Ctrl+U).

1 Show the baseline grid established in the Grids pane of the
Preferences dialog box. Choose View=>Grids & Guides=>Show Baseline
Grid (Option+3+’ or Ctrl+Alt+").

1 Show the document-wide grid established in the Grids pane of the
Preferences dialog box. Choose View=Grids & Guides=>Show Document
Grid (88+’ or Ctrl+").

InDesign has another place to set view settings: in the Pages panel’s flyout
menu, choose View>Show/Hide Master Items. When you choose Show
Master Items, any objects on the currently displayed document page’s
master page are displayed. When you choose Hide Master Items, master
objects on the currently displayed page are hidden. This command is
page-specific, so you can show or hide master objects on a page-by-page
basis.
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Adding Default Colors and Styles

If you're a creature of habit, you may find yourself creating the same colors,
paragraph styles, character styles, table styles, and object styles over and
over again. Save yourself some steps by creating these features when no
documents are open; when you do so, the features will be available to all
future documents.

To set up these often-used items, use the New command in the flyout menus
for the following panels: Swatches (F5), Character Styles (Shift+88+F11 or
Ctrl+Shift+F11), Paragraph Styles (38+F11 or Ctrl+F11), Table Styles (no short-
cut), Cell Styles (no shortcut), and Object Styles (8+F7 or Ctrl+F7). You can
also use the flyout menus’ Load commands to import colors and styles from
existing documents instead of creating them from scratch.

Chapter 6 covers color swatches, Chapter 9 covers object styles, Chapter 13
covers character and paragraph styles, and Chapter 19 covers table and cell
styles in more detail.

b7
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Document
Essentials

The 5th Wave By Rich Tennant
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“Remember, gour Flvis should appear bald and slightly

hunched. Nice Big Yoot, Brad. Keep your two—headed
animals in the shadows and your alien spacecrafts




In this part . . .

Fe reader sees your text and images, but as a layout
artist, you know a lot more is going on behind the
scenes. Your documents contain all sorts of elements —
the publishing equivalent of the girders and beams and so
on of a building — that are essential to delivering the final
text and graphics. This part covers those document
essentials, showing you how to work with the document
files, pages, layers, templates, libraries, and sections —
the basic organizing elements and containers. You also
find out how to create colors that you can use over and
over again.




Chapter 3
Opening and Saving Your Work

In This Chapter
Creating a new document
Opening documents
Saving and exporting documents
Exporting document content

Recovering information after a crash

ou’re eager to create a new document and get started with InDesign. So

you launch InDesign, create or open a new document, and begin work-
ing. Right? Wrong, sort of. You can just plunge in, but you're best served if
you have an idea before you start of what you want to accomplish. That way,
you won't be staring at a blank screen with no brilliant ideas in mind.

After you have an idea of what you want to do, you need to create the docu-
ment that will hold those brilliant ideas. InDesign lets you apply those ideas
from the very start of creating the document and also lets you make changes
later on, as you refine your ideas.

This chapter shows you the basics of working with document files, from creating
and opening them to saving them.

Setting Up a New Publication

After you launch InDesign, you have two options: You can choose File=>Open
(88+0 or Ctrl+O) to open a previously created document or template, or you
can choose File’Newr>Document (38+N or Ctrl+N) to create a new document.

Creating a new document is where all the fun is because you get to create
something yourself, from scratch. Here’s how to create a new document:
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1. Choose File=>New=>Document (88+N or Ctrl+N).

The New Document dialog box appears, as shown in Figure 3-1. It’s here
that you make many up-front decisions about how you want your new
document set up — page size, number of pages, number of columns,
and margin width. Although you’re free to change your mind later, you'll
save yourself time and potential headaches by sticking with the basic
page parameters you establish in the New Document dialog box.

New Document
Document Preset: | [Default] I :1 ( OK W
Number of Pages: 1 ™ Facing Pages I'_ Cancel
"1 Master Text Frame
Save Preset...
— Page Size: | Letter v £
 — S Fewer Options
Width: < 51p0 Orientation: =] 3 =
Height: < 66p0
I
— Columns
Flgure 3-1: Number: =1 Cutter: < 1p0
The New
— Margins
Document = =
. Top: <= 3p0 Inside: = 3p0
dialog box : =
: Bottom: < 3p0 Outside: < 3p0
establishes
the basic — Bleed and Slug
framework Top Bottom  Inside Outside
for your Bleed: 0p0 0p0 0p0 0p0 [
. A
pages. Slug: 0p0 0p0 0p0 0p0 o
I

2. If you know exactly how many pages your publication will have, enter
the number in the Number of Pages field.

If you don’t know for sure, you can easily add or delete pages later. Just
guesstimate.

3. Decide whether to lay out your documents in a spread or as separate
pages.
Here are a few pointers:

e If you're creating a multipage publication that will have a spine,
such as a book, catalog, or magazine, select Facing Pages.

e If you're creating a one-page document, such as a business card,
an ad, or a poster, don’t select Facing Pages.

e Some publications, such as flip charts, presentations, and three-
ring bound documents, have multiple pages but use only one side
of the page. For such documents, don’t check Facing Pages, either.

4. If you want to flow text from page to page in a multipage document,
such as a book or a catalog, check Master Text Frame.
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If you check this box, InDesign automatically adds a text frame to the
document’s master page and to all document pages based on this
master page. Checking this option saves you the work of creating a text
frame on each page and manually threading text through each frame.
(See Chapter 6 for more information about using master text frames.)

. In the Page Size area, you can choose one of the predefined sizes from

the pop-up menu.

Note the new options in InDesign CS4 for various screen sizes; choose one
of these options if you're creating pages that you’ll export for further Web
production in Adobe Dreamweaver or Flash Professional.

. Specify margin values in the Margins area.

If Facing Pages is checked, Inside and Outside fields are available in the
Margins area. Designers often specify larger inside margins for multi-
page publications to accommodate the fold at the spine. If Facing Pages
isn’t checked, Left and Right fields replace the Inside and Outside fields.
You can also specify margin values by clicking the up/down arrows
associated with the fields.

. To specify how many columns your pages have, enter a value in the

Columns field.

You can also specify the number of columns by clicking the up/down
arrows associated with the Column field.

. Specify a gutter distance in the Gutter field.

The gutter is the space between columns. You can also specify a gutter
width value by clicking the up/down arrows associated with the Gutter
field.

. Click the More Options button to access the Bleed and Slug area of the

New Document dialog box.

Clicking the More Options button provides options to set bleed and slug
areas, as shown earlier in Figure 3-1. (Note that the button then changes
to Fewer Options.)

A bleed area is a margin on the outside of the page for objects you want
to extend past the edge of the page — you want them to extend at least
% inch so that if the paper shifts during printing, no white space appears
where the image should be (touching the edge of the page).

The slug area is an area reserved for printing crop marks, color plate names,
and other such printing information — some output devices will cut these
off during printing unless a slug area is defined. For both bleed and slug
areas, you can set the top, bottom, left, and right margins independently.

Click OK to close the New Document dialog box.

Your new, blank document appears in a new document window. Figure
3-2 shows the window of a newly created document that uses the set-
tings shown in Figure 3-1.
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You can bypass the New Document dialog box by pressing Shift+8+N or
Ctrl+Shift+N. When you use this method, the most recent settings in the New
Document dialog box are used for the new document.

Opening documents

Opening documents with InDesign is pretty much the same as opening docu-
ments with any program. Simply choose Filec>Open (8+0 or Ctrl+0), select
the document you want to work on, and then click the Open button. But
InDesign offers a few options for opening documents that you don’t find in
every program. For example, you can

+ Open more than one document at a time. Just select multiple documents
in the Open a File dialog box.

1 Open a copy of a document instead of the original. This option keeps
the original file from being overwritten accidentally — very helpful if
you’re making several variations of one document.

v Open a template under its own name. This setting makes editing templates
easier than it is with other programs, specifically QuarkXPress.
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|
Figure 3-3:
The Open a
File dialog
box.
|

+* Open documents created with Versions 6.0, 6.5, and 7.0 of PageMaker
and Versions 3.3, 4.0, and 4.1 of both QuarkXPress and QuarkXPress
Passport. Unfortunately, you can’t open files created in later versions of
QuarkXPress (or in any version of Microsoft Publisher) unless you buy
a separate utility from Markzware. (Go to www. InDesignCentral.com
for a link to these utilities.)

To open an InDesign file (any version from 1.0 to CS4), follow these steps:

1. Choose File=>Open (38+0 or Ctrl+0).

The Open a File dialog box, shown in Figure 3-3, appears.

e e Open a File
(«]»] (22] =l (& cho2 B (Q search
v DEVICES I ] i Ch _m'e_-'z' Tuning.doc
Jii Zangot » [ Dfine [
3 zangor... [|[08.doc| [l Nik Cho2 Folder )
TEL T W | | DEXEIAN - Nik Cho2.indd
Bl Mac.. & il Nik choz_.__ssed2.indd
_ Nik_02_for...ut-gg.doc
¥ PLACES Nik_02_for layout.doc
L [ [ viveza ’
[ Infoworld
- 5 Name Nik Ch02.indd
Project:
(&) Projects Size 13.9 MB
._Dum&_ Kind InDesign® e
/&% gmgruman CS3 Document | &
E Mavies . Created 5/11/08 5:33 |¥
il il 1
e v Ee=——————..
Enable: | All Readable Documents I ]

(=) Open Normal
(") Open Original
(") Open Copy

2. Locate and open the folder that contains the documents you want to
open.

Select a single filename or hold down the 88 or Ctrl key and select multiple
filenames.

On a Mac, the Open a File dialog box will display all files in a supported file
format with a filename extension. The dialog box includes a Preview pane
that displays a thumbnail version of the selected file or, more commonly, its
icon. Use All Documents in the Enable pop-up menu to display files without
the expected filename extensions (typically, those transferred or copied
from a computer running Mac OS 9).
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In Windows, the Open a File dialog box will display any supported file
formats that have a supported filename extension. Use All Formats in the
Files of Type pop-up menu to display files with no filename extensions.
(Typically, these files are created on an older version of the Mac OS.) The
Files of Type pop-up menu offers several options: PageMaker 6.0-7.0 files,
QuarkXPress 3.3-4.1 files, InDesign files, InDesign Interchange, Adobe
PDF Creation Settings Files, and All Formats. Choose any of these options

to display a specific file format in the file list. (The Adobe PDF Creation
Settings Files option is for experts, so don’t worry about it for now.)

3. Select Open Normal at the bottom of the dialog box to open the
original version of the document or a copy of a template; click Open

Original to open the original version of the document or of a template;

click Open Copy if you just want to open a copy of it.

In Windows, the options are labeled simply Normal, Original, and Copy
and appear under the Open As label.

When you open a copy of a document, it’s assigned a default name
(Untitled-1, Untitled-2, and so on).

(Chapter 5 covers templates.)

4. Click Open to close the dialog box and open the selected files.

Each document you opened appears in a separate document window.
The page and view magnification used when the document was last
saved is also used when you open the document. (Chapter 1 covers

document views.)

Opening foreign formats

One of InDesign’s hallmarks is its ability to open
documents from other programs and convert
them into InDesign documents. You can open
documents created in PageMaker 6.0, 6.5, and
7.0 as well as QuarkXPress and QuarkXPress
Passport 3.3, 4.0, and 4.1.

But beware: InDesign’s ability to open a for-
eign-format file doesn't mean you get a perfect
translation. The other programs’ formats and
capabilities are so different from InDesign’s
that you should expect to spend time cleaning

up the converted files by hand. In some cases,
you may find that the amount of cleanup work
is greater than if you simply re-create the docu-
ment from scratch in InDesign — don’t panic.
And be happy when your documents convert
effortlessly.

The good news is that InDesign will alert
you to any import issues of PageMaker and
QuarkXPress files with a dialog box that appears
after the import is complete.




Chapter 3: Opening and Saving Your Work

A\\S

Saving documents

When you open a new document, it’s assigned a default name — Untitled-1,
Untitled-2, and so on — and the first page is displayed in the document
window. At this point, you're like a painter in front of a blank canvas. You can
work on your layout without giving it a name, but you're better off giving it a
name by saving it as soon as possible so that you don’t lose any changes to a
power outage or other system problem.

The second group of commands in InDesign’s File menu — Close, Save, Save
As, Save a Copy, Check In, and Revert — provide options for saving the active
(frontmost) document. Here’s a rundown of what each command does:

v Close (88+W, or Ctrl+W or Ctrl+F4) closes the active document. If the
document has never been saved or if it has been changed since it was
last saved, a dialog box lets you save, close without saving, or cancel
and return to the document.

To close multiple windows at once, use the shortcuts Option+Shift+38+W
or Ctrl+Alt+Shift+W.

v~ Save (88+S or Ctrl+S) saves changes you’'ve made to the active document
since you last saved. (If you choose Save for a document that hasn’t yet
been saved, the Save As dialog box appears.)

1~ Save As (Shift+88+S or Ctrl+Shift+S) lets you save a copy of the active
document using a different name (or with the same name in a different
folder). When you choose Save As — and when you choose Save for
an unsaved document — the Save As dialog box, shown in Figure 3-4,
appears. This dialog box lets you create or choose a folder for the
document, as well as name the document.

1 Check In saves the current document as a version within a Version Cue
project. This latest save will be considered a version of the previously
saved file. (This expert feature is not covered in this book.)

1~ Save a Copy lets you create a copy of the active document in a different
(or in the same) folder using a different (or the same) name. When you
use the Save a Copy command, the original document remains open and
retains its original name. It differs from Save As only in that it keeps the
original document open.

+ Revert undoes all changes you've made to a document since you last
saved it.
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Exporting document content

InDesign’s Save commands (Save, Save As, and Save a Copy) let you save
documents and templates in InDesign’s native file format. But the Export
command (FileExport [38+E or Ctrl+E)) lets you save the stories — and in
some cases stories and whole layouts — from InDesign documents in several
formats: InDesign Interchange, Rich Text Format (RTF), Text Only, InDesign
Tagged Text, Encapsulated PostScript (EPS), Portable Document Format
(PDF), JPEG, Flash video (SWF), and Flash project (XFL).

The ability to export to the two Flash formats is new to InDesign CS4. Gone is
the ability to export to the Scalable Vector Graphics (SVG) image format.

Note that when exporting a file, you need to choose a format from the Format
menu (Mac) or Save as Type menu (Windows).

Here are your format options in more detail:

1 InDesign Interchange format: You can make your InDesign CS4 files
readable by InDesign CS3 users by saving your files in the InDesign
Interchange CS3 format. (Only InDesign CS3 and CS4 can open
InDesign Interchange CS3 files.)
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v InDesign Markup (IDML) format: This format can be opened only by
InDesign CS4 or custom software designed to handle this new format.
It’s essentially an interchange format for outsiders.

1 Word-processing formats: If you place the text cursor into a story, you can
export its text (select a range of text if you want to export only that selec-
tion) into one of two formats: RTF, for import into word processors with
only basic formatting retained; and Text Only, for import into word pro-
cessors that don’t support RTF (with Text Only, note that no formatting is
retained).

You can save only one text file at a time. If you need to export several
stories from the same document, you must do so one at a time.

1 InDesign Tagged Text format: If text is selected via the Type tool, you
can save the story in the InDesign Tagged Text format for editing in a
word processor and later reimporting into InDesign with all formatting
retained.

v Production formats: If text or a frame is selected via the Type tool or the
Direct Selection tool, you can save the document — not just the story —
in EPS or PDF formats for use by prepress tools and service bureaus or
for import into other applications as pictures.

+* Online formats: If text or a frame is selected via the Type tool or the
Direct Selection tool, you can save the document — not just the story —
in XML format for use in online database-oriented, content-management
systems. (XML is an advanced feature not covered in this book.) You
can save as a specific page, spread, or text selection into JPEG files for
use as online graphics.

v Multimedia formats: You can export your document to two Adobe Flash
format: the SWF play-only format and the XFL format that lets you further
work on the file in Adobe Flash Professional. Furthermore, the PDF format
mentioned previously in this list can also contain multimedia elements,
such as page transitions, sound, and video.

Two separate options are available for the entire document (no matter what
tool is active) or for whatever objects are selected. One is File>Export for
Dreamweaver, which lets you export InDesign layouts to the structured
HTML format for use in Web creation programs such as (but not limited to)
Adobe Dreamweaver. The other is Filec>Export for Digital Editions, which lets
you create a special type of online multimedia document, called an e-book.
Chapter 24 explains the basics for these two types of documents. Note that
these two menu options had different names in previous versions of InDesign.
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Recovering from Disaster

When you work on InDesign documents, make sure that you follow the first
rule of safe computing: Save early and often.

InDesign includes an automatic-recovery feature that protects your documents
in the event of a power failure or a system crash. As you work on a document,
any changes you make after saving it are stored in a separate, temporary file.
Under normal circumstances, each time you choose Save, the information in
the temporary file is saved to the document file. The data in the temporary file
is important only if you aren’t able to save a document before a crash. (A word
of warning: Although InDesign’s automatic recovery feature is a nice safety net,
you should still be careful to save your work often.)

If you suffer a system crash, follow these steps to recover your most recent
changes:

1. Relaunch InDesign or, if necessary, restart your computer and then
launch InDesign.

2. If automatic-recovery data is available, InDesign automatically opens
the recovered document and displays the word “Recovered” in the
document’s title bar.

This “Recovered” indicator lets you know that the document contains
changes that weren’t included in the last saved version.

3. If you want to save the recovered data, choose File~>Save (88+S or
Ctrl+S).

“Recovered” is removed as part of the filename, and InDesign asks
whether you want to overwrite the old file.

Overwriting the old file is easier than using Filec>Save As (Shift+3+S or
Ctrl+Shift+S) and entering a name — unless you do want to save a copy
of the file in case you want to go back to the old version later. If you
want to use the last saved version of the document (and disregard the
recovered data), close the file (Filem>Close [88+W or Ctrl+W]) without
saving and then opening the file (File=>Open [3+0 or Ctrl+O]).

Sometimes, InDesign can’t automatically recover the documents for you.
Instead, it gives you the choice of recovering any files open during a crash
or power outage, saving the recovery data for later, or deleting the recovery
data. You typically want to recover the files immediately.
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Discovering How Pages and
Layers Work

In This Chapter

Adding and removing document pages
Adjusting page numbers and creating sections
Navigating through a document

Adjusting page layouts and objects

Setting up layers

Working with individual objects on layers

Manipulating entire layers

t’s a rare InDesign user who creates only one-page documents. Even if you

spend your time working on business cards, ads, and posters, you prob-
ably produce at least a few multipage documents. And if you create newslet-
ters, newspapers, books, catalogs, or any other such multipage publications,
you must know how to add pages to your document, move pages around if
you change your mind, and delete pages if necessary. InDesign also lets you
divide multipage documents into independently numbered sections.

As documents grow in size, getting around can be a real drag — on your time,
that is. The longer you spend getting to the page you want, the less time you
have to work on it. Fortunately, InDesign provides several navigation aids
that make it easy to move around on a page or in a document.

Understanding the Pages Panel

The Pages panel is where you do most of your page actions, so you get to
know it better as you use InDesign more.
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If you intend to create a multipage document, you want to display the Pages
panel (Windowr>Pages [38+F12 or Ctrl+F12]), shown in Figure 4-1, because it
provides the controls that let you add pages (both document and master),
delete and move pages, apply master pages to document pages, and navigate

through a document.

For more information about using the Pages panel to work on master pages,

see Chapter 5.
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Keep in mind that the overwhelming majority of multipage documents are
facing-pages publications, such as books, catalogs, and magazines. Some
exceptions are flip charts and three-hole-punched publications printed on
only one side. In this chapter, the figures show examples of a facing-pages
document. If you create a single-sided multipage document, the techniques
are the same as for facing-pages documents, but the icons in the Pages panel

show only single-sided page icons. (The icons aren’t dog-eared.)
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Adding pages

A document can contain as many as 9,999 pages — more than anyone would
ever want to have in one file. In general, try to break up long publications
into logical pieces. For example, if you're creating a book, it’s a good idea

to create separate documents for the front matter, each chapter, the index,
and any other parts (appendixes and so on). Also, if you're producing a long
document, you want to take advantage of master pages (covered in Chapter
5), which save you the work of building each page from scratch.

When you create a multipage document, you're free to add however many
pages you want. But be careful: Even though InDesign will let you create a
seven-page newsletter, in real life, facing-page publications always have an
even number of pages — usually a multiple of 4 and often a multiple of 16 —
because of the way printers arrange multiple pages on a single sheet of paper
before folding and cutting them into the final document.

Here’s how to add pages to a document:
1. If it’s not displayed, open the Pages panel by choosing Window=>Pages
(38+F12 or Ctrl+F12).
2. From the Pages panel’s flyout menu, choose Insert Pages.
3. In the Pages field, type the number of pages you want to add.

4. Select an option from the Insert pop-up menu: After Page, Before
Page, At Start of Document, or At End of Document.

Be careful: If you've already started working on page 1, for example, make
sure that you add new pages after page 1. Otherwise, it won’t be page 1
anymore, and you’ll have to move the objects you already created.

5. Type a page number in the field next to Insert or use the arrows to
increase or decrease the value in one-page increments.

6. From the Master pop-up menu, select the master page you want to
apply to the new pages.

7. When you're finished, click OK to close the dialog box.

InDesign offers a faster way to add and manipulate pages if you don’t happen
to have the Pages panel already open: Choose Layout=>Pages and then select
the appropriate option, such as Add Pages, from the submenu. The resulting
dialog boxes match those accessed from the Pages panel.
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If you want to quickly add just one page after the current page, click
Layout=>Pages~>Add Page (Shift+88+P or Ctrl+Shift+P).

You can also add new pages or spreads one at a time at the end of a docu-
ment by clicking the Create New Page iconic button at the bottom of the
Pages panel. (Spreads are added if a spread is selected in the Pages panel.)
When you use this method, the master page applied to the last document
page is applied to each new page. Pages are added after the currently
selected page in the panel.

You can also click and drag a master page icon (or both pages in a facing-
pages spread to add a spread) from the top of the Pages panel to add a page
using a master page’s settings (use the [None] page for a plain page) between
any pair of document page spreads or to the right of the last document
spread. If a vertical bar appears when you release the mouse button, the
spread is placed between the spreads on either side of the bar. If a vertical
bar doesn’t appear between document page spreads when you release the
mouse button, the new spread is placed at the end of the document.

When you insert an uneven number of new pages into a facing-pages docu-
ment, existing pages are automatically changed from left-hand pages to right-
hand pages, and vice versa. You can prevent this change for selected spreads
by first selecting them in the Pages panel and then clicking Keep Spread
Together in the flyout menu. You may opt for this approach for a spread, such
as a two-page table, that you don’t want to have broken apart when other
pages are added or deleted. Of course, for proper printing, you may need to
move that spread when you're done adding or deleting pages so that it follows
a complete spread.

Selecting pages

InDesign offers several choices for selecting pages from a document, so you
can move, delete, copy, or otherwise manipulate them:
v Click a page’s icon in the Pages panel to select it.

v To select both pages in a spread, the easiest way is to click a spread’s
page numbers to select both pages.

v To select a range of pages, you can click a page icon or spread number
beneath it and then Shift+click another page icon or spread number.

v To select multiple, noncontiguous pages, hold down the 88 or Ctrl key
and click page icons or spread numbers.
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s\gN\BEI? InDesign shows a preview image of your pages in the Pages panel. You can
& control the display by choosing Panel Options from the panel’s flyout menu.
In the Panel Options dialog box, select the desired icon size and make sure
that Show Thumbnails is checked. You can also set separate view settings for
master pages.

Copying pages
You can copy pages from one document to another by clicking and dragging
the page icons from the source document’s Pages panel to the target docu-

ment’s Pages panel. Any master pages associated with the copied document
pages are copied as well.

You can also duplicate the current spread within the current document by
clicking Duplicate Spread from the Pages panel’s flyout menu or by choosing
Layout=>Pages=>Duplicate Spread.

Deleting pages

The fastest way to delete selected pages is to click and drag them to the
pane’s Delete Selected Pages button (the trashcan icon) or simply click the
Delete Selected Pages button.

Moving pages within documents

To move a page within a document, drag its icon between two spreads or

between the pages of a spread inside the Pages panel. A vertical bar indicates

where the selected page will be placed. Release the mouse button when the

vertical bar is where you want to move the page. To move a spread, drag the

MBER page numbers beneath the icons (rather than the page icons themselves).
InDesign automatically scrolls the Pages panel’s pages as you move pages up
or down.

Alternatively, you can select the pages you want to move in the Pages

panel and then choose Move Pages from the Pages panel’s flyout menu.

(If you don’t want to work through the Pages panel, you can also choose
Layout=>Pages=>Move Pages.) In that dialog box, you can specify where to
move the pages: after a specific page, before a specific page, at the beginning
of the document, or at the end of the document.
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Although you can move pages around in a document, do so only with great
care — if at all. Generally, if you want to move the objects on one page to
another page, it’s safer to cut (Edit=>Cut [38+X or Ctrl+X]) or copy (Edit=>Copy
[38+C or Ctrl+C]) the objects than to move the page, which can cause subse-
quent pages to shuffle.

What'’s the big deal about shuffling? Shuffling will move pages around to make
space for the moved page, which can move what had been left-hand pages to
the right-hand side of the spread and vice versa. If you have different align-
ments on left and right pages — such as having page numbers on the outside
of pages — this shuffling can wreak havoc with that alignment.

If you absolutely must move a single page, it’s safer to move its spread. (Of
course, if you're working on a single-sided facing-page document, shuffling
isn’t an issue.)

Moving pages among documents

You can also copy or move pages to other documents. Select the page in
the Pages panel and then drag its icon to the document you want to copy

or move it to. (You'll need to have that other document window accessible
by having it displayed in a tiled view, as described in Chapter 1.) The Insert
Pages dialog box then appears, giving you a choice of where to insert the
page in the new document as well as whether to copy or move the page into
the new document. To move a page rather than copy it, be sure to check the
Delete Pages After Inserting option.

Alternatively, you can copy or move pages among documents by choosing
Layout>Pages>Move Pages or by choosing Move Pages from Pages panel’s
flyout menu, either of which opens the Move Pages dialog box. Here, you
also can select the destination (at which page number to insert the new
pages) and which document you want to move the page into via the Move to
pop-up menu. (The document must be open to display in that pop-up menu.)
To move a page rather than copy it, be sure to check the Delete Pages After
Moving option.

Figure 4-2 shows both the Insert Pages and Move Pages dialog boxes.
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Starting documents on a left page

By default, InDesign starts all documents on the right page, which makes
sense because the first sheet in a document is always a right-hand page. But
sometimes you want documents to start on a left-hand page, particularly if
they’re a chapter or section in a larger document. For example, magazine arti-
cles often start on a left page, giving the introduction a full spread. To start a
document on a left page:

1. Select the first page in the Pages panel and then choose Numbering
& Section Options from the panel’s flyout menu or choose
Layout~>Numbering & Section Options.

2. Select the Start Page Numbering At option and enter an even number
in the field.

3. Click OK.
The Pages panel updates, showing the start page on the left of the spine.

You may not want to assign a starting page number (for example, if
the starting page number is unknown because the number of pages
that precede this document is unknown and you let the book feature
determine the page numbers later). In this case, repeat Step 1, but
deselect Start Section. Doing so leaves the page as a left-hand page
but lets the book feature figure out the page number.
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See Chapter 22 for more information on the book feature and long-document
creation. Sections are covered in the “Dividing a document into sections” sec-
tion, later in this chapter.

Working with Page Numbers

|
Figure 4-3:
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By default, pages are numbered automatically starting at 1, but you can
change the page numbering from Arabic numerals to Roman numerals or
letters, as well as change the start page to something other than 1. To do

so, select the first page in the document in the Pages panel and choose
Layout=>Numbering & Sections or choose Numbering & Section Options from
the Pages panel’s flyout menu. You get the dialog box shown in Figure 4-3. (If
the current page isn’t the first page in the document and if a section hasn’t
been applied to this page previously, the dialog box is called New Section. Its
options are identical.)

To change the initial page number, select the Start Page Numbering At option
and type a new starting page number in its field. To change the page num-
bering style from the default of Arabic numerals (1, 2, 3,4 .. .), use the Style
pop-up menu and choose from I, I, III, IV . . . ; i, ii, iii,iv...; A, B,C,D...; and
a,b,c,d....

Numbering & Section Options

—¥! Start Section - T OK g
® Automatic Page Numbering f_ Cancel )

(0) Start Page Numbering at: 22

— Page Numbering

Section Prefix:
Style: [ 1, 2,3, 4... )
Section Marker: |[Enhancing Realit

" Include Prefix when Numbering Pages

— Document Chapter Numbering -
Style: (1,2,3,4... 15
() Automatic Chapter Numbering
(® Start Chapter Numbering at: 6 |
Same as Previous Document in the Book

Book Name: N/A

To have a facing-pages document start on a left-hand page, the starting page
number must be even.
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Dividing a document into sections

Some long documents are divided into parts that are numbered separately.
For example, the page numbers of book introductions often use Roman
numerals, while standard Arabic numerals are used for the body of the book.
If the book has appendixes, you can apply a separate numbering scheme to
these pages. In InDesign, such independently numbered parts are referred to
as sections.

A multipage document can contain as many sections as you want. (A section
has to contain at least one page.) If each section of a document uses a differ-
ent page layout, you probably want to create a different master page for each
section. Here’s how to create a section:

1.

If it’s not displayed, open the Pages panel by choosing Window=>Pages
(38+F12 or Ctrl+F12).

2. Click the icon of the page where you want to start a section.

. Choose Numbering & Section Options from the panel’s flyout menu.

If you've selected the document’s first page, the Numbering & Section
Options dialog box appears (refer to Figure 4-3). Otherwise, the identical
New Section dialog box appears. By default, the Start Section option is
selected. Leave it selected.

You can also create a section starting at the current page in your docu-
ment by choosing Layout>Numbering & Section Options.

. In the Section Prefix field, type up to eight characters that identify the

section in the page-number box at the lower-left corner of the docu-
ment window.

For example, if you type Sec2, the first page of the section will be dis-
played as Sec2:1 in the page-number box. This prefix won’t appear as
part of the actual page numbers when you print — it’s really just a way
for you to keep track of sections while you work.

. From the Style menu, choose the Roman numeral, Arabic numeral, or

alphabetic style you want to use for page numbers.

. For Page Numbering, select the Automatic Page Numbering option if

you want the first page of the section to be one number higher than
the last page of the previous section.

The new section will use the specified style; the previous section may
use this style or another style.

. Select the Start Page Numbering At option and type a number in the

accompanying field to specify a different starting number for the section.
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For example, if a book begins with a section of front matter, you could
begin the body section of a book on page 1 by choosing Start At and
typing 1 in the field. If you select Continue from Previous Section,

the first page of the body section begins one number higher than the
numeral on the last page of the front matter.

8. In the Section Marker field, type a text string that you can later auto-
matically apply to pages in the section.

You may want to enter something straightforward like Section 2 or, if
the section is a chapter, the name of the chapter.

You can insert the section marker name so that it prints in folios,
chapter headings, and story text by choosing Typer>Insert Special
Character=>Markers=>Section Marker. This technique is a great way to
get a chapter name (if you use it as the section marker) in your folio or
to have cross-references in text to a section whose name might later
change. (A folio is the collection of a page number, magazine or chapter
name, section name, or issue date, and so on that usually appears at the
top or bottom of pages.)

9. Click OK to close the dialog box.

When you create a section, it’s indicated in the Pages panel by a small black
triangle over the icon of the first page in the section, as shown in Figure 4-4.
(If you move the mouse pointer over the black triangle, the name of the sec-
tion appears.) The page-numbering scheme you specify is reflected in the
page numbers below the page icons. When you begin a section, it continues
until the end of the document or until you begin a new section.

By default, the Pages panel displays section numbers beneath the icons

of document pages. If you want to display absolute page numbers — the
first page is page 1 and all other pages are numbered sequentially —

you can do so by choosing InDesign=>Preferences=>General (88+K) or
Edit>Preferencest>General (Ctrl+K). Then choose Absolute Numbering from
the General pane’s View pop-up menu.

Removing a section start

If you decide that you want to remove a section start, navigate to the page
that begins the section, choose Numbering & Section Options from the Pages
panel’s flyout menu, or choose Layout>Numbering & Section Options, and
deselect the Section Start option. That’s it! The pages in the former section
remain, but their numbering now picks up from the previous pages.
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Navigating Documents and Pages

Moving from page to page in a long document and scrolling around a large or
magnified page are among the most common tasks you perform in InDesign.
The more time you spend navigating to the page or page area you want to
work on, the less time you have to do the work you need to do. Like most
trips, the less time you spend between destinations, the better.

Navigating with the Pages panel

For navigating through the pages of a document, the Pages panel
(Window>Pages [3+F12 or Ctrl+F12]) offers the fastest ride.

When the Pages panel appears, you can use it to quickly move from page
to page in a multipage document and to switch between displaying master
pages and document pages. To display a particular document page, double-
click its icon. The selected page is centered in the document window. To
display a master spread, double-click its icon in the lower half of the panel.
(Note that you can reverse the order of master pages and regular pages in
the Pages panel by choosing the Panel Options option in the flyout menu.)
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The Fit Page in Window command (View=>Fit Page in Window [38+0 or
Ctrl+0]) and Fit Spread in Window command (View>Fit Spread in Window
[Option+88+0 or Ctrl+Alt+0]) let you enlarge or reduce the display magnifica-
tion to fit the selected page or spread in the document window. Related view
options are View=>Fit Spread in Window (Option+8+0 or Ctrl+Alt+0) and
Viewr>Entire Pasteboard (Option+Shift+3+0 or Ctrl+Alt+Shift+0). (Note that
the shortcuts use the numeral 0, not the letter O.)

Navigating with the menus and shortcuts

The oldest way to navigate pages in InDesign is via the Page-turning but-
tons, pop-up menu, and field at the bottom left of the document window, as
described in Chapter 1.

InDesign also offers several menu commands and keyboard shortcuts to
quickly navigate your layout, as Table 4-1 details.

Table 4-1 Page Navigation Menus and Shortcuts
Navigation Menu Sequence Macintosh Windows Shortcut
Shortcut

Go to first page LayouteoFirst Shift+38+PgUp Ctrl+Shift+Page Up
Page

Go back one Layout=>Previous Shift+PgUp Shift+Page Up

page Page

Go forward one Layout>Next Shift+PgDn or Shift+Page Down

page Page or 8+PgDn or Ctrl+keypad
Layout=>Go PgDn
Forward

Go to last page Layout=>Last Shift+38+PgDn Ctrl+Shift+Page
Page Down

Go to last page Layout>Go Back 98+PgUp Ctrl+keypad PgUp

viewed

Go forward one Layout=>Next Option+PgDn Alt+Page Down

spread Spread

Go back one Layoute>Previous Option+PgUp Alt+Page Up

spread Spread

Go to a specific Layout=>Go to 38+J Ctrl+J

page

Page
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The New Navigator Option

You can use the navigator to move among
pages: With the Hand tool selected, click and
hold the mouse button to zoom and then move
the mouse to move through the document's
pages, as shown in the figure. Release the
mouse when you’re at the desired location.
You'll be put back to the original zoom level.

If the autozoom is too fast, you can use the
up and down arrow keys instead to manually
move through various zoom levels. And if you

decide you've navigated some place you didn't
mean to, just press Esc — as long as the mouse
button is still pressed — to start over.

This navigator feature replaces the Navigator
panel from previous versions of InDesign. |
believe this approach is more useful for scrolling
within a page, particularly for doing detail work
on a page that's displayed at a high magnifica-
tion, than for moving from page to page. But you
get to decide what's right for you.
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Adjusting Page Layouts and Objects

|
Figure 4-5:
The Layout
Adjustment
dialog box.
|

If you've ever created and worked with a document all the way to the fin-
ishing touches and then discovered that the page size was wrong from the
beginning, you know the meaning of frustration. Manually adjusting the size
and placement of all the objects in a document is an ugly chore — one you
want to avoid at all costs. However, should the unthinkable happen — you
have to modify the size, orientation, or margins of a document that is
partially or completely finished — InDesign can automatically resize and
reposition objects when you change its basic layout.

For example, maybe you created a magazine for an American audience that
subsequently needs to be converted for publication in Europe. Most news-
letters in the United States use letter-sized pages (8% x 11 inches), while in
Europe the standard page size for such publications is A4 (210 x 297 mm),
which is slightly narrower and slightly taller than U.S. letter size. Of course,
you have to change color to colour, apartment to flat, and so on, but you also
have to both squeeze (horizontally) and stretch (vertically) every item on
every page to accommodate the A4 page’s dimensions.

The Layout Adjustment command (Layout=>Layout Adjustment) gives you
the option of turning this chore over to InDesign, which automatically adjusts
object shape and position according to the new page size, column guides,
and margins.

The Layout Adjustment dialog box lets you turn layout adjustment on or off
and specify the rules used to adjust objects when you change page size or
orientation, margins, or columns. To adjust a layout, follow these steps:

1. Choose Layout-~>Layout Adjustment to display the Layout Adjustment
dialog box, shown in Figure 4-5.

Layout Adjustment

M Enable Layout Adjustment - -
V| Enable Layout Adjustmen (T
Snmap Zone: = 0p2
Cancel

!21 Allow Graphics and Groups to Resize
@‘ Allow Ruler Cuides to Move
lignore Ruler Guide Alignments

@ Ignore Object and Layer Locks

2. Select the Enable Layout Adjustment option to turn on the feature;
deselect it to turn it off.
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3. In the Snap Zone field, type the distance within which an object edge will
automatically snap to a guideline when layout adjustment is performed.

4. Select the Allow Graphics and Groups to Resize option if you want
InDesign to resize objects when layout adjustment is performed.

If you don’t select this option, InDesign will move objects but not resize
them (the preferred option, so you don’t get awkward sizes).

5. Select the Allow Ruler Guides to Move option if you want InDesign to
adjust the position of ruler guides proportionally according to a new
page size.

Generally, ruler guides are placed relative to the margins and page
edges, so you probably want to select this option.

6. Select the Ignore Ruler Guide Alignments option if you want InDesign
to ignore ruler guides when adjusting the position of objects during
layout adjustment.

If you think that objects might snap to ruler guides that you don’t want
them to snap to during layout adjustment, select this option. If selected,
InDesign will still snap object edges to other margin and column guides.

7. Select the Ignore Object and Layer Locks option to let InDesign
move locked objects (either objects locked directly via Object=>Lock
Position [38+L or Ctrl+L] or objects that reside on a locked layer).

Otherwise, locked objects aren’t adjusted.

8. When you’re done, click OK to close the dialog box.

The Layout Adjustment feature works best when you don’t have much work
for it to do. Otherwise, it usually creates more work than it saves. For exam-
ple, the switch from a U.S. letter-sized page to an A4-sized page is a relatively
minor change, and the layout adjustments will probably be barely noticeable.
But if you decide to change a tabloid-sized poster into a business card in
midstream, well, you're probably better off starting over.

Here are a few things to keep in mind if you decide to use InDesign’s Layout
Adjustment feature:

v 1If you change page size, the margin widths (the distance between the left
and right margins and the page edges) remain the same.

v If you change page size, column guides and ruler guides are repositioned
proportionally to the new size.

v If you change the number of columns, column guides are added or
removed accordingly.

v~ If an object edge is aligned with a guideline before layout adjustment, it
remains aligned with the guideline after adjustment. If two or more edges
of an object are aligned with guidelines, the object is resized so that the
edges remain aligned with the guidelines after layout adjustment.
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v If you change the page size, objects are moved so that they’re in the
same relative position on the new page.

v If you used margin, column, and ruler guides to place objects on pages,
layout adjustment will be more effective than if you placed objects or
ruler guides randomly on pages.

v Check for text reflow when you modify a document’s page size, margins,
or column guides. Decreasing a document’s page size can cause text to
overflow a text frame whose dimensions have been reduced.

v Check everything in your document after the adjustment is complete. Take
the time to look over every page of your document. You never know what
InDesign has actually done until you see it with your own eyes.

<P If you decide to enable layout adjustment for a particular publication, you may
want to begin by using the Save As command (Filez>Save As [Shift+38+S or
Ctrl+Shift+S]) to create a copy. That way, if you ever need to revert back to the
original version, you can simply open the original document.

Using Layers

If you've ever seen a series of clear plastic overlays in presentations, under-
standing layers is easy. In one of those old overhead presentations, the
teacher may choose to start with one overlay containing a graphic, add
another overlay with descriptive text, and then add a third overlay con-
taining a chart. Each overlay contained distinct content, but you could see
through each one to the others to get the entire message. InDesign’s layers
are somewhat like these overlays, letting you isolate content on slices of a
document. You can then show and hide layers, lock objects on layers, rear-
range layers, and more.

You can use layers in the following situations (and in many others):

v A project with a high-resolution background image: For example, a
background such as a texture may take a long time to redraw. You can
hide that layer while designing other elements and then show it occa-
sionally to see how it works with the rest of the design.

v+ A document that you produce in several versions: For example, a pro-
duce ad may have different prices for different cities, or a clothing cata-
log may feature different coats depending on the climate in each area.
You can place the content that changes on separate layers and then
print the layers you need.



Chapter 4: Discovering How Pages and Layers Work

v A project that includes objects you don’t want to print: If you want to
suppress printout of objects for any reason, the only way you can do
it is to place them on a layer and hide the layer. You can have a layer
that’s used for nothing but adding editorial and design comments, which
can be deleted when the document is final. (Even though InDesign sup-
ports nonprinting notes, they can be inserted only into text, so having a
design-comments layer is still useful to be able to make annotations for
frames, images, and other nontextual elements.)

1 A publication that is translated into several languages: Depending on
the layout, you can place all the common objects on one layer and then
create a different layer for each language’s text. Changes to the common
objects need to happen only once — unlike creating copies of the origi-
nal document and flowing the translated text into the copies, which
you’d need to do for each language’s version.

+* To ensure folios and the like are never overprinted: By placing stan-
dard elements, such as folios (the document’s page numbers, running
headings, and so on), on their own layer, they’re uppermost in the layer
stack. This order ensures that they’re never accidentally obscured by
other objects.

1 To help text print properly over transparent elements: Layers are also
useful to isolate text above other objects with transparency effects. This
isolation avoids the rasterizing of text during output to plate or film —
something that can make the text quality look poor.

Layer basics

Each document contains a default layer, Layer 1, which contains all your objects
until you create and select a new layer. Objects on the default layer — and any
other layer for that matter — follow the standard stacking order of InDesign.
(What'’s the stacking order? Well, the first object you create is the backmost, the
last one you create is the frontmost, and all the other objects fall somewhere

in between. This order is how InDesign knows what to do with overlapping
objects.)

Like the clear plastic overlays, the order of the layers also affects the stacking
order of the objects. Objects on the bottom layer are behind other objects,
and objects on the top layer are in front of other objects. For example, for a
business card, the Default layer would contain the business card’s standard
graphics and the main text. An additional layer would contain a different set
of contact information — in separate text frames — for a different person.
Each new person would have his information on his own new layer. Each
layer has its own color, and frames will display in that color if frame edges are
visible. (Choose View=>Show Frame Edges [Control+3+H or Ctrl+H.])
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Figure 4-6:
The Layers
panel and
its flyout
menu.
|

Although people often compare layers to plastic overlays, one big difference
exists: Layers aren’t specific to individual pages. Each layer encompasses the
entire document, which doesn’t make much difference when you're working
on a one-page ad but makes a significant difference when it comes to a 16-page
newsletter. When you create layers and place objects on them, you must con-
sider all the pages in the document.

The Layers panel (choose Window=>Layers [F7]) is your gateway to creating
and manipulating layers (see Figure 4-6).

New Layer... PAGES|+ LaYERs |TCHES | b |§
Duplicate Layer "Default"... [ [ |Doefaute L
Delete Layer "Default” T I |Mingan sun

® [@ |Mcalen Gruman

Layer Options for "Default”...

Show All Layers
Unlock All Layers

Paste Remembers Layers E avers ]

Delete Unused Layers

Small Panel Rows

Working with layers

Each document contains a default layer, Layer 1, that contains all the objects
you place on master pages and document pages. You can create as many
layers as you need. After you create a new layer, it’s activated automatically
so that you can begin working on it.

Creating a layer

The Layers panel (choose Window=>Layers [F7]) provides several methods
for creating new layers. It doesn’t matter which document page is displayed
when you create a layer because the layer encompasses all the pages in the
document. To create a layer, do one of the following:

1 To create a new layer on top of all existing layers, click the New Layer
button on the Layers panel to open the New Layer dialog box. The layer
receives the default name of Layer x.

1 To create a layer above the selected layer, 8 +click or Ctrl+click the
New Layer button. The layer receives the default name of Layer x.

+* To create a new layer on top of all existing layers but customize its
name and identifying color, Option+click or Alt+click the New Layer
iconic button, or choose New Layer from the Layers panel’s flyout menu.
Use the New Layer dialog box to specify options for the layer. (The New
Layer dialog box — set with a custom name and color — is shown in
Figure 4-7.)
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|
Figure 4-7:
The New
Layer dialog
box.
|

New Layer
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[ Lock Layer "1 Lock Guides
@ Print Layer
1 Suppress Text Wrap When Layer is Hidden

Customizing layers

You can customize the name, identifying color, guides, and lock status of
objects on a new or existing layer. If you choose to customize the layer
when you create it (by Option+clicking or Alt+clicking the New Layer iconic
button or by choosing New Layer from the Layers panel’s flyout menu), the
New Layer dialog box appears. If you choose to customize an existing layer,
double-click it to display the Layer Options dialog box. (You can also choose
Layer Options for Layer Name from the flyout menu on the Layers panel.)

Whether you're using the New Layer dialog box shown in Figure 4-7 or the
nearly identical Layer Options dialog box, the options all work the same:

+» Name field: Type a descriptive name for the layer. For example, if you're
using layers for multilingual publishing, you might have a United States
English layer, a French layer, and a German layer. If you're using layers
to hide background objects while you're working, you might have a
Background Objects layer.

+* Color pop-up menu: Choose a color from the menu. A layer’s color helps
you identify which layer an object is on. The color appears to the left of
the layer name in the Layers panel and appears on each object on that
layer. The color is applied to frame edges, selection handles, bounding
boxes, text ports, and text wraps. By default, InDesign applies a different
color to each new layer, but you can customize it to something meaning-
ful for your document and workflow.

v Show Layer check box: Selected by default, this control lets you specify
whether objects on a layer display onscreen. Hidden layers also don’t
print. The Show Layer option has the same effect as clicking the eye icon
on the Layers panel.

v Lock Layer check box: Deselected by default, this option lets you con-
trol whether objects on a layer can be edited. You can lock a layer that
contains boilerplate text or a complex drawing that you don’t want
altered. Locking and unlocking layers is easy, so you can lock one layer
while focusing on another and then unlock it. Select Lock Layer if you
don’t want to be able to select items and modify them. For example, in
a document containing multiple versions of text on different layers, you
can lock the layer containing background images and other objects that
stay the same. The Lock Layer option has the same effect as clicking the
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lock icon on the Layers panel. The Layers panel’s flyout menu contains
additional locking options to, for example, unlock all layers and lock all
layers but the active one.

When you lock an object to a page (by choosing Object=>Lock Position
[88+L or Ctrl+L]), the object’s position stays locked regardless of its
layer’s lock status.

v Print Layer check box: Selected by default, this option lets you control

whether the layer prints or exports to PDF. You can use this option for a
layer containing design comments, for example. (In previous versions of
InDesign, deselecting Show Layer also prevented the layer from printing.
That remains true, but now you can control whether unhidden layers
print or not as well.) You can also override whether nonprinting layers
print in the Print dialog box, as explained in Chapter 25.

v Suppress Text Wrap When Layer Is Hidden check box: Deselected by

default, this option prevents text wrapping around the layer’s objects
when the layer is hidden. Be sure to select this option when you use
multiple layers for variations of the same content, such as multilingual
text or different contacts for business cards. Otherwise, your layer’s text
can’t display because it’s wrapping around a hidden layer with an object
of the same size in the same place.

v Show Guides check box: This check box lets you control the display

of guides that were created while the selected layer was active. When
selected, as it is by default, you can create guides while any layer is
active and view those guides on any layer. When deselected, you can’t
create guides. Any guides you create while that layer is active aren’t
displayed, but you can still see guides that you created while other
layers were active. Note that when guides are hidden entirely (choose
Viewr>Grids & Guides~Hide Guides or 8+; [semicolon] or Ctrl+; [semi-
colon)), this command has no apparent effect.

+* Lock Guides check box: This option works similarly to Show Guides in

that it affects only the guides that you created while the layer is active.
When deselected, as it is by default, you can move guides on any layer

for which Lock Guides is deselected. When selected, you can’t move
guides created while that layer was active. You can, however, move
guides on other layers for which Lock Guides is deselected. Note that
when all guides are locked (choose View>Grids & Guides=>Lock Guides or
Option+88+; [semicolon] or press Ctrl+Alt+; [semicolon]), this command
has no apparent effect.

You can select multiple layers and customize them all at once. However,
because each layer must have a different name, the Name field isn’t available
in the Layer Options dialog box when multiple layers are selected.



Chapter 4: Discovering How Pages and Layers Work 8 ’

3

Working with objects on layers

Whether you're designing a magazine template from the ground up or modify-
ing an existing ad, you can isolate specific types of objects on layers. You can
create objects on a layer, move objects to a layer, or copy objects to a layer.

The active layer is the one on which you’re creating objects — whether
you're using tools, importing text or graphics, clicking and dragging objects
in from a library, or pasting objects from other layers or other documents. A
pen icon to the right of a layer’s name means it’s the active layer. Although
more than one layer can be selected at a time, only one can be active. To
switch the active layer to another layer, click to the right of the layer name
that you want to be active; the pen icon moves, making that the new active
layer. Keep in mind that to activate a layer, it must be visible.

Selecting objects on layers

Regardless of the active layer, you can select, move, and modify objects on
any visible, unlocked layer. You can even select objects on different layers
and manipulate them.

The Layers panel (choose Window=>Layers [F7]) helps you work with
selected objects in the following ways:

v To determine which layer an object belongs to, match the color on its
bounding box to the color that appears to the left of a layer name.

v To determine which layers contain active objects, look to the right of
the layer names. A small square — the object icon — to the right of a
layer name indicates that you have selected an object on that layer.

v To select all the objects on a layer, Option+click or Alt+click the layer’s
name in the Layers panel. The layer must be active, unlocked, and visible.

To select master-page objects as well as document-page objects on a layer,
you need to Option+Shift+click or Alt+Shift+click the layer name.

Placing objects on layers

To place objects on a layer, the layer must be active as indicated by the pen
icon. Anything you copy, import, or create in InDesign goes on the active
layer.

When you create objects on master pages, they're placed on the default layer
and are therefore behind other objects on document pages. To create objects
on master pages that are in front of other objects, place the objects on a dif-
ferent layer while the master page is displayed.
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You can cut and paste objects from one page to another, but have the objects
remain on their original layer — without concern about the active layer.

To do so, be sure the Paste Remembers Layers check box is selected in the
Layers panel’s flyout menu before choosing Edit=>Paste (88+V or Ctrl+V).

Moving objects to different layers

When an object is on a layer, it isn’t stuck there. You can copy and paste
objects to selected layers, or you can move them by using the Layers panel.
When you move an object to a layer, it’s placed in front of all other objects
on a layer. To select multiple objects, remember to Shift+click them and then
move them in one of the following ways:

1~ Paste objects on a different layer. First cut or copy objects to the
Clipboard. Activate the layer on which you want to put the objects and
then use the Paste command (by choosing Edit=>Paste [88+V or Ctrl+V]).
This method works well for moving objects that are currently on a variety
of layers.

1 Move objects to a different layer. Click and drag the object icon for the
selected objects (to the right of a layer’s name) to another layer. When
you use this method, it doesn’t matter which layer is active. However,
you can’t move objects from several different layers to the same layer
using this method. (If you select multiple objects that reside on different
layers, dragging the box moves only objects that reside on the first layer
on which you selected an object.)

1 Move objects to a hidden or locked layer. Press 3 or Ctrl while you
click and drag the selected objects’ object icon.

1 Copy rather than move objects to a different layer. Press Option or Alt
while you click and drag the selected objects’ object icon.

1~ Copy objects to a hidden or locked layer. Press Option+88 or Ctrl+Alt
while you drag the selected objects’ object icon.

Manipulating entirve layers

In addition to working on objects and their layer positions, you can also
select and manipulate entire layers. These changes affect all the objects on
the layer — for example, if you hide a layer, all its objects are hidden; if you
move a layer up, all its objects appear in front of objects on lower layers.
Functions that affect an entire layer include hiding, locking, rearranging,
merging, and deleting. You work on entire layers in the Layers panel.

The active layer containing the pen icon is always selected. You can extend
the selection to include other layers the same way you multiple-select objects:
Shift+click for a continuous selection and 88 +click or Ctrl+click for a noncon-
tiguous selection.
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Rearranging layers

Each layer has its own front-to-back stacking order, with the first object you
create on the layer being its backmost object. You can modify the stacking
order of objects on a single layer by using the Arrange commands on the
Object menu. Objects are further stacked according to the order in which the
layers are listed in the Layers panel. The layer at the top of the list contains
the frontmost objects, and the layer at the bottom of the list contains the
backmost objects.

If you find that all the objects on one layer need to be in front of all the
objects on another layer, you can move that layer up or down in the list. In
fact, you can move all currently selected layers up or down, even if the selec-
tion is noncontiguous. To move layers, click the selection and drag it up or
down. When you move layers, remember that layers are document-wide, so
you'’re actually changing the stacking order of objects on all the pages.

Combining layers

When you're just discovering the power of layers, you can create a document
that is unnecessarily complex (for example, you may have put each object on
a different layer and realized that the document has become too difficult to
work with). The good news is that you can also merge all the layers in a docu-
ment to flatten it to a single layer. To flatten all layers:

1. Select the target layer (the layer where you want all the objects to
end up) by clicking it.

2. Select the source layers (the layers that contain the objects you want
to move) in addition to the target layer.
Shift+click or 88+click or Ctrl+click to add the source layers to the selection.

3. Make sure that the target layer contains the pen icon and that the
target and source layers are all selected.

4. Choose Merge Layers from the Layers panel’s flyout menu.

All objects on the source layers are moved to the target layer, and the
source layers are deleted.

When you merge layers, the stacking order of objects doesn’t change, so the

design looks the same, but with one notable exception: If you created objects
on a layer while a master page was displayed, those objects go to the back of
the stacking order with the regular master-page objects.
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Deleting layers

If you carefully isolate portions of a document on different layers and then
find that you don’t need that portion of the document, you can delete the
layer. For example, if you have a United States English and an International
English layer and you decide that you can’t afford to print the different ver-
sions, you can delete the unneeded layer. You can also delete layers that you
don’t end up using to simplify a document.

When you delete layers, all the objects on the layer throughout the document
are deleted.

Using the Layers panel, you can delete selected layers in the following ways:

v Click and drag the selection to the Delete Selected Layers iconic button.

v Click the Delete Selected Layers iconic button. The currently selected
layers are deleted.

v Choose Delete Layer from the Layers panel’s flyout menu.
If any of the layers contain objects, a warning reminds you that they’ll be

deleted. And, of course, the ubiquitous Undo command (choose Edit=>Undo
[38+Z or Ctrl+Z]) lets you recover from accidental deletions.

To remove all layers that don’t contain objects, choose Delete Unused Layers
from the Layers panel’s flyout menu.



Chapter 5
The Joys of Reuse

In This Chapter
Working with templates

Using master pages
Organizing with libraries

Working with snippets

u nless you enjoy continually reinventing the wheel, you’ll want to take
full advantage of the features that InDesign offers to help you work
more productively. After you make some important decisions about elements
in your document that will repeat, page after page, in the same spot (such as
page numbers, graphics, headers and footers, and so on), you want to set up
mechanisms that make the process simple.

Fewer activities in life are less rewarding than doing the same job over and
over, and publishing is no exception. Fortunately, InDesign includes some
valuable features that let you automate repetitive tasks. In this chapter, I
focus on three of them: templates, master pages, and libraries.

Building and Using Templates

A template is a prebuilt InDesign document that you use as the starting point
for creating multiple versions of the same design or publication. For example,
if you create a monthly newsletter that uses the same basic layout for each
issue, but with different graphics and text, you begin by creating a template
that contains all the elements that are the same in every issue — placeholder
frames for the graphics and text, guidelines, and so on.
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Creating templates

Creating a template is very similar to creating a document. You create char-
acter, paragraph, and object styles, master pages, repeating elements (for
example, page numbers), and so on. The only thing you don’t add to a template
is actual content.

Most often, you create a template after building the first iteration of a docu-
ment. After you have that document set up the way you like, you simply strip
out the content (that first issue’s stories and graphics in your newsletter
example) and save it as a template.

Here are the steps for creating a template:

1. Choose Filer>Save As (Shift+8+S or Ctrl+Shift+S) to display the Save
As dialog box.

2. Choose a folder and specify a name for the file.

3. Choose InDesign CS4 Template in the Format pop-up menu (Mac) or
Save as Type pop-up menu (Windows).

4. Click Save to close the Save As dialog box and save the template.

If you're designing a template that will be used by others, you may want to
add a layer of instructions. When you’re ready to print a document based on
the template, simply hide the annotation layer. (See Chapter 4 for more
information about working with layers.)

If you didn’t know better, you might think that a template is exactly the same
as a regular InDesign document. It is, with one major exception: A template
is a bit more difficult to override. When you open a template, InDesign actu-
ally opens a copy and provides that copy a default name (Untitled-1,
Untitled-2, and so on). The first time you choose Filer>Save (88+S or
Ctrl+S), the Save As dialog box appears, so you can give it a real name.

Modifying templates

As you use a template over time, you may discover that you forgot to include
something — perhaps a paragraph style, a repeating element on a particular
master page, or an entire master page. To modify a template, you have two
options:

v+ Open it as a normal file, make your changes, and then choose File=>Save
As (Shift+88+S or Ctrl+Shift+S) to save it again as a template (using the
same name to overwrite the original template). To open a file as a normal
file, be sure that Open Normal (Mac) or Normal (Windows) — the default
option — is selected at the bottom of the Open a File dialog box.
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v Open it as an original file (see Chapter 3), make your changes, and then
choose File>Save (36+S or Ctrl+S) to save it again as a template. To open
a file as an original file, be sure that Open Original (Mac) or Original
(Windows) is selected at the bottom of the Open a File dialog box —
forgetting to select this option is easy, so most people end up using the
previous technique to resave the template.

Creating documents from templates

You can easily create a document from a template: Just open a template file
and save it with a new name, making sure that InDesign CS4 Document — the
default option — is selected in the Format pop-up menu (Mac) or Save as
Type pop-up menu (Windows). Work on your document and continue to save
changes normally.

A more complicated way to create a document from a template is to choose
Filec>New=>Document from Template. This command opens the Adobe Bridge
program, which can contain InDesign templates that you open and then save
as documents. Bridge is meant as a central place for all Creative Suite docu-
ments and many related files, such as color libraries, to help workgroups
have one place for all their Creative Suite needs. It’s more complicated than it
is useful, at least for InDesign users. (Many Photoshop users love it.)

Building and Using Master Pages

A master page is a preconstructed page layout that you can use to create new
pages — it’s the starting point for document pages. Typically, master pages
contain text and graphic elements, such as page numbers, headers, foot-

ers, and so on, which appear on all pages of a publication. Master pages also
include guidelines that indicate page edges, column boundaries, and margins,
as well as other manually created guidelines to aid page designers in placing
objects. By placing items on master pages, you save yourself the repetitive
work of placing the same items one by one on each and every document page.

Don’t confuse master pages with templates. Think of a master page for use
within a document; with master pages, you can apply consistent formatting
to document pages when desired, and you can have multiple master pages

in a document so that you can easily format different kinds of pages. By con-
trast, a template is simply a document that, when you save it, you must pro-
vide a new name. Templates contain document pages, master pages, color
swatches, style sheets — the entire file. You use templates for documents
you want to reuse as a whole, such as each month’s edition of a newsletter or
each new title in a book series.
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It may surprise you to know that every InDesign document you create already
contains a master page, called A-Master. Whether you use the default master
page or create and use additional master pages depends on what kind of docu-
ment you want to create. If it’s a single-page document, such as a flier or an ad,
you don’t need master pages at all, so you can just ignore them. However, if
you want to create a document with multiple pages — a brochure or booklet,
for example — master pages save time and help ensure consistent design.

Creating a new master page

When you’re ready to create a new master page, here’s what you do:
1. If the Pages panel isn’t displayed, choose Windows->Pages (36+F12 or
Ctrl+F12).
The Pages panel is covered in more detail in Chapter 4.
2. From the Pages panel’s flyout menu, choose New Master.

You can also hold Option+8 or Ctrl+Alt and click the Create New Page
iconic button at the bottom of the panel. The New Master dialog box,
shown in Figure 5-1, appears.

New Master

Prefix: A € ok )
Name: Master | [ Cancel

Based on Master: | [None] s 1

Number of Pages: 2

3. In the Prefix field, specify a one-character prefix to attach to the front
of the master page name and display on associated document page
icons in the Pages panel.

The default will be a capital letter, such as the A in Figure 5-1.
4. In the Name field, give your new master page a name.
It’s a good idea to use a descriptive name, such as Title Page.

5. To base the new master page (the child) on another master page (the
parent), choose the parent master page from the Based on Master
pop-up menu.

6. In the Number of Pages field, enter the number of pages you want to
include in the master spread.

For a document with a single-page design, enter 1; if the document will
have facing pages, enter 2.

7. Click OK to save the page and close the dialog box.
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Your new master page appears in the document window. The name of the
master page appears in the Page Number field in the bottom-left corner of the
document window. To make changes to a master page’s attributes, simply click
its icon at the top of the Pages panel, choose Master Options from the panel’s
flyout menu, and then change settings in the Master Options dialog box.

Note that you can move master pages to be at the bottom of the Pages panel —
rather than at the top — by choosing Panel Options from the flyout menu and
enabling the Pages on Top option.

When you’re building a master page, you should think more about the overall
structure of the page than about details. Keep the following in mind:

v To build a document with facing pages, create facing-page master
spreads. The facing pages are somewhat like mirror images of each
other. Typically, the left-hand master page is for even-numbered docu-
ment pages, and the right-hand master page is for odd-numbered docu-
ment pages.

+* To have page numbers automatically appear on document pages,
add a page number character on each page of your master spreads
by drawing a text frame with the Type tool where you want the
page number to appear and then choosing Type=’Insert Special
Character~>Markers=Current Page Number (Option+8+N or Ctrl+Alt+N).
The prefix of the master page (A, B, C, and so on) appears on the master
page, but the actual page number is what appears on document pages.
Don’t forget to format the page number on the master page so that page
numbers will look the way you want them to in the document.

v Specify master page margins and columns by first making sure that
the page is displayed in the document window and then choosing
Layout=>Margins and Columns. The Margins and Columns dialog box,
shown in Figure 5-2, is displayed. The controls in this dialog box let you
specify the position of the margins, the number of columns, and the
gutter width (space between columns).

Margins and Columns
— Margins 1 @ oK 3
o Inside: =
Top: = 6p0 ~|5p6 F r——
B2 Ap— S i Ap— _ Cancel
Bottom: = 6p0 Outside: =176
E Preview
— Columns —
Number: =1 Cutter: = 1p0 ‘

You can place additional guidelines on a master page — as many custom
guidelines as you want (see Chapter 10.)
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Basing one master page on another

Some publications benefit from having more than one master page. If you're
building a document with several pages that are somewhat similar in design,
it’s a good idea to start with one master page and then use it as a basis for
additional master pages.

For example, if the brochure you're working on uses both two-column and
three-column page layouts, you can create the two-column master spread
first. (Be sure to include all repeating page elements.) You can then create
the three-column master page spread, basing it on the two-column master,
and simply specify different column formats. The child master page will be
identical to the parent except for the number of columns. If you later change
an element on the original master page, the change will apply automatically
to the child master page.

When you create a new master page, the New Master dialog box provides the
option to base it on an existing master page. To help you keep things straight,
when you base a master page on another master page, InDesign displays the
prefix of the parent page on the icon of the child page.

If you base a master spread on another master spread, you can still modify the
master objects (that is, the objects inherited from the parent master) on the
child master page. As with regular document pages, you have to Shift+3+click
or Ctrl+Shift+click the object inherited from a parent master to release it
before you can edit it on a child master.

Basing a master spread on a document spread

You may be talented enough to create an effective spread, one that is so
handsome that you want to create a master page from it to use on future
documents. Simply highlight the spread by clicking the page numbers below
the relevant page icons in the Pages panel and choose Save as Master from
the Pages panel’s flyout menu. The new master is assigned a default name
and prefix. To change any of its attributes, click its name in the Pages panel
and then choose Master Options from the flyout menu.

Duplicating a master spread

Create a copy of a master spread by selecting its icon and then choosing
Duplicate Master Spread from the Pages panel’s flyout menu or simply by
dragging its icon onto the Create New Page button at the bottom of the panel.
Note that if you duplicate a master spread, the duplicate loses any parent/
child relationships.
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Importing a master page

Sometimes, another document has a master page that you’d like to use

in your current layout. InDesign lets you import those master pages: Just
choose Load Master Pages from the Pages panel’s flyout menu, select the
source document in the dialog box that appears, and click Open. InDesign
will import all master pages from that document into your current one.
(Sorry, there’s no way to select specific master pages.)

If any of the imported master pages have the same name as your current doc-
ument’s master pages (such as the default name A-Master), a dialog box will
appear giving you the choice of replacing the current master pages with the
imported ones that use the same name or of renaming the imported master
pages, so you keep what you have and add the imported ones. InDesign does
the renaming for you.

Note that InDesign will also alert you if the imported master pages use dif-
ferent dimensions than the current document’s pages. It won’t adjust the
imported pages, so some items may appear off the page if the imported
master page has larger dimensions than the current document.

Deleting a master page

To delete a master page, select its name and then choose Delete Master Page
from the Pages panel’s flyout menu. You can also drag the master icon to the
Delete Pages iconic button at the bottom of the Pages panel.

So what happens when you delete a master page on which document pages
are based? Don’t worry — your document pages are unchanged, though they
no longer have a master page. (In the Pages panel, the page icons won'’t dis-
play the letter of a master page in their upper outside corners.)

You can remove a master page from a specific document page without remov-
ing the master page from your document (and thus other pages), by applying
the [None] master page to the document page using the process described in
the following section.
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Applying a master page
to document pages

After you build a master page, you can apply it to new or existing document
pages. (See Chapter 4 for information about adding and removing document
pages.) For documents with facing pages, you can apply both pages of a
master spread to both pages of the document spread, or you can apply one
page of a master spread to one page of the document spread. For example,
you can apply a master page with a two-column format to the left-hand page
of a document spread and apply a master page with a three-column format to
the right-hand page.

To apply a master page to a document page, select the name or icon of the
master page in the top part of the Pages panel and then drag it onto the icon
of the document page you want to format. When the target document page
is highlighted (framed in a black rectangle, as shown in the left side of Figure
5-3), release the mouse button. If both document pages are highlighted, and
if you're applying a master page to the document, both sides of the master
spread are applied to the document spread.

% PAGES EY‘.RS hTCHES | o

[None] D
K-Regular Page
I-Part Opener [E
Z-Blank Ch End

L-Lesson Opener ‘

22-23

R

24-25

6-27

26-
s

’_»@.. Tq
= 3

24 Pages in 12 Spreads Bl &

You can also apply a master page to the currently displayed pages by choosing
Layout>Pages=>Apply Master to Pages.
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Changing master items on document pages

As you work on a document page that’s based on a master, you may find that
you need to change, move, or delete a master object. Any change you make
to a master object on a local page is referred to as a local override.

Whenever you remove a master object from a document page, you sever the
object’s relationship to the master-page object for that document page only.
If you subsequently move or modify the object on the master page, it won’t
affect the deleted object on the document page — it remains deleted on that
particular document page.

The Show/Hide Master Items command in the Pages panel’s flyout menu lets
you show or hide master objects on document pages.

To change a master object on a document page, you must first select it,
which can be a bit tricky. To select a master object on a document page, hold
down Shift+88 or Ctrl+Shift when you click the object with one of the selec-
tion tools. (You can also Shift+88+drag or Ctrl+Shift+drag to select multiple
master objects within the selection marquee.) After you select a master
object on a document page, you can modify it just as you would objects that
aren’t part of a master page.

If you modify one or more master objects on a document page and then
decide you want to revert to using the original master objects, you can
remove the local overrides. To do so, display the document page that con-
tains the master objects you've modified, select the objects, and then choose
Remove Selected Local Overrides from the Pages panel’s flyout menu. If

no objects are selected, the command name changes to Remove All Local
Overrides. If the selected spread doesn’t have any modified master objects,
the command isn’t available.

Sometimes, you don’t want people to have the ability to override a master
page object. InDesign gives you a way to block such overrides: With the
master page open and any objects selected that you don’t want to be over-
ridden, deselect Allow Master Item Overrides on Selection in the Pages
panel’s flyout menu. With this option deselected, someone won’t be able

to override the selected master page objects on any document pages using
them — unless, of course, they reselect the Allow Master Item Overrides on
Selections option.
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Building and Using Libraries

An InDesign library is a file — similar in some ways to a document file —
where you can store individual objects (graphics, text, and so on), groups
and nested objects, ruler guides, and grids (see Chapter 10). Once an item is
in a library, every time you need a copy, you simply drag it out of the library.

Creating a library

Creating a library is easy:

1. Choose File->Newr>Library.

The New Library dialog box appears, with essentially the same options
as the Save As dialog box (see Chapter 3).

2. Choose a location in which to save the library.
3. Give the library a name.
4. Click OK.

You can create as many libraries as you want and store them wherever is
most convenient, including on a networked server so that other InDesign
users can share them. You can also open libraries created on a Mac from a
Windows computer, and vice versa.

Right after you create a new library, you see an empty library panel group.
Each library that you create or open will appear as its own panel within that
panel group, with its name displayed in its tab, as shown in Figure 5-4. To add
items to the library, you simply drag them to the desired panel.

Here is an explanation of some of the controls and commands shown in
Figure 5-4:

v The numbers in the lower-left corner of the panel indicate the number of
items currently displayed in the pane and the number of items in the library.

v The Library Item Information iconic button displays the Item
Information dialog box, as does the Library Item flyout menu option.
Here, you can give each library item a name, a type (for example, image
or text), and a description. Later, you can search for library items based
on these attributes.

v The Show Library Subset iconic button displays a dialog box that lets
you locate and display items that meet certain search criteria, as does
the Show Subset flyout menu option.

v The Delete Library Item iconic button lets you delete highlighted items
in the library, as does the Delete Item(s) flyout menu option.
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Why you'll love snippets

InDesign has a neat option called snippets
that lets you take pieces of your document
and create a file that other InDesign users can
bring into their documents, preserving all for-
matting and effects applied to them. Snippets
in InDesign CS4 have the filename extension
. idms; snippets in previous versions have the
filename extension , inds — InDesign CS4
can work with both types.

Snippets are sort of like libraries, with a key
exception: Each snippet is a separate file, so
they're not as easy or as convenient as libraries
when you have lots of document pieces that you
want to share or make available for reuse. So
snippets are best for sharing specific elements
on an as-needed basis, whereas libraries are
better for having, well, a library of standard,
shared elements. For example, a snippet is a
great way to give another designer a specific
element, such as a masthead or a format-
ted photo, for use in their own documents —
especially by e-mail, because snippets are

easily shared as file attachments. By contrast, a
library is meant to keep in one place a bunch of
objects you intend to use over and over again.

The process of creating snippets is easy:
Select the objects and drag them outside your
document window onto the Mac or Windows
desktop or onto a folder. InDesign automati-
cally creates the snippet file containing those
objects and their formatting. You can also
select the objects you want to be make the
snippet from and choose File=>Export (38+E
or Ctrl+E); choose InDeisgn Snippet from the
Format pop-up menu (Mac) or Save as Type
pop-up menu (Windows), select the destination
folder, and then click Save.

You can then send that snippet to other users
on storage drives, via e-mail, or over the
network — like any other file.

To use the snippet in another document, just
drag the snippet into your document window.
That's it!
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Putting items into a library

You can place individual items, such as text and graphics frames, into a
library. You can also place multiple selected objects, groups, nested frames,
ruler guides, guidelines, and all items on a document page.

To add items to a library:

v Select one or more items and then drag them into an open library panel.
(Open an existing library by choosing File=>Open [38+0 or Ctrl+0].)

v Select one or more items and then choose Add Item from the flyout
menu of an open Library panel.

v Choose Add All Items on Page from the flyout menu of an open Library
panel to add all items on the current page or spread as one library item.
Choose Add All ltems on Page as Separate Objects to add each object on
the page in one step as separate library items.

1 Select one or more items and then click the New Library Item iconic
button at the bottom of an open Library panel.

If you hold down the Option or Alt key when adding an item to a library, the
Item Information dialog box is displayed. This dialog box lets you add search-
able attributes to the library item.

If you import a graphic into a document and then place a copy of the graphic
into a library, the path to the original graphics file is saved, as are any transfor-
mations you've applied to the graphic or its frame (scale, rotation, shear, and
so on). If you save text in a library, all formatting, including styles, is retained.

Tagging library items

Alibrary can hold as many items as you want. As a library grows, locating a
particular item can become increasingly difficult. To make InDesign library
items easier to find, tag them with several searchable attributes.

To tag a library element:
1. Select the library element and then choose Item Information from the

library panel’s flyout menu.

You can also display the Item Information dialog box by double-clicking
a library item or by clicking once on a library item and then clicking
the Library Item Information iconic button at the bottom of the library
panel. (It’s the i in a circle.)

2. Specify a Name, Object Type, and/or Description.

In the Description field, use a few words that describe the object so that
you can easily find it later.
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3. Click OK to close the dialog box and return to the document.

Searching for library items

You can search for library items based on the information specified in the
Item Information dialog box. For example, if you place several different icons
into a library that includes many other items, and if you use the term icon in
the Name or Description field, a search of these fields that includes “icon”
will find and display those items stored in your library.

Follow these steps to search a library:

1. Choose Show Subset from a library panel’s flyout menu or click the
Show Library Subset iconic button at the bottom of the panel.

2. Decide whether to search the entire library or only the items cur-
rently displayed in the page and select the appropriate radio button.

3. In the Parameters area, choose the Item Information category you
want to search from the first pop-up menu.

Your choices are Item Name, Creation Date, Object Type, and Description.

4. From the next pop-up menu, choose Contains if you intend to search
for text contained in the chosen category; choose Doesn’t Contain if
you want to exclude items that contain the text you specify.

5. In the Parameter’s area text-entry field, type the word or phrase you
want to search for (if you selected Contains in Step 4) or exclude (if
you selected Doesn’t Contain).

6. Add more search criteria by clicking the More Choices button; reduce
the number of search criteria by clicking Fewer Choices.

You can create up to five levels of search criteria. If you select two or
more levels of search criteria, you will be able to choose whether to dis-
play items that match all search criteria (by selecting Match All) or

to display items that match any of the search criteria (by selecting
Match Any One).

7. Click OK to conduct the search and close the dialog box.

The library items that match the search criteria are displayed in the panel
(unless no items matched the search criteria). To display all items after con-
ducting a search, choose Show All from the Library panel’s flyout menu.

Deleting items from a library

To delete a library item, drag its icon to the trashcan icon at the bottom of
the panel or select the item and then choose Delete Item(s) from the library
panel’s flyout menu. You can select a range of items by clicking the first one
and then Shift+clicking the last one. You can select multiple, noncontiguous
items by holding down the 88 or Ctrl key and clicking each icon.
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Copying library items
onto document pages

After an item is in a library, you can place copies of that library item into any
document or into another library. To place a copy of a library item onto the
currently displayed document page, drag the item’s icon from the library
panel onto the page. As you drag, the outline of the library item is displayed.
Release the mouse button when the outline of the item is positioned where
you want it to end up. You can also place a library item onto a document by
clicking its icon and then choosing Place Item(s) from the flyout menu.

Copy an item from one library to another by dragging its icon from the source
library panel onto the target library panel. To move (rather than copy) an item
from one library to another, hold down the Option or Alt key when dragging
and dropping an item between libraries.

Managing library panels

You can close an individual library panel by clicking its close box or choos-
ing Close Library from its flyout menu. You can close all libraries at once by
clicking the panel group’s close box.

You can move panels into their own panel groups by dragging their tab out-
side their current panel groups. Likewise, you can combine library panels by
dragging them by their tabs into another panel group (including those that
contain nonlibrary panels).
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Working with Color

In This Chapter

Creating and modifying colors
Setting up tints

Constructing gradients

Managing swatches

Applying colors, tints, and gradients

ou see the world in glorious color. Yet not all publications take advan-

tage of that fact, typically for budget reasons. But when you do have
color available, take advantage of it: It brings a visual dimension that taps into
brains, creating a level of raw visual interest unmatched by anything else.

To take advantage of human beings’ color hot buttons, InDesign offers the
ability to create and apply colors in many creative ways. But even if you
can’t use color in every document, some of the techniques described here —
especially for tints and gradients — can help a staid black-and-white
document get new panache through shades of gray.

Working with Colors

InDesign comes with only a few predefined colors: black, registration (black on
each negative for the printing press), paper (white), none (transparent), cyan,
magenta, yellow, red, green, and blue. You'll likely want to add a few of your own.

Creating color swatches

Before you can apply any colors — whether to bitmap images or to layout
elements, such as strokes, text, frames, and shapes — you must first define
the colors in the Swatches panel (Window=>Swatches [F5]). You can also
import colors from other Adobe programs and from some color images.
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No matter how you define colors, you have a couple of decisions to make
first:

v Do you want to create your own color by mixing basic colors, such as
red, green, and blue (called RGB and typically used for documents like
Web pages and PDF files displayed on-screen); or cyan, yellow, magenta,
and black (called CMYK, or process colors, and typically used for printing
presses and by inkjet printers)?

v Do you want to use a color from an ink maker like Pantone or Toyo?
These colors — called spot colors — are typically used as an extra ink on
your professionally printed document, but can also be converted to the
standard four-process colors and so are handy when you know the color
you want when you see it.

How do you tell what kind of color a specific swatch is? Look at the icons to
the right of the swatch name. In Figure 6-1, you can see that Pantone 1675U

is a process color (the gray square) defined as CMYK (the square made up of
four triangles). Nik Yellow is a spot color (the circle-in-a-square icon) defined
from CMYK colors (that four-triangle square again). Hex:468966 is a process
color (the gray square) defined as RGB (the square made up of three stripes).
Finally, Muddy Yellow is a mixed-ink color (the multiple-drops icon), which is
explained in the “Creating mixed colors” section, later in this chapter.

All the color-creation tools in InDesign support both process and spot colors,
and all have access to the predefined colors like Pantone and Toyo as well as
to the free-form color pickers for mixing CMYK or RGB colors. If you plan to
print the color on its own plate, you need to use a predefined color so that
you know the printer can reproduce it. If you plan to color-separate a color
into the four CMYK plates, it doesn’t matter whether you use a predefined
color or make one of your own. One advantage to using a predefined color is
that it’s easy to tell other designers what the color is; another is that you’ll get
very close matches if you start with a predefined color and then end up having
it color-separated in some documents and kept as a spot color in others.

All colors in the Swatches panel receive a unique name and are tracked by
InDesign. Each color is available to be used on any object in your docu-
ment, with no risk of having slightly different variants. Plus, you can modify
a swatch and ensure that all objects using that swatch are updated. You

can also delete a swatch and tell InDesign which color to use in its place.
Furthermore, when you print, you have control over how each color is
handled (whether it’s printed to its own plate, whether it’s printed at all, and
whether you need to make any adjustments to its ink density or screening
angle). Figure 6-1 shows the Swatches panel.

If no document is open when you create, edit, or delete colors, the new color
palette becomes the default for all future documents.
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To create your own color, go to the Swatches panel and select New Color
Swatch from the flyout menu. The New Color Swatch dialog box, shown in
Figure 6-2, appears. Now follow these steps:

New Color Swatch
Swatch Name: C=52 M=0 Y=64 K=26 § oK )
E MName with Color Value (" Cancel )
Color Type: [ Process 3] ' \
olor Type: (Process 3] ——
- Color Mode: | CMYK |5

D Cyan e — (52 %
Magenta cr———— O %
Yellow e 64 %

Black e———e——— 26 %

1. In the Swatch Name field, give your color a name that describes it,
such as Lemon Yellow or Blood Red.

To do so, uncheck the Name with Color Value option. (If left checked,
InDesign names the color for you based on its color values; see an exam-
ple at the top of Figure 6-2.) Note that this option is not available for
swatch-based colors such as Pantone — you can’t change their names
(that would confuse the printer as to what ink to use).
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2. In the Color Type pop-up menu, choose from Process or Spot.

3. In the Color Mode pop-up menu, choose the mixing system or swatch
library (both are considered to be color models) you'll use:

e CMYK: Cyan, magenta, yellow, and black are the colors used in
professional printing presses and many color laser printers.

¢ RGB: Red, green, and blue are the colors used on a computer mon-
itor, for CD-based or Web-based documents, and for some color
printers.

¢ Lab: Luminosity, A axis, B axis, is a way of defining colors created
by the international standards group Commission Internationale de
I’Eclairage (the CIE, which translates to International Commission
on [llumination in English).

A swatch-based model: Sets of premixed colors from various ven-
dors, including ANPA, DIC, Focoltone, HKS, Pantone, Toyo Ink, and
Trumatch for print documents, as well as a Web-specific set and
sets specific to Windows and the Mac OS for on-screen documents.

Other Library: InDesign also has the Other Library option from
which you can select any color, tint, or gradient swatch library file
in the old Adobe Illustrator 8 format. (You can’t use Illustrator’s
patterned swatches, but don’t worry if the swatch file contains
them: InDesign will simply ignore them.)

4. For the CMYK, RGB, and Lab models, use the sliders to create your
new color; for the swatch-based models, scroll through the lists of
colors and select one.

A preview appears in the box on the left.

5. If you want to create multiple colors, click Add after each color defi-
nition and then click Done when you’re finished; to create just one
color, click OK instead of Add.

You can also click Cancel to abort the current color definition.

The most popular swatch libraries used by North American professional
publishers are those from Pantone, whose Pantone Matching System (PMS)
is the de facto standard for most publishers in specifying spot-color inks.
The Pantone swatch libraries come in several variations, of which InDesign
includes 13. Most of the time, you’ll use one of the following four:

v Pantone Process Coated: Use this library when you color-separate
Pantone colors and your printer uses the standard Pantone-brand
process-color inks. (These colors reproduce reliably when color-sepa-
rated, while the other Pantone swatch libraries’ colors often don’t.)

+* Pantone Solid Coated: Use this library when your printer will use actual
Pantone inks (as spot colors) when printing to coated paper stock.
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v~ Pantone Solid Matte: Use this library when your printer will use actual
Pantone inks (as spot colors) when printing to matte-finished paper stock.

1+ Pantone Solid Uncoated: Use this library when your printer will use actual
Pantone inks (as spot colors) when printing to uncoated paper stock.

Color swatches based on the CMYK colors — such as Focoltone, Pantone
Process, and Trumatch — will accurately color-separate and thus print accu-
rately on a printing press because a printing press uses the CMYK colors.
Other swatches’ colors often don’t color-separate accurately because they’re
supposed to represent special inks that may have added elements like metals
and clays designed to give metallic or pastel appearances that simply can’t
be replicated by combining cyan, magenta, yellow, and black. Similarly, some

colors (like several hues of orange and green) can’t be accurately created

using the CMYK colors.

The bad way to create colors

Many people try to use the Color panel
(Window=>Color [F6]) to define colors, which
can be a mistake. At first, you may not realize
thatyou can create colors from the Color panel.
It shows a gradation of the last color used and
lets you change the tint for that color on the
current object. But if you go to its flyout menu
and choose a color model (RGB, CMYK, or Lab),
you get a set of mixing controls.

So what's the problem? Colors created through
the Color panel won't appear in your Swatches
panel, so they can't be used for other objects.
They're called unnamed colors because they
don’t appear in the Swatches panel, but may be
used by objects in a document, which can cause
problems when you print. (Adobe added them to
InDesign to be consistent with how lllustrator
defines colors — a foolish consistency.)

Fortunately, you can prevent unnamed colors:
If you go to the Color panel and modify a color

without thinking about it, choose Add Unnamed
Colors from the Swatches panel’s flyout menu
to add the modified color to the Swatches panel.
Of course, if you forget to do so, you have an
unnamed color, so it's best to think Swatches
panel when you think about adding or editing
colors instead of the more obvious Color panel.
Even better, close the Color panel so thatyou're
not tempted to use it in the first place.

Similarly, don’t use this InDesign feature: the
ability to create colors by double-clicking the
Stroke and Fill buttons on the Tools panel, using
a Photoshop-style color picker. As with colors
created in the Color panel, you can rectify this
sin by adding any colors created this way to the
Swatches panel by using the Swatches panel’s
Add Unnamed Colors menu item. Otherwise, you
run the same risk as creating colors through the
Color panel.
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Using Kuler colors

ATURE There’s a Web site out there that lets users share palettes of colors they've
created. The idea is to give people with little fashion sense sets of colors that
work well together. InDesign CS4 lets you tap into these colors and add them
to your Swatches panel, using the Kuler panel (Windowr>Extensionst>Kuler)

You go to the Browse pane in the Kuler panel and choose from the color
swatch palettes — called themes — already there. You can use the unlabeled
pop-up menus at the top and the search field to narrow down your choices.
Click one you want and then click the Add Selected Theme to Swatches
iconic button at the bottom right of the panel. Repeat for each theme you
want to copy.

You can create your own themes in the Create pane (as well as edit an exist-
ing theme; click the Create Theme in Create Pane iconic button in the Browse
pane to do so). The options are mostly for expert users, but the principles
aren’t too hard: For each of the five color swatches, use the color wheel to
select new values or drag its current color (the circles) to a new location on
the wheel. Click the Add Selected Theme to Swatches iconic button at the
bottom right of the panel. You can also save the themes and upload them to
the Kuler site for other users to enjoy.

Figure 6-3 shows both the Browse and Create panes of the Kuler panel.

® W
9 KULER | | [#KuLer |

[ About [ Browse | Create | [ About | Browse | Creaw |

| Highest Rated - HAII Time v‘

B T Firenze v
[ T7 T sandy stone be...
B T T[] watermeion

[N orange on olive
B[] oo
BT [ | Kobenhavn Pop
T --=rese Carden
LT T T Il cranny Smith A...

[»

Figure 6-3:
The Kuler
panel lets
you copy

predefined

themes
(left) — sets
of colors —

aswell as
R — 255
create and AL ]

176
even share || = —
BO3B

&

Control the amount of black
‘ in the color

Base Color
-

N [

% 5 © 4 &

your own
(right).




Chapter 6: Working with Color 1 05

Creating mixed colors

InDesign offers another type of color: mixed-ink color. Essentially, a mixed-
ink color combines a spot color with the default process colors (cyan,
magenta, yellow, and black) to create new color swatches. For example, you
can combine 100 percent Pantone Yellow with 10 percent Deep Brown to get
a darker version of yellow (called a duotone, though InDesign doesn’t limit
you to mixing spot colors with just black, as traditional duotones do).

To create a mixed-ink swatch, add a spot color swatch if none exists and then
follow these steps:

1. Choose New Mixed Ink Swatch from the Swatches panel’s flyout menu.
The New Mixed Ink Swatch dialog box appears, as shown in Figure 6-4.

2. Select the percentages of the spot color and any or all of the default
process colors you want to mix and give the new color a name.

3. Click Add to add another mixed-ink swatch based on the current spot
color.

If you're creating just one color, click OK instead of Add. You can click
Cancel to abort the current mixed-ink color definition.

4. Click OK when you’'re finished.

|

Figure 6-4:
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New Mixed Ink Group, a related option in the Swatches panel’s flyout menu,
lets you create a set of colors from the same mix. You get to set the initial
percentage of each color you want in the mix and the final value, as well as
how many increments of each color you want. InDesign then takes all this
information and creates a bunch of color swatches that combine each of the
colors at each level so that you get a whole range of colors. The idea is to get
a set of related colors created for you, such as a set of blue-green hues that
range from light aqua to dark marine. Experiment with this expert feature to
see what it can do for you.

Defining Tints

|
Figure 6-5:
The New
Tint Swatch
dialog box
lets you
define
colors; a
nearly
identical
dialog box
named
Swatch
Options lets
you edit
them.
|

A tint is simply a shade of a color. InDesign lets you create such tints as separate
color swatches — like any other color — so they're easy to use for multiple
items. The process is easy:

1. In the Swatches panel, select a color from which you want to create a
tint.

2. Using the Swatches panel’s flyout menu, select New Tint Swatch.
The New Tint Swatch dialog box, shown in Figure 6-5, appears.

3. Click and drag the slider to adjust the tint or type a value in a field on
the right.

4. Click Add to create another tint from the same base color and then
click OK when you’re finished.

(If you're adding a single tint, you don’t need to click Add; just click OK
when done.)

New Tint Swatch
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Click Cancel if you change your mind about the current tint. Any new
tint will have the same name as the original color and the percentage of
shading, such as Sky Blue 66%.

You can create a tint from a tint, which can be confusing. Fortunately,
InDesign goes back to the original color when letting you create the new
tint. Thus, if you select Sky Blue 66% and move the slider to 33%, you get
a 33 percent tint of the original Sky Blue, not a 33 percent tint of the Sky
Blue 66% (which would be equivalent to a 22 percent tint of the original
Sky Blue).

You modify and delete tint swatches like any other color swatch, using the
Swatches panel’s flyout menu.

<P You can also apply tints to objects without creating a separate swatch for
each tint. After applying the color (described in the “Applying swatches” sec-
tion, later in this chapter), select the object and change the value in the Tint
field of the Swatches panel or use its pop-up menu’s predefined tint values.
Easy as pie!

Working with Gradients

A long-popular design technique is the gradient (also called a blend or gradu-
ated fill), which blends two or more colors in a sequence, going smoothly
from, say, green to blue to yellow to orange. InDesign has a powerful gradient-
creation feature that lets you define and apply gradients to pretty much any
object in InDesign, including text, lines, frames, shapes, and their outlines
(strokes).

Creating gradient swatches

In the Swatches panel, where you define colors and tints, you can also define
gradients. Just select the New Gradient Swatch option in the flyout menu.
You get the dialog box shown in Figure 6-6. The first two options are straight-
forward, but the rest of the controls are tricky, so pay close attention:

1. Type a name for the gradient in the Swatch Name field.

Picking a name is a bit more difficult than naming a color, but use some-
thing like “Blue to Red” or “Bright Multihue” or “Logo Gradient” that has
a meaning specific to the colors used or to its role in your document.

2. In the Type pop-up menu, choose Linear or Radial.

A linear blend goes in one direction, while a radial blend radiates out in
a circle from a central point.
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|
Figure 6-6:
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3. Select a stop point — one of the squares at the bottom of the dialog

box on either end of the gradient ramp (the gradient ramp shows the
gradient as you define it).

The stop points essentially define the start color (the stop point on the
left) and the end color (the stop point on the right). With a stop point
selected, you can now define its color.

4. In the Stop Color pop-up menu, choose what color model you want to

use — select from CMYK, RGB, Lab, and Swatches — for the selected
stop point.

The area directly beneath the pop-up menu changes accordingly, dis-
playing sliders for CMYK, RGB, or Lab, or a list of all colors from the
Swatches panel for Swatches, depending on which model you choose.

5. Create or select the color you want for that stop point.

If you selected Swatches in the Stop Color pop-up menu, you can select
the [Paper] swatch — essentially, transparency or no color — as a stop
point in a gradient. (Note that you may have to scroll through the list
of swatches to find it; it’s near the top of the swatch list.) You can also
click and drag swatches from the Swatches panel to the gradient ramp.

6. Repeat Steps 3 to 5 for the other stop points (you can have several).

Note that the color models for the two stop points don’t have to be the
same — you can blend from a Pantone spot color to a CMYK color, for

example. (If a gradient mixes spot colors and process colors, InDesign

converts the spot colors to process colors.)
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You now have a simple gradient. But you don’t have to stop there. Here are
your other options:

» You can change the rate at which the colors transition by sliding the
location controls (the diamond icons) at the top of the gradient ramp.

»* You can create additional stop points by clicking right below the gradient
ramp. By having several stop points, you can have multiple color transi-
tions in a gradient. (Think of them like tab stops in text — you can define
as many as you need.) You delete unwanted stop points by clicking and
dragging them to the bottom of the dialog box.

Notice that a location control appears between each pair of stop points —
that means each pair can have its own transition rate.

When you create a new gradient, InDesign uses the settings from the last one
you created. If you want to create a gradient similar to an existing one, click
that existing gradient before selecting New Gradient Swatch from the flyout
menu. InDesign copies the selected gradient’s settings to the new one, which
you can then edit. For example, you would first click a linear gradient and then
select New Gradient Swatch to create a radial version of that existing linear
gradient.

The Swatches panel shows the actual gradient next to its name. The pattern
also appears in the Fill button or Stroke button in the Tools panel if that gra-
dient is currently selected as a fill or stroke, as well as in the Gradient button
in that panel, whether or not it’s currently applied as a fill or stroke.

Understanding the Gradient panel

Just as it does with unnamed colors, InDesign lets you create unnamed
gradients — gradients that have no swatches. Unlike unnamed colors, you
can use these to your heart’s content because all colors in a gradient are
converted to process colors and/or use defined spot-color swatches — so no
unnamed colors are in their output. The process is pretty much the same as
creating a gradient swatch (covered in the previous section, “Creating gradi-
ent swatches”), except that you select an object and then open the Gradient
panel (Window=>Gradient). In that panel, you select a stop point and then
choose a color to apply to it by clicking a color in the Swatches panel or in
the Color panel. You create and adjust stop points here just as you do when
defining a gradient swatch.

The difference? You can reuse gradients in the Swatches panel, whereas you
can’t reuse gradients applied through the Gradient panel. But you can add
them to the Swatches panel by Control+clicking or right-clicking the gradi-
ent in the Tools panel’s Fill or Stroke iconic button and then choosing Add to
Swatches in the contextual menu that appears.
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The Gradient panel can also manipulate gradient swatches: After you
apply a linear gradient — whether via a gradient swatch or as an unnamed
gradient — you can change the angle of the gradient, rotating the gradi-
ent within the object. Just type the desired degree of rotation in the Angle
field to rotate the gradient’s direction by the value. Negative values rotate
counterclockwise, whereas positive values rotate clockwise.

Note that you can’t rotate a radial gradient because it’s circular and, thus,
any rotation has no effect. That’s why InDesign grays out the Angle field for
radial gradients.

But you can still adjust the location of a radial gradient — as well as that of a
linear gradient — by using the Gradient tool in the Tools panel. After apply-
ing a gradient to an object, select the Gradient tool and draw a line in the
object, as shown in Figure 6-7:

v For a linear gradient, the start point of your line corresponds to where
you want the first stop point of the gradient to be; the end point of the line
corresponds to the last stop point. The length of the line determines how
stretched or compressed the gradient is, while the starting point of the
line determines how much the gradient is offset within the object. Also,
the angle at which you draw the line becomes the angle for the gradient.




Chapter 6: Working with Color

WMBER
&‘&‘
&

v For aradial gradient, the line becomes the start and end point for the
gradient, in effect offsetting it.

The Gradient Feather tool — accessed through the Gradient tool’s pop-out
menu or via the shortcut Shift+G — acts just like the Gradient tool except that
it starts with transparency as the initial “color,” as shown in Figure 6-7. See
Chapter 8 for more on gradient feather and other lighting effects.

Managing Swatches

WBER
“&
&

When you create colors, tints, and gradients, don’t go overboard and make
too many. You'll also find that different documents have different colors,
each created by different people, and you'll likely want to move colors from
one document to another. InDesign provides basic tools for managing colors
in and across documents.

Editing swatches

Modifying a swatch to change its settings is simple: Just double-click it in the
Swatches panel. (You can also choose Swatch options from the Swatches
panel’s flyout menu.) The Swatch options dialog box appears, a clone of the
New Color Swatch, New Tint Swatch, or New Gradient Swatch dialog box
(based on what kind of swatch you double-clicked).

The New Swatch and the Swatch Option dialog boxes do have a slight differ-
ence: The Swatch Option dialog boxes include the Preview option, which lets
you see your changes in a selected object (if it’s visible on-screen, of course)
as you make changes in the Swatch Options dialog box.

Copying swatches

To duplicate a swatch so that you can create a new one based on it, use the
Duplicate Swatch option in the Swatches panel. The word copy is added to
the name of the new swatch. You edit it — including its name — as you would
any swatch.

When selecting swatches for deletion or duplication, you can 38+click

or Ctrl+click multiple swatches to work on all of them at once. Note that
Shift+clicking selects all swatches between the first swatch clicked and the
swatch that you Shift+click, whereas 88+click or Ctrl+click lets you select spe-
cific swatches in any order and in any location in the panel.

111
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Deleting swatches

InDesign makes deleting swatches simple: Just select the color, tint, or gradi-
ent in the Swatches panel. Then choose Delete Swatch from the flyout menu
or click the trash can iconic button at the bottom of the Swatches panel.

Well, that’s not quite it. You then get the Delete Swatch dialog box, which
lets you either assign a new color to anything using the deleted swatch (the
Defined Swatch option) or leave the color on any object that is using it but
delete the swatch from the Swatches panel (the Unnamed Swatch option).
(As explained in this chapter’s sidebar “The bad way to create colors,” you
should avoid unnamed colors so don’t choose the Unnamed Swatch option.)

If you delete a tint and replace it with another color, any object using that
tint will get the full-strength version of the new color, not a tint of it. Likewise,
if you delete a color swatch that you've based one or more tints on, those
tints will also be deleted if you replace the deleted swatch with an unnamed
swatch. However, if you delete a color swatch and replace it with a defined
swatch, any tints of that deleted swatch will retain their tint percentages of
the replacement-defined swatch.

InDesign offers a nice option to quickly find all unused colors in the Swatches
panel: the flyout menu’s Select All Unused option. With this option, you can
delete all the unused colors in one fell swoop. Note that you don’t get the
option to assign each deleted color separately to another color in the Delete
Swatch dialog box — they all are replaced with the color you select or are
made into unnamed colors. Because no object uses these colors, choosing
Unnamed Swatch in essence is the same as replacing them with a color using
the Defined Swatch option.

If you delete a swatch and replace it with an unnamed swatch, you can recap-
ture that deleted swatch later by choosing the Add Unnamed Colors menu
item in the Swatches panel’s flyout menu.

Importing swatches

A quick way to import specific colors from another InDesign document or
template is to click and drag the colors from that other file’s Swatches panel
into your current document or template.

You can import colors from other Creative Suite programs from which

you have saved Adobe Swatch Exchange color library files, choosing Load
Swatches from the Swatches panel’s flyout menu. You can also import
swatches directly from other InDesign documents. From the resulting dialog
box, navigate to the file that contains the colors you want to import, select
that file, and click Open.
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When you import color swatches from other documents or Adobe Swatch
Exchange files, InDesign brings in all the colors. You can’t choose specific

colors to import.

Also, when you import a graphic file in PDF or EPS format, any named colors
(swatches) in that file are automatically added to the Swatches panel.

You can also use the new Kuler panel to import sets of color swatches. (For
more on that topic, see the section “Using Kuler colors,” earlier in this chapter.)

You

any

exp

1.

Sampling colors

may wonder how you can use colors in your

imported graphics for which InDesign can't find

swatch information, such as in TIFF files or

photos embedded in a PDF file. As you may

ect, InDesign provides a way to capture

these colors: the Eyedropper tool. Here's how
it works:

In the Tools panel or Swatches panel,
choose the Fill iconic button or Stroke
iconic button.

It doesn't really matter which button you use
unless you'llimmediately create a shape or
enter text after capturing the desired color;
in that case, choose whichever aspect
you'll want the new object or text to have
the color applied to.

. Select the Eyedropper tool and then click

the graphic where the desired color is
used.

The Fill or Stroke iconic button now has that
color. (If the Eyedropper tool isn't visible in
the Tools panel, look for the Measure tool
and then click and hold down its icon to get
the pop-up menu that lets you select the
Eyedropper tool.)

3. The Eyedropper tool changes to the Marker
tool.

Any object you select with the Marker
tool will have the color applied to its fill or
stroke, depending on whether the Fill or
Stroke iconic button is active. Note that you
can switch between the Eyedropper and
Marker tools to select different colors and
apply them by holding the Option or Alt key
to get the Eyedropper tool back and then
releasing it to switch to the Marker tool.

4. To add the new, unnamed color to the
Swatches panel, Control+click or right-
click the Fill iconic button or Stroke iconic
button (whichever has the captured color)
and choose Add to Swatches from the con-
textual menu that appears.

Now you can edit and apply the captured
color like any other color swatch.

The following figure shows a composite image
that highlights the Eyedropper tool at center left
(over the cat's ID tag) and the Marker tool at
right (over the rectangle at the bottom).

(continued)
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Exporting swatches
You can do more than import swatches. InDesign also lets you save swatches
into color library files for use by other Creative Suite users. Just select the
colors you want to save and then choose Save Swatches from the Swatches
panel’s flyout menu. You are asked to give the color library file a name before
you save it.
Q‘N\BER . - . .
é‘,\“ InDesign doesn’t include mixed-ink colors when you save swatches for use

by other Creative Suite programs. Any selected such swatches are simply
ignored.
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Applying Swatches
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Applying colors, tints, and gradients to objects in InDesign is quick work.
Select the object and then click the Formatting Affects Text button or
Formatting Affects Container iconic button in the Swatches or Gradient panel
as appropriate. If you're using the Swatches panel, click the appropriate
swatch; if you're using the Gradient panel, adjust the gradient as desired.

When it comes to coloring graphics in InDesign, you can apply color and tints
to grayscale and black-and-white bitmapped images, such as those in the TIFF
and Photoshop formats. But you can’t color vector-based graphics (such as
those in the lllustrator and EPS formats) or color bitmapped images.

Another way to apply colors, tints, and gradients is by selecting the object
and using the Formatting Affects Text, Formatting Affects Content, Fill, or
Stroke iconic buttons in the Tools panel to define what part of the object
you want to color. You can use the Swatches or Gradients panels to select
a swatch or pick the last-used color and gradient from the Apply Color and
Apply Gradient iconic buttons near the bottom of the Tools panel.

For tints, you can use a tint swatch, or you can simply apply a color from the
Swatches panel and enter a tint value in the panel’s Tint field.

When applying color to text, you can apply it to all the text in the frame

by using the Formatting Affects Text iconic button (which is what the
Formatting Affects Contents iconic button is renamed when you select text)
or to specific text by highlighting that text with the Type tool.

You can also apply color as part of your character and paragraph styles in the
Character Color pane when creating or editing styles. See Chapter 13 for more
on styles, and Chapters 14 through 16 for more on text formatting.

You can also apply colors and tints to gaps in strokes. Open the Stroke panel
by choosing Window=>Stroke (88+F10 or Ctrl+F10), then select a color in the
Gap Color menu (if you don’t see this option in the Stroke panel, select Show
Options from the panel’s flyout menu).
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In this part . . .

T]e rubber really hits the road when you’ve got your
basic layout structure in place. Now you can focus on
the meat of your documents: the objects that contain your
text and graphics. It’s amazing all the objects you can
create — from simple rectangles to complex curves. And
it’s equally amazing all the things you can do to objects,
such as rotate them, color and align them, and apply
special effects, such as drop shadows and directional
feathers. And you can even save a lot of these settings so
that you can apply them consistently to other objects
later — a real timesaver that also ensures quality results.

Note that you can apply most of these effects to objects
whether or not they already contain their graphics and
text — so if you're a really structured kind of person,
you'll probably create your basic object containers first,
apply your effects to them, and then bring in the text and
graphics. But if you’re more free-form in your approach,
you’ll likely bring in all your text and graphics and then
start arranging the objects that contain them to produce
your final layout. That'’s fine. Either way, you just apply
the techniques in this part while doing so.




Chapter 7
Adding Essential Elements

In This Chapter

Creating frames and shapes
Making lines and paths
Using strokes

' he fundamental components of any layout are its objects. This chapter
explains how to create these building blocks: frames, shapes, lines, and
paths, as well as the strokes you apply to them.

Working with Frames and Shapes

An object is a container that can (but doesn’t have to) hold text or graphics,
as well as display attributes such as color, strokes, and gradients. When an
object contains an imported graphic or text, or if an object is created as a
placeholder for a graphic or text, it’s referred to as a frame in InDesign.
Otherwise, it’s called a shape.

“&N\BEH The difference between frames and shapes is artificial. Because a shape can
& easily become a frame simply by placing text or graphics into it, it’s easiest to
think of shapes and frames as the same thing. [ tend to use the word “frame”
to mean either frames or shapes.

Designing pages in InDesign is largely a matter of creating and modifying

frames and shapes, as well as modifying the text and graphics that the frames
contain.

Creating frames and shapes

As Figure 7-1 shows, the Tools panel contains several tools for creating both
shapes and frames:
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The

frame- and
shape-
creating
tools in the
Tools panel,
aswell as
the other
tools to
create and
manipulate
lines and
paths.
|

7

’/

17

1.
2.

The Rectangle, Ellipse, and Polygon shape tools: The Ellipse and
Polygon tools are available through the pop-up menu that appears if you
click and hold on the Rectangle tool.

The Rectangle Frame, Ellipse Frame, and Polygon Frame tools: The
Ellipse Frame and Polygon Frame tools are available through the pop-up
menu that appears if you click and hold on the Rectangle Frame tool.

The Type tool: You can use this tool to create rectangular text frames in
addition to letting you work with text.

Here’s how to create a frame (or shape):

Select the desired tool from the Tools panel.

Optionally, set up the polygon’s number of sides and the depth of its
spikes.

To do so, double-click the tool you're using (Polygon or Polygon Frame)
so the Polygon Settings dialog box appears. Figure 7-2 shows that dialog
box and example starburst. Adjust the number of sides and their depth
(the Star Inset field) as desired and then click OK. If you don’t adjust
the polygon’s settings and instead just begin drawing on as in the next
steps, InDesign will use the last-used settings for the selected tool.
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Figure 7-2:
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3. Move the mouse pointer anywhere within the currently displayed
page or on the pasteboard.

4. Click and drag in any direction.

As you drag, a crosshair pointer appears in the corner opposite your
starting point; a colored rectangle indicates the boundary of the frame.
(The color is blue for objects on the default layer; objects on other
layers have that layer’s color. See Chapter 4 for more on layers.) You
can look at the width and height values displayed in the Control panel or
the Transform panel as you drag to help you get the size you want.
Holding down the Shift key as you drag limits the tool to creating a
frame or shape within a square bounding box.

5. When the frame is the size and shape you want, release the mouse
button.

Pretty easy, huh? At this point, you can begin typing in the frame, paste text
or a graphic into it, or import a text or a graphics file, as Chapters 10 and 16
explain.

If you create a text frame with the Type tool, be sure not to click in an existing
text frame when your intention is to create a new one. If you click within an
existing frame when the Type tool is selected, the flashing cursor appears, and
InDesign thinks you want to type text.

When any of the frame-creation tools is selected, you can create as many new
frames as you want. Simply keep clicking, dragging, and releasing. After you
create a graphics frame, you can modify it (without changing tools) by adding
a border or a colored background or by applying any of the effects — such as
rotation, shear, and scale — in the Control panel. You can also move or
resize a graphics frame, but you have to switch to the Selection tool or the
Direct Selection tool to do so. Chapter 8 explains how to resize, move, delete,
and otherwise manipulate frames and other objects.
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Reshaping frames and shapes

Sometimes, a frame or shape needs to be more than resized or moved. It
needs to be reshaped. InDesign makes it easy to change an object’s shape:

v The simplest way is to select an object with the Direct Selection tool and
then drag any of the handles or frame edges. Notice how the frame’s
shape actually changes, as shown in Figure 7-3.

v To change a shape more radically, choose the desired shape from
Object=>Convert Shape’s submenu. Your choices are Rectangle,
Rounded Rectangle, Beveled Rectangle, Inverse Rounded Rectangle,
Ellipse, Triangle, Polygon, Line, and Orthogonal Line. (Note that if you
choose Polygon, InDesign will use whatever the last polygon settings
were, which you can see by double-clicking the Polygon or Polygon
Frame tool. Also, if you try to convert a text frame into a line, InDesign
will abort the action, telling you it can’t do the conversion.)

» You can manually edit a shape by adding or removing anchor points —
the points in a shape’s edges that you can adjust, as described in the
next section.

InDesign has a quick way to switch between the Selection tool and the Direct
Selection tool: Just double-click an object. (Of course, the Direct Selection tool
has no effect on text frames, so double-clicking an object selected with the
Selection tool changes you to the Type tool instead.)

Creating Lines and Paths

When you’re drawing the old-fashioned way, with pen and paper, you typi-
cally use one tool to draw straight lines, curved lines, and free-form objects.
InDesign is less flexible, using different tools for different kinds of lines.
InDesign lets you create straight lines with the Line tool and zigzag lines,
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curved lines, and free-form shapes with the Pen and Type on a Path tools.
(Those nonstraight lines and free-form shapes are called paths in InDesign.)
Figure 7-1, earlier in this chapter, shows these tools on the Tools panel.

Drawing a straight line

Although not as flashy or versatile as shapes and paths, lines can serve many
useful purposes in well-designed pages. For example, you can use plain ol’
vertical rules to separate columns of text in a multicolumn page or the rows
and columns of data in a table. Dashed lines are useful for indicating folds
and cut lines on brochures and coupons. And lines with arrowheads are
handy if you have to create a map or a technical illustration.

Follow these steps to draw a simple, straight line:

1. Select the Line tool (or press \).

2. Move the pointer anywhere within the currently displayed page or on
the pasteboard.

3. Click and drag the mouse in any direction.

As you drag, a thin, blue line appears from the point where you first
clicked to the current position of the cross-hair pointer. Holding down
the Shift key as you drag constrains the line to a horizontal, vertical, or
45-degree diagonal line.

4. When the line is the length and angle you want, release the mouse
button.

Don’t worry too much about being precise when you create a line. You
can always go back later and fine-tune it.

When you release the mouse button after creating a line, the line is active. As
illustrated in Figure 7-4, if the Selection tool was previously selected, the line
appears within a rectangular bounding box, which contains eight resizing
handles. If the Direct Selection tool was previously selected, moveable
anchor points appear at the ends of the line. In either case, you have to
choose the right tool if you want to change the shape or size of the bounding
box or the line:

v The Selection tool lets you change the shape of the line’s bounding box
(which also changes the angle and length of the line) by dragging any of
the resizing handles.

v The Direct Selection tool lets you change the length and angle of the line
itself by moving anchor points on the frame.

As long as the Line tool is selected, you can create as many new lines as you
want. Simply keep clicking, dragging, and releasing.
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When you create a line, it takes on the characteristics specified in the Stroke
panel (Window=>Stroke [38+F10 or Ctrl+F10]), covered in the “Applying
strokes” section later in this chapter. When you first open a document, the
default line width is 1 point. If you want to change the appearance of your
lines, double-click the Line tool and adjust the Weight setting in the Stroke
panel that appears. If you make this adjustment when no document is open,
all new documents will use the new line settings.

Understanding paths

Paths are a lot more complex than lines, so you need to understand some of
the theory behind paths so that you can create and manipulate them more
easily.

Every object you create with InDesign’s object-creation tools is a path.
Regardless of the tool you use to create a path, you can change its
appearance by modifying any of four properties that all paths share:

v Closure: A path is either open or closed. Straight lines created with the
Line tool and curved and zigzag lines created with the Pen tool are
examples of open paths. Basic shapes created with the Ellipse,
Rectangle, and Polygon tools and free-form shapes created with the Pen
and Pencil tools are examples of closed shapes. A closed free-form shape
is an uninterrupted path with no end points.

v Stroke: If you want to make a path visible, you can apply a stroke to
it by selecting it with a selection tool, entering a Weight value in the
Stroke panel (Window=>Stroke [8+F10 or Ctrl+F10]), and selecting a
color from the Swatches panel (see Chapter 6). (An unselected,
unstroked path isn’t visible.)
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v Fill: A color, color tint, or gradient applied to the background of a path
is called a fill. You apply fills by using the Swatches panel.

1 Contents: You can place a text file or a graphics file in any path except a
straight line. When a path holds text or a graphic, the path functions as
a frame. Although InDesign can place text or graphics in an open path,
placing text and pictures in closed paths is far more common than
placing them in open paths. In addition to putting text inside paths, you
can also have text on the path itself, following its shape, as Chapter 17
explains.

No matter how simple or complicated, all paths are made up of the same
components. Figure 7-5 shows the parts that make up a path:

v A path contains one or more straight or curved segments.

v An anchor point is located at each end of every segment. The anchor
points at the ends of a closed path are called end points. When you
create a path of any kind, anchor points are automatically placed at
the end of each segment. After you create a path, you can move, add,
delete, and change the direction of corner points.

v InDesign has two kinds of anchor points: smooth points and corner
points. A smooth point connects two adjoining curved segments in a
continuous, flowing curve. At a corner point, adjoining segments —
straight or curved — meet at an angle. The corners of a rectangular path
are the most common corner points.

v A direction line runs through each anchor point and has a handle at both
ends. You can control the curve that passes through an anchor point by
dragging a direction line’s handles, as I explain a little later on.

Figure 7-5:
Anchor
points can
be corner
or smooth,
resulting
in angular
(top) or
curved
(bottom)
connections
between
segments. End point Anchor point
|
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Drawing your own paths

Even if you're an artistic master with a piece of charcoal or a No. 2 pencil,
you need to practice with the Pen tool for a while before your drawing skills
kick in. The good news is that after you get comfortable using the Pen tool,
you can draw any shape you can imagine. (Of course, if you can’t draw very
well in the first place, using the Pen tool won’t magically transform you into a
master illustrator!) If creating a free-form path is new terrain for you, start
simply and proceed slowly.

When creating paths, use as few anchor points as possible. As you become
more comfortable creating free-form paths, you should find yourself using
fewer anchor points to create paths.

For an easy way to draw free-form shapes, use the Pencil tool. This tool simply
traces the movement of your mouse (or pen tablet) as you move it, much like
a pencil works on paper. Although not as exact as the Pen tool, the Pencil tool
creates Bézier curves that you can later edit. Note that the Pencil tool is not
meant for creating straight lines — unless you’re capable of drawing perfectly
straight lines by hand, that is.

Straight and zigzag lines
Follow these steps to draw lines with straight segments, such as a zigzag:

1. Select the Pen tool.
2. Move the Pen pointer to where you want to start your line segment.
3. Click and release the mouse button.
Make sure that you don’t drag before you release the mouse button.
An anchor point appears; it looks like a small, filled-in square.

4. Move the Pen pointer to where you want to place the next anchor
point.

5. Click and release the mouse button.

InDesign draws a straight line between the two anchor points. The first
anchor point changes to a hollow square, and the second anchor point
is filled in, which indicates that it’s the active anchor point.

6. Repeat Steps 4 and 5 for each additional anchor point.

To reposition an anchor point after you click the mouse button but
before you release it, hold down the spacebar and drag. Otherwise, you
need to select it with the Direct Selection tool after you finish drawing
the line and then click and drag it to its new location.



Chapter 7: Adding Essential Elements

How smooth and corner points work

Bézier paths have two kinds of points to join
segments: corner and smooth.

The two segments that form a smooth point's
direction line work together as a single, straight
line. When you move a handle, the line acts like
a teeter-totter; the opposite handle moves in
the opposite direction. If you shorten one of the
segments, the length of the other segment
doesn’t change. The angle and length of

direction lines determine the shape of the seg-
ments with which they’re associated.

A corner point that connects two curved seg-
ments has two direction lines; a corner point
that connects two straight segments has no
direction lines; and a corner point that connects
a straight and curved segment has one direc-
tion line. If you drag a corner point’s direction
line, the other direction line, if there is one, isn’t
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affected.

7. To complete the path, 88+click or Ctrl+click elsewhere on the page or
simply choose another tool.

If you 88+click or Ctrl+click, the Pen tool remains active, so you can
continue creating new paths.

Curved lines

Knowing how to draw zigzag lines is fine (see preceding section), but chances
are, you want to draw curved shapes as well. The basic process is similar to
drawing straight segments, but drawing curved paths (technically called
Bézier paths) is more complicated and will take you some time to get the
hang of.

If you want to draw a continuously curvy path that contains no corner points
and no straight segments, you should create only smooth points as you draw.
Here’s how:
1. Select the Pen tool.
2. Move the Pen pointer to where you want to start the curve segment.
3. Click and hold down the mouse button.
The arrowhead pointer appears.

4. Drag the mouse in the direction of the next point you intend to create
and then release the mouse button.

As you drag, the anchor point, its direction line, and the direction line’s
two handles are displayed, as shown in Figure 7-6.
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If you hold down the Shift key as you drag, the angle of the direction line
is limited to increments of 45 degrees.

5. Move the Pen pointer to where you want to place the next anchor

point — and end the first segment — and then drag the mouse.

If you drag in roughly the same direction as the direction line of the
previous point, you create an S-shaped curve; if you drag in the opposite
direction, you create a C-shaped curve.

. When the curve between the two anchor points looks how you want it
to look, release the mouse button.

Alternatively, when you want to connect curved segments to corner
points (shown in Figure 7-7), move the Pen pointer to where you want to
place the next anchor point — and end the first segment — and then
press and hold Option or Alt as you click and drag the mouse. As you
drag, the anchor point’s handle moves, and the direction line changes
from a straight line to two independent segments. The angle of the direc-
tion line segment that you create when you drag the handle determines
the slope of the next segment.
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7. Repeat Steps 5 and 6 for each additional desired curved segment.

8. To complete the path, 38+click or Ctrl+click elsewhere on the page or
simply choose another tool.

If you 38 +click or Ctrl+click, the Pen tool remains active, so you can
create new paths.

You can also complete the path by clicking the first point you created,
which creates a closed path.

If you create two open paths that you want to join together into one path,

you can do so in InDesign CS4 by selecting the two paths and then choosing
Object>Pathsc>Join. InDesign usually joins the two closest points with a
straight line, but it sometimes joins the last point of the first path and the first
point of the second path.

Do note that if you try to join a text path with a regular path, the text will be

deleted if it’s the second path selected. If you join two text paths, the second
path’s text will also be deleted. Finally, if you select three or more paths and
choose Object>Paths>Join, nothing will happen.

Closed paths

A closed path is simply a path that ends where it began. When it comes to
creating closed paths with the Pen tool, the process is exactly the same as
for creating open paths (such as curved lines and zigzag lines), as explained
in the “Curved lines” and “Straight and zigzag lines” sections, earlier in this
chapter, with one difference at the end:

v To create a straight segment between the end point and the last anchor
point you created, click and release the mouse button.

v To create a curved segment, click and drag the mouse in the direction of
the last anchor point you created and then release the mouse button.

Just like an open path, a closed path can contain straight and/or curved
segments and smooth and/or corner anchor points. All the techniques
explained earlier in this chapter for drawing lines with curved and straight
segments and smooth and corner points apply when you draw closed paths.

You can also, of course, edit and adjust your curves in InDesign, but doing so
requires some more expertise with drawing tools such as those in Adobe
llustrator and is beyond the scope of this book. Check out lllustrator CS4 For
Dummies by Ted Alspach or Adobe InDesign CS4 Bible by Galen Gruman
(both by Wiley Publishing) for more details.
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Applying Strokes

All objects have a stroke with a width of 0 built in, so you never really have to
add strokes. But to use them, you need to modify them so that they have
some thickness onto which you can apply attributes, such as colors and
gradients.

Setting stroke appearance

The Stroke panel is where you give the stroke its width, as well as apply the
type of stroke and other attributes:

1. Select either of the selection tools and click the object whose stroke
you want to modify.

2. If the Stroke panel isn’t displayed, show it by choosing
Window=>Stroke (88+F10 or Ctrl+F10).

Figure 7-8 shows the panel.

3. To change the width of the stroke, enter a new value in the
Weight field.

You can also change the Weight value by choosing a new value from the
field’s pop-up menu or by clicking the up and down arrows. (Each click
increases or decreases the stroke by 1 point.)

4. Set the Miter Limit.

The default of 4 is fine for almost all frames. You rarely need to use this
feature, so don’t worry about it.
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. Click any of the three Cap iconic buttons to specify how dashes will

look if you create a dashed stroke (covered in Step 9).

Experiment with them in your objects to see which looks best for your
situation.

. Click any of the three Join iconic buttons to specify how corners are

handled.

Again, experiment with these buttons to see what works best for you.

. Choose an Align Stroke option.

The default is the first button, Align Stroke to Center, which has the
stroke straddle the frame. You can also choose Align Stroke to Inside,
which places the entire thickness inside the frame boundary, or Align
Stroke to Outside, which places the entire thickness outside the frame
boundary.

. You can also choose end points for your strokes by using the Start and
End pop-up menus.

End points appear only on lines and other open paths, not on rectangles,
ellipses, and other closed-loop shapes.

Figure 7-9 shows the options.

. To create a dashed line instead of a solid line, choose an option from
the Type pop-up menu.
These options are also available from the Control panel.
Choose from 18 types of predefined dashes and stripes. The Gap Color
and Gap Tint fields at the bottom of the Stroke panel become active as

well, to let you choose a specific color and tint for the gaps in dashes
and stripes.
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Adding fills

The option to add a stroke to any shape becomes  Adding a fill to a shape is much like adding a

even more powerful when combined with the  stroke, and the options available for specifying

option to fill any shape with a color or tint. For  color and tint are identical. The only difference

example, adding a fill to a text frame is an effec- s thatyou click the Filliconic button in the Tools

tive way to draw attention to a sidebar. panel or Swatches panel rather than the Stroke
iconic button.

After you have a visible stroke, you want to color it. Here’s how:

1. Select either of the selection tools and click the frame to which you
want to add a stroke.

2. Click the Stroke iconic button in the Swatches panel or Tools panel.

3. Click a color, tint, or gradient from the Swatches panel; or click one
of the three boxes at the bottom of the Tools panel, which let you use
(from left to right) the last-selected color, last-selected gradient,
or None.

(The None option removes the stroke’s color, tint, or gradient.)

For information about adding colors to the Swatches panel and applying
colors to objects, see Chapter 6.

Creating stroke styles

InDesign lets you create custom strokes, known as stroke styles, in any of
three types: dashed, dotted, and striped. To create custom dashes or stripes,
choose the Stroke Styles option in the Stroke panel’s flyout menu. In the
resulting Stroke Styles dialog box, you can create new strokes, edit or delete
existing ones, and import strokes from a stroke styles file, which you create
by saving a document’s strokes as a separate file for import into other
documents. Stroke style files have the filename extension . inst.

Note that you can’t edit or delete the seven default stripe patterns shown

in the Stroke Styles dialog box, nor can you edit or delete the default dash
patterns — they’re not even available in the dialog box. When you edit or
create a stroke pattern, you get the New Stroke Style dialog box, shown in
Figure 7-10. In the Name field, enter a name for your stroke. In the Type
pop-up menu, you can choose to create (or convert a stripe you're editing to)
a dashed, dotted, or striped stroke.
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Figure 7-10:
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the New
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For dashes, you can resize the dash component by dragging the down-
pointing triangle at the end of the dash in the ruler section. You can add dash
segments by simply clicking the ruler and dragging a segment to the desired
width. Or you can use the Start and Length fields to manually specify them.
The Pattern Length field is where you indicate the length of the segment that
will be repeated to create a dashed line.

In the Corners pop-up menu, you tell InDesign whether to adjust how the
dashes and gaps are handled at corners; the default is Adjust Dashes and
Gaps, a setting you should keep — it will make sure that your corners have
dash segments that extend along both sides of the corner, which looks
neater. (Your other options are Adjust Dashes, Adjust Gaps, and None.) You
can also choose a cap style and the stroke weight. The preview section of the
pane lets you see your dash as you create or edit it.

For dots, you get a similar dialog box as for dashes. The Start and Length
fields disappear, replaced with the Center field that determines where any
added dots are placed on the ruler. (The initial dot, shown as a half-circle,
starts at 0 and can’t be moved or deleted.) The Caps field is also gone.

To delete a dash or dot segment, just drag it to the left, off the ruler.

For stripes, you also get a similar dialog box. The principle is the same as for
dashes: You create segments (in this case vertical, not horizontal) for the
stripes by dragging on the ruler. However, the stripes version of the dialog
box expresses its values in percentages because the actual thickness of each
stripe is determined by the stroke weight — the thicker the stroke, the
thicker each stripe is in the overall stroke.
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In all three versions of the New Stroke Style dialog box, you click Add to add
the stroke to your document, and then you can create a new stroke. When
you're done creating strokes, click OK. (When editing a stroke, the Add
button won’t be available.)

Be sure to use the Preview Weight slider shown in Figure 7-10. This slider is
available in all three versions of the New Stroke Style dialog box. It lets you
increase or decrease the preview size so that you can better see thin or small
elements in your stroke.



Chapter 8
Manipulating Objects

In This Chapter

Resizing, moving, and deleting objects
Keeping objects from printing
Rotating, shearing, and flipping objects
Changing object attributes

Applying special effects

Frames, shapes, lines, and paths are the building blocks of your layout.
But as anyone who ever played with Legos or Tinkertoys knows, it’'s how
you manipulate the building blocks that results in a unique creation, whether
it be a Lego house, a Tinkertoys crane, or an InDesign layout.

InDesign provides a lot of control over layout objects so that you can create
really interesting, dynamic publications suited to any purpose. In this
chapter, I explain the controls that apply to all objects.

This chapter focuses on various effects and actions that apply to any frame
or path. Chapter 16 covers various actions specific to text frames and paths,
while Chapter 18 covers actions specific to graphics frames. Chapter 7
explains how to add frames, shapes, lines, and paths in the first place.
Chapter 10 explains how to align objects and precisely position them.

Selecting Objects

Before you can manipulate an object, you have to select it so that InDesign
knows what you want to work on. To select an object (rather than its
contents), use the Selection tool. Selected items display their item boundary
(arectangle that encompasses the object), as well as eight small resizing
handles (one at each of the four corners and one midway between each side
of the item boundary). Figure 8-1 shows an example.
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To select an individual object, just click it with the Selection tool. To select
multiple objects, you have several options:

v Click the first object and Shift+click each additional object.

v Click and drag the mouse to create a selection rectangle (called a mar-
quee) that encompasses at least part of each desired object. When you
release the mouse, all objects that this marquee touches are selected.

v Choose Editm>Select All (38+A or Ctrl+A) to select all objects on the cur-
rent spread.

<P If an object is on a master page and you’re working on a document page, you
must Shift+38+click or Ctrl+Shift+click the object to select it. How do you know
whether an object is on a master page? Easy: If you try to select it by clicking
and it doesn’t become selected, it must be on a master page.

A\

Choose Viewr>Show Frame Edges (Control+8+H or Ctrl+H) to see object edges
if they aren’t already visible.

These options are pretty easy, but it can get tricky when you want to select
objects that overlap or are obscured by other objects. (See Chapter 10 for
more details on object stacking.) So how do you select them?
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One way is to use the Select Previous Object or Select Next Object iconic
buttons in the Control panel. (If you Shift+click either button, InDesign jumps
past four objects and selects the fifth one. If you 88+click or Control+click
either button, InDesign selects to the bottommost or topmost object, respec-
tively.) Note that the buttons don’t display when the default Essentials
workspace is in use; they do appear in the Advanced workspace, and you can
turn them on individually by modifying the Control panel’s appearance.
(Choose Customize from its flyout menu and then go to the Object section to
turn on the Select Container & Content option.)

If you use the Select Previous Object or Select Next Object iconic buttons and
reach the top or bottom of the object stack, InDesign cycles back. For exam-
ple, if you reach the topmost object and click Select Previous Object, InDesign
moves to the bottommost object.

Another way to select buried objects is by using the Select submenu option
in the Object menu.

The first four options in the Select submenu let you select another object
relative to the currently selected object:

v First Object Above (Option+Shift+88+] or Ctrl+Alt+Shift+]) selects the
topmost object.

v Next Object Above (Option+3+] or Ctrl+Alt+]) selects the object
immediately on top of the current object.

1 Next Object Below (Option+38+[ or Ctrl+Alt+]) selects the object
immediately under the current object.

v Last Object Below (Option+Shift+88+[ or Ctrl+Alt+Shift+[) selects the
bottommost object.

If no objects are selected, InDesign bases its selection on the order in which
the objects were created, the topmost object being the one that was most
recently created.

You can also access these four selection options by Control+clicking or
right-clicking an object and choosing the Select menu from the contextual
menu that appears.

The Select submenu has four other options:

v If you select an object’s content (text or graphic), choose
Object>Select>Container to choose the frame or path. Using this option
is the same as selecting the object with the Selection tool.

v~ If an object has content (text or graphic) and you select it, choose
Object=>Select=>Content to choose the content within the object. This
option is basically the same as selecting the frame with the Direct
Selection tool.
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v If you select an object in a group of objects by using the Direct Selection
tool, choose Object=>Select=>Previous Object in Group to navigate to the
previous object in the group.

v~ Similarly, if you select an object in a group of objects by using the Direct
Selection tool, choose Object=>Select>Next Object in Group to navigate
to the next object in the group.

The order in which the objects were created determines what is “previous” or
“next” in a group.

The Control panel also provides iconic buttons to select the next or previous
object, as well as to select the content or container (frame). These last two
buttons appear only if you've selected a group. The buttons for selecting the
next or previous object appear only if you're using the Direct Selection tool,
while the buttons for selecting the content or container appear whether
you're using the Selection or Direct Selection tool. (Yes, this interface
approach is very confusing!) Figure 8-2 shows the buttons.

The Select Next Object and Select Previous Object functions now work for
anchored objects in text. If you select an anchored object and use these
functions, InDesign CS4 will move to the next (or previous) anchored object in
the current story. (Chapter 10 covers anchored objects.)

To deselect objects, just click another object, an empty part of your page, or
the pasteboard. To deselect individual objects after you've selected multiple
objects, Shift+click those you want to deselect.
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s\gN\BEI? The Direct Selection tool lets you select any of the individual anchor points
& (and direction handles of free-form shapes and curved lines) on an object. If
you use the Direct Selection tool to click an object that has a bounding box,
the shape within is selected, and the bounding box is deselected. You use
this tool to work on the contents independently of its container frame.
You can also move a graphic within its frame by clicking within the object
(see Chapter 18).

Resizing and Scaling Objects

Two closely related features are resizing and scaling. What’s the difference?
Resizing affects just the container — the frame or path — whereas scaling
affects both the container and its contents.

Resizing objects

You resize objects in pretty much the same way you move them: by using the
mouse for inexact sizes or the Control panel for precise sizes.

To resize an object with the mouse, click and drag one of the frame’s (or
path’s) handles with the Selection tool. (Hold the Shift key as you drag to
maintain the proportions of the frame.) Drag a corner handle to resize both
the width and height or a side handle to resize just the height or width. This
method leaves the contents’ size unchanged but changes the size of the
frame or path.

\TUR,

‘Q@‘U\ ¢ InDesign CS4 now shows you the new dimensions as you scale an object via

< the mouse, with an information box that pops up near the control point you're
dragging, as Figure 8-1, earlier in this chapter, shows.
You can also enter new values in the W: and H: fields (for width and height) of
the Control panel. This action also doesn’t change the contents’ size.

QQ,N\BEH Remember those reference points for positioning an object from Chapter 1?
& They come into play for resizing objects as well. Basically, the object will grow

or shrink starting from the selected reference point, called the control point. So
if the upper-left reference point is selected and you enter greater W: and H:
values, the object will add the extra width to the right and the extra height
below. But if you choose the center reference point, it will grow on both sides
as well as on the top and bottom, spreading the extra size evenly.
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Another way to resize a frame — this method doesn’t apply to paths — is to
choose Objectr>Fitting=>Fit Frame to Content (Option+8+C or Ctrl+Alt+C).
For a graphic, this action makes the frame the same size as the graphic itself.
For text, it increases or decreases the depth of the text frame to match the
depth of the text; it doesn’t widen or narrow the frame.

Double-clicking one of a frame’s four handles — the squares at the midpoints
of each side — resizes the frame to the content in that axis. For example,
double-clicking the left or right handles fits the frame to the contents’ width,
while double-clicking the top or bottom handle fits the frame to the contents’
height. Likewise, double-clicking a corner handle resizes the frame in both
directions.

Scaling objects

InDesign offers several ways to scale an object, resizing both its contents and
its frame (or path):

v Enter percentage values in the Scale X Percentage and Scale Y
Percentage fields of the Control panel. If the icon to the right of these
fields shows a solid chain, adjusting one field automatically adjusts the
other by the same percentage, creating proportional resizing. If the icon
shows a broken chain, the two dimensions are resized independently,
distorting the contents. Click the iconic button to toggle between the
unbroken chain and broken chain icons.

» You can also scale an object using the mouse. Select the object with the
Selection tool, make sure that the desired control point is active to con-
trol where the scaling operation starts, and then select the Scale tool.
Now drag the mouse away from the object to enlarge it or into the object
to reduce it. Objects scaled this way are scaled unproportionally; to
scale the object proportionally, hold the Shift key when moving the
mouse. (You can also use the Free Transform tool in the same way.)

v For graphics frames, use the content-fitting options in the Object menu
and Control panel, described in Chapter 18.

Moving Objects

The easiest way to move an object is by using the mouse. With the Selection
tool, click an object and drag it to a new location. When you release the
mouse, the object is deposited in the new location.
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If you want to more precisely move an object, you can enter specific X: and Y:
coordinates in the Control panel, as explained in Chapter 10.

QUING/ Be sure to select the correct reference point to be used as the control point
S when entering coordinates. The little squares at the top left of the Control
panel and Transform panel represent the object’s reference points (corners,
side midpoints, and center). Click a reference point to make it the control
point (it turns black, the others turn white); all coordinates are now based on
this point.

Deleting Objects

Alas, not all the objects you create survive all the way to the final version of

your publication. Some wind up on the cutting room floor. You can always

move an object to the pasteboard if you're not sure whether you want to get

rid of it altogether. (Objects on the pasteboard don’t print.) But when it’s

time to ax an object, oblivion is just a keystroke or two away.

V?\‘\\1\16!

S If you delete a text or graphics frame or path, the contents are removed as
well as the frame.

Here’s how to delete objects: Using any selection tool, select the object or
objects you want to delete and then press the Delete key or Backspace key.
You can also delete a selected item by choosing Edit=>Clear.

<P Choosing Edit=>Cut (88+X or Ctrl+X) also removes a selected object. However,
in this case, a copy of the object is saved to the Clipboard, and you can paste
it elsewhere (by choosing Edit=>Paste [38+V or Ctrl+V]) until you cut or copy
something else, or you shut down your computer.

Preventing Objects from Printing

InDesign lets you prevent a specific object from printing. To do so, select the
object with the Selection or Direct Selection tool, open the Attributes panel
(Window=>Attributes), and then select the Nonprinting check box. (The other
settings in this panel duplicate stroke settings, covered in Chapter 7.)

You use this feature for comments and other elements that should not print
but that the designer needs to have visible on-screen. Another approach to

nonprinting objects is to place them all on a layer and make the entire layer
nonprinting, as explained in Chapter 4.
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Transforming Objects

A\

InDesign offers several tools and methods for transforming objects. I discuss
resizing, scaling, and moving earlier in this chapter, but you can also take
advantage of several other useful transformation tools, including rotating,
shearing (skewing), flipping, and reshaping.

Rotating is just spinning an object around. Shearing is a little more compli-
cated: Shearing skews an object (slanting it in one direction) while also
rotating the other axis at the same time.

Regardless of whether you use the mouse or numeric controls to apply rota-
tion and/or shearing to graphics, you first need to follow these steps:

1. Select the Selection tool.
2. Click the object you want to modify.
3. If you want, change the object’s control point.

By default, the control point is the upper-left corner of a frame or
shape. You can change the control point by clicking one of the little
black boxes — the reference points — in the upper-left corner of the
Control panel.

4. Choose the appropriate tool — Rotate, Shear, or Free Transform — or
use the flip options in the Control panel.

Figure 8-3 shows the Tools panel and Control panel iconic buttons for
these controls.

If you hold down the Option or Alt key before and while moving and object,
InDesign copies the object and then moves that copy. If you start rotating or
resizing, or otherwise transforming an object and then hold Option or Alt,
InDesign applies the transformation to a copy. (If you hold Option or Alt first,
InDesign opens a dialog box that lets you enter in the new values, such as

for scaling or rotating, and choose Copy to apply the new attributes to a copy
of the object.

Rotating objects

With the Rotate tool selected, click and drag a selected object to rotate it —
the object rotates following your mouse movement. (Holding down the Shift
key while dragging limits rotation increments to multiples of 45 degrees.)
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InDesign CS4 now shows the current angle of rotation in a pop-up box near the
mouse as you rotate an object, similar to how it shows the new dimensions as

you resize (refer to Figure 8-1).

For more precise rotation, use the Control panel. You can change the angle of
a selected object by entering a value in the Rotation Angle field. If you choose
to enter a value in the Rotation Angle field, positive values rotate the selected
item counterclockwise around the control point; negative values rotate it
clockwise.

Or you can choose one of the predefined angles from the Rotation Angle
field’s pop-up menu, or choose any of the three rotation options —
Rotate 180°, Rotate 90° CW, and Rotate 90° CCW — in the Control panel’s
flyout menu.

If you choose one of these flyout menu options, the current angle of the
selected object is added to the applied angle. For example, if you choose
Rotate 90° CCW (counterclockwise), an object that’s currently rotated 12
degrees will end up with a rotation angle of 102 degrees.

No matter what method you choose to rotate an object, the center of rotation
will be whatever control point is selected in the Control panel.

To “unrotate” an object, enter a Rotation Angle value of 0.
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Sometimes, rotated objects — especially those containing text — can be hard
to edit in the regular view of a page. InDesign CS4 thus lets you rotate a spread
so that you can view it at 90-, 180-, and 270-degree views — in addition to the
standard 0-degree view, of course. Note that the actual spread isn’t rotated,
just its appearance in InDesign; it still prints correctly. Figure 8-4 shows an
example; note the rotation icon that appears in the pages panel to the right of
the rotated spread.

You can rotate a spread’s view in two ways:

v Choose Viewr>Rotate Spread and then choose the desired rotation
amount from the submenu.

1 Select the desired spread for which to rotate its view in the Pages panel
and then choose Rotate Spread View and the desired rotation amount
from the submenu.

To set the view back to normal, choose the Clear Rotation option in the
submenu.

® InDesign File Edit layout Type Object Table View Window Help & ar O & @ < # (= 519PM = Q \
ece | O W E- B e —
§§§x:vnn WL | et roa| & osh | 0 g s
v: 3 38p1 W | = % ; z 20 LPJ S ohe | (o) | 3 [00% o] |
[ES -Correct Color template.indd @ 100% |
7 0 [E I il 2 PACES
[ e T Insert Pages... & —
% H . ~ Move Pages... None] D m‘m
#‘ E New Master... A m 2| W LAveEs
. -Regular Fage
. Duplicate Page S T g swareries
1. = Delete Page >
Al Select Unused Masters .ﬁ |
e || Aa cuvms
® Rotate Spread View > 90° CW \ g
O‘ = = Page Transitions » 90° CCW | = TR
gt By T oy, E st 180° |
217 Bi5p §8uf0A] MasterOptions : | —
SE ZE®.27 Apply Master to Pages... Clear Rotation |
&, BEps ZuZig
B Egga EEEE;E' Sava as Maste ||| 0 e
K B EE O ;ggg ¥!  Load Master Pages... g |
- AR | B
i NEE F é‘g g ? 5| Hide Master Items | S
= | 1 E ﬁ g § E i E Override All Master Page Items N48L % HYPERLINKS
5 [F g-gj EE §5-.-0 Remove All Local Overrides
ik gﬁg 8 iaF ;;é% Detach All Objects from Master 2% zrrecrs:
HRHH
T ﬁggﬁgééggii. : 4] PARAGRAPH
e ] EEE 23 §& g é" g + Allow Document Pages to Shuffle ol paraRAPH sTVLES
B _é'g & éﬁ’ﬁ%? ;_ﬁ:/Allow Selected Spread to Shuffle
- ER 2525
b I f5521 2 B2 ¥E:  Numbering & Section Options... e Al cHaracTer
Spread Flattening » E s
(= E E v & 'CHARACTER STYLES
= Panel Options... 24 Pages In 12 Spreads 5 @
T
2
] s , i3
| EERY § B, B33 2
4 4 27 [~ » ¥ @ lemor v @] T




Chapter 8: Manipulating Objects 1 45

Shearing objects

With the Shear tool selected, click and drag a selected object to shear it.
(Holding down the Shift key constrains the selected object’s rotation value

to increments of 45 degrees.) If you drag the mouse in a straight line parallel
with one set of edges (such as the top and bottom), you skew the graphic
(just slant it in one direction). But if you move the mouse in any other
direction, you slant the object’s edges closest to the direction that you move
the mouse the furthest and rotate the rest of the graphic. Give it a few tries to
see what happens.

As with other functions, you can also use the Control panel for more precise
control. Just enter a Shear X Angle value in the Control panel or choose a
predefined value from the field’s pop-up menu. Positive shear values slant an
object to the right (that is, the top edge of the object is moved to the right),
whereas negative values slant an object to the left (the bottom edge is moved
to the right). You can enter shear values between 1 and 89 (although values
above 70 cause considerable distortion).

Note that when you use the Shear tool, you change the selected object’s
angle of rotation and skew angle simultaneously. If you use the mouse, you
can in effect get different skew and rotation angles based on how you move
the mouse, but if you use the Control panel, both the skew and rotation will
have the same angles applied.

To “unshear” an object, enter a Shear X Angle value of 0.

Flipping objects

The Object menu has two flipping commands: Object~>Transform=>Flip
Horizontal and Object=>Transform=Flip Vertical. They’re also available in the
Control panel as iconic buttons (refer to Figure 8-3).

These controls let you make a mirror image of a selected object and its con-
tents. If you choose Flip Horizontal, the graphic is flipped along a vertical axis
(that is, the right edge and left edge exchange places); if you choose Flip
Vertical, the object is flipped upside down. (You're not making a flipped copy
of the select object, but actually flipping the selected object.)

As with other tools, the invisible line over which an object is flipped is based
on what reference point is currently active as the control point for that
object.

<MBER The Control panel displays the current object’s flip status. (Look for the
large P in the panel when an object is selected; it’s to the right of the two flip
buttons.) The P changes appearance so that it’s flipped the same way as the
selected object.
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Advanced users will like the Free Transform
tool. When you select this tool, InDesign lets
you scale, rotate, and resize — but not
shear — selected objects — as follows:

v If you click within the frame, you can move
the object by dragging it.

v If you select a frame handle (whether
corner or midpoint), you can resize the
object by dragging.

Using the Free Transform tool

v Finally, if you move the mouse close to a
frame handle, you see a curved arrow,
which indicates that you can rotate the
object around that object’s center point.

Having a tool that does more than one
thing can be confusing, but once you get
the hang of it, it sure beats constantly changing
tools!

Repeating transformations

Whatever transformations you use, you can apply them repeatedly. InDesign
remembers the effects that you apply to frames via the Control panel,
Transform panel, and transform tools. Choose Object=>Transform

Again~>Transform Again (Option+3+3 or Ctrl+Alt+3) to repeat the last trans-
formation on the selected object. (It can be a different object than you last

applied a transformation to.)

Or choose Object=>Transform Again=>Transform Sequence Again
(Option+8&+4 or Ctrl+Alt+4) to apply all recent transformations to a selected
object. That sequence of transactions stays in memory until you perform a
new transformation, which then starts a new sequence, so you can apply the
same transformation to multiple objects.

Two other transform-again options are available through the
Object>Transform Again menu option’s submenu: Transform Again
Individually and Transform Sequence Again Individually. You use these
options on groups; they work like the regular Transform Again and Transform

Sequence Again options but apply any effects to each object individually
within the group. For example, applying Transform Again to a group rotates
the entire group as if it were one unit, but choosing Transform Again
Individually rotates each object in the group separately, not the group as a
unit. Try it and see exactly what it does!

Replacing Object Attributes

A really painstaking task in any layout is going through it to fix formatting to
frames, lines, or other objects once the design standards have changed.
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InDesign has a very handy way to apply object formatting consistently to
objects — the object styles feature described in Chapter 9 — but even

if you use these styles, you'll still have local formatting applied to at least
some objects.

That’s where the Object pane of the Find/Replace dialog box comes in, letting
you replace attributes throughout your document, no matter what they’re
applied to. Figure 8-5 shows that pane.

Here’s how it works:

1.

Open the Find/Change dialog box by choosing Edit~>Find/Change
(38+F or Ctrl+F) and then go to the Object pane.

. Select the desired object attributes and click OK when you’re done.

To do so, click the Specify Attributes to Find iconic button to the right of
the Find Object Format list. In the dialog box that appears (see Figure
8-5), select the attributes to search (choose one category at a time from
the list at left and then set the desired parameters in the pane that
appears) and click OK when you’re done.

Highlight an attribute in the list and click the Clear Object Find Format
Settings iconic button — the trashcan icon — if you want to remove an
attribute from your search. (This dialog box is nearly identical to the
New Object Style dialog box covered in Chapter 9.)

. If you’re replacing attributes, click the Specify Attributes to Change

iconic button to the right of the Change Object Format list.

These controls work like the Find Object Format controls.

. Limit or expand the search range by choosing an option from the

Search pop-up menu: Selection, Document, and All Documents.

. Choose the type of frames to search in the Type pop-up menu: All

Frames, Text Frames, Graphic Frames, and Unassigned Frames.

. Determine the scope of your search by selecting or deselecting any of

the five buttons at the bottom of the pane.

From left to right, the five buttons are Include Locked Layers, Include
Locked Stories, Include Hidden Layers, Include Master Pages, and
Include Footnotes. Note that the first two buttons apply only to
finds; you can’t change the formatting of locked objects. (If an icon’s
background darkens, it’s selected.)

. Click Find, Change, Change All, or Change/Find as desired to perform

your search and/or replace operation.

. Click Done when done.
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Making Fancy Corners

Anytime you’re working on an object that has any sharp corners, you have
the option to add a little pizzazz to those corners via InDesign’s Corner
Options feature (Object>Corner Options). Five built-in corner options,
shown in Figure 8-6, are available. Note that if the shape contains only
smooth points, any corner option you apply won’t be noticeable.

To add a corner option:

1. Select either of the selection tools and click the object to which you
want to add a corner effect.

2. Choose Object~>Corner Options to display the Corner Options

dialog box.

Select the Preview check box to view changes as you make them.

3. Choose an option from the Effect pop-up menu.
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4. Enter a distance in the Size field.

The Size value determines the length that the effect extends from the
corner.

You can also use the new nudge buttons to increase or decrease
the sizes in increments. (The increments depend on the default
measurement unit selected; see Chapter 2.)

5. Click OK to close the dialog box and apply your changes.

If you can’t see a corner effect after applying one, make sure that a color is
applied to the stroke or try making the object’s stroke thicker. Increasing
the Size value in the Corner Options dialog box can also make a corner effect
more visible.

Using Transparency and Lighting Effects

InDesign was a pioneer in the use of transparency effects on objects. These
effects let you overlay objects without completely obscuring them, allowing
for very interesting visual effects, such as fades and shadows. It provides rich
controls over transparency and lighting so that you can create effects such
as embossing and beveled edges and control the intensity and direction of
shadows and light.
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Basic transparency

One of InDesign’s most sophisticated tools is its set of transparency options,
which let you make objects partially transparent. You apply transparency
with the Effects panel (Window>Effects [Shift+38+F10 or Ctrl+Shift+F10]),

by choosing ObjectEffects>Transparency, or by clicking the Effects iconic
button (the fx icon) in the Control panel and choosing Transparency from its
pop-up menu.

The first option displays the Effects panel, which takes the least screen space
and is best used for simple operations. The other options open the more
complex and larger Effects dialog box. (Be sure that the Transparency pane
is visible in the Effects dialog box; if not, click the Transparency option in the
option list at left.)

Figure 8-7 shows the Effects panel as well as a text title that uses transpar-
ency as it overprints a background photo. The photo has an Opacity setting
of 40 percent, making it partially transparent. The text has an Opacity setting
of 65 percent but also has a blending mode applied, which changes how the
transparency appears.

To set the transparency level, in the Opacity field of the Effects panel or
Effects dialog box’s Transparency pane, enter a value or choose one from the
pop-up menu. A value of 0 is completely invisible, whereas a value of 100 is
completely solid.

You can’t apply transparency to text selections or to entire layers, but
InDesign does let you apply different transparency settings to an object’s
contents, fill, and stroke, as well as to the object itself. You do so by choosing
the desired component in the list in the Effects panel or using the Settings For
pop-up menu in the Effects dialog box. (If you see only Object listed in the
Effects panel, click the right-facing triangle to its left to display the rest.)

If you want more than basic transparency, you have a lot of other options.
Most are for experts, but a few are worth describing. One is the set of 16
transparency types — called blending modes. (Photoshop and Illustrator
users will recognize these expert options.) You access blending modes in the
pop-up menu in the Effects panel or via the Mode pop-up menu on the Effects
dialog box’s Transparency pane. The differences among them can be subtle
or extreme, depending on a variety of issues. Experiment with them to see
what effect works best in each case.

The Difference, Exclusion, Hue, Saturation, Color, and Luminosity modes don’t
blend spot colors — only process colors.



Chapter 8: Manipulating Objects ’5 ’

® InDesign File Edit Layout Type Object Table View Window Help ¥2 o» © © & < & (= 1205PM = Q ‘
0o g m - |- =y @ | TypocrARHY ¥ | [0 search Diss

oo X[ =125p6 w: = 15p7.929 .| =T1oox ﬁj 2 o B & D] Ao |Fom I i=q= P

. F]1006 wEimesar | % | @ 100w _&-! = ﬂ| & 5n LPJ G o | (— |G 3] | =

*Lisbon guide.indd @ 125% %

| e races
& Lves
B swaTches
| Aa cLypHs
Figure 8-7: |o. s i
The Effects | Colambus = smoce
panel and start"@er, = ' [ Bty
its flyout e B g o
menu (right), N 0 svreris
as well
as trans- == Clinrn,
parency e o Y [
applied to -
the image S
and text
(the original
objects are
atleft).
I . ————— | -

You have two other options in the Effects panel and in the Transparency
pane of the Effects dialog box:

v~ Isolate Blending restricts the blending modes to the objects in a group,
instead of also applying them to objects beneath the group. This option
can prevent unintended changes to those underlying objects.

+* Knockout Group obscures any objects below the selected group. But
those objects are still affected by any blend mode settings applied to the
group, unless Isolate Blending is also checked.

Drop shadows and inner shadow's

The Effects panel and dialog box, as well as the Object~>Effects menu com-
mand, give you access to a bunch of other lighting features, including drop
shadows.



152

Part lll: Object Essentials

|
Figure 8-8:
The Drop
Shadow
pane of the
Effects
dialog box.
|

To get to these other lighting features, choose Effectse>Drop Shadow from
the Effects panel’s flyout menu or choose Drop Shadow from the £x iconic
button’s pop-up menu. In the Effects dialog box, select Drop Shadow from the
option list at left. Or just press Option+38+M or Ctrl+Alt+M. No matter how
you get there, you see the following options in the Drop Shadow pane of the
Effects dialog box, shown in Figure 8-8.

1 Choose what component of the object to apply the drop shadow to by
using the Settings For pop-up menu. (You can apply multiple drop shad-
ows, one to each component of an object.)

v Enable the Drop Shadow check box option to turn on the drop shadow
function for the selected component.

1 Select a lighting type (technically, a blend mode) by choosing one of the
16 options in the Mode pop-up menu. (These blending modes are the
same ones used for transparencies.)

v Specify the opacity by entering a value in the Opacity field — 0% is
invisible, whereas 100% is completely solid.

v Specify the shadow’s position relative to the object by using the X Offset
and Y Offset fields. A positive X Offset moves the shadow to the right; a
positive Y Offset moves the shadow down. Negative values go in the
other direction.

v Specify the shadow’s size by entering a value in the Distance field — this
option blurs a copy of the object used in the drop shadow to make it
look like it was created by shining light on the object.

v Choose a lighting angle in the Angle field or use the mouse to move the
direction within the circle to determine the direction of the shadow. You
can also select the Use Global Light option, which then uses whatever
settings you define in the Global Light dialog box — a handy way to have
consistent settings for all objects. (Choose Object>Effects>Global Light,
or choose Global Light from the Effects panel’s flyout menu, to open the
Global Light dialog box.)

Effects

Settings for: | Object % Drop Shadow
Moo [ Blending

Mode: | Multiply Il opacty: 75% |2

r— Position
Distance: =+ 0p9.899 X Offset: = 0p4.95

Angle @ 120° Y Offset: = 0p8.573
# Use Global Light

— Options
Size: 210p5 ™ Object Knocks Out Shadow
Spread: b% |I| E‘Shadnw Honors Other Effects

Noise: 0% T

OBECT. Diference 65 Drop Shadon. ()
Outer Glow. A
STROKE: Normal 100¥; (no effects)

FILL: Normal 100%; (no effects)

TEXT: Normal 100%; {no effects)

M Preview (" cancel ) ( oK )
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v Choose a color source — Swatches, RGB, CMYK, or Lab — from the
Color pop-up menu in the Effect Color dialog box, which you get by
clicking the color swatch to the right of the Mode pop-up menu, and
then select a color from the sliders or swatches below that menu. You
get sliders for RGB, CMYK, and Lab colors or a set of previously defined
color swatches if you selected Swatches in the Color pop-up menu.

v Adjust the other settings, if desired, to control other, expert drop
shadow characteristics: Size, Spread, Noise, Object Knocks Out Shadow,
and Shadow Honors Other Effects.

v To see the effects of your various setting adjustments in the actual
layout, check the Preview option. (Because the Effects dialog box is so
big, you'll likely need a large monitor to have room for both the dialog
box and the object you're applying the effects to.)

InDesign has a second shadow option: inner shadows. It works pretty much
like drop shadows, with a nearly identical pane in the Effects dialog box. The
visual difference is that an inner shadow is contained within the object, as if
the frames were a wall blocking the shadow, whereas a drop shadow occurs
outside the frame, as if the frame were casting a shadow outside.

Feathering and other lighting effects

A similar option to drop shadows is feathering, which essentially softens the
edges of objects. Three types of feathering are available:

v Basic feathering: This option softens the edges on all sides of an object.

1 Directional feathering: This option lets you control the direction of the
feathering as well as separate feather widths for each side, creating a
smeared-border effect.

v Gradient feathering: This option provides a gradient effect to the
feathered area.

The other effects are outer glow, inner glow, bevel and emboss, and satin.
Figure 8-9 shows examples of each.

You apply them the same ways as you do drop shadows, selecting the object
component in the Settings For pop-up menu and modifying the various con-
trols such as opacity, light angle and distance, blending mode, and effect size,
as appropriate for the specific effect. Once you get a hang for transparency
and drop shadows, it’s easy to use the other effects.
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Chapter 9
Organizing Objects

In This Chapter
Grouping and ungrouping objects
Locking and unlocking objects
Changing the stacking order of objects
Working with object styles
Managing links to graphics and text files

ou use objects throughout your layout: lines, text frames, graphics

frames, shapes, and so on. A big part of working with them involves
organizing them — deciding when to group them together, when to lock them
in location, how to arrange objects with others, and so on. That’s where this
chapter comes in.

[ also discuss a powerful new feature called object styles that lets you save
object attributes. Finally, I show you how to manage objects’ relations with
their source files, so that you can make sure that you're using the correct
version of your graphics and text.

Combining Objects into a Group

Groups have many uses. For example, you can create a group to

v Combine several objects that make up an illustration so that you can
move, modify, copy, or scale all objects in a single operation.

v Keep a graphics frame and its accompanying caption (text) frame
together so that you can reposition both objects at once if you change
your mind about their placement.

v Combine several vertical lines that are used to separate the columns
of a table so that you can quickly change the stroke, color, length, and
position of all lines.
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InDesign lets you combine several objects into a group. A group of objects
behaves like a single object, which means that you can cut, copy, move, or
modify all the objects in a group in a single operation.

To create a group, select all the objects (which can include other groups)
that you want to include in your group and then choose Object=>Group (38+G
or Ctrl+G).

Keep in mind the following when creating groups:

v If you create a group from objects on different layers, all objects are
moved to the top layer and stacked in succession beneath the topmost
object.

v You can’t create a group if some of the selected objects are locked and
some aren’t locked. All selected objects must be locked or unlocked
before you can group them. (Locking and unlocking objects are covered
in the following section.)

N If you want to manipulate a group, choose the Selection tool and then click
any object in the group. The group’s bounding box appears. Any transforma-
tion you perform is applied to all objects in the group.

If you want to manipulate a specific object in a group, use the Direct Selection
tool to select that object. If you want to change something that requires
the Selection tool to be active, switch to it by selecting the Selection tool
or simply by double-clicking the object. (See Chapter 8 for more details on
selecting objects.)
SMBER . . .
If you remove an object applied (via cut and paste or copy and paste) from
a group that had transparency, that pasted object will not retain the group’s
transparency settings.

After creating a group, you may eventually decide that you want to return
the objects to their original, ungrouped state. To do so, simply click any
object in the group with the Selection tool and then choose Object=>Ungroup
(Shift+3+G or Ctrl+Shift+G). If you ungroup a group that contains a group,
the contained group isn’t affected. To ungroup this group, you must select it
and choose Ungroup again.
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Locking Objects

If you're certain that you want a particular object to remain exactly where it
is, you can select Object=>Lock Position (88 +L or Ctrl+L) to prevent the object
from being moved. Generally, you want to lock repeating elements such as
headers, footers, folios, and page numbers so that they’re not accidentally
moved. (Such repeating elements are usually placed on a master page; you
can lock objects on master pages, too.)

A'locked object can’t be moved whether you click and drag it with the
mouse or change the values in the X: and Y: fields in the Control panel or
Transform panel. Not only can you not move a locked object, but you can’t
delete it, either. However, you can change other attributes of a locked object,
including its stroke and fill.

To unlock a selected object, choose Object=>Unlock Position (Option+8+L or
Ctrl+Alt+L).

You can also lock entire layers, as described in Chapter 4.

Working with Object Styles

A\

Object styles let you organize your settings so that you can apply them to
other objects for consistent, easy formatting.

[ suspect that object styles are underappreciated and underused, rarely used
in real-world documents. That’s a pity, because the use of styles for object
formatting — not just text formatting — makes your work easier by automati-
cally and reliably applying time-consuming settings to multiple objects and
ensuring that your object formatting is both consistent and easily managed.

Creating object styles

You create object styles by using the Object Styles panel (Window=>Object
Styles [88+F7 or Ctrl+F7]) and selecting New Object Style from the flyout
menu, shown in Figure 9-1. You can also click the New Object Style iconic
button at the bottom of the panel.

The simplest way to create an object style is to select an already-formatted
object with any selection tool and then choose New Object Style from the
Object Styles panel’s flyout menu. InDesign records all the settings automati-
cally from the selected object so that they’re in place for the new object style.

157
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Whether you start with an existing object or create a new object style com-
pletely from scratch, you use the New Object Style menu option that opens
the New Object Style dialog box shown in Figure 9-2.

At the left side of the dialog box is a list of types of attributes that are or can
be set. The checked items are in use for this style — you can uncheck an
item so that InDesign doesn’t apply its settings to objects using the style. For
example, if Fill is unchecked, the object style won’t apply any Fill settings to
objects using that style (and won’t change any fill settings that have been
applied to that object locally).

To switch from one type of attribute to another, simply click the item
name for the type of attribute that you want to adjust, such as Stroke or
Transparency.

Be sure to select the Preview option to see the results of object styles on the
currently selected object. Of course, you need to make sure that the object is
visible on-screen to see those effects.
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When you open the New Object Style dialog box, you see the General pane,
which lets you create a new style based on an existing object style (by using
the Based On pop-up menu), and which lets you assign a keyboard shortcut
for fast application of this style (by using the Shortcuts field).

You can use the Based On feature to create families of object styles. For
example, you can create a style called Photo-Standard for the bulk of your
placed photographs and then create variations, such as Photo-Sidebar and
Photo-Author. The Photo-Standard style might specify a hairline black stroke
around the photo, while Photo-Sidebar may change that to a white stroke.
But if you later decide you want the stroke to be 1 point and change it in
Photo-Standard, Photo-Sidebar automatically gets the 1-point stroke while
retaining the white color.

The General pane also lets you see the current style settings. Click any of the
arrows in the Style Settings section to get more details on how they’re set for
this object style.

The other panes in the New Object Styles dialog box provide the same capa-
bilities that you find elsewhere in InDesign, brought into one convenient
place so that you can use them in styles. Because it has so many panes, the
New Object Style dialog box now breaks them into two sections. The first
section — Basic Attributes — contains the following panes:

v The Fill pane lets you set colors for fills using whatever colors are
defined in the Swatches panel. You can also set the tint and, if you select
a gradient fill, the angle for that gradient. Finally, you can choose to have
the fill overprint the contents of the frame by selecting the Overprint Fill
option.

Chapter 9: Organizing Objects 159
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v The Stroke pane is identical to the Fill pane except that options specific
to fills are grayed out, and options available to strokes are made avail-
able. The color, tint, and gradient angle options are the same as for the
Fill pane. You can also choose the type of stroke (solid line, dashed line,
or dotted line) by using the Type pop-up menu and adjust the thickness
by filling in the Weight field. You can choose to overprint the stroke
over underlying content, plus determine — if your stroke is a dotted or
dashed line — the color, tint, and overprint for the gap.

1 The Stroke & Corner Options pane lets you set stroke position and how
corners and line ends are handled. It also lets you apply fancy corners
to frames. The Stroke Options section is where you align the strokes to
the frame edges, determine how lines join at corners, and decide what
line endings are applied. The Corner Options section is where you select
from five fancy corners, such as Bevel and Rounded, by using the Effect
pop-up menu, and where you specify the radius, or reach, of the corner
by using the Size field. (See Chapter 7 for the low-down on strokes and
Chapter 8 for the skinny on corner options.)

v The Paragraph Styles pane controls what paragraph style, if any, is
applied to text in the frame. Chances are you won’t use this setting
except for frames that contain only consistent, very simple text, such as
pull-quotes or bios. (See Chapter 11 for details.)

v The Text Frame General Options pane controls how text is handled
within a frame. This pane essentially replicates the controls in the
General pane of the Text Box Options dialog box (Object=>Text Frame
Options [38+B or Ctrl+B]), including number of columns, column width,
gutter settings, inset spacing (how far from the frame edge text is
placed), vertical justification (how text is aligned vertically in the frame),
and whether text wrap settings are ignored when this frame overlaps
other frames. (See Chapter 11 for details.)

+* The Text Frame Baseline Options pane controls how text is handled
within a frame. This pane essentially replicates the controls in the
Baseline Options pane of the Text Box Options dialog box (Object>Text
Frame Options or 38+B or Ctrl+B), including how the text baseline is cal-
culated for the frame and whether the text frame gets its own baseline
grid. (See Chapter 10 for details.)

+ The Story Options pane enables optical margin alignment — its controls
are the same as in the Story panel (Typew>Story), detailed in Chapter
16. Optical margin alignment adjusts the placement of text along the left
side of a frame so that the text alignment is more visually pleasing.

v The Text Wrap & Other pane lets you set text wrap, mirroring the
features of the Text Wrap panel (Window=Text Wrap [Option+388+W or
Ctrl+Alt+W]), explained in Chapter 16, as well as make an object non-
printing (normally handled through the Attributes panel by choosing
Windowr>Attributes).
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v The Anchored Object Options pane lets you set the attributes for inline
and anchored frames, mirroring the controls in the Anchored Object
Options dialog box (Object®Anchored Object=>Options), which [ explain
in Chapter 10.

v The Frame Fitting Options pane lets you set the defaults for how frames
fit to the graphics and text placed in them, mirroring the controls in
the Frame Fitting Options dialog box (Objectc>Fitting=>Frame Fitting
Options), as explained in Chapter 18.

The second set of panes all relate to the features found in the Effects dialog
box and panel, as covered in Chapter 8.

Managing object styles

The Object Styles panel’s flyout menu (refer to Figure 9-1) has several
options for managing object styles:

v Duplicate Object Style: Click an object style’s name and then choose
this menu option to create an exact copy. If you want to create an object
style that’s similar to one you already created, you may want to choose
New Object Style rather than Duplicate Object Style and then use the
Based On option to create a child of the original. If you choose Duplicate
Object Style, the copy is identical to, but not based on, the original; if
you modify the original, the copy isn’t affected.

v Delete Style: Choose this option to delete selected object styles. To
select multiple styles, press and hold 8 or Ctrl as you click their names.
To select a range of styles, click the first one and then press and hold
Shift and click the last one. You can also delete styles by selecting them
in the pane and then clicking the Delete Selected Styles iconic button
(the trashcan icon) at the bottom of the panel.

+” Redefine Style: To modify an existing object style, first make changes to
an object that already has an object style defined for it and then select
Redefine Style. The newly applied formats are applied to the object style.

v~ Style Options: This option lets you modify an existing object style. When
a style is highlighted in the Object Styles panel, choosing Style Options
displays the Object Style Options dialog box, which is identical to the
New Object Style dialog box.

1 Load Object Styles: Choose this option if you want to import object
styles from another InDesign document. After selecting the document
from which to import the styles, you get a dialog box listing the styles in
the chosen document so that you can decide which ones to import. Note
the Incoming Style Definitions window at the bottom of the dialog box; it
lists the style definitions to help you decide which to import, as well as
which to overwrite or rename.
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InDesign comes with three predefined object styles — [Basic Text Frame],
[Basic Graphics Frame], and [Basic Grid] — that you can modify as desired.

Applying object styles

After you create an object style, it’s a simple process to apply it: Just click
an object and then click the object style name in the Object Styles panel or
press its keyboard shortcut. (Windows users must make sure that Num Lock
is on when using shortcuts for styles.)

You can set which object styles are automatically used for new text and
graphics frames: In the Object Styles panel’s flyout menu, choose Default Text
Frame Style and select the desired style from the submenu to set a default text
frame; choose Default Graphic Frame Style and select the desired style from
the submenu to set a default graphics frame. To no longer have object styles
automatically applied to new objects, choose [None] in the Default Text Frame
and/or Default Graphic Frame submenus.

When you apply an object style to selected objects, all local formats are
retained. All other formats are replaced by those of the applied style — that
is, unless you do one of the following:

v 1f you press and hold Option or Alt when clicking a name in the Object
Styles panel, any local formatting that has been applied to the objects is
removed. You can achieve the same effect by choosing Clear Attributes
Not Defined by Style from the Object Styles panel’s flyout menu or by
clicking the Clear Attributes Not Defined by Style iconic button at the
bottom of the Object Styles panel.

v If you want to override any local changes with the settings in the object
style, choose Clear Overrides in the flyout menu or click the Clear
Overrides iconic button at the bottom of the Object Styles panel. The
difference is that Clear Attributes Not Defined by Style removes all attri-
butes for which the object style contains no settings, whereas Clear
Overrides imposes the object style’s settings over conflicting attributes
that you set manually.

v To have InDesign automatically override local changes when applying a
style, be sure the Clear Overrides When Applying Style flyout menu option
is checked. Choosing the item toggles between selecting (checking) and
deselecting (unchecking) this option.
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If a plus sign (+) appears to the right of an object style’s name, it means that
the object has local formats that differ from those of the applied object style.
This formatting difference can occur if you apply an object style to object
text to which you've done some manual formatting, or if you modify format-
ting for an object after applying an object style to it. (For example, you may
have changed the fill color, which is a local change to the object style and
causes the + to appear.)

To remove a style from an object, choose Break Link to Style from the Object
Styles panel’s flyout menu. The object’s current formatting won’t be affected,
but it will no longer be updated when the object style is changed.

Managing object styles

InDesign also lets you manage your styles, such as creating groups of styles
to make it easier to find relevant ones, and bring in styles from other docu-
ments. Because these features work the same for paragraph, character, table,
and cell styles as well, I cover these features in one place: Chapter 13.

Managing Links

The Links panel (Windowr>Links [Shift+88+D or Ctrl+Shift+D]) is a handy
place to manage the links to your graphics and text, particularly when you
need to update them.

Figure 9-3 shows the Links panel. If you've used previous versions of InDesign,
note how different the Links panel is in InDesign C5S4 — Adobe’s given it a
major overhaul.

InDesign always creates links for graphics files. But it creates links to source

text files (including spreadsheets) only when the Create Links When Placing
Text and Spreadsheet Files option is checked in the File Handling pane of the
Preferences dialog box (InDesign=>Preferences=>File Handling [38+K] on the Mac,
or Edit>Preferences=>File Handling [Ctrl+K] in Windows). This option is not
checked by default because many designers don’t want text files easily updated
in their layouts. That’s because all the formatting they’ve done to the file in
InDesign is removed when the link to the source file is updated, causing the

text to be replaced. (Note that this option has moved from the Type pane of the
Preference dialog box, where it resided in previous versions of InDesign.)
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The first four sets of commands in the Links panel’s flyout menu let you rees-
tablish links to missing and modified files, display an imported graphic or

text file in the document window, open the program used to create a graphic
or text file, and work on copies and versions of the source graphics and text:
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v+ Relink: This command, and the Relink iconic button (at the bottom of
the panel), lets you reestablish a missing link or replace the original file
you imported with a different file. When you choose Relink or click the
button, the Relink dialog box is displayed and shows the original path-
name and filename. You can enter a new pathname and filename in the
Location field, but clicking Browse is easier, which opens a standard
Open a File dialog box. Use the controls to locate and select the original
file or a different file and then click OK. (You can also drag and drop
a file icon from the Mac OS Finder or Windows Explorer directly into
the Relink dialog box.) If you want to restore broken links to multiple
files simultaneously, highlight their filenames in the scroll list and then
choose Relink or click the Update Link button.
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Previous versions of InDesign let you relink all instances of a file in your
layout, so you only have to do the operation once. InDesign CS4 changes
how relinking works: Be sure to hold Option or Alt when clicking the
Relink command or Relink iconic button. Also, InDesign is now smarter
about finding missing files when you open a file; if the Find Missing Links
Before Opening Document option is enabled in the File Handling pane

of the Preferences dialog box, InDesign CS4 searches your drives for the
files and automatically updates them if it finds them.

v Relink to Folder: This new command lets you relink multiple files at the
same time, and even change the type of graphic files to use at the same
time. First, be sure to select all files in the panel you want to relink —
only selected files will be updated. Then choose this option and navigate
to the folder that has the files. If the filenames in the new folder match
the filenames of the selected files in the panel, InDesign updates them.
(It leaves alone any it can’t find.)

Notice that the Open a File dialog box that appears when you choose
this command contains an option called Match This Filename But This
Extension. Say that someone gave you JPEG files as placeholders for
your layout and then delivered the final TIFF files for high-quality print
output. In previous versions, you’d have to relink every single file manu-
ally. Now, you can use this option and enter TIFF (or TIF, depending on
the filename extension used) to substitute the high-quality TIFF files for
the original low-quality JPEG files. That’s a real timesaver! (Note that the
new file can be any format supported by InDesign, not just TIFF.)

v+~ Update Link: Choose this option or click the Update Link iconic button
(at the bottom of the panel) to update the link to a modified graphic or
text file. Highlight multiple filenames and then choose Update Link or
click the Update Link button to update all those links at once.

v+~ Update All Links: Choose this option to update all files marked as
modified, without having to select individual files.

» Go to Link: Choose this option or click the Go to Link iconic button
(second from left) in the panel to display the highlighted file in the docu-
ment window. InDesign will, if necessary, navigate to the correct page
and center the frame in the document window.

+* Embed Link (for graphics only): This option lets you embed the com-
plete file of any imported graphics file. (InDesign normally imports only
a low-resolution screen preview when you place a graphic that is 48K or
larger.) If you want to ensure that the graphics file will forever remain
with a document, you can choose to embed it — however, by embed-
ding graphics, you’ll be producing larger document files, which means it
will take you longer to open and save them. If you do use this option, an
alert appears to inform you about the increased document size that will
result. Click Yes to embed the file. Note that this menu option changes
to Unembed File, so you can re-enable the original link at any time.
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v+ Unlink (for text files only): This option removes the link to the source
text file, so it can’t be updated. Note that you can’t undo this option
from the Links panel; you have to choose Edit=>Undo (8+Z or Ctrl+Z).
And this option is available only if you enabled text linking via the
Create Links When Placing Text and Spreadsheet Files option in the File
Handling pane of the Preferences dialog box.

v Edit Original: If you want to modify an imported graphic or text file,
choose Edit Original from the flyout menu or click the Edit Original
button (far right) at the bottom of the panel. InDesign tries to locate and
open the program used to create the file, which may or may not be pos-
sible, depending on the original program, the file format, and the pro-
grams available on your computer.

v Edit With: This new menu option lets you choose what program to edit
a select object with.

+* Reveal in Finder (Macintosh) and Reveal in Explorer (Windows): This
menu option opens a window displaying the contents of the folder that
contains the source file, so you can perhaps move, copy, or rename it.
(The Reveal in Bridge option is a similar feature for the expert Adobe
Bridge companion program not covered in this book.)

When you relink missing and update modified graphics, any transforma-
tions — rotation, shear, scale, and so on — that you've applied to the
graphics or their frames are maintained, unless you’'ve deselected the new
Preserve Image Dimensions When Relinking option in the File Handling pane
of the Preferences dialog box (InDesignr>Preferences=>File Handling [ 36 +K]
on the Mac, or Edit=>Preferences>File Handling [Ctrl+K] in Windows).

The Utilities menu option in the flyout menu provides access to several
expert features not covered in this book.

You can control what appears in the Links panel using the Panel Options
option in the flyout menu. You can specify what information appears with
each filename, including whether icons of the file contents display.

Finally, you can see extensive information about the file in the Link Info sec-
tion of the Links panel, containing all the attributes that are also available

in Adobe’s Bridge, such as file dimensions and color profile. To toggle this
information off, just click the Show/Hide Item Information iconic button at the
bottom left of the Links panel.



Chapter 10
Aligning and Arranging Objects

In This Chapter

Using exact coordinates

Working with document grids and guidelines
Making objects line up

Anchoring objects to text

then you draw objects like frames or lines, they appear where you
draw them. That’s what you expect, right? But sometimes you want

them to appear where you meant to draw them, not where you actually did.
Working with the mouse is inexact, but you can overcome that obstacle.

This chapter shows you how to use a variety of InDesign features to precisely
control the placement of objects, including the ability to enter actual coor-
dinates for objects, to use grids and guidelines features to ensure that your
objects and text line up where you want them to, and to use the Align panel
and related commands to make sure that objects line up relative to each
other, so that your layouts are all neat and tidy.

The other part of keeping your layouts neat and tidy is managing the arrange-
ments of objects. In addition to the grouping and locking functions covered
in Chapter 9, InDesign also lets you control the stacking order of objects that
overlap and tie objects to spots in text so they stay close to the text that ref-
erences them.

Positioning Precisely with Coordinates

The most precise way to position objects is by entering the object’s desired
coordinates in the X: and Y: fields of the Control panel or the Transform
panel. (You can also precisely change the object’s size by entering values

in the W: and H: fields.) The Control panel is visible by default at the top of
the document window. If it’s not visible, open the Control panel by choosing
Window=>Control (Option+8+6 or Ctrl+Alt+6).
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Figure 10-1:
The Control
panel
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Transform
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The Control panel is more powerful than the Transform panel, which is
a holdover from older versions of InDesign, but if you want to use the
Transform panel, choose Window=>Object & Layout=>Transform. Figure 10-1

shows both the Control panel and Transform panel and a selected frame.

Everyone should use the Control panel’s coordinates to make sure that
objects are consistently placed from page to page. Many designers place
objects by eye, using the mouse, but that approach typically means that
small position and size variations that shouldn’t be there occur from page to
page. Many readers won't notice if the differences are slight, but even small
differences make small adjustments to text flow that can add up over pages.

And it’s all so unnecessary.

You usually want to enter coordinates based on the upper-left corner, so be

sure that the upper-left reference point is made into the control point (just

click it if it’s not). How do you know which reference point is the current
control point? The control point is black, while the other reference points are

white. (Chapter 1 provides the deeper details.)
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If you've ever seen a carpenter use a chalked string to snap a temporary line
as an aid for aligning objects, you understand the concept behind ruler guide-
lines and grids. They’re not structurally necessary, and they don’t appear in

the final product, yet they still make your work easier.
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InDesign provides several types of grids and guidelines:

+* Ruler guides are moveable guidelines that are helpful for placing objects
precisely and for aligning multiple items.

v+ Margin and column guides are part of your page setup when you create
or modify a document (see Chapter 3), providing the default margin
around the sides of the page and the space between the default text
frame’s columns.

ATURE 1 Smart guides are created on the fly as you work with objects. They use
the centerpoints and frame edges of nearby objects and display accord-
ingly so that you can line up your current object to match a nearby
object’s position or size.

v A document grid is a set of horizontal and vertical lines that help you
place and align objects.

v A baseline grid is a series of horizontal lines that help in aligning lines of
text and objects across a multicolumn page. When a document is open
and it has a baseline grid showing, the page looks like a sheet of lined

paper.

v A frame-based grid is similar to a baseline grid except that it’s just for a
specific text frame.

You won'’t need to display all the grids and guidelines at once. You’ll most
likely use a combination of guides and grids, but using all four at once is
more complicated than necessary.

Using ruler guides

InDesign lets you create individual ruler guides manually. You can also set
ruler guides automatically with the Create Guides command (Layout=>Create
Guides).

Manually creating ruler guides
To create ruler guides on an as-needed basis, follow these steps:

1. Go to the page or spread onto which you want to place ruler guides.

2. If the rulers don’t appear at the top and left of the document window,
choose View-=>Show Rulers (8+R or Ctrl+R).

3. Drag the pointer (and a guideline along with it) from the horizontal
ruler or vertical ruler onto a page or the pasteboard.
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4. When the guideline is positioned where you want it, release the
mouse button.

If you release the mouse when the pointer is over a page, the ruler
guide extends from one edge of the page to the other (but not across a
spread). If you release the mouse button when the pointer is over the
pasteboard, the ruler guide extends across both pages of a spread and
the pasteboard. If you want a guide to extend across a spread and the
pasteboard, you can also hold down the 3 or Ctrl key as you drag and
release the mouse when the pointer is over a page.

Place both a horizontal and vertical guide at the same time by pressing & or
Ctrl and dragging the ruler intersection point (where the two rulers meet) onto
a page. You can also place a guide that extends across the page or spread and
pasteboard by double-clicking the vertical or horizontal ruler.

Ruler guides are cyan in color (unless you change the color by choosing
Layout=>Ruler Guides) and are associated with the layer onto which they’re
placed. You can show and hide ruler guides by showing and hiding the layers
that contain them. You can even create layers that contain nothing but ruler
guides and then show and hide them as you wish. (See Chapter 4 for more
information about layers.)

To create ruler guides for several document pages, create a master page, add
the ruler guides to the master page, and then apply the master to the appro-
priate document pages. (Chapter 4 covers master pages.)

Automatically creating ruler guides
Here’s how to create a set of ruler guides automatically:

1. If the documents contain multiple layers, display the Layers panel
(Window=>Layers [F7]) and click the name of the layer to which you
want to add guides.

2. Choose Layout=>Create Guides to display the Create Guides dialog
box, shown in Figure 10-2.

To see the guides on the page while you create them, check Preview.

3. In the Rows and Columns areas, specify the number of guides you
want to add in the Number fields and, optionally, specify a Gutter
width between horizontal (Rows) and vertical (Columns) guides.

Enter 0 (zero) in the Gutter fields if you don’t want gutters between
guides.

4. In the Options area, click Margins to fit the guides in the margin
boundaries; click Page to fit the guides within the page boundary.

5. Remove any previously placed ruler guides by checking Remove
Existing Ruler Guides.
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6. When you finish specifying the attributes of the ruler guides, click OK
to close the dialog box.

Working with ruler guides

You can show and hide, lock and unlock, select and move, copy and paste,
and delete ruler guides. Here are a few pointers for working with ruler guides:

v Display or hide ruler guides by choosing View=>Grids & Guides=>Show/
Hide Guides (88+; or Ctrl+; — note that these are semicolons).

v Lock or unlock all ruler guides by choosing View=>Grids &
Guides~Lock Guides (Option+88+; or Ctrl+Alt+;). Ruler guides are locked
when Lock Guides is checked.

1 Select a ruler guide by clicking it with a selection tool. To select mul-
tiple guides, hold down the Shift key and click them. The color of a guide
changes from cyan to the color of its layer when it’s selected. To select
all ruler guides on a page or spread, press Option+8+G or Ctrl+Alt+G.

v Move a guide by clicking and dragging it as you would any object. To
move multiple guides, select them and then drag them. To move guides to
another page, select them, choose Edit>Cut (88+X or Ctrl+X) — or choose
Edit=>Copy (88+C or Ctrl+C) to copy — then display the target page and
choose Edit>Paste (88+V or Ctrl+V). If the target page has the same dimen-
sions as the source page, the guides are placed in their original positions.

171
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v Delete ruler guides by selecting them and then pressing Delete or
Backspace.

1 Change the color of the ruler guides and the view percentage above
which they’re displayed by choosing Layout=>Ruler Guides. The Ruler
Guides dialog box appears. Modify the View Threshold value, choose
a different color from the Color pop-up menu, and then click OK. If you
change the settings in the Ruler Guides dialog box when no documents
are open, the new settings become defaults and are applied to all subse-
quently created documents.

v Display ruler guides behind — instead of in front of — objects by
choosing InDesignm>Preferences>Guides & Pasteboard (8 +K) on the
Mac or Edit=>Preferences=>Guides & Pasteboard (Ctrl+K) in Windows.
Then select the Guides in Back option in the Guide Options section of
the dialog box.

1 Make object edges snap (align) to ruler guides when you drag them
into the snap zone by selecting the Snap to Guides option (View=>Grids
& Guides=>Snap to Guides [Shift+38+; or Ctrl+Shift+;]). To specify the
snap zone (the distance — in pixels — at which an object will snap to a
guide), choose InDesign=>Preferences>Guides & Pasteboard (38+K) on
the Mac or Edit=>Preferences=>Guides & Pasteboard (Ctrl+K) in Windows
and enter a value in the Snap to Zone field in the Guide Options section
of the dialog box.

Working with column guides

You can also adjust column guides if your document has them, though you
don’t get the same flexibility in adjusting column guides as you do ruler
guides. Column guides are created when you create a new document and set
it up as having multiple columns (see Chapter 3).

By default, column guides are locked. To unlock them (or relock them)
choose Views>Grids & Guides=>Lock Column Guides. (If the menu option has
a check mark to its left, the column guides are locked.)

To move a column guide, click and drag it. Note that the color of a selected
column guide doesn’t change as the color of a selected ruler guide does. Also
note that you can’t select multiple column guides or move them to other
pages. The only way to add or delete column guides is to change the number
of guides in the Margins and Columns dialog box (choose Layout~>Margins
and Columns); adjusting the number of columns undoes any custom moves
applied to column guides.
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Working with smart guides

Using the new smart guides feature is easy. First, make sure that smart guides
are enabled. You do so in the Guides & Pasteboard pane of the Preferences
dialog box by enabling the Align to Object Center and/or the Align to Object
Edges options. Aligning to object center tells InDesign to look for the center-
point of other objects as you move or resize objects and use those as align-
ment targets. Aligning to object frame edges has it look for other objects’
edges and use those as alignment targets. Turning on both produces more
smart guides as you work on objects.

Figure 10-3 shows the smart guide feature in action in three sequences (in
each sequence, at left is an existing object):

v The top sequence shows me adding a second frame. The mouse pointer
is near neither the nearby object’s centerpoint nor its edge, so no smart
guide appears.

v The middle sequence shows what happens as the mouse pointer moves
near the edge of the nearby object: InDesign displays a smart guide to
let me know that if I want the bottom edge of the new frame to align with
the bottom of the nearby object, all [ have to do is let go.

v The third sequence shows me moving a circular frame from the bottom
to the upper right of the page. You can see the smart guide that indi-
cates the mouse is aligned to the centerpoint of the second object, and
if I let go here, the circular frame’s centerpoint will align to that other
object’s centerpoint.

You probably noticed additional visual indicators in the third sequence:

the spacing indicators between each set of objects. This visual indication is
called smart spacing, which you also enable in the Guides & Pasteboard pane
of the Preferences dialog box. When smart spacing is on, InDesign looks at
the relative spacing of nearby objects as you work with one and highlights
when the spacing is the same, or close to being the same (in which case it
moves them for you).

A fourth “smart” feature comes with smart guides (it, too, must be enabled
in the Guides & Pasteboard pane): smart measurements. In this case, as you
resize or rotate objects, InDesign shows a smart guide when the object being
transformed matches the specs — such as dimensions or rotation angle — of
other nearby angles, under the assumption that maybe you want them to be
the same. As with the other smart-guides functions, let go of the mouse when
the guides appear so that you can get those matching settings.
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Using document grids

A document grid is like the grid paper you used in school, a visual crutch to
help ensure that the objects you draw and reposition are placed at desired
increments. Using a grid can help ensure that objects align and are sized
consistently.

If you plan to use a grid, set it up before you start working in the docu-

ment. Because documents tend to have different grid settings based on
individual contents, you probably want to set Grids preferences with

a specific document open so that the grid will apply only to that docu-

ment. Figure 10-4 shows the Grids pane of the Preferences dialog box
(InDesign=>Preferences=>Grids [#8+K] on the Mac, or Edit~>Preferences=>Grids
[Ctrl+K] in Windows).

You have the following options:
v Color: The default color of the document grid is Light Gray. You can

choose a different color from the Color pop-up menu or choose Other to
create your own.
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Figure 10-4:
The Grids
pane of the
Preferences
dialog box.
|

v Gridline Every: The major gridlines, which are slightly darker, are posi-
tioned according to this value. The default value is 6p0; in general, you
want to specify a value within the measurement system you’re using. For
example, if you work in inches, you might enter 1 inch in the Gridline
Every field. You set the horizontal and vertical settings separately.

v Subdivisions: The major gridlines established in the Gridline Every field
are subdivided according to the value you enter here. For example, if
you enter 1 inch in the Gridline Every field and 4 in the Subdivisions
field, you get a gridline at each quarter-inch. The default number of sub-
divisions is 8. You set the horizontal and vertical settings separately.
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By default, the document grid appears on every spread behind all objects. You
can have grids display in front by deselecting the Grids in Back check box.

To make object edges snap (align) to the grid when you drag them into

the snap zone, select the Snap to Document Grid option (View>Grids &
Guides=>Snap to Document Grid [Shift+88+’ or Ctrl+Shift+’ — note that these
are apostrophes]). To specify the snap zone (the distance — in pixels — at
which an object will snap to a gridline), InDesign uses whatever settings you
specified for guidelines, as explained in the “Using ruler guides” section ear-
lier in this chapter.

To display the document grid, choose View=>Grids & Guides=>Show
Document Grid (38+’ or Ctrl+).
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Using baseline grids

You may not already realize that each and every new document you create
includes a baseline grid. A baseline grid can be helpful for aligning text baselines
across columns and for ensuring that object edges align with text baselines.

But chances are that the default settings for the baseline grid won’t match
the baselines (leading) for the majority of your text. The default baseline grid
begins % inch from the top of a document page; the default gridlines are light
blue, are spaced 1 pica apart, and appear at view percentages above 75 per-
cent. If you change any of these settings when no documents are open, the
changes are applied to all subsequently created documents; if a document is
open, changes apply only to that document.

So here’s how to modify the baseline grid:
1. Choose InDesign->Preferences~ Grids (36+K) on the Mac or

Edit~>Preferences~Grids (Ctrl+K) in Windows.

The Grids pane (refer to Figure 10-4) appears. (If you used a shortcut,
then select the Grids pane from the list at left.)

2. Pick a color for the baseline from the Color pop-up menu in the
Baseline Grid area.

3. In the Start field, enter the distance between the top of the page and
the first gridline.
If you enter 0, the Increment Every value determines the distance
between the top of the page and the first gridline.

4. In the Increment Every field, enter the distance between gridlines.

If you're not sure what value to use, enter the leading value for the
publication’s body text.

5. Choose a View Threshold percentage from the pop-up menu or enter a
value in the field.

You probably don’t want to display the baseline grid at reduced view
percentages because gridlines become tightly spaced.

6. Click OK to close the dialog box and return to the document.

The Show/Hide Baseline Grid command (View=Grids & Guides=>Show/Hide
Baseline Grid [Option+8+’ or Ctrl+Alt+’]) lets you display and hide a
document’s baseline grid.

When you set a baseline grid, it applies to the entire document. Gridlines are
displayed behind all objects, layers, and ruler guides. To get text to line up
to the baseline grid, you need to ensure that the Align to Grid pop-up menu
is set to either First Line Only or All Lines in your paragraph style or that the
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Align to Baseline Grid check box is selected in the Paragraph panel or Control
panel. Chapter 12 covers such paragraph formatting in detail.

A document-wide baseline grid is all fine and dandy, but often it’s not enough.
The document-wide baseline grid is basically useful for your body text and
often your headline text, assuming that the baseline grid’s increments match
the leading for that text. But what if you have other elements, like sidebars,
that have different leading?

The answer is to use text frame-specific baseline grids. You set the grid as
part of the text frame options by choosing Object=>Text Frame Options (88+B
or Ctrl+B) and then going to the Baseline Options pane. Its options are almost
identical to those in the Grids pane of the Preferences dialog box. A baseline
grid established for a text frame affects only the text in that frame.

Aligning Objects to Each Other

InDesign lets you align and distribute objects, saving you the hassle of manu-
ally moving and placing each element, or figuring out the correct locations in
the Control panel or Transform panel to do so.

In the section “Working with smart guides,” earlier in this chapter, I explain
how the new smart guides feature helps you align objects and adjust their
spacing (as well as dimensions and even rotation angle) as you work with
them. That’s great for alignment as you work with individual objects. But
what if you want to align multiple objects at the same time? That’s where the
Align panel comes in.

The Align panel (Window=>Object & Layoute>Align [Shift+F7]), shown in
Figure 10-5, has several iconic buttons that let you manipulate the relative
position of multiple objects in two ways. (The buttons show the alignments
they provide.) You can

v~ Line up objects along a horizontal or vertical axis. For example, if
you've randomly placed several small graphic frames onto a page, you
can use the alignment buttons in the Align panel to align them neatly —
either horizontally or vertically.

v~ Distribute space evenly among objects along a horizontal or vertical
axis. Here’s a typical problem that’s easily solved by using this feature:
You've carefully placed five small pictures on a page so that the top
edges are aligned across the page and you have equal space between
each picture. Then you find out that one of the pictures needs to be
cut. After deleting the unneeded picture, you can use the Align panel
to redistribute the space among the remaining pictures so that they’re
again equally spaced.
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The Align buttons don’t work with objects that have been locked with the
Lock Position command (Object=>Lock Position [O+L or Ctrl+L]). If you need
to align a locked object, you must first unlock it (Object=>Unlock Position
[Option+O+L or Ctrl+Alt+L]). If the objects are on a locked layer, you need to
unlock the layer.

When you click an iconic button in the Align panel, selected objects are repo-
sitioned in the most logical manner. For example, if you click the Horizontal
Align Left button, the selected objects are moved horizontally (to the left, in
this case) so that the left edge of each object is aligned with the left edge of
the leftmost object. Along the same lines, if you click the Vertical Distribute
Center button, the selected objects are moved vertically so that an equal
amount of space appears between the vertical center of each object.

Spacing can appear uneven if you click the Horizontal or Vertical Distribute
buttons when objects of various sizes are selected. For objects of different
sizes, you’ll usually want to use the Distribute Spacing buttons (which make
the space between objects even) rather than space objects based on their
centers or sides (which is how the Distribute Object buttons work).

If the two Distribute Spacing icons don’t appear at the bottom of the panel and
you want to distribute objects, choose Show Options from the flyout menu.

Stacking Objects

Arranging your objects is as key to having neat and tidy layouts as using
grids and so on to align objects. (For more on this topic, see the section
“Lining Up Objects with Guidelines and Grids,” earlier in this chapter.)
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Each time you begin work on a new page, you start with a clean slate (unless
the page is based on a master page, in which case the master objects act as
the page’s background; see Chapter 5 for more on master pages). Every time
you add an object to a page — either by using any of InDesign’s object-creation
tools or with the Place command (Filez>Place [88+D or Ctrl+D]) — the new
object occupies a unique place in the page’s object hierarchy, or stacking order.

The first object you place on a page is automatically positioned at the bottom
of the stacking order; the next object is positioned one level higher than the
first object (that is, in front of the backmost object); the next object is stacked
one level higher; and so on for every object you add to the page. (It’s not
uncommon for a page to have several dozen, or even several hundred, stacks.)

Although each object occupies its own stack level, if the objects on a page
don’t overlap, the stacking order isn’t an issue. But some of the most interest-
ing graphic effects you can achieve with InDesign involve arranging several
overlapping objects, so you need to be aware of the three-dimensional nature
of a page’s stacking order.

You may change your mind about what you want to achieve in your layout

after you've already placed objects in it. To change an object’s position in a
page’s stacking order, use the Arrange command (Objectm>Arrange), which
offers four choices (note the use of brackets in the shortcuts):

v Bring to Front (Shift+38+] or Ctrl+Shift+])
v Bring Forward (88+] or Ctrl+])

v Send Backward (88+[ or Ctrl+[)

v Send to Back (Shift+88+[ or Ctrl+Shift+[)

<P To select an object that’s hidden behind one or more other objects, press and
hold & or Ctrl and then click anywhere within the area of the hidden object.
The first click selects the topmost object; each successive click selects the
next lowest object in the stacking order. When the bottom object is selected,
the next click selects the top object. If you don’t know where a hidden object
is, you can simply click the object or objects in front of it and then send the
object(s) to the back. (See Chapter 8 for more on selecting stacked objects.)

Creating Inline and Anchored Frames

In most cases, you want the frames you place on your pages to remain pre-
cisely where you put them. But sometimes, you want to place frames relative
to related text in such a way that the frames move when the text is edited.
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Figure 10-6:
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The simplest way is to use inline graphics. For example, if you're creating a
product catalog that’s essentially a continuous list of product descriptions
and you want to include a graphic with each description, you can paste

graphics within the text to create inline graphics frames.

A close cousin to the inline frame is the anchored frame, in which a frame fol-
lows a point in the text, but that frame isn’t actually in the text. For example,
you might have a “For More Information” sidebar that you want to appear

to the left of the text that first mentions a term. By using an anchored frame,
you can have that sidebar move with the text so that it always appears to its
left, perhaps in an adjacent column or in the page margins.

Figure 10-6 shows examples of both an inline frame and an anchored frame.
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Note that the process of creating inline and anchored frames — especially
anchored frames — can appear overwhelming. It does require thinking
through the frame’s placement and visualizing that placement so that you
pick the right options in the various dialog boxes. But relax: You can experi-
ment until you get the hang of it. That’s why InDesign lets you undo your
work.
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Working with inline frames

An inline frame is treated like a single character (even if it does go deeper
than a single line). If you insert or delete text that precedes an inline frame,
the frame moves forward or backward along with the rest of the text that
follows the inserted or deleted text. Although inline frames usually contain
graphics, they can just as easily contain text or nothing at all.

Inline frames may interfere with line spacing in paragraphs that have
automatic leading. If the inline frame is larger than the point size in use,
the automatic leading value for that line is calculated from the inline frame,
which leads to inconsistent line spacing in the paragraph. To work around
this issue, you can apply a fixed amount of leading to all characters in the
paragraph, adjust the size of inline frames, place inline frames at the begin-
ning of a paragraph, or place inline frames in their own paragraphs.

You can create inline frames in three ways:

v By pasting the frame into text
v By placing the frame into text

v By using the new Anchored Object menu option

The first two methods are the simplest, but the third gives you more control
over the inline frame when you create it. The third way also lets you create
anchored frames, which are covered later in this chapter in the section
“Working with anchored frames.”

Using the Paste command

If you want to create an inline frame from an object you already created, all
you have to do is copy or cut the object and then paste it into text as you
would a piece of highlighted text. Here’s how:

1. Use the Selection tool to select the object you want to paste within
text.

You can use any type of object: a line, an empty shape, a text or picture
frame, or even a group of objects.

2. Choose Edit~>Copy (88+C or Ctrl+C).

If you don’t need the original item, you can use the Cut command
(Edite>Cut [38+X or Ctrl+X]) instead of the Copy command.

3. Select the Type tool and then click within the text where you want to
place the copied object.

Make sure that the cursor is flashing where you intend to place the
inline frame.

4. Choose Edit~>Paste (88+V or Ctrl+V).
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Inline frames often work best when placed at the beginning of a paragraph.
If you place an inline frame within text to which automatic leading has been
applied, the resulting line spacing can be inconsistent. To fix this problem,
you can resize the inline frame.

Using the Place command

You can also use the Place command to create an inline graphics frame from
an external picture file. (You can’t use this technique for inline text frames
because InDesign thinks you’re just inserting the new text at the current
location, not trying to insert a new text frame there.) Here’s how:

1. Select the Type tool and then click within a text frame to establish the
insertion point.

2. Choose File~>Place (88+D or Ctrl+D).

3. Locate and select the graphics file you want to place within the text;
choose Open.

To delete an inline frame, you can select it and then choose Edit>Clear or
Edit=>Cut (8+X or Ctrl+X), or you can position the text cursor next to it and
press Delete or Backspace — just like any other “character.”

Adjusting inline frames
After you create an inline frame, you can adjust its position vertically or
horizontally. Again, you have your choice of several methods.

Two quick-and-dirty methods to move an inline frame vertically are as
follows:

v Use the Type tool to highlight the inline frame as you would highlight
an individual text character. In the Character panel or Control panel’s
Character pane (the A icon), type a positive value in the Baseline Shift
field to move the inline frame up; type a negative value to move the
frame down.

1 Use the Selection tool or Direct Selection tool to select the inline frame;
drag the frame up or down.
A quick way to move an inline frame horizontally is to follow these steps:
1. With the Type tool selected, click between the inline frame and the
character that precedes it.

2. Use the kerning controls in the Character panel or Control panel to
enlarge or reduce the space between the inline frame and the preceding
character.
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You can more precisely control the position of inline frames by using the
Anchored Object Options dialog box, covered in the next section.

Of course, you can also adjust the inline frame’s other attributes as needed,
such as strokes, fills, dimensions, rotation, and skew, by using the Tools panel,
Control panel, and other panels.

Working with anchored frames

Anchored frames give you a whole new way of organizing objects. Essentially,
they follow the relevant text within the parameters you specify, such as staying
to the left of the text or staying at the top of the page that contains the text.

Note that an inline frame is a type of anchored frame, one where the frame
stays within the text it is linked to. For simplicity, I'm using the term anchored
frame to mean only those frames that are at least partially outside the text
frame but remain linked to a specific point in the text.

In addition to preserving anchored frames in imported Microsoft Word files,
InDesign lets you create anchors in your layout. To create anchored frames,
do the following:

1. Select the Type tool and then click within a text frame to establish the
insertion point.

2. Choose Object~>Anchored Object~Insert.
The Insert Anchored Object dialog box appears.

3. In the Object Options section of the dialog box, specify the anchored
frame’s settings.

You can choose the type of content (text, graphics, or unassigned) with
the Content pop-up menu, apply an object style by using the Object
Style pop-up menu, apply a paragraph style via the Paragraph Style
pop-up menu (if Content is set to Text), and set the anchored frame’s
dimensions in the Height and Width fields. Note that the paragraph style
you choose, if any, applies to the anchored frame, not to the paragraph
in which the anchored frame is linked.

4. In the Position pop-up menu, choose what kind of frame you’re
creating: Inline or Above Line (both are inline frames) or Custom (an
anchored frame).

The dialog box displays different options based on that choice, as Figure
10-7 shows.
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Anchored frames that you add by choosing Object=>Anchored
Object>Insert don’t have text automatically wrapped around them. Use
the Text Wrap panel (Window=>Text Wrap [Option+38+W or Ctrl+Alt+W])
to open this panel and set text wrap. But anchored frames created by
pasting a graphic into text do automatically have text wrap around them.

Selecting the Prevent Manual Positioning option ensures that the
positions of individual anchored frames can’t be adjusted by using
InDesign’s other text and frame controls (such as Baseline Shift). This
option forces users to use this dialog box to change the anchored
frame’s position, reducing the chances of accidental change.

. Decide whether to select the Relative to Spine option.

If this option is not selected, the anchored frame is placed on the same
side of the text frame on all pages, whether those pages are left-facing or
right-facing. If the Relative to Spine option is selected, InDesign places
the text frame on the outside of both pages or inside of both pages,
depending on how the anchored position is set.

. In the Anchored Object section of the dialog box, click one of the
positioning squares to set up the text frame’s relative position.

Note that you need to think about both the horizontal and vertical posi-
tion you desire. For example, if you want the anchored frame to appear
to the right of the text reference, click one of the right-hand squares.
(Remember that selecting the Relative to Spine option overrides this
setting, making the right-hand pages’ positions mirror that of the left-
hand pages, rather than be identical to them.) If you choose the topmost



Chapter 10: Aligning and Arranging Objects 1 85

right-hand square, the anchored frame is placed to the right of the text
reference and vertically appears at or below that text reference. But if
you choose the bottommost right-hand square, you're telling InDesign
you want the anchored frame to appear vertically above the text refer-
ence. Experiment with your layout to see what works best in each case.

7. In the Anchored Position section of the dialog box, click one of the
positioning squares to set up the text reference’s relative position.

Although nine squares appear, the only three that matter are those in
the middle row. Typically, you place the text reference on the opposite
side of the anchored frame — if you want the anchored frame to be to
the left, you’d indicate that the text reference is to the right. (If you set
the text reference on the same side as the anchored frame, InDesign
places the anchored frame over the text.) The reason three squares (left,
middle, and right) appear is to accommodate layouts in which you want
some anchored frames to appear to the left of the text and some to the
right; in that case, choose the middle position here and select the right-
or left-hand position in the Anchored Object section as appropriate to
that object.

8. In necessary, use the options in the Anchored Position section to give
InDesign more precise instructions on how to place the anchored
frames.

You have the following options:

¢ The X Relative To pop-up menu tells InDesign from where the
horizontal location is calculated, using the following options:
Anchor Marker, Column Edge, Text Frame, Page Margin, and Page
Edge. The right option depends both on where you want the
anchored frames placed and whether you have multicolumn text
boxes (in which case Text Frame and Column Edge result in differ-
ent placement, while in a single-column text frame they do not).
You can also specify a specific amount of space to place between
the chosen X Relative To point and the anchored frame by typing a
value in the X Offset field.

The Y Relative To pop-up menu tells InDesign from where the
vertical location is calculated, using the following options: Line
(Baseline), Line (Cap-height), Line (Top of Leading), Column Edge,
Text Frame, Page Margin, and Page Edge. As you expect, you can
also indicate a specific amount of space to place between the
chosen Y Relative To point and the anchored frame by typing a
value in the Y Offset field.

¢ The Keep Within Top/Bottom Column boundaries check box
does exactly what it says.

9. Click OK to insert the anchored frame.
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Anchoring caveats

Consider these caveats when creating

hored frames:

Because an anchored frame follows its
text as it flows throughout a document,
you need to ensure that your layout retains
clear paths for those anchored objects to
follow. Otherwise, anchored frames may
overlap other frames as they move.

Anchored frames should generally be small
items and/or used sparingly. The more items
you have anchored to text, the greater the
chance that they’ll interfere with each

stay in specific locations on the page for
good visual appearance. The InDesign
anchored-frame function can accom-
modate that need for specific positioning
on a page, but you need to be careful as
you add or delete text. You don't want to
end up with some pages that have no pull-
quotes at all because you have so much
text between the pull-quotes’ anchor
points. Conversely, you need to make sure
that you don’t have too many pull-quotes
anchored close to each other, which can
result in overlapping.

other’s placement. Likewise, you can move
large items only so far within a page, so
the benefit of keeping them close to their
related text disappears.

Typically, you use anchored frames for small
graphics or icons that you want to keep next
to a specific paragraph (such as the Tip and
Warning icons used in this book). Another
good use is for cross-reference (“For More
Information”) text frames.

v~ Items such as pull-quotes are obvious can-
didates for use as anchored frames. But in
many layouts, you want the pull-quotes to

You can create inline frames using this same basic process, choosing Inline or
Above Line in Step 4 in the preceding steps. You get most of the same controls
as for anchored objects, such as the frame size and type, but, of course, you
don’t see controls for the relative position because an inline frame goes at the
text-insertion point. If you want to create an inline frame, use the techniques
described in the previous section for copying or placing a frame into text.
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Converting existing frames to anchored frames

After you get the hang of when and how to use anchored frames, you'll likely
want to convert some frames in existing documents into anchored frames.
InDesign doesn’t offer a direct way to do that task, but you can take a some-
what circuitous path:

1. Use the Selection or Direct Selection tool to cut the existing frame that
you want to make into an anchored frame by choosing Edit~>Cut (38+X
or Ctrl+X).

You can also copy an existing frame by choosing Edit=>Copy (88+C or
Ctrl+C).
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2. Switch to the Type tool and click in a text frame at the desired
location to insert the text reference to the anchored frame.

3. Paste the cut or copied frame into that insertion point by choosing
Edit~>Paste (38+V or Ctrl+V).

You now have an inline frame.

4. Select the frame with the Selection tool and then choose
Object~>Anchored Object~>Options to display the Anchored Object
Options dialog box.

This dialog box looks like the Insert Anchored Options dialog box,
shown in Figure 10-7, except that it doesn’t include the top Object
Options section; you can see that section in Figure 10-6.

5. Choose Custom from the Position pop-up menu.
This step converts the frame from an inline frame to an anchored frame.

6. Adjust the position for the newly minted anchored frame as described
in the previous section.

7. Click OK when you’re done.

Adjusting anchored frames
After you create an anchored frame, you can adjust its position.

A quick-and-dirty method is simply to click and drag anchored frames or use
the Control panel to adjust their position. If the text the frame is anchored

to moves, however, InDesign overrides those changes. (You can’t manually
move an anchored frame if the Prevent Manual Positioning option is selected
in the Insert Anchored Object dialog box or Anchored Object Options dialog
box. This option is deselected by default.)

For the most control of an anchored frame’s position, choose
Objectr>Anchored Object>Options. The resulting Anchored Object Options
dialog box is identical to the Insert Anchored Object dialog box but without
the Object Options section.

And, of course, you can adjust the frame’s other attributes as needed, such
as strokes, fills, dimensions, rotation, and skew.

The Select Next Object and Select Previous Object functions now work for
anchored objects in text. If you select an anchored object and use these
functions, InDesign CS4 moves to the next (or previous) anchored object in
the current story. (Chapter 8 covers object selection.)
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Releasing and deleting anchored frames

If you no longer want an anchored frame to be anchored to a text location, you
can release the anchor. To do so, select the anchored frame with the Selection
or Direct Selection tool and then choose Object>Anchored Object>Release.

It’s also easy to delete an anchored frame: Select the frame with the Selection
or Direct Selection tool and then choose Edite=>Clear or press Delete or
Backspace. If you want to remove the object but keep it on the Clipboard for
pasting elsewhere, choose Edit=>Cut (38+X or Ctrl+X).
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In this part . . .

Getting words on the page is an important part of
what you do with InDesign. After you have the words
in place, you'll want to tweak the letters and lines, and the
space between them, to make your pages sparkle.

This part shows you how to arrange words on the page,
including words made up of exotic characters. You find
out how to set text in columns and how to add bullets and
numbers to that text. You also discover how to stretch,
squeeze, rotate, and add special effects to text.
Additionally, you see how to become skilled at using char-
acter and paragraph styles to make your life easier and to
speed up your publishing workflow.




Chapter 11
Putting Words on the Page

In This Chapter

Creating text frames

Putting words on your page

Adding pages for new text automatically
Threading text from frame to frame
Using text columns

Making the most of text wrapping

Text is more than words — it’s also a layout element that flows through
your pages in the locations that you need. Much of the work you do in
InDesign involves controlling that flow and working with the text as blocks
that need to have the right arrangement to fit your layout’s goals.

This chapter helps you manage that flow and arrangement, showing you how
to deftly maneuver the text through your layout, just as you would move
your way through the dance floor.

After you have the steps nailed down, you can do the dance: bringing in text
from your source files.

Working with Text Frames

When you're creating a simple layout, such as a single-page flyer or a magazine
advertisement, you'll probably create text frames — the containers for text —
as you need them. But if you're working on a book or a magazine, you’ll want
your text frames placed on master pages so that your text will be consistently
framed automatically when it appears on document pages. And you’ll still have
individual text frames you create for specific elements like sidebars.

Chapter 7 shows you how to create frames (including text frames),

whereas Chapter 5 shows you how to create master pages. This chapter brings
those two concepts together to show you how to work with text frames, both
those in master pages and those you create in your document pages.



192 Ppartv: TextEssentials

Creating master text frames

Master pages — predesigned pages that you can apply to other pages to
automate layout and ensure consistency — can contain several types of text
frames:

v Text frames containing standing text, such as page numbers or page
headers.

v Text frames containing placeholder text for elements such as figure
captions or headlines.

v One master text frame (an automatically placed text frame for flowing
text throughout pages), which you create in the New Document dialog
box (File>New=>Document [8+N or Ctrl+N]).

Think of a master text frame as an empty text frame on the default master
page that lets you automatically flow text through a document. When you
create a new document, you can create a master text frame at the same time.
Here’s how it works:

1. Choose File>"New=>Document (88+N or Ctrl+N).

2. Check the Master Text Frame check box at the top of the New
Document dialog box.

3. Specify the size and placement of the master text frame by entering
values in the Margins area for Top, Bottom, Inside, and Outside (or
Left and Right if Facing Pages is unchecked) fields.

InDesign places guides according to these values and places a text frame
within the guides. The text frame fits within the boundaries of these
values and those of the guides on the master page.

4. To specify the number of columns in the master text frame, enter a
value in the Number field in the Columns area.

You can also specify the amount of space between the columns by
entering a value in the Gutter field.

5. Establish any other needed settings, as described in Chapter 3.

Check the Facing Pages check box if your pages will have different inside
and outside margins. (For example, a book may have different inside and
outside margins for left-hand and right-hand pages.)

6. Click OK to create a new document containing a master text frame.

After you create a document with a master text frame, you’ll see guides on
the first document page that indicate the placement of the frame.
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Figure 11-1:
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Creating individual text frames

Although the master text frame is helpful for containing body text that flows
through a document, you’ll probably need additional text frames on both
master pages and document pages. Generally, these smaller text frames hold
text such as headlines, sidebars, or captions.

To add text frames to a master page for repeating elements such as headers
and footers, first display the master page. Choose Window=>Pages (88+F12
or Ctrl+F12) to display the Pages panel. Then double-click the A-Master icon
in the upper portion of the panel, as shown in Figure 11-1, which displays
the A-Master master page. (If you have multiple master pages in your docu-
ment, you can follow these instructions to add text frames to any of them.
Just choose the desired master page.)
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To add text frames to a document page, first go to the page. You can use any
of the techniques described in Chapter 4 to move among pages.

Now draw the desired frame using any of the frame or shape tools, or the
Type tool, as described in Chapter 6. Modify them with the Control panel (or
Transform panel) or by using the mouse, also as described in that chapter.
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Text frames you add to a master page will show up on any document pages
based on that master page.

If you're working on a document page and want to type inside a text
frame placed on the page by a master page, select the Type tool and then
Shift+8+click or Ctrl+Shift+click the frame.

Setting up automatic page creation

Often when you import a large text file, such as for a book or report, you
don’t know how many pages you need. Chances are that you have a few
pages in your document already set up and then add more pages until the
text is all placed. InDesign CS4now offers an easier way.

InDesign CS4 has a new feature called autoflow that adds pages to the end of
your document until all the text has been placed. For autoflow to work, you
must do two things:

1. Enable autoflow in the Type pane of the Preferences dialog
box (choose InDesign= Preferences- Type [8+K] on the Mac or
Edit~>Preferences=>Type [Ctrl+K] in Windows).

Be sure that Smart Text Reflow is checked and then choose the appro-
priate reflow options in the Add Pages To pop-up menu — End of Story,
End of Section, and End of Document — to determine where the extra
pages are added.

I recommend that you use this feature with the Limit to Master Text
Frames and Preserve Facing-Page Spreads options enabled. The first
option assumes that you set up master text frames, as described in the
“Creating master text frames” section, earlier in this chapter. If you don’t
use such master text frames, don’t check this option. Instead, be sure that
if you set up your own text frames in the master page (see the previous
section) that you have threaded them to each other, as described in the
“Threading text frames” section, later in this chapter. The second option
means that if you have spreads already set up in you document, they
won'’t get messed up (in other words, be split up) by the added pages.

2. When you place your text, do so in your master text frame or in a text
frame defined on your master page.

InDesign uses these (and only these) frames to create the new pages
from. Remember that you can place text in a frame that already has
text (to replace that text or to add more text), as well as place text in
an empty frame. No matter which approach you take, InDesign adds the
necessary number of pages for the placed text to flow into.
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The smart text flow feature doesn’t work if you place text into a document
text frame; it must be placed in a master text frame or in a text frame that is
defined on a master page.

InDesign offers two other methods to autoflow text into master frames,
whether or not smart text flow is enabled:

v 1f you hold the Shift key when placing text, InDesign flows the text into
the master frame and keeps going until it runs out of pages with master
frames. Then it creates more master frames until the text is all placed.
Unlike with the new smart text reflow feature, you can’t control where
those pages are added.

v If you hold Option+Shift or Alt+Shift when placing text, InDesign flows
the text into the nearest master frame and automatically flows it into the
subsequent “open” master frames in your document. Unlike the Shift-
only option, it does not add new pages.

The details on placing text are covered in the “Importing text” section, later
in this chapter.

Making changes to text frames

You're not confined to the settings you originally established when you set
up a master text frame or an individual text frame; you can change the size,
shape, and/or number of columns in the text frame later. Use the Selection
tool to click the desired text frame and then modify it with the following
options (the first six are covered in detail in Chapter 8):

v Change the placement of a selected master text frame by using the X:
and Y: fields in the Control panel.

v Change the size of the master text frame by using the W: and H: fields.

v Change the angle by using the Rotation Angle field.

v Change the skew by using the Shear X Angle field.

v Enter values in the Scale fields to increase or decrease, by percentage
amounts, the width and height of the text frame.

v Use the General pane of the Text Frame Options dialog box
(Object=>Text Frame Options [8+B or Ctrl+B], shown in Figure 11-2) to
make further modifications:

¢ Change the number of columns and the space between them.
¢ Specify how far text is inset from each side of the frame.
e Align text vertically within the frame.

e Control the placement of the first baseline.
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v Use the Baseline Options pane of the Text Frame Options dialog box
to set a baseline grid, if desired, for the text to align to. Chapter 10
describes this feature in more detail.

If you don’t want the text inside this text frame to wrap around any items
<P in front of it, check Ignore Text Wrap at the bottom of the dialog box.

If you open the Text Frame Options dialog box with no document open,
any changes you make will become the default for all new documents.
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I
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v Specify character styles, paragraph styles, object styles, Story panel
settings, text-wrap settings, and other text attributes to apply in the text
frame to the document text you flow into that frame. (You can always
override those attributes by applying other styles or formatting to the
text later.) The rest of Part IV covers these other settings.

Additionally, if you select the frame with the Direct Selection tool, you can
change its shape by dragging anchor points on the frame to other positions,

as described in Chapter 8.

Importing Text

You can import text from a word processor file (Word 97/98 or later, RTF,
ASCII [text-only], or InDesign Tagged Text files) into an InDesign text frame
using the Place dialog box (Filec>Place [88+D or Ctrl+D]). You can also import
Microsoft Excel spreadsheets (Version 97/98 or later). Many of the text’s orig-
inal styles will remain intact, although you will want to review the imported
text carefully to see whether any adjustments need to be made.
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Follow these steps to place imported text:

. Choose File>Place (88+D or Ctrl+D) to open the Place dialog box.
2. Locate the text file you want to import.

. To specify how to handle current formatting in the file, check the

Show Import Options check box.

The appropriate Import Options dialog box for the text file’s format
opens. (Note that no import options exist for ASCII text.) Then click OK
to return to the Place dialog box.

. Click the Open button to import the text.

If you selected an empty frame with the Type tool, InDesign will flow the
text into that frame. If you selected a text frame with the Type tool, InDesign
will flow the text at the text-insertion point in that frame, inserting the new
text within the existing text.

If you hadn’t already selected a frame before starting to import the text,
specify where to place it by clicking and dragging the loaded-text icon to
create a rectangular text frame, clicking in an existing frame, or clicking
in any empty frame.

You can select multiple files — text and/or graphics — by Shift+clicking a
range or 3+clicking or Ctrl+clicking multiple files one by one. InDesign lets
you place each file in a separate frame. Just click once for each file imported,
or Shift+88+click or Ctrl+Shift+click to have InDesign place all files on the
page in separate frames. The loaded-text icon shows the number of files to be
placed, as well as a mini-preview of each file, as shown in Figure 11-3.
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When placing files, you can use the keyboard left- and right-arrow keys to
move through the thumbnail previews before clicking to place the one whose
thumbnail preview is currently displayed. That way, you can place the files in
any order you want.

You can’t click on a master text frame — a text frame that is placed on the
page by the master page in use — and simply start typing. To select a master
text frame and add text to it, Shift+O+click or Ctrl+Shift+click it. (For more on
master pages, see Chapter 5.)

Import options for Microsoft
Word and RTF files

InDesign offers a comprehensive set of import options for Word and RTF
files. With these options, you can control how these files import into
InDesign. To save time on future imports, you can save your import prefer-
ences as a preset file for repeat use.

Figure 11-4 shows the Microsoft Word Import Options dialog box. The import
options for RTF files are identical.

The Preset pop-up menu, at the top of the dialog box, lets you select from
saved sets of import options. You can save the current settings by clicking
the Save Preset button. And you can set a preset as the default import behav-
ior by clicking the Set as Default button; these settings are used for all Word
file imports unless you choose a new default or make changes in this dialog
box. This default preset capability lets you avoid using the Import Options
dialog box for your routine imports.

The Include section of the Import Options dialog box is where you decide
whether to strip out specific types of text (Table of Contents Text, Index
Text, Footnotes, and Endnotes) from the Word file. If you check items, their
corresponding text will be imported. You probably won’t want to import
table-of-contents or index text because you can create much nicer-looking
tables of contents and indexes in InDesign.
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The third section, Options, has just one option: Use Typographer’s Quotes. If
this box is checked, InDesign converts keyboard quotes from your source file
(“and ") to “curly” typographic quotes (,’, “, and ).

The fourth section, Formatting, is fairly complex, so take it one step at a
time. Start with deciding whether to remove or retain the formatting in your
imported text.

To remove text formatting during import so that you can do the formatting
in InDesign, select the Remove Styles and Formatting from Text and Tables
option. You have two additional controls for this option:

v Preserve Local Overrides, which retains local formatting such as ital-
ics and boldface while ignoring the paragraph style attributes. You'd
usually want this option checked so that meaning-related formatting is
retained.

»* You also can choose how tables are “unformatted” during import via the
Convert Tables To pop-up menu. Unformatted Tables retains the table’s
cell structure but ignores text and cell formatting, while Unformatted
Tabbed Text converts the table to tabbed text (with a tab separating
what used to be cells and a paragraph return separating what used to
be rows) and strips out any formatting. If you intend to keep tables as
tables but format them in InDesign, choose Unformatted Tables.
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To retain text formatting during import so that the InDesign document at
least starts out using the settings used in Word, choose the Preserve Styles
and Formatting from Text and Tables option. This option includes several
controls and bits of information:

v The Manual Page Breaks pop-up menu lets you retain any page breaks
entered in Word, convert them to column breaks, or strip them out.

v Checking the Import Inline Graphics check box enables the import of
any graphics in the Word text.

v Checking the Import Unused Styles check box means that all Word style
sheets transfer into InDesign, rather than just the ones you actually
applied to text in the file. Unless you want all those extra Word styles,
keep this box unchecked.

v Checking the Track Changes check box preserves the revisions track-
ing information from Word so that you can see it in the companion
Adobe InCopy editing program. But InDesign itself doesn’t display or let
you use that tracking information. This book doesn’t cover the expert
InCopy add-on software.

v Checking Convert Bullets & Numbers to Text removes any automatic
bullet and numbering lists in Word, converting the bullets and numbers
into the actual characters. If you select this option and insert an item in
an imported numbered list, the list doesn’t renumber automatically, as
it would if you leave this unchecked. (In previous versions of InDesign,
bullets and numbers were converted, eliminating the automatic aspect.)

v~ If InDesign detects that the Word file has a style with the same name
as your InDesign document, it notes how many to the right of the Style
Name Conflicts label. You have choices in how to handle these conflicts:

¢ Use InDesign Style Definition preserves the current InDesign style
sheets and applies them to any text in Word that uses a style sheet
of the same name. Redefine InDesign Style causes the Word style
sheet’s formatting to permanently replace that of InDesign’s style
sheet. Auto Rename renames the Word file’s style sheet and adds
it to the Paragraph Styles or Character Styles panel. This option
preserves your existing InDesign style sheets while also preserving
those imported from the Word file.

e Customize Style Import lets you decide which specific InDesign
styles override same-name Word styles, which Word styles over-
ride same-name InDesign styles, and which Word styles are
renamed during import to prevent any overriding.



Chapter 11: Putting Words on the Page 20 ’

Figure 11-5:
The Import
Options
dialog box
for an Excel
file.
|

Import options for Microsoft Excel files

When importing Excel spreadsheets, you have several options, as Figure 11-5

shows.

In the Options section, you can control the following settings:

v The Sheet pop-up menu lets you choose which sheet in an Excel workbook
to import. The default is the first sheet, which is usually named Sheet1
unless you renamed it in Excel. (If you want to import several sheets, you'll
need to import the same spreadsheet several times, choosing a different

sheet each time.)

v The View pop-up menu lets you import custom views that are defined in
Excel for that spreadsheet. If the spreadsheet has no custom views, this
pop-up menu is grayed out. You can also ignore any custom views by
choosing [Ignore View] from the pop-up menu.

v+~ In the Cell Range pop-up menu, you specify a range of cells using stan-
dard Excel notation Sx:Ey, where S is the first row, x the first column,
E the last row, and y the last column, such as A1:G35. You can enter a
range directly in the pop-up menu, which also acts as a text-entry field,
or choose a previously entered range from the pop-up menu.

v Checking the Import Hidden Cells Not Saved in View check box imports
hidden cells. Be careful when doing so, because these cells are usually
hidden for a reason. (Typically, they show interim calculations and the

like.)
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In the Formatting section, you can control the following settings:

v In the Table pop-up menu, you choose from Formatted Table, which
imports the spreadsheet as a table and retains text and cell formatting;
Unformatted Table, which imports the spreadsheet as a table but doesn’t
preserve formatting; and Unformatted Tabbed Text, which imports the
spreadsheet as tabbed text (tabs separate cells and paragraph returns
separate rows) with no formatting retained.

v In the Table Style pop-up menu, you choose an InDesign table style to
apply to the imported table or leave it alone (by choosing [No Table

Style]).

v In the Cell Alignment pop-up menu, you tell InDesign how to align the

text in cells. You can retain the spreadsheet’s current alignment settings

by choosing Current Spreadsheet or override them by choosing Left,

Right, or Center.

v Checking the Include Inline Graphics check box imports any graphics

placed in the Excel cells.

v The Number of Decimal Places to Include field is where you enter how
many decimal places to retain for numbers.

v Check the Use Typographer’s Quotes check box to convert keyboard

¢«

quotes (‘ and ") to the “curly” typographic quotes (*,’, “, and ”). Keeping
this box checked is a good idea.

Keep characters to a minimum

When you're working with text in a professional
publishing application, such as InDesign, you
need to keep in mind some differences between
the professional method and traditional way of
typing:

v Remember that you don't need to type
two spaces after a period or colon; books,
newspapers, magazines, and other profes-
sional documents all use just one space
after such punctuation.

v Don’t enter extra paragraph returns for
space between paragraphs and don’t enter
tabs to indent paragraphs — instead, set up
this formatting using InDesign’s paragraph

attributes (Type=>Paragraph [Option+88+T
or Ctrl+Alt+T]).

v To align text in columns, don’t enter extra
tabs; place the same number of tabs
between each column and then align
the tabs (Type=>Tabs, or Shift+38+T or
Ctrl+Shift+T).

To see where your InDesign document has tabs,
paragraph breaks, spaces, and other such invis-
ible characters, choose Type=>Show Hidden
Characters (Option+88+I or Ctrl+Alt+l). You can
also view them from the application bar's View
Options pop-up menu (see Chapter 1).
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Pasting text into an InDesign document

As you probably already know, you can hold text on the Mac or Windows
Clipboard by cutting it or copying it from its original location. After you’'ve
captured some text on the Clipboard, you can paste it into an InDesign docu-
ment at the location of the cursor. You can also replace highlighted text with
the text that’s on the Clipboard. If no text frame is active when you do the
pasting, InDesign creates a new text frame to contain the pasted text.

InDesign uses standard menu commands and keyboard commands for cut-
ting/copying text to the Clipboard, and for pasting text. On the Mac, press

8 +X to cut, 88+C to copy, and 88+V to paste. In Windows, press Ctrl+X to cut,
Ctrl+C to copy, and Ctrl+V to paste.

Text that is cut or copied from InDesign normally retains its formatting,
whereas text pasted from other programs loses its formatting. But you can
specify whether pasted text from other programs always retains its for-
matting. Go to the Clipboard Handling pane in the Preferences dialog box
(choose InDesign=>Preferences=>Clipboard Handling [88+K] on the Mac,

or choose Edit>Preferences=>Clipboard Handling [Ctrl+K] in Windows)

and select the All Information option in the When Pasting Text and Tables
from Other Applications section. If you select this option, you can still tell
InDesign to not preserve the formatting on a case-by-case basis by choosing
Edit>Paste without Formatting (Shift+8+V or Ctrl+Shift+V).

Dragging and dropping text

You can drag highlighted text from other programs — or even text files from
the desktop or a folder — into an InDesign document. Text that you drag and
drop is inserted at the location of the cursor, replaces highlighted text, or is
placed in a new rectangular text frame.

When you drag and drop a text selection, its original formatting is usually
retained — unless you hold the Shift key when dragging. If you hold the Shift
key, the text takes on the attributes of the text you drag it into.

When you drag and drop a text file, the process is more like a text import:
The text retains its formatting and styles. Unlike the Place command
(Filec>Place [88+D or Ctrl+D]) that imports text, drag and drop doesn’t give
you the option to specify how some of the formatting and styles in the
imported text file are handled.
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Threading Text Frames
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The text that flows through a series of frames is what InDesign considers a
story, and the connections among those frames are called threads. When you
edit text in a threaded story, the text reflows throughout the text frames. You
can also spell-check and do a find/change operation for an entire story, even
though you have just one of the story’s text frames active on-screen.

When you have threaded text frames, you'll see visual indicators on your text
frame, assuming that you choose Viewr>Show Text Threads (Option+88+Y or
Ctrl+Alt+Y) and have selected the frame with one of the selection tools. At
the lower right of the text frame is a small square, called the out port, which
indicates the outflow status:

v~ If the square is empty, that means you have no text flowing to another
frame, and not enough text to flow to another frame.

v~ If the square is red and has a plus sign in it, that means you have more
text than fits in the selected frame but that it’s not flowing to another
frame. This condition is called overset text.

v~ If the square has a triangle icon, the text is flowing to another frame.
That doesn’t mean that text is flowing, just that if you have more text
than the current frame can hold, it will flow.

Similarly, an in port at the upper left of a text frame indicates whether text is
flowing from another frame into the current frame:

v~ If the square is empty, no text is flowing from another frame, making this
frame the first (and perhaps only) frame in a story.

v~ If the square has a triangle icon, the text is flowing from another frame.
That doesn’t mean that text is flowing, just that if you have more text
than the other frame can hold, it will flow into this frame.

So how do you thread the frames in the first place? You have four options in
InDesign: manual, semi-autoflow, and two types of autoflow. Each of these
options has its own icon. The method you choose depends on the amount of
text you're dealing with and the size and number of your text frames:

v To link two empty text frames across several pages (for example, for an
article that starts on page 2 and continues on page 24) — for frames
where you will later want to text to flow across — you might use the
manual method, in which you click the first text frame’s out port and
then click on the second text frame.

v To link a text frame with text to another text frame, you might also use
the manual method, in which you click the first text frame’s out port and
then click on the second text frame.
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v To link a succession of text frames, you might want to use the semi-
autoflow method, which allows you to click a series of text frames to
flow text from one frame to the next. Hold the Option or Alt key when
clicking the mouse during text placement. Remember that, as you're
threading frames, Option+click or Alt+click each text frame, or you’ll
revert to manual threading.

v To import text that is intended for long documents (such as a book
chapter or brochure), you might want to use the autoflow method to
add text frames and pages that accommodate the text you're importing.
Hold the Shift key when clicking the mouse during text placement to fill
all open master frames and create new ones as needed. Be sure to
Shift+click near the upper-left corner of the master text frame so that
InDesign uses that frame rather than create a new one. Note that even if
you've already placed a text file into a single text frame or a threaded
chain of text frames, you can still autoflow text from the last text frame.
To do so, click the out port and then Shift+click any page to indicate
where to start the autoflow.

v+ To import text into a long page where you don’t want new pages
added, hold Option+Shift or Alt+Shift. The text autoflows into each open
page, but no new pages are added.

+* To place multiple text frames in an array — such as for bios or other
snippet-size text — hold Shift+88 or Ctrl+Shift when dragging the mouse
in your document. The files will be placed in an array, each in its own
frame within the area defined when dragging the mouse. This new
InDesign CS4 feature creates as many frames as it that array, placing the
files into them. Any files not placed remain in the load-text icon for
placement elsewhere.

For a quick glance at your text threads while you're threading text across
pages, simply change the document view briefly to 20 percent or so.

Text flows in the order in which you select frames. If you move a frame, its
order in the text flow remains unchanged. If you’re not careful, you can, for
example, accidentally have text flow from a frame at the top of the page to a
frame at the bottom of a page and then to one in the middle of a page.

Always switch to a selection tool when you’re threading frames. Oddly, you
can’t thread frames while the Type tool is selected. Oh well.



206 Part IV: Text Essentials

Breaking and rerouting threads

After text frames are threaded, you have three options for changing the
threads: You can break threads to stop text from flowing, insert a text frame
into an existing chain of threaded text frames, and remove text frames from a
thread. Here are the techniques in a nutshell:

1 Break the link between two text frames by double-clicking either
an out port or an in port. The thread between the two text frames is
removed, and all text that had flowed from that point is sucked out of
the subsequent text frames and stored as overset text.

1~ Insert a text frame after a specific text frame in a chain by clicking its
out port. Then, click and drag the loaded-text icon to create a new text
frame. That new frame is automatically threaded to both the previous
and the next text frames.

” Reroute text threads — for example, to drop the middle text frame
from a chain of three — by clicking the text frame with the Selection
tool and then pressing Delete or Backspace. This technique deletes the
text frame and reroutes the threads. You can also Shift+click to multiple-
select text frames to remove. Note that you can’t reroute text threads
without removing the text frames.

Working with Columns

\\j

Where you place columns on the page — and the amount of space you allow
between columns — has a big impact on readability. Used with a little know-
how, column width works with type size and leading to make text easier to
read. Columns help you keep from getting lost from one line to the next, and
from getting a headache as you're trying to read the words on the page.

Generally, as columns get wider, the type size and leading increase. For
example, you might see 9-point text and 15-point leading in 2/4-inch columns,
whereas 15-point text and 13-point leading might work better in 3%-inch
columns.

InDesign lets you place columns on the page automatically, create any
number of columns within a text frame, and change columns at any time.
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Specifying columns in master frames

You can specify the number of columns at the same time you create a master
text frame — a text frame placed automatically within the margin guides.

In the Columns area in the New Document dialog box, use the Number field to
specify how many columns, and the Gutter field to specify how much space
to place between the columns. (The gutter is the space between columns.)
Whether or not you check Master Text Frame (which makes the frame appear
on all pages), guides for these columns are still placed on the page and can
be used for placing text frames and other objects.

Changing columns in text frames

You can change the number of columns in a text frame (whether an individ-
ual text frame or a master text frame), even after you've flown text into the
frame — and doing so isn’t difficult. First, select the text frame with a selec-
tion tool or the Type tool (or Shift+click to select multiple text frames and
change all their columns at once). Then choose Object~>Text Frame Options
(88+B or Ctrl+B) and set the desired Number and Gutter values in the General
pane of the Text Frame Options dialog box, shown in Figure 11-2.

You can also use the Control panel to quickly change the number of columns,
but note that this control doesn’t display on a monitor set below 1152-x-870-
pixel resolution unless you customize the Control panel interface (to disable
other controls to make room for this one) using the Customize command in
its flyout menu.

Some designers like to draw each column as a separate frame. I strongly rec-
ommend against this practice; it’s too easy to create columns of slightly dif-
ferent widths and slightly different positions, so text doesn’t align properly.
Instead, specify columns in your text frames so that you don’t have to worry
about sloppy layouts.

Note that the options in the Columns area of the Text Frame Options dialog
box work differently depending on whether Fixed Column Width is checked
or unchecked:

v If Fixed Column Width is unchecked, InDesign subtracts from the text
frame the space specified for the gutters and then divides the remaining
width by the number of columns to figure out how wide the columns can
be. For example, if you specify a 10-inch-wide text frame with three col-
umns and a gutter of /% inch, you end up with three 3-inch columns and
two /-inch gutters. The math is (10 - (2 x 0.5)) + 3.
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v~ If Fixed Column Width is checked, InDesign resizes the text frame to fit
the number of columns you selected at the indicated size, as well as the
gutters between them. For example, suppose that you're using a 10-inch-
wide text frame with a column width of 5 inches and a gutter of % inch,
and you choose three columns: You end up with a 15-inch-wide text
frame containing three 5-inch columns and two %-inch gutters. The math
is(5x3)+(2x2).

Check Preview to see the effects of your changes before finalizing them.

Wrapping Text around Objects

A\\S

In the days before personal computers and page-layout software, wrapping
text around a graphic or other object was a time-consuming and expensive
task. Text wraps were rare, found only in the most expensively produced
publications. Not any more. Not only do all page-layout programs let you
create text runarounds, most programs — including InDesign — provide
several options for controlling how text relates to graphics and other objects
that obstruct its flow.

When a frame is positioned in front of a text frame, InDesign provides the
following options. You can

v~ Ignore the frame and flow the text behind it.
v Wrap the text around the frame’s rectangular bounding box.
v Wrap the text around the frame itself.

v Jump the text around the frame (that is, jump the text from the top of
the frame to the bottom).

v Jump the text to the next column or page when the text reaches the top
of frame.

v Specify the amount of distance between the text and the edge of the
obstructing shape.

v Flow text within the obstructing shape rather than outside it.

InDesign lets you wrap text around frames on hidden layers — as well as
remove text wrap for objects on hidden layers. This technique is handy when
you want to hide images or other distracting items but preserve the layout.
See Chapter 4 for details on using layers.

If you want to wrap text around only a portion of a graphic — perhaps you
need to isolate a face in a crowd — the best solution is to open the graphics
file in its original program, create a clipping path around that portion, and
then resave the file and import it and its clipping path into an InDesign docu-
ment. (Chapter 18 explains clipping paths.)
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The Text Wrap panel

The controls in the Text Wrap panel (see Figure 11-6) let you specify how a
selected object will affect the flow of text behind it. Remember, the flow of
text around an obstructing object is determined by the text-wrap settings
applied to the obstructing object.

You can override the text-wrap settings of objects that are in front of a text
frame by telling the text frame to ignore them. To do so, click a text frame and
then choose Object>Text Frame Options (8+B or Ctrl+B). In the Text Frame
Options dialog box’s General pane, select Ignore Text Wrap and then click OK.
Text in the frame now flows behind any obstructing items regardless of the
text-wrap settings applied to them.

The Text Wrap panel has three options that may not display when you open
it: Wrap Options, Contour Options, and Include Inside Edges. You can more
easily hide/show these functions by double-clicking the double-arrow symbol
to the left of the Text Wrap label in the panel’s tab or by choosing Hide
Options/Show Options from the flyout menu.

Here’s how to apply text-wrap settings to a frame or other object:

1. If the Text Wrap panel isn’t displayed, choose Window=>Text Wrap
(Option+38+W or Ctrl+Alt+W).

2. Click any of the selection tools.
3. Click the object to which you want to apply text-wrap settings.

The object can be anywhere, but you’ll probably want to position it on
top of a text frame that contains text so that you can see the results of
the settings you apply.

4. Click one of the five text-wrap iconic buttons at the top of the Text
Wrap panel.

The iconic buttons show you what each wrap does conceptually.

5. If you want, adjust the space between the surrounding text and the
obstructing shape by typing values in the Top Offset, Bottom Offset,
Left Offset, and Right Offset fields.

These fields aren’t available if you click the No Text Wrap button. If the
object is a rectangle, all four fields are available if you click the Wrap
around Bounding Box button or Wrap around Object Shape. Only the
Top Offset field is available if you click the Wrap around Object Shape
button for a free-form shape or the Jump to Next Column button. The
Top Offset and Bottom Offset fields are available if you click the Jump
Object button.
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If the Make All Settings the Same iconic button displays a chain, then
changing any of the offset values will cause the other offset values to
match. If the icon shows a broken chain, each offset value is indepen-
dent of the others. Click the button to switch between these two modes.

6. Select Invert if you want to flow the text in the obstructing shape.

7. If you choose the Wrap around Object Shape button and a graphic
is in the frame, you can also select from the Contour Options’s Type
pop-up menu.

You have six options:

* Bounding Box is the same as clicking the Wrap around Bounding
Box button.

e Detect Edges tries to determine the graphic’s outside boundary
by ignoring white space — you’d use this option for bitmapped
images that have a transparent or white background.

¢ Alpha Channel uses the image’s alpha channel, if any, to create a
wrapping boundary (see Chapter 18).

¢ Photoshop Path uses the image’s clipping path, if any, to create a
wrapping boundary (see Chapter 18).

¢ Graphic Frame uses the frame’s boundary rather than the
bounding box.

e Same as Clipping uses the clipping path for the graphic created in
InDesign (see Chapter 18).

8. You can control how text wraps around an object that splits a column
by choosing an option from the Wrap To pop-up menu.

The options are Right Side, Left Side, Both Right & Left Sides, Side
Towards Spine, Side Away from Spine, and Largest Area. You'll rarely
choose Both Left and Right Sides, because unless the object is small, read-
ers’ eyes will stop at the interposed object and not see the rest of the text
on the other side of it. Use either of the spine options to have the text stay
on the outside or inside of a page, relative to the object, based on whether
the page is right-facing or left-facing. You'll often choose Largest Area
because that gives the text the most space next to the interposed object,
which tends to be what looks good in many situations.

9. By selecting the Include Inside Edges option, InDesign lets text appear
inside any interior “holes” in the graphic.

You'll rarely use this technique because in most cases it’s hard for the
reader to follow text that wraps around an image, flows inside it, and
then continues to flow outside it. But if the interior is large enough and
not too distant from the text that flows on the outside, this effect may be
readable.
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If you specify text-wrap settings when no objects are selected, the settings are
automatically applied to all new objects.

To apply text-wrap settings to a master item on a document page, press and
hold Shift+88 or Ctrl+Shift to select the item and then use the controls in the
Text Wrap panel as described in the preceding steps. If you don’t want the
text wrap applied to existing document items, just to new ones, choose Apply
to Master Page Only in the flyout menu.

Setting text-wrap preferences

You should be aware of several global text-wrap options, all of which

are accessed via the Composition pane of the Preferences dialog box.
(Choose InDesign=>Preferences=>Composition [3+K] on the Mac or
Edit>Preferences>Composition [Ctrl+K] in Windows.) Here are the options:

v Justify Text Next to an Object: This option is useful when you have left-
aligned text that wraps around an object at the right. (It also works if
you have right-aligned text that wraps around an object at the left.) This
option can lead to an awkward wrap, however, because InDesign won’t
try to make the text align precisely to the wrap’s contour (because the
text isn’t justified). Use this option to justify the text just around the
wrap and then continue using the text’s specified nonjustified alignment.

v~ Skip by Leading: This option makes text wrap below or above an object
based on the text’s leading so that you have at least a full line space
between the text and the object, even if the object’s text-wrap settings
would allow less space.

1 Text Wrap Only Affects Text Beneath: This option, if selected, pre-
vents text frames placed on top of an object from wrapping, while those
behind the graphic frame will still be allowed to wrap. This option allows
some text to overlap the graphic and other text to wrap around it. Note
that this setting is global, affecting all objects. To override wrap settings
of individual text frames, choose Object>Text Frame Options (88+B or
Ctrl+B) and enable the Ignore Text Wrap option in the General pane.

Chapter 11: Putting Words on the Page 2 ’ ’
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Chapter 12
The Ins and Quts of Text Editing

In This Chapter

Editing text in your layout

Searching and replacing words and formats
Checking spelling as you type or all at once
Customizing the spelling and hyphenation dictionaries

Whether you import text or type it into text frames directly in InDesign,
you’ll appreciate the tools that let you edit, search and replace, spell-

check, and hyphenate your text. You can find out all about these capabilities
in this chapter.

Editing Text

InDesign offers basic editing capabilities, not unlike those found in a word
processor: cutting and pasting, deleting and inserting text, searching and

replacing of text and text attributes, and spell-checking. (Cutting, pasting,
inserting, and deleting text works just like it does for any standard Mac or
Windows program, so [ don’t repeat those details for you here.)

To do anything with text, you need to use the Type tool. When the Type tool
is selected, you can click in any empty frame. (If it’s not already a text frame,
it becomes one automatically when you click it with the Type tool.) Or you
can click and drag to create a new text frame. You can even click in an exist-
ing block of text. From this point, start typing to enter text.

Chapter 7 gets into more of the nitty-gritty of creating frames. And you can
discover all about importing text in Chapter 11.
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Controlling text view

In many layout views, the text is too small to work with. Generally, you zoom
in around the block of text using the Zoom tool. Select the tool and then click
to zoom in. To zoom out, hold the Option or Alt key when clicking.

Another way to zoom in is to use the keyboard shortcut 38+= or Ctrl+=. Each
time you use it, the magnification increases. (Zoom out via 8+- or Ctrl+-.)

In addition to seeing the text larger, zooming in also helps you see

the spaces, tabs, and paragraph returns that exist in the text. Choose
Type>Show Hidden Characters (Option+88+I or Ctrl+Alt+I) to have the non-
printing indicators for those characters display. You can also use the Show
Options iconic pop-up menu in the application bar to access this command,
as Chapter 1 explains.

Navigating through text

To work at a different text location in your InDesign document, click in a dif-
ferent text frame or another location in the current text frame. You can also
use the four arrow (cursor) keys on the keyboard to move one character

to the right, one character to the left, one line up, or one line down. Hold 38
or Ctrl when pressing the arrow keys to jump one word to the right or left,

or one paragraph up or down. The Home and End keys let you jump to the
beginning or end of a line; hold 38 or Ctrl when pressing those keys to jump
to the beginning or end of a story. (A story is text within a text frame or that is
linked across several text frames.)

Highlighting text

To highlight (or select) text, you can click and drag. Or you can use some
keyboard options. For example, Shift+3+— or Ctrl+Shift+— highlights the
next word to the right. Likewise, Shift+38+End or Ctrl+Shift+End highlights all
the text to the end of the story.

To highlight a word, double-click (this action doesn’t select its punctuation)
and triple-click to select the entire paragraph. If you're highlighting a word and
also want to include the punctuation that follows the word, double-click, and
then press Shift+3+— or Ctrl+Shift+— to extend the selection.

To select an entire story, choose Edit=>Select All (38+A or Ctrl+A).
To deselect text, choose Edit>Deselect All (Shift+8+A or Ctrl+Shift+A). An

even easier way to deselect text is simply to select another tool or click
another area of the page.
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Undoing text edits

InDesign makes it easy for you to change your mind about text edits. Choose
Edit>Undo (88+Z or Ctrl+Z) and Edit~>Redo (Shift+8+Z or Ctrl+Shift+Z) any
time you change your mind about edits.

Using the Story Editor

The Story Editor is a window that lets you see your text without the distrac-
tions of your layout. In it, you see your text without line breaks or other non-
essential formatting — you just see attributes like boldface and italics, as well
as the names of the paragraph styles applied in a separate pane to the left
(see Figure 12-1). After clicking in a text frame, you open the Story Editor by
choosing Edit>Edit in Story Editor (88+Y or Ctrl+Y).

PO il Correct Color template.indd: The Journey from Cam...
colors into *C|MYK (cyan, magenta, yellow, and black) and then ships them of f
to the printer that sprays each color millions of times through tiny spray

nozzles onto the correct size and place on the paper.
cC cho1-07
Just so you know and beware: some of the software commonly used today speaks

the Tanguage of color in a very indistinct way. Some of these software
packages presume that the term celer has a single meaning (like yellow cab
lyellow). This kind of approach is about as informative as a restaurant menu
item simply called meat. You get the idea. If you are using this kind of
software, it 15 one reason why your pictures may not print correctly. We will
make some recommendations about software that respects the color process.
Without this control it will be guite impossible to achieve correct color.
You can now probably appreciate why reproducing color is not quite as easy as
it sounds. People have been told (frem ambitious advertising programs) that
today's technology is now so advanced that it is easy. In some sense this is
a true statement. Unfortunately, easy has been misinterpreted to mean simple.
Technology isn’t simple. Technology by its very nature is quite complicated.
CC ChDl-08
As technology advances it produces solutions that are easier to dfal with.
The misleading message sometimes promoted is that new technology has all but
erased the need for the user to know anything about photography or printing.
That's as realistic as assuming that automobiles have become so advanced that
people no longer need to know how to drive.
Your digital camera is an amazing and powerful tool that captures memories of
the world around you in a way never before possible. With today’s digital
cameras you can control 1ight, color, and action in amazingly creative ways.
When your camera is set up properly, you can both capture moods and create
emotions. Photography with today’s cameras goes way beyond merely taking
Figure 12_1: pictures. With the control that your digital camera offers, you have more

creative freedom than even professional photographers had just a few years

The Story ||.go.
Editor. lljcc choi-o9
Your camera 1s 1ike al11 other digital cameras in that they all use the same
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In the Story Editor, you use the same tools for selection, deletion, copy-

ing, pasting, and search and replace as you would in your layout. The Story
Editor isn’t a separate word processor; it’s simply a way to look at your text
in a less distracting environment for those times when your mental focus is
on the meaning and words, not the text appearance.

The Story Editor also shows you the column depth for text, using a ruler
along the left side of the text, just to the right of the list of currently applied
paragraph styles. Overset text (text that goes beyond the text frame or
beyond the final text frame in a threaded story) is indicated by the word
Overset and is furthermore noted with a red line to the right of the text.

You can dock the Story Editor window into the document tabs so that you
can more easily switch in and out of it as needed. Just drag the Story Editor
window into the tabs, and InDesign converts it for you. Drag it back out to
make it a floating window.

Searching and Replacing Text

InDesign has a handy Find/Change feature (Edit>Find/Change [3+F or
Ctrl+F]) that is similar to the search-and-replace features with which you may
already be familiar if you've used any word processor or page-layout applica-
tion. With the Find/Change dialog box, you can find and change text, or you
can extend the search to include attributes. Before starting a Find/Change
operation, first determine the scope of your search:

v To search within a text selection, highlight the selection.

v To search from one point in a story to its end, click the cursor at that
beginning location.

v To search an entire story, select any frame or click at any point in a
frame containing the story.

v To search an entire document, simply have that document open.

v To search multiple documents, open all of them (and close any that you
don’t want to search).

Then choose the appropriate search scope — InDesign’s term for range —
using the Search pop-up menu and the scope iconic buttons below it.

Figure 12-2 shows the Find/Change dialog box. It can search for much more
than just text, including special characters (glyphs) and object attributes (see
Chapter 8), plus it lets you save search/replace queries so you can use them
repeatedly. (It also lets you use the Unix grep syntax for conducting criteria-
based searches; this feature is for experts familiar with grep searching and so
is not covered in this book.)
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Replacing text

To search for text, follow these steps:

1.

Determine the scope of your search, open the appropriate documents,
and insert the text cursor at the appropriate location.

. Choose Edit~>Find/Change (88+F or Ctrl+F).

Go to the Text pane if it’s not already displayed.

. Use the Search pop-up menu, as shown in Figure 12-2, to specify the

scope of your search by choosing All Documents, Document, Story, To
End of Story, or Selection.

Note that the Search options that display are based on what you’ve
selected before going to the Find/Change dialog box. For example, if you
didn’t select text, there’ll be no Selection option. Likewise, if no story is
selected, the Story and To End of Story options won’t appear.

. Type or paste the text you want to find in the Find What field.

To use special characters, use the Special Characters for Search pop-up
list (the icon to the right of the Find What field) to select from a menu of
special characters (see Figure 12-2).

. Type or paste the replacement text into the Change To field.

To use special characters, use the Special Characters for Replace pop-up
list (to the right of the Find What field).

. Specify any additional parameters for your search by selecting

or deselecting the seven iconic buttons at the bottom of the pane:
Include Locked Layers, Include Locked Stories, Include Hidden
Layers, Include Master Pages, Include Footnotes, Case Sensitive, and
Whole Word.
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If an icon’s background darkens, it’s selected.

7. To search for or replace with specific formatting, use the Find Format
and Replace Format areas.

If the Find Format and Replace Format areas don’t display in the dialog
box, click the More Options button. (Look for details in the “Replacing
formatting” section that comes next.)

8. Click the Find button to start the search.

After the search has begun, click the Find Next button (it changes from
the Find button after you start the search) to skip instances of the Find
What text and click the Change, Change All, or Change/Find buttons as
appropriate. (Clicking the Change button simply changes the found text,
clicking the Change All button changes every instance of that found text

in your selection or story, and clicking the Change/Find button changes
the current found text and moves on to the next occurrence of it — it basi-
cally does in one click the actions of clicking Change and then Find Next.)

If you use the Change All feature, InDesign reports how many changes
were made. If the number looks extraordinarily high and you suspect the
Find/Change operation wasn’t quite what you wanted, remember that
you can use InDesign’s undo function (Edit=>Undo [88+Z or Ctrl+Z]) to
cancel the search and replace and then try a different replace strategy.

9. Click the Done button when you’re finished doing the finding and
replacing.

Replacing formatting

To find and change formatting or text with specific formatting, use the
expanded Find/Change dialog box. For example, you can find all the words in
14-point Futura Extra Bold and change them to 12-point Bodoni.

The expanded dialog box contains two areas where you specify the format-
ting to search and change: Find Format and Replace Format. If these aren’t
visible in the Find/Change dialog box, click the More Options button.

To replace text formatting, follow these steps:

1. Use Specify Attributes to Find iconic button (the magnifying-glass-
over-a-T icon) to open the Find Format Settings dialog box. (It’s to the
right of the Find Format area.)

In the Find Format Settings dialog box, your options are Style Options (para-
graph and character styles), Basic Character Formats, Advanced Character
Formats, Indents and Spacing, Keep Options, Bullets and Numbering,
Character Color, OpenType Features, Underline Options, Strikethrough
Options, Conditions, and Drop Caps and Other. You can change multiple
attributes at once by making selections from as many panes as needed.
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Go to each pane whose formatting you want to find and select the
desired formatting to search. Click OK when done; InDesign will bring
you back to the Find/Change dialog box.

. Use the Specify Attributes to Change iconic button (the magnifying-

glass-over-a-T icon) to open the Change Format Settings dialog box.
(It’s to the right of the Replace Format area.)

The options in the Change Format Settings dialog box are the same as in
the Find Format settings dialog box. Go to each pane whose formatting
you want to change and select the desired formatting to replace. Click
OK when done; InDesign returns you to the Find/Change dialog box.

. Click Find Next and then Change to change the next occurrence or

click Change All to change all occurrences.

4. Click Done when you’re finished with the search and replace.

To search and replace formatting only — regardless of the text to which it is
applied — leave the Find What and Change To fields blank.

Changing special characters

InDesign also lets you replace special characters (glyphs) through a separate
Glyph pane in the Find/Change dialog box, shown in Figure 12-3. The Glyphs
pane makes it easier to actually enter the desired characters than using the
Text pane. The process is mostly straightforward (just ignore the parts of the
pane not described in the following steps):

1.

In the Find Glyph section, choose the font of the desired character
in the Font Family pop-up menu and its style in the Font Style pop-up
menu.

. To choose the character itself, click the unnamed pop-up menu to the

right of the Glyph field.

You get a dialog box that mimics the Glyphs panel (see Chapter 15);
choose the character from the panel by double-clicking it.

. Repeat Steps 1 and 2 using the controls in the Change Glyph section to

select the replacement glyph.

. Set the scope of your search using the Search pop-up menu and the

Include Locked Layers, Include Locked Stories, Include Hidden
Layers, Include Master Pages, and Include Footnotes buttons, as
described in the “Replacing text” section, earlier in this chapter.

. Execute the search and/or replace using the Find, Change, Change All,

and Change/Find buttons as described in the “Replacing text” section.

. Click Done when done.
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Figure 12-3:
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If you want to quickly wipe out the selected glyphs, click the Clear Glyphs
button.

Working with saved queries

If you plan to do the same search and/or replace operation repeatedly, you
can save queries in InDesign. After entering the find and search information,
click the Save Query iconic button, enter a name in the Save Query dialog
box that appears, and click OK. That query now appears in the Query pop-up
menu in the Find/Change dialog box.

To run a saved query, just choose it from the Query pop-up menu. (You'll see
those that you saved plus some that came preinstalled with InDesign.) To
delete a saved query, choose it from the Query pop-up menu and then click
Delete Query iconic button.

That’s all there is to it!

Checking Spelling

The spell-check feature not only helps you eradicate spelling errors, but

it also catches repeated words, as well as words with odd capitalization,
such as internal capitalization (called intercaps) in words such as InDesign.
InDesign also flags words not found in the spelling dictionary. You can
customize the spelling dictionary, and you can purchase additional spelling
dictionaries.
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The solution to missing fonts

Sometimes, when you open a document,
InDesign tells you that it can’t find the fonts
used in the documents on your computer. You
getthe option of finding the missing fonts, which
opens the Find Fonts dialog box. (You can also
open it after opening a document by choosing
Type=>Find Font.) This dialog box shows the
names of all missing fonts; if you select one, you
can change all occurrences of that font to one
that you do have by selecting a new font family
and font style from the menus at the bottom of

the dialog box and then clicking Change All. If
selected, the Redefine Style When Changing
All check box ensures that any font replaced is
also replaced in any paragraph and character
styles that used the original font.

Of course, another — often preferable —
solution is to get the fonts installed on your com-
puter. After all, the design shouldn’t change just
because you don't happen to have the needed
fonts on your computer.

Checking spelling as you type

You can have InDesign check your spelling as you type by simply choosing

Edite>Spelling=>Dynamic Spelling. If that menu option is checked, your spell-
ing will be checked as you type, as will the spelling of any text already in the
document. Suspected errors are highlighted with red squiggle underlining so
that you can correct them as needed. If you want InDesign to suggest proper
spelling, you need to use the Check Spelling dialog box, covered in the next
section.

Correcting mistakes on the fly

If you use a word processor, chances are it’s one that corrects mistakes as
you type. Microsoft Word, for example, has a feature called AutoCorrect
that lets you specify corrections to be made as you type, whether those
be common typos you make or the expansion of abbreviations to their full
words (such as having Word replace tq with thank you).

InDesign offers much of the same functionality, which it calls Autocorrect.
Unlike Word, you can’t use this feature to replace symbols, such as having
InDesign convert (R) to the ® symbol as you type. Note that — like Word —
Autocorrect works only for text entered in InDesign after Autocorrect is turned
on; it doesn’t correct imported or previously typed text.
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You enable Autocorrect in the Autocorrect pane of the Preferences dialog
box. Choose InDesignr>Preferences=>Autocorrect (88+K) on the Mac or
choose Edit=>Preferences=>Autocorrect (Ctrl+K) in Windows. If you want
InDesign to automatically fix capitalization errors, check the Autocorrect
Capitalization Errors check box. Typically, this feature finds typos involving
capitalizing the second letter of a word in addition to the first. For example,
InDesign replaces FOrmat with Format.

To add your own custom corrections, click the Add button. You see the Add
to Autocorrect List dialog box, where you can enter the typo text or code
that you want InDesign to be alert for in the Misspelled Word field, as well
as the corrected or expanded text you want InDesign to substitute in the
Correction field.

You can’t use special characters in autocorrect, such as to automatically
replace two hyphens (-) with an em dash (—).

Using the Check Spelling dialog box

The Check Spelling dialog box not only lets you choose what part of the
document to spell-check, but it also provides suggestions on correct spelling.
Plus, you can use the dialog box to add correctly spelled words to InDesign’s
spelling dictionary. Even if you use the new dynamic spell-checking feature,
you’ll still want to do a final spell-checking pass with the Check Spelling
dialog box.

Specifying the text to check is a two-step process: First set up the spell-
check’s scope in the document (in other words, exactly what text you want
to be checked). Second, specify the scope in the Search menu. Here’s how:

1. To set up the scope for the spell-check, highlight text, click in a story
to check from the cursor forward, select a frame containing a story, or
open multiple documents.

2. Open the Check Spelling dialog box (Edit~>Spelling=>Check Spelling
[38+I or Ctrl+I]) and choose an option from the Search pop-up menu:
Document, All Documents, Story, To End of Story, and Selection.

Figure 12-4 shows the dialog box.

You may not see all the options in the Search pop-up menu; the list

of options depends on how you set up the scope. For example, if you
didn’t highlight text, the Selection option isn’t available. However, you
can change the scope setup in the document while the Check Spelling
dialog box is open — for example, you can open additional documents
to check. You can also make the spell-check case-sensitive by checking
the Case Sensitive check box.



Chapter 12: The Ins and Outs of Text Editing 223
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Note that when you first open the Check Spelling dialog box, if text is
selected or the text cursor is active, it immediately begins checking the
spelling, going to the first suspect word. Otherwise, the dialog box dis-
plays Ready to Check Spelling at the top.

3. To begin checking the text, click Start.

4. As InDesign finds suspect words and phrases, it displays that text to
you and provide several options to fix them.

When the spell checker encounters a word without a match in the dic-
tionary or a possible capitalization problem, the dialog box displays Not
in Dictionary at the top and shows the word. When the spell checker
encounters a duplicate word, such as of of, the dialog box displays
Duplicate Word and shows which word is duplicated. Use the buttons
along the right side of the dialog box to handle flagged words as follows:

¢ Click the Skip button (it appears only after the spell-check has
started) to leave the current instance of a Not in Dictionary word
or Duplicate Word unchanged. To leave all instances of the same
problem unchanged, click the Ignore All button.

¢ To change the spelling of a Not in Dictionary word, click a word
in the Suggested Corrections list or edit the spelling or capitaliza-
tion in the Change To field. To make the change, click the Change
button.

¢ To correct an instance of a Duplicate Word, edit the text in the
Change To field, and then click the Change button.

¢ To change all occurrences of a Not in Dictionary word or a
Duplicate Word to the information in the Change To field, click the
Change All button.
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¢ To add a word flagged as incorrect — but that you know is correct —
to InDesign’s spelling dictionary, click the Add button. (If you have
multiple dictionaries, first choose the dictionary to add it to using
the Add To pop-up menu.)

¢ To add a word flagged as incorrect to a specific dictionary, click
the Dictionary button. A Dictionary dialog box appears, which lets
you choose the dictionary to which you want to add the word, as
well as what language to associate it with.

5. After you finish checking spelling, click the Done button to close the
Check Spelling dialog box.

Changing the spelling and
hyphenation dictionaries

The spelling dictionary that comes with InDesign is pretty extensive, but
you’ll likely need to add words to it. For example, your company may use
words that are company-specific terms. Or you may use some product

or individuals’ names that wouldn’t typically be found in the dictionary.
Additionally, you may have some words that you prefer not to hyphenate or
others that you want to hyphenate in a specific manner. To address these
issues, you can customize InDesign’s spelling and hyphenation dictionar-
ies. InDesign handles both spelling and hyphenation in one dictionary for
each language so that you use the same controls to modify both spelling and
hyphenation.

If you're in a workgroup, be sure to share the edited dictionary file so that
everyone is using the same spelling and hyphenation settings. (The file

is located in the Dictionaries folder inside the Plug-ins folder inside your
InDesign folder.) You can copy it for other users, who must then restart
InDesign or press Option+88+/ or Ctrl+Alt+/ to reflow the text according to the
new dictionary’s hyphenation.

Customizing the spelling dictionary

When you add a word to the spelling dictionary, this word won’t be flagged
any more when you check spelling.

When you add words to the dictionary, you can specify their capitalization.
For example, InDesign’s dictionary prefers E-mail. You can add e-mail if you
prefer a lowercase e or email if you prefer to skip the hyphen. To add words
to the dictionary, follow these steps:

1. Choose Edit~>Spelling=>Dictionary.

The Dictionary dialog box, shown in Figure 12-5, appears.
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2. Choose whether the addition to the dictionary affects just this docu-
ment or all documents.

The Target pop-up menu lists the current document name as well as the
name of the user dictionary.

3. Choose the dictionary that you want to edit from the Language pop-up
menu.

4. Type or paste a word in the Word field.

The word can have capital letters if appropriate, and it can include spe-
cial characters, such as accents and hyphens.

5. To have the added word accepted as being spelled correctly only with
the capitalization specified in the Word field, check the Case Sensitive
check box.

6. To edit the hyphenation of the word, click the Hyphenate button.
I cover hyphenation in the next section.
7. Click the Add button.

8. To import a word list or export one for other users to import into their
copies of InDesign, click the Import or Export button.

You then navigate to a folder and choose a filename in a dialog box. Note
that when you click the Export button, InDesign exports all selected
words from the list. If no words are selected, it exports all the words in
the list.
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9. When you’re finished adding words, click the Done button.

To delete a word that you added to the dictionary, select it in the list and
click the Remove button. To change the spelling of a word you added,
delete it and then re-add it with the correct spelling. You can see all deleted
words — just those deleted since you opened the dialog box — by selecting
Removed Words from the Dictionary List pop-up menu so that you can add
back any deleted by error.

Customizing hyphenation points

People can be particular about how to hyphenate words. Fortunately,
InDesign lets you modify the hyphenation dictionary by specifying new, hier-
archical hyphenation points.

Follow these steps to specify hyphenation points:

1. Choose Edit=>Spelling= Dictionary.

2. In the Language pop-up menu, pick the dictionary that you want to
edit.

3. Type or paste the word in the Word field.
You can also double-click a word in the list.

4. To see InDesign’s suggestions for hyphenating the word, click the
Hyphenate button.

If you want to change the hyphenation, continue on to Step 5.

5. Type a tilde (~, obtained by pressing Shift+", the open single keyboard
quote at the upper left of the keyboard) as your first preference for a
hyphenation point in the word.

If you don’t want the word to hyphenate at all, type a tilde in front of it.

6. To indicate an order of preference, use two tildes for your second
choice, three tildes for your third choice, and so on.

InDesign first tries to hyphenate your top preferences (single tildes),
and then it tries your second choices if the first ones don’t work out,
and so on.

7. Click the Add button.
8. Continue to add words until you're finished.

9. Click the Done button.

To revert a word to the default hyphenation, select it in the list and click the
Remove button. To change the hyphenation, double-click a word in the list
to enter it in the Word field, change the tildes and then click the Add button.
When you’re adding variations of words, you can double-click a word in the
list to place it in the Word field as a starting place.
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t’s the dirty secret of desktop publishing: Most users avoid using styles,

even though they know they should. Instead, they apply formatting locally
to text, hoping it’s the same as a few pages back. It’s a lot like not eating your
vegetables: Even though you know that they’re good for you (and they even
taste good), it’s easier to get something already made, never mind what'’s in it.

So, I'm going to tell you about styles before I get to the other ways to format
text. Styles really are good for you: They save you lots of work, help you
avoid embarrassingly inconsistent formatting, and give you more time to
indulge in the guilty pleasure of local formatting.

I cover the particulars of paragraph and character formatting in Chapters

14 and 15, respectively. The formats themselves are the same whether you
apply them directly (locally) or through a style (globally). I cover table styles
and cell styles in Chapter 19 and object styles in Chapter 9, although the
basic creation and management methods are the same for all styles.

Text in your layout may already have styles applied, using styles defined in
Microsoft Word, as Chapter 11 explains.

Creating Styles

A style is a simple but powerful concept: It’s a collection of formatting attri-
butes that you can apply to text all at once, saving you time. Even better, if
you change the style, all text that uses it is automatically updated, saving you
time and ensuring consistency. That’s got to be appealing!



2 2 8 Part IV: Text Essentials

InDesign gives you two kinds of styles for text: paragraph and character.
Paragraph styles apply formatting to entire paragraphs, while character
styles apply formatting to text selections. Unless you're doing a one-page ad,
the formatting of which won’t be repeated, you should have paragraph styles
for all different types of paragraphs in your layout. You also need character
styles for places where you consistently want to override your paragraph
styles, such as for the lead-in of a bulleted paragraph that may have the first
few words in a different font or color.

Whether you're creating styles for paragraphs or characters, the basic pro-
cess is the same. (They're also pretty much the same for object styles, cov-
ered in Chapter 9, and for table styles and cell styles, covered in Chapter 19.)

The easiest way is to format your text using the Paragraph and Character
panels, as described in Chapters 14 and 15, and then make sure that you've
selected the text you want to use as the model for your new style. Next,
create the appropriate type of new style:

v For paragraph styles, open the Paragraph Styles panel by choos-
ing Typer>Paragraph Styles (8+F11 or Ctrl+F11). Then choose New
Paragraph Style from the flyout menu to open the New Paragraph Style
dialog box, shown in Figure 13-1.

New Paragraph Style
General Style Name: Paragraph Style 1
Basic Character Formats Location
Advanced Character Formars General
Indents and Spacing )
Tabs Based On: | GX

Paragraph Rules

ar||ar

o
Keep ptions Next Style: | [Same style]

Hyphenation Shortcut:
lustification

Drop Caps and Nested Styles Reset To Base

GREP Style Style Settings:

Bullets and Numbering GX + next: [Same style]
Character Color
OpenType Features
Underline Options

Strikethrough Options

Figure 13-1:
The New
Paragraph
Style

dialog box's
General
pane.
|

1 Apply Style to Selection

"] Preview ( cancel )€ oK 2]
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Figure 13-2:
The New
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v For character styles, open the Character Styles panel by choosing
Typer>Character Styles (Shift+38+F11 or Ctrl+Shift+F11). Then choose
New Character Style from the flyout menu to open the New Character
Style dialog box, shown in Figure 13-2.

New Character Style
GCeneral Style Name: Character Style 1
Basic Character Formats fontin
Advanced Character Formats General
Character Calor
OpenType Features Based On: | [None] ™ i
Underline Options
Strikethrough Options
Shortcut:
2 Reset To Base
Style Settings:
Nonel
1 Apply Style to Selection
™ Preview I" Cancel ) ( OK \

In both cases, the style picks up the selected text’s formatting. Adjust the
style further if desired, give the style a name using the Style Name field in the
General pane, and then click OK.

Of course, you can specify all the formatting directly in the new-style dialog
boxes rather than having InDesign pick it up from existing text. Create the
new styles as just described and then go through each of the panes (selecting
each from the list at the left of the dialog box) and choose your settings.

In the General pane of the New Paragraph Style and New Character Style
dialog boxes are several controls that make styles work more intelligently:

v The Based On pop-up menu displays the names of other styles. You use
this feature to create families of styles. Thus, if you change a style that
other styles are based on, all those styles are updated with the new
settings.

v In the Shortcut field, hold down any combination of 3, Option, and Shift
(or Ctrl, Alt, and Shift) and press any number on the keypad. (You can’t
use letters, punctuation, and nonkeypad numbers for keyboard short-
cuts, and Windows users need to make sure that Num Lock is on.)

v If you want to apply a new style to text that is selected, be sure to check
the Apply Style to Selection check box before clicking OK to save the
new style.
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InDesign comes with a predefined default paragraph style called [Basic
Paragraph] that text in a new frame automatically has applied to it. You can
edit [Basic Paragraph] like any other style. Similarly, InDesign offers a pre-
defined character style called [Basic Character]. (Style names that include
surrounding brackets mean you can’t delete the styles, even though you can
modify them.)

You need to keep in mind several things when creating paragraph styles.
(Character styles are pretty straightforward, so I'm not presenting a similar
list for them.)

v To have InDesign automatically apply a different style to the next para-
graph when you type text, choose a style name from the Next Style
pop-up menu while defining a style. For example, when you define a
style named Headline, you can choose Byline as the next style, so after
you type in a headline, the next paragraph will be formatted for a byline.
Obviously, you need to have the Byline style available.

v If you want your paragraph style to use a character style, you must
define that character style first. (Drop caps and nested styles use
character styles.)

Getting Fancy with Nested Styles

A special function available only in paragraph styles is something called a
nested style. Basically, a nested style is a way of applying a series of character
styles within a paragraph style based on a set of parameters you specify. For
example, in a numbered list, you might want one character style applied to
the numeral, and another to the first sentence, and then have the paragraph
style’s text formatting applied to the rest of the paragraph. With nested
styles, you build all that into the paragraph style and let InDesign do the
heavy lifting. Here’s how it works:

1. Define any character styles that you’ll apply to text through a nested
style.

Even if all you're doing is making text italic, you need to define a charac-
ter style to do so. The Nested Styles feature can’t apply any attributes
other than those available in a character style.

2. Open the Paragraph panel (Type->Paragraph Styles [3#+F11 or
Ctrl+F11]), choose Style Options from the flyout menu to open the
Paragraph Style Options dialog box, and go to the Drop Caps and
Nested Styles pane.



Chapter 13: The Styles of Text 23 ’

10.

. Click New Nested Style.

An entry appears in the Nested Styles section of the dialog box. This
entry is what will be applied to text.

. Click the style name in the Nested Styles section of the pane to choose

from an existing character style.

When you click the style name, a list of other styles appears, including
[None], which uses the paragraph style’s default formatting.

You also have the [Repeat] option, which, if selected, lets you repeat a
sequence of previous styles. (You choose the number of repetitions in
the third column.)

. Click in the second column to determine the scope end point.

Your choices are Through or Up To. For example, if you choose Through
for a nested style that is set for four words, all four words will get the
nested style. If you choose Up To, the first three words will get the style,
and the fourth will not.

. In the third column, specify how many items you want InDesign to

count in determining the scope’s end point.

For example, if you want to have the first seven characters have the
style applied, choose 7. If you want to have the style applied up to the
first tab, choose 1.

. Click the item in the fourth column to specify the scope of text to

which you’re applying the nested styles.

Figure 13-3 shows the options. They break into three groups: a number
of items (characters, words, and so on), a specific character (tab, em
space, and so on), and a specific marker character (inline graphic
marker, auto page number, and section marker). Whatever you choose
needs to be consistent in all your text because InDesign will follow these
rules slavishly.

. Create multiple nested styles in one paragraph with different rules for

each.

Obviously, you may not need to do this step, but the option exists.
InDesign applies the styles in the order in which they appear in the
dialog box, and each starts where the other ends. Use the up and down
arrow buttons to change the order of nested styles.

. Select the Preview option to preview the formatting if you selected

sample text before opening the dialog box.

Click OK when you’re done.
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Figure 13-3:
You can use
a nested
style to, for
example,
apply a
specific
character
style to the
two first
words in a
paragraph.
|

CATURE
$
=

Paragraph Style Options

Style Name: Heading 1
Location:

Drop Caps and Nested Styles

— Drop Caps
Lines Characters

=0

Character Style

(None] H

=0

1 Align Left Edge "1 Scale for Descenders

- Nested Styles

Lesson Prefix Words ml ] ‘
Sentences
¥ Words
Characters
Letters
Digits
End Nested Style Character

through 2

(" New Nested Style ) [ Delete )

Tab Characters
Forced Line Break

Nested Line Styles -

Click New Line Style button to create a line style.

Indent to Here Character
Non-breaking Spaces
Em Spaces

En Spaces

(" NewLineStyle ) Delete

Anchored Object Marker
Auto Page Number
Section Marker

I Preview

At the bottom of the Nested Styles dialog box is a new feature: nested line
styles. It works just like other nested styles except that it lets you apply a
character style to a certain number of lines in a paragraph — a popular design
approach, such as having the first line in small caps. You specify the desired
character style and how many lines you want it applied to, and InDesign does
the rest.

Managing Styles

InDesign provides lots of ways to manage your styles. In this section, I cover
the common ones. Note that the options described here also apply to object
styles, table styles, and cell styles — so, for example, the Load Paragraph
Styles menu option will have a counterpart in the Object Styles, Table Styles,
and Cell Styles panels’ flyout menus.

Updating styles

If you've already created a style and want to change it, just go to the appro-
priate styles panel and choose Style Options from its flyout menu. If you've
selected text that has the formatting you want the style to use in place of
its current formatting, just choose Redefine Style from the flyout menu.
Remember that all text using the style is automatically updated when the
style changes.
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Sharing styles with others

The Load Paragraph Styles or Load Character Styles menu option (based on
which styles panel is open) and the Load All Text Styles menu option let you
import styles from another InDesign document. (Load All Text Styles imports
paragraph and character styles at the same time.) You get a dialog box list-
ing the styles in the chosen document so that you can decide which ones to
import.

If you import styles whose names match those in the current document,
InDesign gives you a chance to let the imported style overwrite the current
style or to leave the current style as is and give the imported style a new
name. If an entry appears in the Conflict with Existing Style, you can click that
entry for a pop-up menu that provides two choices: Auto-Rename and Use
Incoming Style Definition. Figure 13-4 shows this Load Styles dialog box.

Note that at the bottom of the dialog box is the Incoming Style Definitions
window, which lists the style definitions to help you decide which to import,
as well as which to overwrite or rename.

Load Styles
[Type [ incoming styte | Conflict with Existingsyle | (0K )
™ @ Fcredit Auto-Rename Earical
™ @ FC + Use Incoming Definition
™ 4 FCw/F credit ~Use Incoming Defini...
™ 4 FM Author Use Incoming Defini...
™ 9 FM Copyright Legal Text Use Incoming Defini...| ;
™ 9 FM Copyright Text Use Incoming Defini...| v
(" Check Al ) ( Uncheck All )
Incoming Style Definition Existing Style Definition
& + hyphenation zone: OpO + space after: —] [6+ hyphenation zone: 0p0 + space after -
150 + tabs: count = 1, [position: 5p4, O 1p0 + tabs: count = 1, [position: 5p4, D
alignment: left] + News Gothic + max. alignment: left] + ITC Novarese + max.
wordspace: 125% + min. wordspace: B5% + | |wordspace: 125% + min. wordspace: BSX +
kee all tagether + keep fines + tint: 100% + 4| |keep all rogetner + keep lines + tint: 1005% +
rule above color: White + rule above weight-0 | v [ |rule above color: White + rule above weight-0 | v
2|

Using style groups

To help you find the desired style in documents that have dozens of them,
InDesign lets you create style groups, which create a folder in the styles
panel’s style list that you can open and close as desired. To create a group,
choose New Style Group from the panel’s flyout menu or click the Create New
Style Group iconic button (folder icon) on the bottom of the panel. Enter a
name in the dialog box that appears and click OK.
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When working with style groups (which have a folder icon to the left of their
names in the panel list), you have several options to add styles:

» You can drag any desired styles into the group.

» You can copy a selected style to the group by choosing Copy to Group
and then selecting the target group in the dialog box that appears.

v~ If multiple styles are selected, you can create a group and move them into
it in one fell swoop by choosing New Group from Styles in the flyout menu.
(Note that this option is grayed out if any of the predefined styles — [None]
< and either [Basic Paragraph] or [Basic Character] — are selected.)
To quickly open all groups, choose Open All Groups in the panel’s flyout
menu. To quickly close them all, choose Close All Groups.

Other management options

The styles panels’ flyout menus have several other options to manage your
styles:

v Duplicate Style copies the currently selected style so that you can work
on the copy.

v Delete Style — no surprise! — deletes selected styles.

v Select All Unused selects all styles not used in the document so that you
can delete them all at once with the Delete Style menu option — part of
keeping your document neat and tidy.

v Sort by Name alphabetizes the list of style names. (You can change the
order of style names by dragging them within the list.)

Applying Styles to Text

Applying paragraph styles and character styles have some subtle differences,
so [ cover those particulars in the following sections. But two techniques
work the same for both types of style:

v If your text selection uses more than one paragraph style or more than
one character style, the styles panel displays the text (Mixed) at the
upper left to let you know.

v InDesign has a neat capability that lets you apply multiple styles at once
to selected text:
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1. Define the various styles and be sure that each style has a differ-
ent style selected in the Next Style pop-up menu in the Paragraph
Style Options or New Paragraph Style dialog boxes. For example, if
you have Headline, Byline, and Body Copy styles, make sure that
Headline has Byline selected in Next Style and that Byline has Body
Copy selected in Next Style.

2. Highlight all the text that uses this sequence of styles. Now
Control+click or right-click Headline and select Apply "Headline"
Then Next Style from the contextual menu. InDesign applies
Headline to the first paragraph, Byline to the second paragraph,
and Body Copy to the rest.

Remember that Headline is just the example style used here; the
actual contextual menu option will replace Headline with the actual
style name you select inside the quote marks.

Paragraph particulars

To apply a paragraph style, just click within a paragraph or highlight text in
a range of paragraphs and then click the style name in the Paragraph Styles
panel or press its keyboard shortcut. (Windows users must make sure that

Num Lock is on when using shortcuts for styles.)

When you apply a style to selected paragraphs, all local formats and applied
character styles are retained. All other formats are replaced by those of

the applied style. If you want to override those attributes, choose Clear
Overrides from the Paragraph Styles panel’s flyout menu or hold the Option
or Alt key when clicking the style name in the panel.

If you want to remove a style from a paragraph so that it’s not changed if the
style is later updated, choose Break Link to Style from the flyout menu. The
upper left of the panel displays the text (No Style).

Character characteristics

To apply a character style, just highlight text and then click the style name
in the Character Styles panel or press its keyboard shortcut. (Windows users
must make sure that Num Lock is on when using shortcuts for styles.)

If you want to remove a style from a text selection so that it’s not changed if
the character style is later updated, choose Break Link to Style from the
flyout menu or simply apply the [None] style. Note that if you later apply a
paragraph style to text with the [None] character style, the text takes on
the paragraph style’s formatting rather than retaining its local formatting.
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What's that Quick Apply panel?

Another way to apply paragraph and character
styles (and object styles, scripts, menu com-
mands, and other elements) is by using the
Quick Apply feature. Quick Apply is a consoli-
dated list of styles that you access by choosing
Edit=>Quick Apply, by clicking the Quick Apply
iconic button (the lightning-bolt icon) in many
panels, or by pressing 38+Return or Ctrl+Enter.

If you have selected text or have the text-
insertion point active, the Quick Apply panel
presents all stored formatting attributes avail-
able. You can scroll down to the one you want,
or you can type the first few letters of the style
name in the text field at the top to jump to styles
beginning with those letters and then navigate
to the one you want. Then press Return or Enter,
which brings you back to where you were

working with your text. Pressing 88+Return or
Ctrl+Enter again closes the Quick Apply panel.

For users who are working on layouts from their
keyboards — perhaps a layout artist who's
working on a notebook while commuting —
Quick Apply can be handy because you can
switch to it, apply the style, and return to your
text without touching the mouse.

InDesign has tons of attributes in the Quick
Apply panel, so it can quickly get overwhelm-
ing. To remove attributes you likely will never
use in this panel — such as scripts and menu
customizations — choose the unnamed pop-up
menu at the top of the panel and deselect
unwanted attributes. (The check marks indicate
attributes that will display.) You can also choose
what attributes display in the Quick Apply panel
by choosing Customize from its flyout menu.




Chapter 14
Fine-Tuning Paragraph Details

In This Chapter

Understanding paragraph fundamentals
Changing basic and advanced paragraph formats
Applying bullets and numbering

Working with hyphenation and justification
Adding ruling lines to paragraphs

p aragraphs are more than lines of text; they’re chunks of information that
themselves help convey meaning by organizing that information into
related bits. Various types of paragraph formatting let you both make those
chunks clearly distinguishable from each other and highlight certain chunks,
such as lists or long quotes, from others.

This chapter explains what you need to know about formatting paragraphs,
from setting indents and alignment — the two most commonly used
paragraph attributes — to more sophisticated tasks like adding bullets

and ruling lines.

Applying Paragraph Formats
InDesign provides three ways to apply paragraph formats:

v Use the controls in the Paragraph panel, shown in Figure 14-1, or
their keyboard shortcuts. This method is great for working on individual
paragraphs, although it’s not the best method when working with
lots of paragraphs you want to have the same formatting. You can open
the Paragraph panel in three ways: Choose TyperwParagraph, choose
Window=>Type & Tables>Paragraph, or press Option+8+T or
Ctrl+Alt+T.



2 3 8 Part IV: Text Essentials

v Use the controls in the Control panel. (Be sure that the Type tool is
active and that the § iconic button is selected in the panel to display
paragraph-oriented functions.) These controls mirror those in the
Paragraph panel, and using them instead of the Paragraph panel can
reduce screen clutter. If the Control panel isn’t visible (it almost always
is), display it by choosing Window=>Control (Option+8+6 or Ctrl+Alt+6).

v Create and apply paragraph styles, as covered in Chapter 13. Paragraph
styles let you apply consistent formatting — and easily change it to all
affected paragraphs — throughout your document.

Whichever method you use — and you’ll use them all — the types of
formatting available to you are the same.

MBER The Paragraph panel and Control panel provide access to most of InDesign’s
paragraph-formatting options. Also, several of the options have keyboard
shortcuts, as shown in the menus. But to set tabs, you must open the Tabs
panel, as Chapter 19 covers.

Figure 14-1 shows the Paragraph panel. If you choose Hide Options from the
flyout menu, the Space Before, Space After, Drop Cap Number of Lines, Drop
Cap Number of Characters, Hyphenate, and Align/Do Not Align to Baseline
Grid controls aren’t displayed. You can use the double-arrow iconic button to
the left of the panel name to toggle among showing the panel title, the basic
options, and all options.

Hide Options

v Adobe Paragraph Composer
Adobe Single-line Composer

Only Align First Line to Grid

Balance Ragged Lines

Justification... )
Keep Options... NEK
Hyphenation...

Drop Caps and Nested Styles... XER
GREP Styles...

Paragraph Rules... X

Bullets and Numbering...

Define Lists...

% PARACRAPH A

Figure 14-1:
The full
Paragraph
panel.
|
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Specifying Alignment and Indents

<MBER
é‘,\*

Alignment and indents give paragraphs their fundamental appearance.
Indentation helps readers visually separate paragraphs — the indent acts as
the separator, like the blank lines used to separate paragraphs in typewritten
documents — while alignment provides visual texture.

The alignment buttons at the top of the Paragraph panel control how a
selected paragraph begins and ends relative to the left and right margins.
To apply a paragraph alignment to selected paragraphs, click one of the
buttons. You can also use the keyboard shortcuts described in the following
list. Here’s a description of each alignment option (the icons themselves
illustrate what they do):

v~ Align Left (Shift+8+L or Ctrl+Shift+L): This alignment places the left
edge of every line at the left margin (the margin can be the frame
edge, frame inset, left indent, or column edge) and fits as many words
(or syllables, if the hyphenation is turned on) on the line as possible.
In left-aligned paragraphs, the right margin is said to be ragged because
the leftover space at the right end of each line differs from line to line
and produces a ragged edge.

v~ Align Center (Shift+3+C or Ctrl+Shift+C): This alignment makes both
the left and right edges of the paragraphs equally ragged.

v~ Align Right (Shift+88+R or Ctrl+Shift+R): This alignment is a mirror
opposite of Align Left. The right edge is straight; the left edge is ragged.

v~ Justify, Last Line Aligned Left (Shift+8+J or Ctrl+Shift+J): In justified
text, the left and right ends of each line are flush with the margins.
(You can find out more about justification in the section “Controlling
Hyphenation and Justification,” later in this chapter.) Justified text
is nearly always hyphenated — if you don’t hyphenate justified text,
spacing between letters and words is very inconsistent. Aligning the
last line flush left is the traditional way of ending a paragraph.

v~ Justify, Last Line Aligned Center: This alignment produces justified text
with the last line centered.

v~ Justify, Last Line Aligned Right: This alignment produces justified text
with the last line aligned to the right.

v~ Justify All Lines (Shift+8+F or Ctrl+Shift+F): This alignment produces
justified text with the last line forcibly justified. This option can
produce last lines that are very widely spaced. The fewer the number
of characters on the last line, the greater the spacing.

The previous three alignment options are rarely used, and for good
reason. People expect justified text to have the last line aligned left; the
space at the end of the line marks the end of the paragraph. By changing
the position of that last line, you can confuse your reader.
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v~ Align Toward Spine: Essentially, this option automatically creates right-
aligned text on left-hand pages and left-aligned text on right-hand pages.
InDesign chooses a left or right alignment based on the location of the
spine in a facing-pages document.

v Align Away from Spine: This option is the same as Align Toward Spine
except that the alignment is reversed: Text aligns to the left on left-hand
MBER pages and to the right on right-hand pages.
X\
Y
< When creating paragraph styles, all the preceding controls are available in the
Indents and Spacing pane of the New Paragraph Styles dialog box.

Adjusting indent controls

The indent controls in the Paragraph panel let you both move the edges of
paragraphs away from the left and/or right margins and indent the first line.

Your options are as follows:

v~ Left Indent: Moves the left edge of selected paragraphs away from the
left margin by the amount you specify in the field. You can also click the
up and down arrows. Each click increases the value by 1 point; holding
down the Shift key while clicking increases the increment to 1 pica.

v Right Indent: Moves the right edge of selected paragraphs away from
the right margin by the amount you specify in the field. You can also use
the up and down arrows.

v First-Line Left Indent: Moves the left edge of the first line of selected
paragraphs away from the left margin by the amount you specify
in the field. You can also click the up and down arrows to adjust the
indentation. The value in the First-Line Left Indent field is added to
any Left Indent value. Using a tab or spaces to indent the first line
of a paragraph, which is what was done in the age of typewriters, is
usually not a good idea. You're better off specifying a First-Line
Left Indent.

v Last-Line Right Indent: Moves the right edge of the last line of selected
paragraphs away from the right margin by the amount you specify in
MBER the field. You can also click the up and down arrows.
X\
Q
< When creating paragraph styles, all the preceding controls are available in the
Indents and Spacing pane of the New Paragraph Styles dialog box.
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Inserting space between paragraphs

To format a lengthy chunk of text with multiple paragraphs, you can indicate
a new paragraph by indenting the paragraph’s first line (by specifying a First-
Line Left Indent value, as covered in the previous section, “Adjusting indent
controls”). Or you can insert some extra space between the new paragraph
and the preceding one. Although no rule states that you can’t use both of
these spacing methods, it’s a good idea to use one or the other — not both:

v To insert space before selected paragraphs, enter a value in the Space
Before field in the Paragraph panel or Control panel. You can also use
the up and down arrow buttons; each click increases the value by 1
point and holding down Shift key increases the increment to 1 pica.

v The Space After field works the same as the Space Before field but
inserts space below selected paragraphs. If you use Space Before to
space paragraphs, you won’t need to use Space After, and vice versa;
combining both can be confusing.

What you don’t want to do is insert extra paragraph returns between
paragraphs. Doing so makes it harder to ensure that columns begin with text
(as opposed to blank lines).

Controlling space between lines

Leading (pronounced “ledding”) is the space between lines of text within a
paragraph. Even though leading is traditionally an attribute of the paragraph,
InDesign treats it as a character format, which you specify by using the
Leading control in the Character panel or Control panel.

To change this character-oriented approach to affect entire paragraphs,
select the Apply Leading to Entire Paragraphs option in the Type pane of the
Preferences dialog box. (Choose InDesign=>Preferences>Type [88+K] on

the Mac or Edit=>Preferences=>Type [Ctrl+K] in Windows.)

Another way to control space between lines of text is to use baseline grids,
as described in Chapter 10. Essentially, a baseline grid overrides the leading
specified for paragraphs — you choose whether it overrides the spacing of
every line in the paragraph or just the first line. To align to baseline grids,
you must click the Align to Baseline iconic button in the Paragraph panel
(the rightmost iconic button on the bottom of the panel) for the selected
paragraphs. To prevent such locking to the baseline, click the Do Not Align
to Baseline iconic button to its immediate left. These same buttons also exist
on the right side of the Control panel.
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Controlling where paragraphs break

InDesign’s Keep Options feature lets you prevent widows and orphans; it also
lets you keep paragraphs together when they would otherwise be broken at
the bottom of a column. A widow is the last line of a paragraph that falls at
the top of a column. (The poor thing has been cut off from the rest of the
family, the last survivor.) An orphan is the first line of a paragraph that falls
at the bottom of a column. (It, too, has become separated from its family, the

only survivor.)

When you choose Keep Options from the Paragraph panel’s flyout menu, the
Keep Options dialog box, shown in Figure 14-2, appears.

Keep Options
Keep with Next: = 0 lines 0K 4
[ \21 Keep Lines Together — - Cancel
| E
() All Lines in Paragraph ) Preview
1 -2 () At Start/End of Paragraph -
Figure 14-2: @ g
The Keep Start: - 2 lines
: End: 52 lines
Options | |
dlalOQ box. Start Paragraph: | Anywhere 3
|

The Keep Options dialog box holds several options for how paragraphs are
managed as text breaks across columns and pages:

* Keep with Next Lines: This option applies to two consecutive para-
graphs and controls the number of lines of the second paragraph that
must stay with the first paragraph if a column or page break occurs
within the second paragraph.

1 Keep Lines Together: If you click this check box, it prevents paragraphs
from breaking. When this box is checked, the two radio buttons below it
become available. The radio buttons present an either/or choice. One
must be selected; At Start/End of Paragraph is selected by default.

v~ All Lines in Paragraph: This option prevents a paragraph from being
broken at the end of a column or page. When a column or page break
occurs within a paragraph to which this setting has been applied, the
entire paragraph moves to the next column or page.

v~ At Start/End of Paragraph: Select this check box to control widows and
orphans. When this button is selected, the two fields below it become

available:
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e Start x Lines: This field controls orphans. The value you enter is
the minimum number of lines at the beginning of a paragraph that
must be placed at the bottom of a column when a paragraph is
split by a column ending.

¢ End x Lines: This field controls widows. The value you enter is the
minimum number of lines at the end of a paragraph that must be
placed at the top of a column when a paragraph is split by a
column ending.

v Start Paragraph: From this pop-up menu, choose Anywhere to let the
paragraph begin where it would fall naturally in the sequence of text
(no forced break). Choose In Next Column to force a paragraph to begin
in the next column; choose In Next Frame to make it begin in the next
frame in the story chain; choose On Next Page to force a paragraph to
begin on the next page (such as for chapter headings). Your other
choices are similar: On Next Odd Page and On Next Even Page.

When creating paragraph styles, all the preceding controls are available in the
Keep Options pane of the New Paragraph Styles dialog box.

Adding Drop Caps

WMBER
@ﬁ
&

Drop caps are enlarged capital letters that are often used to embellish
paragraphs (usually the first paragraph of a chapter or story) and draw
attention to paragraphs. In the Paragraph panel or Control panel, InDesign
lets you specify the number of letters you want to include in a drop cap and
the number of lines you want to drop them down into.

To add one or more drop caps to selected paragraphs, enter a number in the
Drop Cap Number of Characters field in the Paragraph panel or Control
panel. The number you enter determines how many characters in a selected
paragraph will be made into drop caps. To specify the number of lines a drop
cap will extend into a paragraph (and therefore the height of the drop cap),
enter a number in the Drop Cap Number of Lines field.

After you create a drop cap, you can modify it by highlighting it and changing
any of its character formats — font, size, color, and so on — by using the
Character panel or Control panel, as well as other panes such as Stroke and
Swatches. Even better: Apply a character style to it that has all the desired
attributes stored in one place. Figure 14-3 shows two examples of drop caps.

When creating paragraph styles, the preceding controls are available in the
Drop Caps and Nested Styles pane of the New Paragraph Styles dialog box.
(See Chapter 13 for details on nested styles.)
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Figure 14-3:
A one-
character
drop cap
three lines
deep (top),
and a two-
line, four-
character
drop cap
with the first
word setin
small caps
(bottom).
|
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Examples of drop caps.

Controlling Hyphenation
and Justification

Hyphenation is the placement of hyphens between syllables in words that
won't fit at the end of a line of text. A hyphen is a signal to the reader that the
word continues on the next line. InDesign gives you the option to turn para-
graph hyphenation on or off. If you choose to hyphenate, you can customize
the settings that determine when and where hyphens are inserted.

Justification is the addition or removal of space between words and/or letters
that produces the flush-left/flush-right appearance of justified paragraphs.
InDesign’s justification controls let you specify how space is added or
removed when paragraphs are justified. If you justify paragraphs, you almost
certainly want to hyphenate them, too. If you opt for left-aligned paragraphs,
whether to hyphenate is a personal choice.

InDesign offers both manual and automatic hyphenation.

Manual hyphenation

To break a particular word in a specific place, you can place a discretionary
hyphen in the word. If the word doesn’t entirely fit at the end of a line in a
hyphenated paragraph, InDesign uses the discretionary hyphen to split the
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Figure 14-4:
The
Hyphenation
Settings
dialog box.
|

word if the part of the word before the hyphen fits on the line. To insert
a discretionary hyphen, use the shortcut Shift+3+- or Ctrl+Shift+— (note the
hyphen in the shortcuts) in the text where you want the hyphen to appear.

If a word has a discretionary hyphen, and hyphenation is necessary, InDesign
breaks the word only at that point. But you can place multiple discretionary
hyphens within a single word. If a word needs to be hyphenated, InDesign
uses the hyphenation point that produces the best results.

You can prevent a particular word from being hyphenated either by placing

a discretionary hyphen in front of the first letter or by highlighting the word
and choosing No Break from the flyout menu of the Control panel or Character
panel. (You need to select the A iconic button in the Control panel to get

this option in its flyout menu.) But be careful: If you select more than a line’s
width of text and apply No Break, InDesign doesn’t know what to do, and so it
doesn’t display the rest of the story.

To prevent hyphenation for an entire paragraph, click anywhere inside
of it and uncheck Hyphenate from the Paragraph panel or Control panel.
(Be sure the { button is selected in the Control panel.)

Automatic hyphenation

To have InDesign automatically hyphenate selected paragraphs, all you have
to do is check the Hyphenate check box in the Paragraph panel or Control
panel. (Remember that in the Paragraph panel, the Hyphenate check box
appears only if you choose Show Options from the flyout menu.)

You can control how InDesign actually performs the hyphenation via the
Hyphenation option in the flyout menu. When you choose Hyphenation,
the Hyphenation Settings dialog box, shown in Figure 14-4, appears.

Hyphenation Settings

- \2| Hyphenate (T
Words with at Least: <6 letters e
Cancel
After First: =3 letters E
™ Preview

e
W

Before Last: letters

A
4]

Hyphen Limit: hyphens

Hyphenation Zone: = 0p0

e S B
Better Spacing 3 Fawer Hyphens

121 Hyphenate Capitalized Words E Hyphenate Last Word

@ Hyphenate Across Column
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The options in the Hyphenation Settings dialog box include

+* Hyphenate: This option is a duplicate of the Hyphenate check box
in the Paragraph panel and Control panel. If you didn’t check it before
opening the Hyphenation Settings dialog box, you can check it here.

1 Words with at Least x Letters: This spot is where you specify the
number of letters in the shortest word you want to hyphenate.

v After First x Letters: In this field, enter the minimum number of
characters that can precede a hyphen.

1 Before Last x Letters: The number entered in this field determines the
minimum number of characters that can follow a hyphen.

+* Hyphen Limit: x Hyphens: In this field, you specify the number of
consecutive lines that can be hyphenated. Several consecutive hyphens
produce an awkward, ladder-like look, so consider entering a small
number, such as 2 or 3, in this field.

v Hyphenation Zone: The entry in this field applies only to nonjustified
text and only when the Adobe Single-Line Composer option is selected
(in the Paragraph panel’s flyout menu). A hyphenation point must fall
within the distance specified in this field in relation to the right margin
in order to be used. Acceptable hyphenation points that don’t fall within
the specified hyphenation zone are ignored. You can also use the Better
Spacing/Fewer Hyphens slider below the field to pick a value rather than
entering a value in the Hyphenation Zone field.

1 Hyphenate Capitalized Words: If you check this box, InDesign hyphen-
ates, when necessary, capitalized words. If you don’t check this box, a
capitalized word that would otherwise be hyphenated gets bumped to
the next line, which may cause excessive spacing in the previous line.

1+ Hyphenate Last Word: Check this box to allow InDesign to break the
last word in a paragraph. Otherwise, InDesign moves the entire word
to the last line and spaces the preceding text as necessary. Many
typographers believe hyphenating the last word in a paragraph looks
bad, so it’s rare to enable this option.

+* Hyphenate Across Column: Check this box to let text hyphenate at the
end of a column. Many typographers believe hyphenating the word at
the end of a column looks bad, so it’s also rare to enable this option.
SMBER

R

& When creating paragraph styles, all the preceding controls are available in the

Hyphenation pane of the New Paragraph Styles dialog box — except for the
composer setting, covered in the next sections.
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Controlling justification

To control how justification is achieved, you can

v Condense or expand the width of spaces between words.
v Add or remove space between letters.

v Condense or expand the width of characters.

The options in the Justification dialog box, shown in Figure 14-5, let you
specify the degree to which InDesign adjusts normal word spaces, character
spacing, and character width to achieve justification. Access this dialog

box by choosing Justification in the flyout menu in the Control panel or in
the Paragraph panel, or by pressing Option+Shift+8+J or Ctrl+Alt+Shift+J.
When specifying values in the Justification dialog box, Minimum values
must be smaller than Desired values, which in turn must be smaller than
Maximum values.

Justification
Minimum Desired Maximum [ r—
Word Spacing: 85% 100% 125% ——
Letter Spacing: 0% 0% 0% .ﬂ.-
Clyph Scaling: |100% 100% 100% [ Preview

Auto Leading: |120%

Single Word Justification: | Full Justify 4 !

Composer: | Adabe Paragraph Composer |% ]

The Justification dialog box lets you specify the following options:

1 Word Spacing: Enter the percentage of a character that you want to use
whenever possible in the Desired field. (The default value is 100%, which
uses a font’s built-in width.) Enter the minimum acceptable percentage
in the Minimum field; enter the maximum acceptable percentage in
the Maximum field. The smallest value you can enter is 0%; the largest
is 1000%.

1 Letter Spacing: The default value of 0% in this field uses a font’s
built-in letter spacing. In the Desired field, enter a positive value to add
space (in increments of 1% of an en space) between all letter pairs;
enter a negative value to remove space. Enter the minimum acceptable
percentage in the Minimum field; enter the maximum acceptable
percentage in the Maximum field.
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v Glyph Scaling: The default value of 100% uses a character’s normal
width. In the Desired field, enter a positive value to expand all character
widths; enter a negative value to condense character widths. Enter the
minimum acceptable percentage in the Minimum field and the maximum
acceptable percentage in the Maximum field. If you do apply glyph
scaling, keep it to a range of 97 to 103 percent at most.

If you use the Adobe Paragraph Composer option (see the following section)
for justified paragraphs, specifying a narrow range between minimum and
maximum Word Spacing, Letter Spacing, and Glyph Scaling generally pro-
duces good-looking results. However, if you choose the Adobe Single-Line
Composer option, a broader range between Minimum and Maximum gives
the composer more leeway in spacing words and letters and hyphenating
words and can produce better-looking results. The best way to find out what
values work best is to experiment with several settings. Print hard copies and
let your eyes decide which values produce the best results.

When creating paragraph styles, all the preceding controls are available in the
Justification pane of the New Paragraph Styles dialog box.

Composing text

The Paragraph panel’s flyout menu offers two options for implementing the
hyphenation and justification settings you establish:

v Adobe Single-Line Composer: In single-line composition, hyphenation
and justification settings are applied to each line in a paragraph, one line
at a time. The effect of modifying the spacing of one line on the lines
above and below it isn’t considered in single-line composition, so it can
cause poor spacing.

v Adobe Paragraph Composer: InDesign’s Adobe Paragraph Composer
is selected by default. It takes a broader approach to composition than
the Adobe Single-Line Composer by looking at the entire paragraph at
once. If a poorly spaced line can be fixed by adjusting the spacing of a
previous line, the Adobe Paragraph Composer reflows the previous line.

The Adobe Paragraph Composer is more sophisticated than the Single-
Line Composer, offering better overall spacing because it sacrifices
optimal spacing a bit on one line to prevent really bad spacing on
another, something the single-line method doesn’t do.

These options are also available in the Justification dialog box, covered in the
previous section.
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Ruling Vour Paragraphs

If you want to place a horizontal line within text so that the line moves
with the text when editing causes the text to reflow — an often effective
highlighting device — you need to create a paragraph rule. A paragraph
rule looks much like a line created with the line tool but behaves like a text
character. Here’s how to create paragraph rules:

Figure 14-6:
The Para-
graph Rules
dialog box.
|

1. Select the paragraphs to which you want to apply a rule above and/or

a rule below and then choose Paragraph Rules from the Paragraph
panel’s or Control panel’s flyout menu.

Alternatively, you can use the shortcut Option+8+J or Ctrl+Alt+lJ.

You can also specify rules as part of a paragraph style. The Paragraph
Rules dialog box, shown in Figure 14-6, is displayed.

==

TS ™ Rule On

Weight: =lo.s pt T_1 Type: | eo— 3]
Color: (M [Blacky |31 Tint: =/100% Ti
i‘ Overprint Stroke -
Gap Color: ' [#1[None] + | Gap Tint: =
= Overprint Gap
Width: [ Column |4 Offset: < 0p9
Left Indent: = 0p0 Right Indent: = 0p0

" Preview r Cancel \Ir oK ‘\

Paragraph Rules

Rule Above

Keep In Frame

. Choose Rule Above or Rule Below and then click Rule On.

To add rules both above and below, click Rule On for both options and
specify their settings separately. To see the rule while you create it,
select the Preview option.

. Choose a predefined thickness from the Weight pop-up menu or enter

a value in the Weight field.

. Choose a rule type from the Type pop-up menu.

You can choose from 17 types, including dashed, striped, dotted, and
wavy lines.

. Choose a color for the rule from the Color pop-up menu.

This menu lists the colors displayed in the Swatches panel
(Windowr>Swatches [F5]).
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6.

10.

11.

From the Width pop-up menu, choose Column to have the rule extend
from the left edge of the column to the right edge of the column;
choose Text to have the rule extend from the left edge of the frame or
column to the right.

. To indent the rule from the left and/or right edges, enter values in the

Left Indent and/or Right Indent fields.

. Control the vertical position of the rule by entering a value in the

Offset field.

For a rule above, the offset value is measured upward from the baseline
of the first line in a paragraph to the bottom of the rule; for a rule below,
the offset is measured downward from the baseline of the last line in a
paragraph to the top of the rule.

. Check the Overprint Stroke box if you want to print a rule on top of

any underlying colors.

This option ensures that any misregistration during printing won’t result
in white areas around the rule where the paper shows through. A similar
Overprint Gap check box is available for lines that have a Gap Color.

To ensure that a rule over a paragraph at the top of a frame displays
within the frame, check the Keep in Frame option.

Click OK to close the dialog box, implement your changes, and return
to the document.

To remove a paragraph rule, click in the paragraph to which the rule is
applied, choose Paragraph Rules from the Paragraph panel’s flyout menu,
uncheck the Rule On box, and then click OK.

When creating paragraph styles, all the preceding controls are available in the
Paragraph Rules pane of the New Paragraph Styles dialog box.
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Finessing Character Details

In This Chapter

Working with character formats

Changing font families, styles, and sizes
Applying other character formats
Controlling horizontal and vertical spacing

then you create documents, you have lots of opportunities to make
decisions about how the text appears. With its comprehensive set

of character-formatting tools, InDesign lets you change the look of type so
that it can precisely match the communication needs of your publications.
You can control not just the font and size of type, but also many other
variations.

Decisions about type matter. A document relies on good typography to allow
others to easily read and understand it. The appearance of type supports the
message you're conveying, and doing a good job of character formatting is
worth your time.

Specifying Character Formats

InDesign lets you modify the appearance of highlighted characters or
selected paragraphs with the following options:

v Character panel: Highlight the text and open the Character panel
(Typew>Character [8+T or Ctrl+T]), which is shown in Figure 15-1.
(You can also choose Window=>Type & Tools>Character.) Be sure
Show Options is visible in the flyout menu in order to see all the
possible options. You can also use the double-arrow iconic button to
the left of the panel name to toggle among showing the panel title, the
basic options, and all options.

The Character panel provides access to most of InDesign’s character
formatting options. Three of the options — Font Family, Font Style, and
Font Size — are also available via the Type menu, and several options
have keyboard shortcuts.
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v~ Paragraph panel: Select a paragraph and open the Paragraph panel
(Typew>Paragraph [Option+8+T or Ctrl+Alt+T]). Chapter 14 covers these
settings in detail.

v Control panel: The Control panel offers all the formatting options of the
Character panel plus others. If the Control panel doesn’t show all the
character formatting options, select the text and then click the A iconic
button on the panel. If the Control panel isn’t visible (it almost always
is), display it by choosing Window=>Control (Option+3+6 or Ctrl+Alt+6).

<P To change the default character formats — the settings that InDesign uses
when you type text into an empty frame — make changes in the Character
panel or Control panel when no text is selected or when the text-insertion
cursor isn’t flashing. That step saves you the hassle of having to reformat
new text.

You can choose to apply character formats to highlighted text in two ways:

v Create and apply character styles. Character styles offer an important
advantage: A character style’s settings are stored, so you can apply the
exact same settings easily to other text. When you change a character
style’s settings, any text based on that style is automatically changed to
reflect the new settings. (Chapter 13 covers styles in detail.)

v Use the local controls in the Character panel, the Control panel, the
Type menu, or their keyboard shortcuts, which I cover in the upcoming
sections. Even when you do use character styles, you’ll probably also do
some local formatting from time to time. For example, you’d probably
use the Character panel to format the type on the opening spread of a
feature magazine article and then use character styles to quickly format
the remainder of the article.

D ———i )
4+ CHARACTER E Hide Op[ions \
ITC Kallos LT St B - - -
o = OpenType » Discretionary Ligatures
? E A Caps YT @ Fractions
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Ay merrics ) my 5o 73]  Superscript 8= [Swash]
— = = - Subscript = [Titling Alternates]
IT [oos 1) [ |69 . v [Contextual Alternates)
a2 Sopt T Un!derlme 138U {All Small Caps]
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<P If you have a smallish monitor, set at 1024 by 768 pixels — the norm for a
17-inch display — the Character and Character Styles panels may be shoved
to the bottom of the panel dock. When they’re selected, the only thing you see
is their panel tab and flyout menu icon. You have a few choices: Shorten other
panel groups in the dock to make room for them, remove other panel groups
to make room for them, or drag them out of the dock and make them floating.

Modifying Font, Type Style, and Size

Many people use typographic terms — font, face, typeface, font family, and
type style — inconsistently. Which terms you use doesn’t matter as long as
you make yourself understood, but | recommend becoming familiar with the
font-related terms in InDesign’s menus and panels:

 Font or typeface: A collection of characters — including letters, num-
bers, and special characters — that share the same overall appearance,
including stroke width, weight, angle, and style.

For example, Helvetica Regular and Adobe Garamond Semibold Italic are
well-known fonts.

v+~ Font family: A collection of several fonts that share the same general
appearance but differ in stroke width, weight, and/or stroke angle.

For example, Helvetica and Adobe Garamond are font families.

v~ Font style: Each of the fonts that make up a font family. When you
choose a font family from the Character panel’s Font Family menu,
InDesign displays the family’s font style variations — what most
of the design world calls type styles — in the accompanying Font Style
pop-up menu.

For example, Regular and Semibold Italic are examples of font styles.

Changing font family and font style

When you change from one font to another in InDesign, you can choose a
new font family and font style independently in the Character panel. For
example, changing from Arial Bold to Times Bold or from Arial Regular to
Berthold Baskerville Regular is a simple change of font family (Arial to
Berthold Baskerville). However, if you switch from, say, Bookman Light to
Century Schoolbook Bold Italic, you're changing both family and style
(Bookman to Century and then Light to Bold Italic).
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InDesign can display previews of fonts when you select fonts via the Control
panel, various text-oriented panels, and the Type menu. You turn on this
capability in the Type pane of the Preferences dialog box by choosing
InDesign=>Preferences®>Type (88+K) on the Mac or Edit=>Preferences=>Type
(Ctr1+K) in Windows. But doing so makes your menus huge, often so much
that they’re unwieldy to use. Although it can help you get familiar with your
fonts, its unwieldy nature may not be worth that benefit. Only you can
decide, but if you do use the preview feature, | recommend keeping the
preview size small to limit its size.

Whether you use the Control panel or Character panel, you can choose
between two methods for changing the font family:

v Choose the Font Family menu and then select a name from the list of
available font families.

v Place the cursor in front of or highlight the font name displayed in the
Font Family field, type the first few letters of the font family you want to
apply, and then press Return or Enter. For example, entering Cas selects
Caslon (if it’s available on your computer).

If you choose only a font family when font styles are available in an accompa-
nying submenu, no changes are applied to the selected text. So be sure to
select a font style from the submenu.

When creating character styles, the preceding controls are available in the
Basic Character Formats pane of the New Character Styles and New Paragraph
Styles dialog boxes.

Changing type size

You can be very precise with type sizes (what InDesign calls font size).
InDesign supports sizes from 0.1 point to 1,296 points (108 inches) in
increments as fine as 0.001 point. Of course, you want to use good judgment
when choosing type sizes. For example, headlines should be larger than
subheads, which in turn are larger than body text, which is larger than photo
credits, and so on.

Change the type size of highlighted text with the following methods:

v Choose TypewSize and then choose one of the predefined sizes listed in
the Size submenu. If you choose Other from the submenu, the Font Size
field is highlighted in the Character panel. Enter a custom size and then
press Return or Enter.
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v Use the Character panel or Control panel:
1. Choose one of the predefined sizes from the Font Size menu.

2. Highlight the currently applied type size displayed in the
accompanying editable field, enter a new size, and then press
Return or Enter.

3. Make sure that the Font Size field is selected and then use the up
and down arrow keys to increase or decrease the size in 1-point
increments. Pressing Shift multiplies the increment to 10.

v Control+click or right-click a text selection and then choose a size from
the Size submenu. If you choose Other from the submenu, the Font Size
field is highlighted in the Character panel. Enter a custom size and then
press Return or Enter.

If text is highlighted and the Font Size field is empty, more than one type size
is used in the selected text.

When creating character styles, the Font Size control is available in the Basic
Character Formats pane of the New Character Styles dialog box.

Using Other Character Formats

<MBER
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In the Control panel, you can adjust other character formats, including all
caps, small caps, superscript, subscript, underline, strikethrough, kerning,
tracking, horizontal and vertical scale, baseline shift, skew, font style, and
language. Through the flyout menu, you can also set ligatures, modify
underline and strikethrough settings, control whether text may break (be
hyphenated), select its case (such as all caps and small caps), and select
OpenType features. (The next several sections explain each of these terms,
except for OpenType features, which let you apply a variety of controls to
OpenType fonts — an expert topic that this book doesn’t get into detail on.)

In the Character panel, you can adjust kerning, tracking, horizontal and
vertical scale, baseline shift, skew, and language. Through its flyout menu
(refer to Figure 15-1), you can also set all caps, small caps, superscript, sub-
script, underline, strikethrough, ligatures, and underline and strikethrough
settings, as well as control whether text may break (be hyphenated) and
select OpenType features. (InDesign also lets you create custom underlines
and strikethroughs, as Chapter 16 describes.)

When creating character styles, the kerning, tracking, subscript, superscript,
case, ligature, underlining, break, and strikethrough controls are available in
the Basic Character Formats pane of the New Character Styles and New
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Figure 15-2:
Various
character
formatting
options
applied to
text.
|

Paragraph Styles dialog boxes. The scale, baseline shift, skew, and language
controls are in the Advanced Character Formats pane. OpenType controls are
in the OpenType Features pane. Custom underline and strikethrough options,
covered in Chapter 16, are available in the Underline Options and
Strikethrough Options panes, respectively.

You must choose Show Options from the Character panel’s flyout menu
to display the Vertical Scale, Horizontal Scale, Baseline Shift, Skew, and
Language options in the panel.

The Control panel has the same functions as the Character panel, except the
all caps, small caps, superscript, subscript, underline, and strikethrough
options are in the panel itself rather than in its flyout menu.

Figure 15-2 shows the various effects in action. In its top row, InDesign has

a different font style applied, incredible has been scaled horizontally, and
control is in all caps, while over has had each letter’s baseline shifted by a
different amount. In the middle row, the word text has been skewed, the word
with is in small caps, a gradient and underline are applied to typographic, a
custom underline has been applied to capabilities, and the word formatting
has been vertically scaled. In the bottom row, compare the baseline shifts in
the top row to the true superscript and subscript following the words most
and people. The word never has a custom strikethrough applied, while even
uses a standard one. The word heard has a colored stroke applied and a

fill of white.

InDesign has incredible CONTROL °Ver
XL fﬂrmamng, WITH fypog capabilities

most! people, have newer ever [agaril of!

Horizontal Scale and Vertical
Scale options

InDesign’s Horizontal Scale option lets you condense and expand type by
squeezing or stretching characters. Similarly, the Vertical Scale option lets
you shrink or stretch type vertically.
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Typographers tend to agree that you should avoid excessive scaling. If you
need to make text bigger or smaller, your best bet is to adjust font size; if
you need to squeeze or stretch a range of text a bit, use InDesign’s kerning
and tracking controls because the letter forms aren’t modified — only the
space between letters changes when you kern or track text. (For more on
this topic, see the upcoming section “Controlling Space between Characters
and Lines.”)

Unscaled text has a horizontal and vertical scale value of 100 percent.

You can apply scaling values between 1 percent and 1,000 percent. If you
apply equal horizontal and vertical scale values, you’re making the original
text proportionally larger or smaller. In this case, changing font size is a
simpler solution.

To change the scale of highlighted text, enter new values in the Horizontal
and/or Vertical Scale fields in the Character panel or Control panel. If a
value is highlighted in the Horizontal Scale or Vertical Scale field, you can
also use the up and down arrow keys to increase and decrease the scaling
in 1-percent increments; press Shift to increase or decrease in 10-percent
increments.

Baseline shift

The baseline is an invisible horizontal line on which a line of characters rests.
The bottom of each letter sits on the baseline (except descenders, such as
iny, p, q, j, and g). When you perform a baseline shift, you move highlighted
text above or below its baseline. This feature is useful for carefully placing
such characters as trademark and copyright symbols and for creating
custom fractions.

To baseline-shift highlighted text, enter new values in the Baseline Shift field
in the Character panel or Control panel. You can also use the up and down
arrow keys to increase the baseline shift in 1-point increments or press Shift
with the arrow keys to increase or decrease it in 10-point increments.

Skew (false italic)

For fonts that don’t have an italic type style, InDesign provides the option to
skew, or slant, text to create an artificial italic variation of any font. Like
horizontal and vertical text scaling, skewing is a clunky way of creating italic-
looking text. Use this feature to create special typographic effects, as shown
in Figure 15-3, or in situations where a true italic style isn’t available.
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N Skewing works better for sans-serif typefaces than for serif typefaces because
the characters are simpler and have fewer embellishments that can get oddly
distorted when skewed.

To skew highlighted text, you have three options:

v~ Enter an angle value between -85 and 85 in the Skew field in the
Character panel or Control panel. Positive values slant text to the left;
negative values slant text to the right.

v Press the accompanying up/down arrow keys when the cursor is in the
Skew field to skew text in 1-degree increments. Pressing the Shift key
with an arrow key changes the increment 4 degrees.

v Skew all the text in a text frame using the Shear tool or by changing the
value in the Shear X Angle field in the Control panel after selecting the
frame. Slanting text by shearing a text frame doesn’t affect the skew
angle of the text. You can specify a skew angle for highlighted text
independently from the frame’s shear angle.

|

Figure 15-3:
Characters
in skewed
text can
= | Skewed shadow
forward, like
italics, or
backward,
as in this
example.
|

Capitalization options

When you choose All Caps, the uppercase version of all highlighted charac-
ters is used: Lowercase letters are converted to uppercase, and uppercase
letters remain unchanged.

Similarly, the Small Caps option affects just lowercase letters. When you
choose Small Caps, InDesign automatically uses the Small Caps font style if
one is available for the font family. (Few font families include this style.) If a
Small Caps type style isn’t available, InDesign generates small caps from
uppercase letters using the scale percentage specified in the Advanced Type
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pane of the Preferences dialog box. (Choose InDesign=>Preferences=
Advanced Type [$8+K] on the Mac or Edit=>Preferences>Advanced Type
[Ctrl+K] in Windows). The default scale value used to generate small caps
text is 70% (of uppercase letters).

Another handy way to change the case of text is to highlight the text, choose
Type=>Change Case, and then select from the appropriate submenu option:
Uppercase, Lowercase, Title Case, and Sentence Case. Title Case capitalizes
the first letter in each word, whereas Sentence Case capitalizes the first letter
in the beginning of each sentence.

Superscript and Subscript

When you apply the Superscript and Subscript character formats to
highlighted text, InDesign applies a baseline shift to the characters, lifting
them above (for superscript) or lowering them below (for subscripf) their
baseline, and reduces their size.

The amount of baseline shift and scaling that’s used for the Superscript
and Subscript formats is determined by the Position and Size fields

in the Advanced Type pane of the Preferences dialog box. (Choose
InDesign=>Preferences>Advanced Type [38+K] on the Mac or choose Edit~>
Preferences>Advanced Type [Ctrl+K] in Windows). The default Position
value for both formats is 33.3%, which means that characters are moved
up or down by one-third of the applied leading value. The default Superscript
and Subscript Size value is 58.3%, which means that superscripted and
subscripted characters are reduced to 58.3% of the applied font size. The
Advanced Type pane lets you specify separate default settings for
Superscript and Subscript.

To apply the Superscript or Subscript format to highlighted text, choose the
appropriate option from the Character panel’s flyout menu.

Underline and Strikethrough

Underline and Strikethrough formats are typographically considered to be
unacceptable for indicating emphasis in text, which is better accomplished
by using bold and/or italic font styles.

Underlines can be useful in kickers and other text above a headline, as well
as in documents formatted to look as if they’re typewritten. Strikethrough
can be used in cases where you want to indicate incorrect answers,
eliminated choices, or deleted text.
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If you use underlines and strikethrough, InDesign lets you specify exactly
how they look through the Underline Options and Strikethrough Options
dialog boxes available in the flyout menus of the Character panel and
Control panel.

InDesign lets you create your own underlines and strikethroughs, in addition
to using the standard ones, as Chapter 16 explains.

Ligatures

A ligature is a special character that combines two letters. Most fonts include
just two ligatures — fi and fl. When you choose the Ligature option, InDesign
automatically displays and prints a font’s built-in ligatures — instead of the
two component letters — if the font includes ligatures.

One nice thing about the Ligature option is that even though a ligature looks
like a single character on-screen, it’s still fully editable. That is, you can click
between the two-letter shapes and insert text, if necessary. Also, a ligature
created with the Ligature option doesn’t cause InDesign’s spell checker to
flag the word that contains it.

To use ligatures within highlighted text, choose Ligatures from the Character
panel’s or Control panel’s flyout menu. (Ligatures is set to On by default.)
Figure 15-4 shows an example of text with a ligature.

You can also insert ligatures manually:

»* On the Mac, press Option+Shift+5 to insert the fi ligature and
Option+Shift+6 to insert the fl ligature. You can also use the Mac OS
X’s Character Palette utility or InDesign’s Glyphs panel (Type=>Glyphs
[Option+Shift+F11 or Alt+Shift+F11]) to choose them visually.

finally, I finally, I
can float! can float!
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v+ In Windows, you have to use a program such as the Character Map
utility that comes with Windows. Choose Start=>All Programs=>
Accessories>System Tools>Character Map; if you have the Classic Start
menu interface enabled, choose Start>Programsm>Accessoriest>System
Toolsw>Character Map.

However, if you do enter ligatures yourself, InDesign’s spell checker flags any
words that contain them. For this reason, you’ll typically want InDesign to
handle the task of inserting ligatures automatically.

Turning off hyphenation and other breaks

You can prevent individual words from being hyphenated or a string of
words from being broken at the end of a line. For example, you may decide
that you don’t want to hyphenate certain product names, such as InDesign.
The No Break option was created for situations such as these.

To prevent a word or a text string from being broken, highlight it and then
choose No Break from the Character panel’s flyout menu or the Control
panel’s flyout menu. You can also prevent a word from being hyphenated
by placing a discretionary hyphen (Shift+8+— or Ctrl+Shift+-) in front of the
first letter. (See Chapter 14 for more on hyphenation controls.)

Controlling Space between
Characters and Lines

The legibility of a block of text depends as much on the space around it —
called white space — as it does on the readability of the font. InDesign offers
two ways to adjust the space between characters:

v Kerning is the adjustment of space between a pair of characters. Most
fonts include built-in kerning tables that control the space between char-
acter pairs, such as LA, Yo, and WA, that otherwise may appear to have
a space between them even when there isn’t one. For large font sizes —
for example, a magazine headline — you may want to manually adjust
the space between certain character pairs to achieve consistent spacing.

v Tracking is the process of adding or removing space among all letters in
a range of text.

You can apply kerning and/or tracking to highlighted text in !/1.00-em
increments, called units. An em is as wide as the height of the current font
size (that is, an em for 12-point text is 12 points wide), which means that
kerning and tracking increments are relative to the applied font size.
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Leading (rhymes with sledding) controls the vertical space between lines of
type. It’s traditionally an attribute of paragraphs, but InDesign lets you apply
leading on a character-by-character basis. To override the character-oriented
approach, ensuring that leading changes affect entire paragraphs, check

the Apply Leading to Entire Paragraphs option in the Type pane of the
Preferences dialog box. (Choose InDesign=>Preferences=>Type [3+K] on the
Mac or Edite>Preferences>Type [Ctrl+K] in Windows.)

Kerning

The Kerning controls in the Character panel and Control panel provide three
options for kerning letter pairs:

1 Metrics: Controls the space between character pairs in the highlighted
text using a font’s built-in kerning pairs.

v Optical: Evaluates each letter pair in highlighted text and adds or
removes space between the letters based on the shapes of the
characters.

+* Manual: Adds or removes space between a specific letter pair in user-
specified amounts.

When the flashing text cursor is between a pair of characters, the Kerning
field displays the pair’s kerning value. If Metrics or Optical kerning is applied,
the kerning value is displayed in parentheses.

To apply Metrics or Optical kerning to highlighted text, choose the appropri-
ate option from the Kerning pop-up menu. To apply manual kerning, click

between a pair of letters and then enter a value in the Kerning field or choose
one of the predefined values. Negative values tighten; positive values loosen.

When letter shapes start to collide, you've tightened too far.

Tracking

Tracking is uniform kerning applied to a range of text. (For more on kerning,
see the preceding section.) You can use tracking to tighten character spacing
for a font that you think is too spacey or loosen spacing for a font that’s

too tight. Or you can track a paragraph tighter or looser to eliminate a short
last line or a widow (the last line of a paragraph that falls at the top of a page
or column).

To apply tracking to highlighted text, enter a value in the Character panel’s
or Control panel’s Tracking field or choose one of the predefined values.
Negative values tighten; positive values loosen (in 0.001-em increments).
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You may wonder how tracking is different than kerning. They’re essentially
the same thing, with this difference: Tracking applies to a selection of three or
more characters, whereas kerning is meant to adjust the spacing between just
two characters. You use tracking to change the overall tightness of character
spacing; you use kerning to improve the spacing between letters that just
don’t quite look right compared to the rest of the text.

Leading

Leading (rhymes with sledding, not heeding) refers to the vertical space
between lines of type as measured from baseline to baseline. Leading in
InDesign is a character-level format, which means that you can apply
different leading values within a single paragraph. InDesign looks at each
line of text in a paragraph and uses the largest applied leading value within
a line to determine the leading for that line.

By default, InDesign applies Auto Leading to text, which is equal to 120
percent of the type size. As long as you don’t change fonts or type sizes in a
paragraph, Auto Leading works pretty well. But if you do change fonts or
sizes, Auto Leading can result in inconsistent spacing between lines. For this
reason, specifying an actual leading value is safer.

In most cases, using a leading value that is slightly larger than the type size is
a good idea. When the leading value equals the type size, text is said to be set
solid. That’s about as tight as you ever want to set leading, unless you're
trying to achieve a special typographic effect or working with very large text
sizes in ad-copy headlines. As is the case with kerning and tracking, when
tight leading causes letters to collide — ascenders and descenders are the
first to overlap — you’ve gone too far.

You can change InDesign’s preset Auto Leading value of 120%. To do so,
choose Typer>Paragraph (Option+3+T or Ctrl+Alt+T) to display the
Paragraph panel. Choose Justification in the flyout menu, enter a new value
in the Auto Leading field, and then click OK. (Why a character format setting
is accessed via the Paragraph panel and what Auto Leading has to do with
Justification are both mysteries.)

To modify the leading value applied to selected text, choose one of the
predefined options from the Leading pop-up menu in the Character panel or
Control panel or enter a leading value in the field. You can enter values from
0 to 5,000 points in 0.001-point increments. You can also use the up and down
arrow keys to change leading in 1-point increments.
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Chapter 16
Tricks with Text

In This Chapter

Adding bullets and formatting lists

Creating reverse type

Specifying optical margin alignment

Creating custom underlines and strikethroughs
Adjusting text strokes

Converting text to graphics

Running text along a path

Wth the myriad of text-formatting techniques available in InDesign,
you can create some snazzy and sophisticated effects. You can

stretch, skew, rotate, and color text. You can use a wide range of characters
for bullets. You can add shadows and feathering effects to give words a dra-
matic flair. As with all good things, moderation in your use of text effects will
keep your documents looking professional. This chapter shows you some
InDesign features that can produce typographic special effects and gives sug-
gestions on when to use them. (Chapters 14 and 15 cover more prosaic for-
matting controls.)

You can also apply all sorts of transformations to text frames, which affect
the text inside of them. Chapter 9 covers these capabilities.

Using Bulleted and Numbered Lists

Automatic bullets and numbering are available as a paragraph format in
InDesign. You access these options (after selecting the paragraphs you want
to make into automatic lists, of course) by choosing Bullets and Numbering
Options from the Paragraph panel’s or Control panel’s flyout menus. Doing so
displays the Bullets and Numbering dialog box, as shown in Figure 16-1.
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\&Q,N\BEH The bulleted or numbered list you're working with may have been first
& created in a word processor and then placed in InDesign. Perhaps the writer
simply used an asterisk followed by a space to indicate a bullet or used the
word processor’s automatic bullet or numbering feature. You can deal with
imported bulleted and numbered lists as described in Chapter 11.

Bullets and Numbering Bullets and Numbering
List Type: | Bullets [ List Type: | Numbers %
List: | [Default] 1 Level: =1 List: | [Default] &) Level: =1
— Bullet Character — Numbering Style
— el [ (_add. ) Format: [1,2,3,4... [#
- . Delete Number: [A#.At Ta) &
Figure 16-1:
Character Style: [ [None] %
The Bullets ;
dN b Text After: At L Mode: | Continue from Previ... |&] 1
an umn- Character Style: [ [None] [ | Restart Numbers at This Level After:  Any Previous Level +
ering dialog | ! ‘
b Bullet or Number Position 1 Bullet or Number Position -
ox set Alignment: [ Left % Alignment: [ Left  |#
for bullets Left Indent: = Left Indent:
(|Eft) and First Line Indent: First Line Indent: =
numbering Tab Position: Tab Position: =
"] Preview Cancel oK "] Preview Cancel oK
I

To set bullets or numbered lists in the Bullets and Numbering dialog box,
first select either Bullets or Numbers from the List Type pop-up menu and
then follow these steps:

la. For bullets, choose a bullet character from the Bullet Character area.

This area shows bullet characters available for the current font; you can
add to the available selections by clicking the Add button, which opens
the Add Bullets dialog box in which you see a list of available glyphs for
whatever font you choose from its Font family and Font Style pop-up
menus. Choose the desired bullet and click OK to return to the Bullets
and Numbering dialog box. The chosen bullet appears in the Bullet
Character area.

1b. For numbered lists, set the desired formatting from the several other
options that control how numbered lists display.

You use three most of the time:

¢ In the Format pop-up menu, choose a numbering style to format
the numbers’ appearance, such as setting them to use Roman (i, ii,
iii, iv) or Arabic (1, 2, 3, 4) numerals.
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¢ In the Number field, you can insert all sorts of special spaces and
characters, giving you broad control on how numbers display. You
can also choose number placeholders, which tell InDesign what
numbers to insert in the list. For simple lists, choose Current Level
from the Insert Number Placeholder pop-up submenu. The other
levels are used when you have sublists, an expert feature. You can
also choose Chapter Number to insert the chapter’s number as the
list item’s number.

¢ Use the Mode pop-up menu to choose whether the numbers con-
tinue or start anew at the current paragraph. (Your choices are
Continue from Previous Number and Start At.)

2. Adjust the font settings for the bullets or numbers by using the
Character Style pop-up menu to choose a character style.

The default setting ([None]) uses the paragraph’s current formatting.

3. In the Bullet or Number Position section of the dialog box, set the
indentation for the list.

Using the Alignment pop-up menu, choose Left, Center, or Right to deter-

mine where the bullet or numeral is positioned within its tab. You can

set the hanging indent amount and the bullet’s or number’s overhang by
<P using the Left Indent, First Line Indent, and Tab Position fields.

Select the Preview check box to see the results of your choices before
you finalize them.

4. When you finish formatting the bulleted or numbered list, click OK.

InDesign gives you even more control over bulleted and numbered lists
through the options you get by choosing Type=Bulleted & Numbered Lists:

v The Apply/Remove Bullets and Apply/Remove Numbers submenu
options quickly let you turn on or off the bullets or numbering for
selected paragraphs. You can also use the iconic buttons for these
controls on the Control panel.

v The Restart/Continue Numbering options are a handy way to control
which paragraphs are numbered, such as when you have an unnum-
bered paragraph within a list. (These options are also available in the
flyout menu of the Paragraph panel and Control panel.)

v The Convert Bullets to Text and Convert Numbering to Text options
remove the automatic bullets or numerals in a paragraph but leave an
actual bullet character or numeral at the beginning of the paragraph for
you to do as you please.
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A more expert option is the Define Lists option (available in two places: by
choosing Typer>Bulleted & Numbered Lists>Define Lists or by choosing
Define Lists from the Paragraph panel’s flyout menu). Here, you create list
styles with just two options: Continue Numbers Across Stories and Continue
Numbers from Previous Document in a Book. These list styles are accessed
when you create or edit paragraph styles using the style dialog boxes’ Bullets
and Numbering pane, or when you apply bullets and numbering through the
Paragraph panel’s or Control panel’s flyout menu. (Either way, choose the
appropriate style in the List pop-up menu.)

When you choose the first option, InDesign continues numbering text based
on the last number used in the previous story rather than restarting the num-
bering at each story (the normal behavior). When you choose the second
option, InDesign continues numbering text based on the last number used in
the previous chapter of a book (see Chapter 21) rather than starting over
again with this document (the normal behavior).

For the bullets in a list, you're not limited to using the small round bullet (*)
included in most typefaces. You can use any character in the body text font,
or you can switch to a symbol or pi font and choose a more decorative
character. Zapf Dingbats and Wingdings are the most common symbol fonts,
offering an array of boxes, arrows, crosses, stars, and check marks.

Labeling Paragraphs

\\3

Along with using drop caps, which I cover in Chapter 14, changing the
formatting of the first few words in a paragraph as a label can serve as a
visual indicator that the reader has arrived at the beginning of a story,
chapter, or new topic. To experiment with label formatting, use the attributes
available via the Character panel or Control panel and their flyout menus,
such as font changes, horizontal scale, or small caps. After you decide on the
formatting for labels, you can apply it by using character styles after para-
graph styles are applied — and after the text is final. You may also be able to
use the nested styles feature if the label text follows a specific pattern, such
as a specific number of words or characters or an entire sentence.

A real easy way to consistently apply the desired label formatting to text is to
use a nested style, as explained in Chapter 13.

The following descriptions show frequently used label formatting:

+* Boldface: Bold type is often used for titles and subheads in magazines,
newspapers, and reports. To apply boldface in InDesign, select the bold
version of the typeface from the Font Style pop-up menu in the
Character panel.
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v ltalics: Ttalic text is a good choice for emphasizing specific words and for
applying to tertiary heads. To apply italics in InDesign, select the
oblique version of the typeface from the Font Style pop-up menu on the
Character panel.

v Underlines: Underlined text isn’t used as frequently as it once was,
simply because page-layout programs such as InDesign offer more
sophisticated options for labeling text. Still, you may have occasion to
use underlines, such as to emphasize a label. Use the Underline com-
mand in the menu on the Character panel or via the iconic button in
the Control panel’s character (A) pane. Note that you have no control
over the style, thickness, or placement of the underline if you use
this option; for custom underlines, use the controls described in the
“Custom underline and strikethrough options” section, later in this
chapter.

1 sMALL cAps: Small caps offer a subtle, classic look that blends well with the
rest of the document. You have two choices for applying small
caps from the Character pane: Choose a small-caps variation of a
typeface from the Font Style pop-up menu or choose the Small Caps
command from the Character panel’s flyout menu, or via the iconic
button in the Control panel’s character (A) pane.

v Typeface change: Rather than relying on different variations of a font, you
can use a different font altogether, such as Futura Medium, for a label.
To contrast with serif body text, you might choose a sans-serif typeface
that complements the look of your publication. To apply a different
typeface, use the Font Family pop-up menu in the Character panel or
Control panel.

v Scaled text: Scaling text horizontally — up 10 or 20 percent —is a
subtle effect that makes the section of text visually distinct. Scaling text
vertically, however, can be too subtle unless combined with boldface or
another style. Use the Horizontal Scale and Vertical Scale fields in the
Character panel or Control panel to scale text.

v Size change: Bumping the size of a label up a point or two is another
subtle design choice. To change the size of type, use the Font Size field
in the Character panel or Control panel.

Adding Special Type Treatments

Skilled graphic designers make decisions based on what best serves the
content. In doing so, they often rely on special typographic techniques.
For example, the use of reverse type helps to break up pages and organize
text, while careful formatting of fractions and hanging punctuation adds a
professional touch.
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Reversing type out of its background

Reversed type is white type on a black background rather than black type on
a white background. Of course, reversed type doesn’t have to be white on
black; it can be any lighter color on a darker color. You often find reversed
type in table headings, kickers (explanatory blurbs following headlines), and
decorative layout elements.

To lighten the text, highlight it with the Type tool, click the Fill button on the
Tools panel, and choose a light color from the Swatches panel (Window=
Swatches [F5]). For the dark background, you have three options: filling the
text frame with a darker color, making the text frame transparent and placing
it on top of darker objects, or placing a thick, dark ruling line behind the text.

For the first two options, select the text frame and then click the Fill iconic
button on the Tools panel.

v To fill the text frame with a darker color, click a color from the Swatches
panel.

v To make the text frame transparent, click the Apply None iconic button
on the Tools panel. Then place the text frame in front of a darker object
or graphic.

To create reversed type that isn’t in its own text frame, use a ruling line of
the appropriate width (at least a couple points larger than the text size). If
you use a Ruling Line Above, move the line down behind the text; if you use a
Ruling Line Below, move it up. Figure 16-2 shows reversed type used as a
heading, as well as the Paragraph Rules dialog box and the settings used to
create the effect. (To access this dialog box, choose Paragraph Rules from
the flyout menu of the Control panel’s  pane or of the Paragraph panel
[Option+38+J or Ctrl+Alt+J].)

[ explain how to create and adjust ruling lines in greater detail in Chapter 14.
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Creating sidebars and pull-quotes

A sidebar is supplemental text that is often formatted differently from the
rest of the document and placed within a shaded or outlined box. Sidebars
help break up text-heavy pages and call attention to information that is often
interesting but not essential to the main story.

Particularly in text-heavy publications, pulling in-depth information or related
text into sidebars can help provide visual relief. To create a sidebar, you
usually place the text in its own frame, then stroke the frame, and optionally
fill it with a tint. To inset the text from the edges of the frame, use the Text
Frame Options dialog box (Object>Text Frame Options [3+B or Ctrl+B]).

A pull-quote is a catchy one- or two-line excerpt from a publication that is
enlarged and reformatted to achieve both editorial and design objectives.
Pull-quotes draw readers into articles with excerpts that do everything from
summarize the content to provide shock value. From the design perspective,
pull-quotes break up static columns and offer opportunities for typographic
treatment that emphasizes the content, such as colors and typefaces that
support the mood of an article.

To create a pull-quote, copy and paste the relevant text into its own text
frame and then reformat the text and frame as you wish. Use the Text Wrap
panel (Window=>Text Wrap [Option+38+W or Ctrl+Alt+W]) to control how
text in columns wraps around the pull-quote.

To create sidebars, pull-quotes, or other such elements that stay close
to the text that refers to them, use the anchored-object feature described in
Chapter 10.

Formatting fractions

Creating fractions that are formatted correctly can be handy. Compare

the leftmost fraction in Figure 16-3, which really isn’t formatted as a fraction,
to the other three fractions, which are correctly formatted (each using a
different technique). Although InDesign doesn’t provide an automatic
fraction maker, you can use OpenType typefaces, expert typefaces, or
character formats to achieve professional-looking fractions.

Applying a fraction typeface

Some expert typefaces include a variation, appropriately called Fractions,
that includes a number of common fractions, such as !/, /s, !/s, and 3/s. Adobe
has Expert Collection variants for many of its popular Type 1 PostScript
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Figure 16-3:
At left: Four
ways to
make a frac-
tion (from
left to right):
unformatted,
via expert
fonts, via
OpenType
fonts, and
via manual
formatting.
Atright:

The Glyphs
panel lets
you choose
special
characters
such as
fractions not
accessible
easily (or at
all) from the
keyboard.
|

fonts; these collections include true small caps, true fractions, and other
typographic characters. You can also use a symbol font, though the numerals
may not exactly match the appearance of numerals in the rest of your text
because symbol fonts typically use plain fonts like Helvetica as their basis.

To use a true fraction from an Expert Collection font, choose Type=>Glyph
(Option+Shift+F11 or Alt+Shift+F11), select the font and face from the pop-up
menus at the bottom of the dialog box shown in Figure 16-3, and then select
the fraction you want to use.

If you have OpenType fonts, the process can be automated: Be sure that the
Fraction option is enabled for the selected text, either as part of its character
or paragraph style, or by highlighting the text and adjusting the OpenType
options directly:

v For styles, go to the OpenType Features pane when creating or
modifying a paragraph or character style and checking Fractions.

v For local formatting, highlight the text containing the fraction and then
choose OpenTyperFraction from the flyout menu of the Character panel
or Control panel — be sure that Fraction is checked in the menu.

7/8 B B A
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These OpenType options have no effect on non—-OpenType fonts.

Formatting fractions manually

If you're dealing with a wide range of fractions in something like a cookbook,
you probably won'’t find all the fractions you need in your Expert Collection
or OpenType font. And regular Type 1 Postscript and TrueType fonts cer-
tainly won’t have the desired fractions. Because it would be difficult to
format fractions such as */is exactly the same as, say, an expert font’s !/4, you
may opt for formatting all the fractions manually.

The built-in fractions in expert and OpenType fonts are approximately the
same size as a single character in that font, and this consistent size is your
eventual goal in formatting a fraction manually. Usually, you achieve this size
consistency between fractions and surrounding text by decreasing the size of
the two numerals within the fraction, raising the numerator (the first, or top,
number in the fraction) using the baseline shift feature, and kerning on either
side of the slash as necessary. (Chapter 16 covers these controls.) Figure 16-3
shows examples of an unformatted fraction, an expert font’s fraction, an
OpenType-generated fraction, and a manually created fraction.

Macintosh PostScript and TrueType fonts (as well as expert fonts and
OpenType fonts for both Windows and Macintosh) provide another option
for refining fractions: a special kind of slash called a virgule, which is smaller
and at more of an angle than a regular slash. Press Option+Shift+1 to enter
avirgule and then kern around it as you would a slash. (You can see how a
virgule differs from a slash in Figure 16-3: The first and fourth fractions use
slashes, while the second and third use virgules.)

Unless you rarely use fractions, by all means save your formatting as charac-
ter styles. You can apply the formats with a keystroke or use Find/Change
(Edit=>Find/Change [38+F or Ctrl+F]) to locate numbers and selectively apply
the appropriate character style.

Optical margin alignment

When display type, such as a pull-quote or headline type in ads, is left-aligned
or justified, the edges can look uneven due to the gaps above, below, or next
to quotation marks, other punctuation, and some capital letters. Notice the
text frame on the left in Figure 16-4, which doesn’t have hanging punctuation.
To correct the unevenness, you can use a technique called hanging punctua-
tion, or optical margin alignment, which extends the punctuation slightly
beyond the edges of the rest of the text.
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Figure 16-4:
Notice the
difference

between the

standard
alignment
on the left
and the
hanging
punctuation
on the right.

Discover Discover
Undiscovered Undiscovered
Spain: Spain:

The Picos de  The Picos de
Europa Europa

The edge of text is defined by the edges of the text frame or any Inset Spacing
specified in the Text Frame Options dialog box (Object=>Text Frame Options
[38+B or Ctrl+B]).

The optical margin alignment feature automates hanging punctuation,
extending punctuation and the edges of some glyphs (such as the capital 7)
slightly outside the edges of the text. Unfortunately, you can’t control how
much the characters “hang” outside the text boundaries — InDesign decides
that for you. And optical margin alignment applies to all the text frames in a
story, rather than to highlighted text. Therefore, you need to isolate any text
for which you want hanging punctuation into its own story.

To specify optical margin alignment, select any text frame in a story and
choose Type=Story. In the Story panel, check the Optical Margin Alignment
option, as shown in Figure 16-4.

Custom underline and
strikethrough options

You can use InDesign to create text with custom underlines and
strikethroughs. Although you should use these effects sparingly, they
can be effective for signs and other design-oriented text presentations,
such as the examples shown in Figure 16-5.

You can find both the Underline Options and Strikethrough Options menu
items in the flyout menu of the Character panel’s and of the Control panel’s A
pane, and you can use these menu options to get just the look you're inter-
ested in. The process for setting both Underline Options and Strikethrough
Options is similar:



Chapter 16: Tricks with Text 2 /5

Figure 16-5:
Examples
of custom

underlines
and strike-
throughs.

|
|
Figure 16-6:
The Under-
line Options
dialog box
(left) and
Strike-
through
Options
dialog box
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Type pop-up
menu pres-
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line types
available for

underlines.
|

1. Highlight the text to which you want to add the custom underline or

strikethrough.

2. Specify the thickness, type, color, and other settings for the line that

makes up the underline or the strikethrough line.

If you choose an underline or strikethrough line type that has gaps —
such as dashed, dotted, or striped lines — you can also choose a gap
color. Figure 16-6 shows the Underline Options dialog box and the nearly
identical Strikethrough Options dialog box.

3. Apply the underline or strikethrough style.

You apply the underline style via the Control panel, Character panel, or
keyboard shortcut (Shift+3+U or Ctrl+Shift+U). Apply the strikethrough
style via the Control panel, Character panel, or keyboard shortcut
(Shift+88+/ or Ctrl+Shift+/).
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Figure 16-7:
Compare
the adjusted
stroke at
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the stroke
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the regular
stroke at
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aligns the
stroke to
the outside).
You can
see this
difference
by compar-
ing the €'s
and r's.

Note that a custom underline or strikethrough created and applied this way
is in effect only for the first text to which an underline or strikethrough is
applied. InDesign reverts to the standard settings the next time you apply
an underline or strikethrough. If you want to use a custom underline or
strikethrough setting repeatedly, you should define the setting as part of a
character style.

Adjusting character strokes

InDesign CS4 lets you adjust the strokes that make up characters, as Figure
16-7 shows. You'll rarely use this design effect. To change the stroke, select
the text you want to adjust and then go to the Stroke panel (Window=>Stroke
[38+F10 or Ctrl+F10]) and adjust any of the following settings: Join, Miter
Limit (if Miter Join is the selected Join), and Align Stroke. Note that for text,
you only get the Center and Outside options for Align Stroke, not Inside.
(Chapter 7 covers strokes in more detail.)
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Converting Text into Shapes

If you want to use the shape of a letter or the combined shapes of several let-
ters as a frame for text or a graphic, you could test your skill with the Pen tool
and create the letter shape(s) yourself. But getting hand-drawn characters to
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look just the way you want them to can take lots of time. A quicker solution is
to use the Create Outlines command to convert text characters into editable
outlines. The Create Outlines command is particularly useful if you want to
hand-tweak the shapes of characters, particularly at display font sizes, or
place text or a graphic within character shapes.

If all you need to do is apply a stroke or fill to characters within text, you don’t
have to convert the characters into outlines. Instead, simply highlight the
characters and use the Stroke panel (Window=>Stroke [88+F10 or Ctrl+F107])
and Swatches panel (Window=>Swatches [F5]) to change their appearance.
This way, you can still edit the text. (See Chapter 7 for more details.)

When you use the Create Outlines command, you have the choice of creating
an inline compound path that replaces the original text or an independent
compound path that’s placed directly on top of the original letters in its own
frame. If you want the text outlines to flow with the surrounding text, create
an inline compound path. If you want to use the outlines elsewhere, create an
independent compound path.

To convert text into outlines:

1. Use the Type tool to highlight the characters you want to convert into
outlines.

Generally, this feature works best with large font sizes.

2. Choose Typer>Create Outlines (Shift+38+0 or Ctrl+Shift+O — that’s the
letter O, not a zero).

If you hold down the Option or Alt key when you choose Create Outlines
(or if you press Shift+Option+8+0 or Ctrl+Alt+Shift+O), a compound
path is created and placed in front of the text. In this case, you can use
either of the selection tools to move the resulting compound path. If you
don’t hold down Option or Alt when you choose Create Outlines, an
inline compound path is created. This object replaces the original text
and flows with the surrounding text.

After you create text outlines, you can modify the paths the same as you
can modify hand-drawn paths. You can also use the transformation tools,
the Control panel (Window=>Control [Option+8+6 or Ctrl+Alt+6]), and the
Transform panel (Window=>Transform) to change the appearance of text
outlines. You can’t, however, edit text after converting it to outlines.

Additionally, you can use the Place command (File=>Place [36+D or Ctrl+D])
or the Paste Into command (Edit=>Paste Into [Option+88+V or Ctrl+Alt+V])
to import text or a graphic into the frames created by converting text to
graphics.

277



278

Part IV: Text Essentials

Making Text Follow a Path

Figure 16-8:
The Type
on a Path

Options dia-

log box lets
you apply

special
effects,
alignment,
and flip to
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ing a path.
|

InDesign lets you have text follow any open or closed path, such as a line or
frame. Simply select the path or shape with the Type on a Path tool, which is
available from the Type tool’s pop-up menu. Now start typing (or paste or
place) your text.

After you enter the text and format it with font, size, color, and so on, you can
apply special effects to it using the Type on a Path Options dialog box,
accessed by choosing Type=>Type on a Path=>Options.

You can also double-click the Type on a Path tool to open the Type on a Path
Options dialog box.

Figure 16-8 shows the dialog box and several examples of its formatting. In
the dialog box:
v Use the Effect pop-up menu to choose a visual effect.

v Use the Align pop-up menu to choose what part of the text is aligned
(baseline, center, ascender, or descender).

v Use the To Path pop-up menu to choose whether to align to the center,
bottom, or top of the path.

v Flip the text by selecting the Flip option.

1 Change the text’s spacing by entering a value in the Spacing field
(positive numbers space out the text, while negative ones contract it).
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Graphics
Essentials

The Sth Wave By Rich Tennant

“Wou know Kids — gou can’t buy them just any
web authoring software.” )



In this part . . .

Fey say a picture is worth a thousand words, and,
well, a lot of them are. Graphics make layouts come
alive, providing a visceral connection that text by itself
just can’t. So it should be no surprise that InDesign has
tons of features that let you work and even create graph-
ics. This part shows you how to work with imported
graphics files, cropping them and making them fit your
layout’s canvas.

You may wonder why this part is so short, given how
many graphical effects InDesign offers. If you haven’t read
Part III, that confusion is understandable: InDesign lets
you apply most of its special effects and controls to any
object, not just those containing graphics, so Part Il
covers that common razzle-dazzle in one place.




Chapter 17
Importing Graphics

In This Chapter

Getting graphics ready for InDesign
Bringing graphics into your layout
Working with layered images

Wlat is a layout without graphics? Boring, that’s what. And that’s why
InDesign lets you import a wide variety of graphics types so that you
have a lot of choices and flexibility in the images you use.

And through the Mac and Windows Clipboards (copy and paste), you can
import file formats — to a limited degree — that aren’t directly supported by

InDesign.
QQ,N\BER The terms graphic and picture are interchangeable, referring to any type of
& graphic — though InDesign consistently uses the word graphic in its user

interface and documentation. An image is a bitmapped graphic, such as that
produced by an image editor, digital camera, or scanner, while an illustration
or drawing is a vector file produced by an illustration program.

Preparing Graphics Files

InDesign offers support for many major formats of graphics files. Some for-
mats are more appropriate than others for certain kinds of tasks. The basic
rules for creating your graphics files are as follows:

v Save line art (drawings) in a format such as EPS, PDF, Adobe Illustrator,
Windows Metafile (WMF), Enhanced Metafile (EMF), or PICT. (These
object-oriented formats are called vector formats. Vector files are com-
posed of instructions on how to draw various shapes.) InDesign works
best with EPS, PDF, and Illustrator files.
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v Save bitmaps (photos and scans) in a format such as TIFF, Adobe
Photoshop, PNG, JPEG, PCX, Windows Bitmap (BMP), GIF, Scitex
Continuous Tone (SCT), or PICT. (These pixel-oriented formats are
called raster formats. Raster files are composed of a series of dots, or
pixels, that make up the image.) InDesign works best with TIFF and
Photoshop files.

InDesign can also import InDesign files as if they were graphics — in a mul-
tipage document, you choose the page you want to import and which layers
you want to display, as you can with PDF files. (Be sure to enable Show
Import Options in the Place dialog box to get these controls.)

Note that you can’t edit InDesign files imported as graphics in your InDesign
layout. (You must update the original file instead.) But you can quickly open
the InDesign file for editing by selecting it and then choosing Edit=>Edit
Original.

Make EPS and TIFF formats your standards because these formats have
become the standard in publishing. If you and your service bureau are work-
ing almost exclusively with Adobe software, you can add the PDF, Illustrator,
and Photoshop formats to this mix. (The Illustrator and PDF formats are vari-
ants of EPS.) If you use transparency in your graphics, it’s best to save them

in Photoshop, Illustrator, or PDF formats, because other formats (particularly
EPS and TIFF) remove much of the transparency layering data that will help an
imagesetter optimally reproduce those transparent files.

The graphics file formats that InDesign imports include (the text in monofont
is the filename extension for the format):

v BMP: The native Windows bitmap format (. bmp, .dib).

v EPS: The Encapsulated PostScript file format favored by professional
publishers (. eps).

v GIF: The Graphics Interchange Format common in Web documents
(.gif).

v JPEG: The Joint Photographers Expert Group compressed bitmap
format often used on the Web (. jpg).

v+~ Illustrator: The native format in Adobe Illustrator 5.5 through CS4. This
file format is similar to EPS (. a1).

v PCX: The PC Paintbrush format that was very popular in DOS programs
and early version of Windows; it’s now been largely supplanted by other
formats (.pcx, .rle).

v PDF: The Portable Document Format that is a variant of EPS and is used
for Web-, network-, and CD-based documents. InDesign CS4 supports
PDF Versions 1.3 through 1.8 (the formats used in Acrobat 4 through 9)
(.pdf).
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v Photoshop: The native format in Adobe Photoshop 5.0 through CS4
(.psd). (Note that InDesign can’t import the Photoshop Raw format.)

v PICT: Short for Picture, the Mac’s native graphics format until Mac OS X
(it can be bitmap or vector) that is little used in professional documents
and has become rare even for inexpensive clip art (.pct).

v PNG: The Portable Network Graphics format introduced more than a
decade ago as a more capable alternative to GIF (.png).

v QuickTime movie: For use in interactive documents, InDesign supports
this Apple-created, cross-platform format (. mov).

v Scitex CT: The continuous-tone bitmap format used on Scitex prepress
systems (.ct).

v TIFF: The Tagged Image File Format that is the bitmap standard for pro-
fessional image editors and publishers (.tif, .tiff).

v Windows Metafile: The format native to Windows but little used in pro-
fessional documents. Since Office 2000, Microsoft applications create
a new version called Enhanced Metafile, also supported by InDesign
(.wmf, .emf).

<P Spot colors (called spot inks in Photoshop) are imported into InDesign when
you place Photoshop, Illustrator, and PDF images into InDesign, as well as
for InDesign documents imported as graphics. They appear in the Swatches
panel, which is covered in Chapter 6.

Importing and Placing Graphics

When you import a graphic into a document, InDesign establishes a link
between the graphics file and the document file and then sends the original
graphics file to the printer when the document is output. (For more details
on managing linked files, see Chapter 9.)

InDesign links to graphics because a graphics file, particularly a high-
resolution scanned graphic, can be very large. If the entire graphics file is
included in an InDesign document when you import it, InDesign documents
would quickly become prohibitively large. Instead, InDesign saves a low-
resolution preview of an imported graphics file with the document, and it’s
this file that you see displayed on-screen. InDesign remembers the location
of the original file and uses this information when printing.

The Place command is the method you typically use to bring graphics into
your InDesign layout. Here’s how to use the Place command to import a
graphic:
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1. Choose File>Place (88+D or Ctrl+D).

If you want to import a graphic into an existing frame, select the target
frame using either of the selection tools (either before you choose
Filem>Place or afterward). If you want InDesign to create a new frame
when you import the graphic, make sure that no object is selected when
you choose Place. Either way, the Place dialog box appears.

You can import a graphic into any kind of frame or shape (including a
curved line created with the Pen tool) except a straight line. Be careful:
If the Type tool is selected when you use the Place command to import
a graphic into a selected text frame, you’ll create an inline graphic at the
text cursor’s location.

. Use the controls in the Place dialog box to locate and select the graph-

ics files you want to import.

You can now select multiple files — graphics and/or text — by
Shift+clicking a range or 88+clicking or Ctrl+clicking multiple files one

by one. InDesign lets you place each file in a separate frame. Just click
once for each file imported or Shift+88+click or Ctrl+Shift+click to have
InDesign place all files on the page in separate frames. The loaded-
graphic icon shows the number of files to be placed, as well as a mini-
preview of each file, as Figure 17-1 shows. You can also navigate through
these previews using the keyboard’s left and right arrow keys so that
you can control more easily which file is placed when.

. Specify the desired import options, if any are applicable.

If you want to display import options that let you control how the
selected graphics file is imported, either enable Show Import Options
and then click Open or hold down the Shift key and double-click the file-
name or Shift+click Open.

If you had selected a frame and want whatever you've selected to
replace the contents of that frame, enable Replace Selected Items.

. Click Open, whether or not you selected any import options, to bring

the graphics into the layout.

Note that if you choose to Show Import Options, the dialog box that
appears — EPS Import Options, Place PDF, Place InDesign Document, or
Image Import Options — depends on what kind of graphic you’re import-
ing. If you select multiple graphics, you’ll get the appropriate dialog box
for each in turn. (These options are covered in the “Specifying Import
Options” section, later in this chapter.) After selecting the desired
options, click OK to place the graphic.

. Based on whether a frame was selected when you initiated the Place

command, you may need to tell InDesign where to put the imported
graphics:
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¢ If an empty frame is selected, the graphic is automatically placed
in the frame. The upper-left corner of the graphic is placed in the
upper-left corner of the frame, and the frame acts as the cropping
shape for the graphic.

If a frame already holding a graphic is selected, InDesign

replaces the existing graphic with the new one if you've selected
the Replace Selected Item check box in the Place dialog box.
Otherwise, InDesign assumes that you want to put the new graphic
in a new frame.

To place the graphic into a new frame, click the loaded-graphic
icon on an empty portion of a page or on the pasteboard. The
point where you click establishes the upper-left corner of the
resulting graphics frame, which is the same size as the imported
graphic and which acts as the graphic’s cropping shape.

To place the graphic in an existing, unselected frame, click in the
frame with the loaded-graphic icon. The upper-left corner of the
graphic is placed in the upper-left corner of the frame, and the
frame acts as a cropping shape.

After you place a graphic, it’s displayed in the frame that contains it, and
the frame is selected. If the Selection tool is selected, the eight handles of its
bounding box are displayed; if the Direct Selection tool is selected, handles
appear only in the corners. At this point, you can modify either the frame or
the graphic within, or you can move on to another task.

If you select multiple graphics files for placement, you can hold Shift+88 or
Ctrl+Shift when dragging the mouse in your document to place an array of the
files, each in its own frame within the area defined when dragging the mouse.
This new feature lets you place multiple images in a contact-sheet arrange-
ment. InDesign CS4 creates as many frames as can fit that array, placing a

file into each frame. Any files not placed remain in the load-graphics icon for
placement elsewhere.

When importing JPEG files, InDesign automatically scales the image to fit in
the page. This feature helps deal with digital-camera graphics that tend to be
very large in dimension and, when imported, end up taking much more than
the width of a page. Although you'll likely still need to scale the image to fit
your layout, you can at least see the whole image before doing so.
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Figure 17-1:
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Specifying Import Options

If you've ever used a graphics application — for example, an image-editing
program like Adobe Photoshop or an illustration program like Adobe
Illustrator or CorelDraw — you’re probably aware that when you save a
graphics file, you have several options that control such things as file format,
image size, color depth, preview quality, and so on. When you save a graphics
file, the settings you specify are determined by the way in which the image
will be used. For example, you can use Photoshop to save a high-resolution
TIFF version of a scanned graphic for use in a slick, four-color annual report
or a low-resolution GIF version of the same graphic for use on the company’s
Web page. Or you can use Illustrator or CorelDraw to create a corporate logo
that you’ll use in various sizes in many of your printed publications.
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If you choose to specify custom import settings when you import a graphics file,
the choices you make depend on the nature of the publication. For example,

if it’s bound for the Web, you don’t need to work with or save graphics using
resolutions that exceed a computer monitor’s 72-dpi resolution. Along the same
lines, if the publication will be printed, the image import settings you specify

for a newspaper that will be printed on newsprint on a SWOP (Specifications

for Web Offset Publications) press are different than those you specify for a
four-color magazine printed on coated paper using a sheet-fed press.

If you select Show Import Options when you place a graphic, the options
displayed in the resulting dialog boxes depend on the file format of the
selected graphic. When you set options for a particular file, the options you
specify remain in effect for that file format until you change them. If you don’t
select the Show Import Options check box when you place a graphic, the
most recent settings for the file format of the selected graphic are used.

Import options for bitmap graphics

InDesign gives you two sets of import options for the following types of
bitmap images: TIFF, GIF, JPEG, Scitex CT, BMP, and PCX. You get three
options for PNG files, and a different set of three for Photoshop files. No
import options are available for PICT or QuickTime movie files.

Figure 17-2 shows three of the four possible panes for bitmap images: The
Image and Color panes are for most bitmap formats; PNG files have a third
pane, PNG Settings, and Photoshop files also have a third pane, Layers,
covered later in this chapter.

If you import a Photoshop, TIFF, or EPS file that contains an embedded
clipping path, the Image pane lets you apply any embedded clipping path
and/or alpha channel to the image in order to mask, or cut out, part of

the image. (Otherwise, these options are grayed out.) Check the Apply
Photoshop Clipping Path option to import the clipping path along with the
image; select an alpha channel from the Alpha Channel pop-up menu to
import the alpha channel along with the image. (Chapter 18 covers clipping
paths in more detail.)

In the Color pane, you can turn on color management for the image and
control how the image is displayed. Check the Enable Color Management
option to enable color management. This option is an expert feature, so ask
your production manager or service bureau whether you should make any
adjustments here.
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Figure 17-2:
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Use the PNG Settings pane — available only if you place a PNG file — to use
the transparency information in a PNG file, assuming that it has a transparent
background. You have two choices for controlling transparency handling:
White Background and File-Defined Background. The former forces the trans-
parent portion to display as white in InDesign; the latter uses whatever back-
ground color is specified in the PNG file itself.

This pane also lets you adjust the gamma value during import — an expert
color-management feature you should leave alone unless told otherwise by a
production manager or service bureau.
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Import options for vector file formats

If you're importing vector files, enabling the Import Options check box
results in one of two dialog boxes appearing, depending on what the vector
file type is. If you import older-version Illustrator or EPS files, you get the EPS
Import Options dialog box; if you import PDF and newer-version Illustrator
files, you get the Place PDF dialog box, which has two panes. (Both dialog
boxes are shown in Figure 17-3.) No import options are available for Windows
Metafile or Enhanced Metafile graphics.

<P lustrator CS through CS4 use PDF as their native file format, even though
the filename extension is . ai. InDesign detects these files as PDF files and
provides the PDF options during import. In earlier versions of lllustrator, the
native format was actually a variant of EPS.
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EPS Import Options dialog box

Use this dialog box to import any clipping paths embedded in images that
are in the EPS file. Check the Apply Photoshop Clipping Path option to enable
this option.

Also, use this pane to control how the EPS file appears on-screen in InDesign.
If you select the Use TIFF or PICT Preview option, InDesign uses the low-
resolution proxy image embedded in the EPS file for display on-screen and
prints the graphic using the embedded high-resolution PostScript instruc-
tions. If you select the Rasterize the PostScript option, InDesign converts the
PostScript file into a bitmap image during import. You rarely have a reason to
rasterize an imported EPS file — it just takes up some of your valuable time.

Place PDF dialog box

When you use the Place command to import a PDF file and you select the
Show Import Options check box, the Place PDF file dialog box, shown in
Figure 17-3, is displayed. It provides several controls for specifying how the
file is imported. The General pane provides the following options:

v In the Pages section, select Previewed Page, All, or Range to determine
which page(s) you want to import. You can change the previewed page
by using the arrow buttons under the preview image at left or entering a
specific page number in the field below the preview image. If you want to
import a range, use commas to separate pages and a hyphen to indicate
range; for example, 3, 5-9, 13 imports pages 3, 5 through 9, and 13.

When you place the PDF in InDesign, you get a separate loaded-graphic
icon for each page. As you place each page, a new loaded-graphic icon
appears for the next page, until no more pages are left to place. You can
tell you're placing multiple pages because the loaded-graphics icon has
a plus sign in it.

v In the Options section, select one of the cropping options from the
Crop To pop-up menu. If you choose Content, the page’s bounding box
or a rectangle that encloses all items, including page marks, is used to
build the graphics frame. Choosing Art places the area defined by the
file’s creator, if any, as placeable artwork. For example, the person who
created the file may have designated a particular graphic as placeable
artwork. Choosing Crop places the area displayed and printed by Adobe
Acrobat. Choosing Trim places the graphic in an area equal to the final,
trimmed piece. Choosing Bleed places the page area plus any specified
bleed area. Choosing Media places an area defined by the paper size
specified for the PDF document, including page marks.

v Also in the Options section, select the Transparent Background check
box if you want the white areas of the PDF page to be transparent.
Uncheck this option if you want to preserve the page’s opaque white
background.
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Import options for placed InDesign files

When you import InDesign files to use as a graphic, you can use exactly the
same options as for PDF files. The Place InDesign Document dialog box is
identical to the Place PDF dialog box covered in the previous section, except
of course, for the dialog box’s name.

Working with Image Layers

<MBER
S

InDesign lets you work with individual layers in some imported graphics.
What that means is that you have more control over what displays because
you can turn on or off individual layers. Of course, to use this capability, the
source graphic must be constructed with multiple layers.

You can work with layers while you're importing graphics, using the Image
Import Options dialog box described in the previous section, or after you've
placed graphics, using the Object Layer Options dialog box covered in the
“working with layers after import” section later in this chapter.

Working with layers during import

Use the Layers pane in the Image Import Options dialog box, the Place PDF,
or Place InDesign Document dialog box to select which layers you want vis-
ible in InDesign. (The Layers pane is available only if you place an Illustrator,
PDF, or Photoshop graphic or InDesign file.)

In the Layers pane, you see a list of image layers. Any that have the eye icon
will display in InDesign, and you can select or deselect layers by clicking the
box to the right of the layer name to make the eye icon appear or disappear.
(You can’t change their order — you’d need to go back to Photoshop or
[llustrator and change the layer order there.) Figure 17-3 shows the Layers
pane for the Place PDF dialog box, but it looks the same in Place InDesign,
and Import Options dialog boxes.

Although you can save an image file in the TIFF format and preserve any
layers, InDesign doesn’t give you the ability to manage which layers you
import from a TIFF file into InDesign.

The When Updating Link pop-up menu also has an option to control how
changes to the file are handled in terms of layer management: If you choose
Use Photoshop’s Layer Visibility or Use Illustrator’s Layer Visibility, InDesign
makes all layers that are visible in Photoshop, InDesign, or Illustrator visible
when you update the link to the graphic from InDesign. If you choose Keep
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Layer Visibility Overrides in the When Updating Link pop-up menu, InDesign
imports only the layers chosen in this dialog box if you later update the
graphic in Photoshop, InDesign, or Illustrator.

Working with layers after import

You may not know what layers you want visible when you import a graphic that
has several layers. That’s okay. Just select the graphic in your layout and choose
Object>Object Layer Options. The Object Layer Options dialog box appears,
with the same options as in the Layers pane described in the previous section.

Using the Object Layer Options dialog box, you can also change any layer
visibility settings you made during import in the Layers pane of the Image
Import Options dialog box.

Using Other Ways to Import Graphics

If you want to specify custom import options for an imported graphics file,
you must use the Place command. However, if you don’t need this level of
control, InDesign offers three other options for importing graphics:

» You can use your computer’s Copy (File>Copy [38+C or Ctrl+C]) and
Paste (File>Paste [38+V or Ctrl+V]) commands to move a graphics file
between two InDesign documents or from a document created with
another program into an InDesign document. If you copy an object in an
InDesign document and then paste it into a different InDesign document,
the copy retains all the attributes of the original, as well as the link to the
original graphics file. Otherwise, a link between the original graphics file
and the InDesign document is not established; the graphic becomes part
of the InDesign document, as though you created it using InDesign tools.

»* You can drag and drop graphics file icons from your computer’s desk-
top into InDesign documents. A link between the original graphics file
and the document is established, just as it would be if you had used the
Place command.

v For lllustrator files, you can drag objects directly from Illustrator into
InDesign. Each object becomes a separate, editable InDesign object, as
though you had created it in InDesign. (And no links are established to
the source file.)

If you use these methods to add a graphic to an InDesign document, some of
the attributes of the original graphic may not survive the trip. The operating
system, the file format, and the capabilities of the originating application all
play roles in determining which attributes are preserved. If you want to be
safe, use the Place command.
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Fitting Graphics and Setting Paths

In This Chapter
Displaying just the desired part of graphics

Fitting graphics into frames and vice versa

Using graphics in odd shapes

Using clipping paths
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A fter you import a graphic into an InDesign document, you can modify
either the graphic or the frame that contains it. The most common
actions you’ll take are cropping, repositioning, and resizing. And if you want
to get really fancy, you might work with clipping paths to create “masks”
around picture portions or even cut the graphic into pieces.

Transformations such as resizing, flipping, rotating, and skewing that you're
likely to apply to graphics use the same tools for graphics as for any InDesign
objects. So I cover all these transformations in one place, in Chapter 8.

In almost every case, you select graphics with the Direct Selection tool to
work with the graphic itself, rather than to the frame. If you use the Selection
tool, the work you do will apply to the frame, as Chapter 11 explains.

Cropping Graphics

Remember, when you import a graphic using the Place command (File=>Place
[38+D or Ctrl+D]) or by dragging a graphics file into a document window

(see Chapter 17), the graphic is contained in a graphics frame — either the
frame that was selected when you placed the graphic or the frame that was
automatically created if a frame wasn’t selected. The upper-left corner of an
imported graphic is automatically placed in the upper-left corner of its frame.
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Cropping is a fancy term for deciding what part of the picture to show by
altering the dimensions of the frame holding the graphic. The easiest way to
crop a graphic is to resize the frame that contains it using the Selection or
Position tool. To discover how to resize the frame, go to Chapter 8. Note that
resizing the frame does not resize the graphic.

The other way to crop a graphic is to leave its frame alone and instead move
the graphic within the frame. (The advantage of moving the image within the
frame is that you don’t have to move the frame from its desired position in
the layout.) To do so, you have two options:

v Click on a graphic with the Direct Selection tool and then drag the
graphic within its frame to reveal and conceal different parts of the
graphic. For example, you can crop the top and left edges of a graphic
by dragging the graphic above and to the left of its original position (in
the upper-left corner of the frame).

v Use the X+ and Y+ fields in the Control panel and Transform panel,
which let you determine precisely how much to move the graphic
horizontally and vertically within its frame by entering specific values.
Positive values move the graphic to the right or down relative to the
frame, while negative values move it to the left or up relative to the
frame. This method is more precise than using the mouse.

If you want to mask out (hide) portions of an imported graphic, you have the
option of using an irregular shape as the frame, a graphic’s built-in clipping
path (if it has one), or a clipping path you generated in InDesign, as covered
in the last section of this chapter.

Figuring out the Fitting Commands

If you've placed a graphic in a frame that’s either larger or smaller than

the graphic, you can use the Fitting options (available by choosing
ObjectoFitting or by using the appropriate iconic buttons in the Control
panel) to scale the graphic to fit the frame proportionately or disproportion-
ately or to scale the frame to fit the graphic. Another option lets you center
the graphic in the frame. These options are very handy, and a lot easier than
trying to resize a graphic or frame to fit using the mouse or the Control panel.

Keep in mind that the fitting commands for graphics are available only if
you’ve used the Selection or Position tool to select a graphic’s frame. Here’s
a description of each of the six options:
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v Fit Content to Frame: To scale a graphic to fill the selected frame,
choose ObjectFitting=>Fit Content to Frame (Option+8+E or
Ctrl+Alt+E). If the frame is larger than the graphic, the graphic is
enlarged; if the frame is smaller, the graphic is reduced. If the graphic
and the frame have different proportions, the graphic’s proportions are
changed so that the image completely fills the frame — this Fit Content
to Frame option can distort the graphic’s appearance.

v+~ Fit Frame to Content: To resize a frame so that it wraps snugly around a
graphic, choose Fit Frame to Content (Option+3+C or Ctrl+Alt+C). The
frame is enlarged or reduced depending on the size of the graphic, and
the frame’s proportions are changed to match the proportions of the
graphic.

1 Center Content: To center a graphic in its frame, choose Center Content
(Shift+8+E or Ctrl+Shift+E). Neither the frame nor the graphic is scaled
when you center a graphic.

v+ Fit Content Proportionally: To scale a graphic to fit in the selected
frame while maintaining the graphic’s current proportions, choose
Object=>Fitting=>Fit Content Proportionally (Option+Shift+3+E or
Ctrl+Alt+Shift+E). If the frame is larger than the graphic, the graphic is
enlarged; if the frame is smaller, the graphic is reduced. If the graphic
and the frame have different proportions, a portion of the frame back-
ground shows above and below or to the left and right of the graphic. If
you want, you can drag frame edges to make the frame shorter or
narrower and eliminate any portions of the background that are visible.

v~ Fill Frame Proportionally: To resize a graphic so that it fills its
frame on all sides, choose Object=>Fitting=>Fill Frame Proportionally
(Option+Shift+8+C or Ctrl+Alt+Shift+C). Note that this option may crop
out part of the image, so no gap appears between any part of the image
and the frame. (By contrast, the Fit Frame to Content Proportionally
option can result in extra space at the bottom and/or right sides of a
graphic so that the entire graphic is visible.)

v Frame Fitting Options: To control the default fitting for newly placed
graphics, use the Frame Fitting Options dialog box, shown in Figure 18-1.
Here, you can set the amount of crop, choose the control point for the
imported graphic (see Chapter 1), and automatically apply your choice
of the Fit Content to Frame, Fit Content Proportionally, and Fill Frame
Proportionally options.

For frames with strokes, the Fitting options align the outer edge of a graphic
with the center of the stroke. A stroke obscures a strip along the graphic’s
edge that’s half the width of the stroke. The wider the stroke, the more of the
graphic that gets covered up.

Chapter 18: Fitting Graphics and Setting Paths 295
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You can also use the frame-fitting iconic buttons in the Control panel, shown
in Figure 18-2. But note that these buttons may not display in your Control
panel; by default, InDesign shows them only if your monitor is set to a reso-
lution whose width is 1,280 or more pixels. You can make room for them

at smaller resolutions by customizing the Control panel display: Choose
Customize from the panel’s flyout menu and then deselect some of the Object

controls to make room.
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Working with Graphics
in Irreqular Shapes

Although most graphics you use will be placed in rectangular frames,
InDesign does give you other choices:

» You can select any type of frame — oval or polygonal, not just
rectangular — to place or copy your graphic into.

» You can draw your own shape using the Pencil or Pen tool and then
place or copy your graphic into it. When you create the free-form shape,
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make sure that the default color for the Pen tool is set to None so that
the shape you create is transparent. Otherwise, the colored area in the
shape will obscure the graphic behind it.

The Pen tool lets you create one shape at a time. The Compound Paths
command lets you combine multiple shapes to create more complex
objects. For example, you can place a small circle on top of a larger
circle and then use the Compound Paths command to create a doughnut-
shaped object. (This expert feature isn’t covered in this book.)

If you copy the graphic into a frame or shape, you must use the Paste
Into command (Edit=>Paste Into [Option+8+V or Ctrl+Alt+V]) to place
the copied graphic inside the selected shape, rather than on top of it.

»* You can use a clipping path that was defined in the graphic itself when it
was created or a clipping path that was created in InDesign.

So what is a clipping path, anyway? A clipping path is used to mask certain
parts of a graphic and reveal other parts; it’s basically an invisible outline
placed in the graphic that InDesign can then work with. For example, if you
want to create a silhouette around a single person in a crowd, open the file
in an image-editing program, such as Photoshop, and then create and save
a clipping path that isolates the shape of the person. (You can also erase
everything except the person you want to silhouette; this approach can be
time-consuming, and if you want to reveal other parts of the graphic later,
you'’re out of luck.) TIFF, Photoshop EPS, and Photoshop-native (.psd) files
can have embedded clipping paths.

Regardless of the method you use to clip an imported graphic, you can
modify a clipping path by moving, adding, deleting, and changing the direc-
tion of anchor points and by moving direction lines.

You can convert a clipping path — whether imported or created in InDesign —
to a frame by choosing Convert Clipping Path to Frame for a selected object
using the contextual menu (Control+click or right-click the object).

See the Photoshop For Dummies series (Wiley Publishing) for more on
creating clipping paths in Photoshop.

Using a graphic’s own clipping path

In an ideal world, any graphics that you want to have fit in an irregular shape
will come with their own clipping paths. But many don’t, so you need to
create your own in InDesign, as described in the next section.

But for those graphics that do have their own clipping paths, you would first
be sure to import the clipping path when you place the graphic and then use
InDesign’s Text Wrap panel to access that clipping path.



298 Part V: Graphics Essentials

The steps are easy:

1. Be sure to select the Show Import Options check box in the Place
dialog box (File>Place [38+D or Ctrl+D]) when you import the graphic
and select the Apply Photoshop Clipping Path option in the Image
Import Options dialog box.

2. Open the Text Wrap panel (Window=>Text Wrap [Option+3+W or
Ctrl+Alt+W]).

3. Select the graphic.

4. Click the Wrap Around Object Shape iconic button (the third one from
the left) at the top of the Text Wrap panel.

5. If you want, adjust the space between the surrounding text and the
obstructing shape by typing values in the Top Offset field.

6. Now select the clipping source from the Type pop-up menu in the
Contour Options section of the Text Wrap panel.

Choose from two relevant options:

¢ Alpha Channel uses the image’s alpha channel, if any, to create
a wrapping boundary. (An alpha channel is another type of clip-
ping path and is also created in the source program such as
Photoshop.)

* Photoshop Path uses the image’s clipping path, if any, to create
a wrapping boundary. Use the Path pop-up menu to select which
path to use, if your image has more than one embedded clipping
path.

See Chapter 11 for the basics of text wraps.

Creating a clipping path in InDesign

If you import a graphic that doesn’t have a clipping path, you have two sets
of options for creating one.

The easiest is to use the Text Wrap panel as described in the previous
section but to instead choose one of the following options from the Type
pop-up menu:

v Detect Edges tries to determine the graphic’s outside boundary by
ignoring white space. You'd use this option for bitmapped images that
have a transparent or white background.

v Same as Clipping uses the clipping path for the graphic created in
InDesign. You’d use this approach when the desired clipping path can’t
be created through the Detect Edges option. (I cover this method of
clipping-path creation shortly.)
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You can further modify the clipping path by selecting the graphic with the
Direct Selection tool. The text-wrap boundary appears as a blue line. You can
make the boundary easier to select by setting offsets in the Text Wrap pane,
which moves the boundary away from the frame edge.

A slightly more difficult way to create a clipping path — but one that gives
you more control — is to use the Clipping Path command to generate one
automatically:

1. Select the graphic to which you want to add a clipping path.

Use the Direct Selection tool so that you can see the clipping path within
the frame as you work.

2. Choose Object~>Clipping Path=>Options (Option+Shift+38+K or
Ctrl+Alt+Shift+K).

The Clipping Path dialog box appears, as shown in Figure 18-3.

3. To have InDesign detect the likely boundary of the image, as opposed
to a white or other light background, choose Detect Edges from the
Type pop-up menu.

You can use the other options to select Alpha Channel or Photoshop
Path as the clipping path for graphics that have one or more of these.
(InDesign can only use one alpha channel or Photoshop path as the clip-
ping path, so use the Path pop-up menu to choose the one you want.)

4. Type a value in the Threshold field or click and drag the field’s slider
to specify the value below which pixels will be placed outside the clip-
ping path shape (that is, pixels that will become transparent).

Pixels darker than the Threshold value remain visible and thus are
inside the clipping path shape. The lowest possible Threshold value (0)
makes only white pixels transparent. As the value gets higher, less of the
graphic remains visible. The lightest areas are removed first, then mid-
tones, and so on. (Select the Preview option to see the results of your
changes without closing the dialog box.)
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5. Type a value in the Tolerance field.

This value determines how closely InDesign looks at variations in adja-
cent pixels when building a clipping path. Higher values produce a
simpler, smoother path than lower values. Lower values create a more
complicated, more exact path with more anchor points.

6. If you want to enlarge or reduce the size of the clipping path pro-
duced by the Threshold and Tolerance values, type a value in the
Inset Frame field.

Negative values enlarge the path; positive values shrink it. (The Inset
Frame value is also applied to the path’s bounding box.)

7. Select the Invert option to switch the transparent and visible areas of
the clipping path produced by the Threshold and Tolerance values.

8. If you want to include light areas in the perimeter shape InDesign
generates based on the Threshold and Tolerance values, select the
Include Inside Edges option.

For example, if you have a graphic of a doughnut and you want to make
the hole transparent (as well as the area around the outside of the
doughnut), click Include Inside Edges. If you don’t click Include Inside
Edges, InDesign builds a single shape (in the case of a doughnut, just the
outside circle). The portion of the graphic in the shape remains visible;
the rest of the graphic becomes transparent.

9. Select the Restrict to Frame option if you want InDesign to gener-
ate a clipping path from just the portion of the graphic visible in
the graphic frame, as opposed to the entire graphic (such as if you
cropped the graphic).

10. Select the Use High Resolution Image option if you want InDesign to
use the high-resolution information in the original file instead of using
the low-resolution proxy image.

Even though using the high-resolution image takes longer, the resulting
clipping path is more precise than it would be if you didn’t check Use
High Resolution Image.

11. When you’ve finished specifying clipping path settings, click OK to
close the dialog box and apply the settings to the selected graphic.

If you use the Clipping Path command to generate a clipping path for a graphic
that has a built-in clipping path, the one that InDesign generates replaces the
built-in path.
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Figure 18-4 shows a graphic before and after a clipping path was applied to it
using the Clipping Path command. At left is a graphic of coastal France with
a graphic of a glider superimposed. At right is the same set of graphics, but
with a clipping path applied to the glider so that the outside area is masked
out, making it transparent.

Figure 18-4:
A super-
imposed

image
before (left)
and after
applying

a clipping
path (right).
|

SMBER
)

& The Clipping Path command works very well for images that have a white or

light background but no clipping path. It’s less useful for graphics with back-
grounds that contain a broad range of intermingling values.

You can remove a clipping path by choosing None as the Type in the
Clipping Path dialog box. You can also select a different path — Detect Edges,
Alpha Channel, Photoshop Path, or User-Modified Path — than was selected
previously if you decide to change the current clipping path.

InDesign lets you convert a clipping path into a frame so that you get the
exact shape as your clipping path to use as a container or silhouette in your
layout. Select the clipping path with the Direct Selection tool and choose
Object=>Clipping Path=>Convert Clipping Path to Frame. It’s as easy as that!
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“Ooo—-look ! Sgt. Rodriguez has the felon’s
head floating in a teacup!”



In this part . . .

M icrosoft Word, move over. It used to be that a word
processor did all the business-y stuff like foot-
notes, tables, tables of contents, indexes, and mail-
merges. Not anymore. Over the years, like a slow-moving
movie monster nonetheless catching up with the terror-
ized teens, more and more of these business functions
have found their way into InDesign. This version has even
more such features, such as conditional text.

This part shows you how to suit up your documents. But
relax — you’ll still be a designer at heart!




Chapter 19

Working with Tabs and Tables

In This Chapter
Working with tabs
Setting up and adjusting tables

Formatting tables directly and with styles

Turning tabbed text to tables, and vice versa

perhaps the most common business-oriented formatting done in InDesign
involves tabular material, whether financial tables or simple compara-
tive feature lists. InDesign provides two methods for creating tabular mate-
rial: old-fashioned tabs and more sophisticated tables. Although you can
create tables with tabs, you have less control over the formatting and thus
can create just basic tables when you use tabs. On the other hand, for simple
tables, using tabs is often the faster method. So don’t feel you should never
use tabs — but do be sure that when you mix methods that you don’t let
visual consistency suffer as a result.

Tabs and tables in InDesign work somewhat like the same functions in
Microsoft Word, so if you're familiar with Word’s tabs and tables, you’ll have
a quick adjustment to InDesign’s, at least for the basic capabilities.

Setting Tabs

SMBER

To set tabs in InDesign, you use the Tabs panel, which floats above your text

so that you can keep it open until you're finished experimenting with tabs. To
open the Tabs panel, choose Typer>Tabs (Shift+3+T or Ctrl+Shift+T). Figure 19-1
shows the Tabs panel along with a simple table created using one tab stop.

You can also set up tabs in the Tabs pane of the New Paragraph Styles and
Paragraph Style Options dialog boxes, so tabs are consistently applied to all
paragraphs. Chapter 13 covers styles in more detail.
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Figure 19-1:
The Tabs
panel, its

flyout menu,

and a table
created
using tab
settings.
|

3
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Four buttons — Left, Center, Right, and Align On — on the Tabs panel let

you control how the text aligns with the tab you’re creating. The Align On
option is usually used for decimal tabs, which means that a period in the text
aligns on the tab stop. But you can align on any character, not just periods —
simply specify the align-on character in the Align On field. (If you enter noth-
ing in the Align On field, InDesign assumes that you want to align to periods.)
If the Align On field isn’t visible in the Tabs panel, just widen the panel by
dragging one of its sides so that the field displays.

The X: field of the Tabs panel lets you specify a position for a new tab stop.
You can type a value in this field in 0.01-point increments and then press
Shift+Enter or Shift+Return to create a tab. InDesign positions tabs relative to
the left edge of the text frame or column.

Rather than typing values in the X: field, you can position tabs by clicking at
the desired location on the ruler at the bottom of the Tabs panel. You can also
drag tab stops within the ruler to change their position. And you can reposi-
tion left and right indents and indent hangs using the arrow sliders on the tab
ruler. (The arrow sliders have the same effects as changing indents using the
Paragraph panel or Paragraph Styles panel, as explained in Chapter 14.)

To have the Tabs panel “snap” to your text frame so that you can see exactly
where the tab stops will be, click the Position Panel Above Text Frame iconic
button (the magnet icon).

If you need a tab flush with the right margin — for example, to position a
dingbat at the end of the story — press Shift+Tab. You don’t need to use the
Tabs panel.

InDesign lets you specify up to eight characters, including special characters,
that will repeat to fill any white space. These repeating characters are called
leaders. When you set a leader for a tab stop, the leaders actually fill any
space prior to that tab stop (between the previous text and the tab location).
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To spread out the leader characters, type spaces between the characters you
enter. Don’t enter spaces before and after a single character, though, as that
will result in two spaces between the characters when the pattern repeats
(unless that’s the look you’re going for).

In addition to setting tabs in the Tabs panel, InDesign provides four
additional options through its flyout menu: Clear All, Delete Tab, Repeat Tab,
and Reset Indents.

v The Clear All command deletes any tabs you've created, and any text
positioned with tabs reverts to the position of the default tab stops.
(You can delete an individual tab stop by dragging its icon off the ruler.)

v The Delete Tab command deletes the currently selected tab. (Just click
it in the tab ruler.)

You can also delete tabs by dragging them off the tab ruler using the
mouse.

+* The Repeat Tab command lets you create a string of tabs across the
ruler that are all the same distance apart. When you select a tab on
the ruler and choose this command, InDesign measures the distance
between the selected tab and the previous tab (or, if it’s the first tab on
the ruler, the distance between the selected tab and the left indent/text
inset). The program then uses this distance to place new tabs, with the
same alignment, all the way across the ruler. InDesign repeats tabs only
to the right of the selected tab, but it inserts tabs between other tab
stops.

+” The Reset Indents command removes any changes to the left indent,
right indent, or indent hang settings made in the Tabs panel using the
arrow sliders, and reverts to the indents defined in the paragraph style
currently applied to the text.

Setting Up Tables
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@&
&

You can create tables using tabs, but the more complex the table, the more
work that requires. So make your life easier and use InDesign’s table editor,
which lets you specify almost any attribute imaginable in a table through the
Table panel and the Table menu.

InDesign lets you import tables from Microsoft Word, RTF, and Microsoft
Excel files, including some of their cell formatting. Likewise, you can convert
their tables to tabbed text by using the options in the Import Options dialog
box that is accessible when you place a file through the Place dialog box
(File>Place [38+D or Ctrl+D]), as covered in Chapter 11.
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& InDesign CS4’s tables now support three features that previous versions
neglected:

» You can now insert notes into tables (an expert feature not covered in
this book).

v Changes you make in tables display as tracked changes in the compan-
ion InCopy software (also an expert feature not covered in this book

»* You can now edit tables’ contents in the Story Editor view (see Chapter 12).
To create a table in InDesign:

1. Create or select a text frame with the Type tool and then choose
Table~Insert Table (Option+Shift+38+T or Ctrl+Alt+Shift+T).

If you select an existing text frame, the table is inserted at the cursor’s
location in the existing text.

The Insert Table dialog box appears.

2. Type the number of body rows and columns and the number of
header and footer rows.

Header and footer rows repeat on each page for tables that go across
multiple pages.

3. Click OK to have InDesign create the basic table.

The table is set as wide as the text frame. The depth is based on the
number of rows, with each row defaulting to the height that will hold
12-point text.

You can also apply a table style to the new table by selecting one from the
Table Style pop-up menu. I cover how to create these styles in the “Using
table and cell styles” section, later in this chapter.

With the basic table in place, you now format it using the Table panel and
the Table menu. In both, you can increase or decrease the number of rows
and columns, set the row and column height, set the text’s vertical alignment
within selected cells (top, middle, bottom, and justified), choose one of four
text-rotation angles, and set the text margin within a cell separately for the
top, bottom, left, and right. Note that all the Table panel’s options affect only
the currently selected cells, except for the Number of Rows and Number of
Columns fields. Figure 19-2 shows the Table panel and its flyout menu, as well
as an example table created using these tools.



\\3

Figure 19-2:
The Table
panel and

its flyout
menu, with
an example
table.
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If you have a smallish monitor, set at 1024 by 768 pixels — the norm for a
17-inch display — the Table, Table Styles, and Cell Styles panels may be
shoved to the bottom of the panel dock, and, when they’re selected, the only
thing you see is their panel tab and flyout menu icon. You have a few choices:
Shorten other panel groups in the dock to make room for them, remove other

panel groups to make room for them, or drag them out of the dock and make
them floating.

® InDesign File Edit Layout Type Object Table View Window Help ar [ © O @& <7 4 = 1221PM = Q
000 | g 100% v | F- - [EE - | GALEN'S DEFAULT v | [ 2 J
E‘ Times E R B (1T ™ T | Ayt B)| TR R B T Foe B A (mow ] 4=
9 | lsemiooic B A @ T T oF | mefEr M| a2 Fow V=3 | [enoismusa 0|
JEB -11.c 05 X history.ndd @ 100% X B _ ) D _ ) _
k Ak 0] 30 L ‘24 L |l! ' ‘l! ‘ﬁ \ ‘ﬂ ‘6 \ |l! ‘1& |24 L 30 ‘ ﬂD -
R
& g Table Options > Fp ks
. Cell Options >
FT] [Mac 0S X Version Cat Released . s
AR Insert b 100 Cheetah (code name only) 2001
5 B Delete 100 Puma (code name only) 2001 B swarces
= 102 Taguar 2002 L
= 103 Panther 2003 == STROKE
Q, ] 104 Tiger 2005
BNIE Split Cell Horizontally 10.5 Leopard 207 5] OBlECT STY.
1z | Split Cell Vertically 1027 Snow Leopard 2009
.}(‘ Convert Rows > Jx eFFECTS
| e S TEXT WRAP
al
| = PARAGRAP...
Edit Header Cl
7 I L 0 PARACRAPH
2 R I L]

You set cell text’s horizontal alignment using the paragraph formatting con-
trols (see Chapter 14). You can apply character formatting to cell text (see
Chapter 15). You can also apply tabs within cells using the Tabs panel covered
in the “Setting Tabs” section of this chapter.

To add items to a table, you can type text in any cell, paste text or graphics
into a cell, or place text or graphics into a cell by choosing Filec>Place (88+D
or Ctrl+D). Note that any tabbed text pasted into a cell retains the tabs, with
all the text pasted into the same cell — InDesign doesn’t look at those tabs
and assume that you wanted the tabbed text converted into multiple cells.

To insert a tab character into a table cell, don’t press Tab — that just
advances you to the next cell. Instead, choose Type=Insert Special
Character=>Other=>Tab.
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Adjusting tables

InDesign lets you add and delete rows and columns, as well as split and join
cells using the Insert, Delete, Merge, and Split commands in the Table menu
and in the Table panel’s flyout menu. You can also select rows, columns, and
entire tables using the Table menu. Several shortcuts, shown in Table 19-1,
speed things along if you're a keyboard-oriented person.

These commands work intuitively, so [ won’t bore you with detailed expla-
nations here. For example, to delete a row, select it or a cell within it using
the Type tool and then choose Table>Deleter>Row. To split a cell vertically,
select the cell and choose Tabler>Split Cell Vertically. You get the idea.

Table 19-1 Table-Editing Shortcuts

Command Macintosh Shortcut Windows
Shortcut

Select cell 8+/ Ctrl+/

Select row 8+3 Ctrl+3

Select column Option+86+3 Ctrl+Alt+3

Select table Option+38+A Ctri+Alt+A

Insert column Option+88+9 Ctrl+Alt+9

Insert row 8+9 Ctrl+9

Delete column Shift+Delete Shift+Backspace

Delete row 38+Delete Ctrl+Backspace

Formatting tables

For more sophisticated table attributes, use the Table Options dialog box
and its five panes. (Choose Tabler>Table Options and then the desired pane
from the submenu. To go straight to the Table Setup pane, you can also just
press Option+Shift+88+B or Ctrl+Alt+Shift+B.) You see the Table Setup pane,
shown in Figure 19-3. If you want to go straight to one of the four other panes,
you can do so by choosing the desired pane in the submenu after choosing
Tabler>Table Options.

When formatting tables, take advantage of the Preview option in most dialog
boxes to see the effects of your changes before committing to them.



Figure 19-3:
The Table
Setup pane
of the Table
Options
dialog box.
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Table Options
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If you select more than one cell — meaning the entire cell, not just some of its
contents — the Control panel’s options change to display many of the con-
trols available in the Table panel, as well as some cell-oriented controls, such
as setting cell boundary line weights and line types.

Here are some of the basics to keep in mind:

v The Table Setup pane lets you change the number of rows and columns,
as well as footer rows and columns. You also can specify the table
border, color, line type, and even tint. Use the Table Spacing options to
have space automatically added before and after a table that is in the
same text frame as other text.

v The Row Strokes pane lets you decide how often rows have an alter-
nating pattern of strokes applied to them. For example, you may want
every third row to have a thicker stroke than the first and second rows,
because each set of three rows is related to each other and the third
row marks the end of that set. You choose how many rows you want
the special stroke to skip before being applied in the Alternating Pattern
pop-up menu and then use the rest of the controls to choose the stroke
weight, color, type, and so on.

v The Column Strokes pane works just like the Row Strokes pane, except it
lets you alternate the strokes across columns rather than rows.
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Figure 19-4:
The Fills
pane of

the Table
Options

v The Fills pane (shown in Figure 19-4) works like the Row Strokes pane

and Column Strokes pane, except that it applies a fill to the cells in the
specified series of rows or columns. The reason that there is just one
pane for fills but two for strokes is that you can’t have both row fills
and column fills automatically applied to the same table — that would
usually make for a hard-to-read checkerboard. Of course, you can use
horizontal fills to accentuate rows and use strokes on columns to help
keep them visually separate.

v The Headers and Footers pane lets you change the number of header

and footer rows — just like the Table Setup pane — but it also lets you
control how often the header and/or footer rows repeat: Every Text
Column, Once Per Frame, or Once Per Page.
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InDesign also provides formatting controls over cells, using the Cell Options
dialog box. (Choose Table=>Cell Options and then one of the four desired
panes: Text, Strokes and Fills, Rows and Columns, and Diagonal Lines. You
can go straight to the Text pane by pressing Option+3+B or Ctrl+Alt+B.)
After you selected the cells you want to format, use the various panes as

desired:

v The Text pane works very much like the General pane of the Text Frame

Options dialog box (see Chapter 14). Here, you set how far text is inset
from the cell boundaries, how text is vertically aligned within the cell,
and where the text baseline begins within the cell. Unique to cells, you
can also specify whether the cell grows to fit the text automatically (by
unchecking Clip Contents to Cell) and the degree of text rotation (0, 90,
180, and 270 degrees).
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Figure 19-5:
The Strokes
and Fills
pane of the
Cell Options
dialog box.
|
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v The Strokes and Fills pane, shown in Figure 19-5, lets you set the stroke
and fill for selected cells. You can select which cell boundaries to apply
a stroke to, by selecting the sides from the preview image at the top of
the pane and then choosing the desired options. You can also set the
desired fill color and tint.

Cell Options
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v+ The Rows and Columns pane lets you set the row height, including its
maximum for rows that are allowed to expand automatically as speci-
fied in the Text pane, as well as the column width. You also can specify
which rows must be kept together and if certain rows should start at a
new page, frame, or column.

You can also adjust column and row heights by dragging on the row and
column boundaries with the mouse.

v The Diagonal Lines pane lets you place three types of diagonal lines within
cells — upper left to lower right, lower right to upper left, or both — and
then specify the stroke weight, type, color, and tint. You can also choose
whether the diagonal lines overprint the cell contents or vice versa. To
remove a diagonal line, just click the No Diagonal Lines iconic button.

Using table and cell styles

To make it easy to apply and update table formatting across a document,
InDesign lets you create and apply table and cell styles. They work like para-
graph, character, and object styles, taking the table formatting features cov-
ered in the previous section and bringing them together into the New Table
Style and New Cell Style dialog boxes.

313
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Figure 19-6:
The General
pane of the
New Table
Styles

dialog box.
|

To work with table styles, open the Table Styles panel by choosing
Window>Type & Tables=>Table Styles. To work with cell styles, open the Cell
Styles panel by choosing Windoww>Type & Tablest>Cell Styles. Choose New
Table Style or New Cell Style from the appropriate panel’s flyout menu and
then use the various panes to specify the desired formatting. The panes, and
their options, are the same as described in the previous section, “Formatting
tables.” Figure 19-6 shows the New Table Style dialog box’s General pane.

Whether creating a new table style or a new cell style, the easiest method is to
format an existing table or cell the way you want it, select it, and then create

a new table or cell style — InDesign picks up the existing formatting for the
new style. Otherwise, you have to specify everything in the New Table Style or
New Cell Style dialog box, where it’s harder to see the effects of your settings.
(Even if you enable the Preview option, the dialog boxes are fairly large and
tend to obscure most of your document.)

New Table Style
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Shortcut:

Style Settings:
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ws: 1 + Alternating Fill Next Rows: 1 + Aftarnating Raw

— Cell Styles
Header Rows: [[Same as Body R...|#] Left Column: ([Same as Body R...| 5]
Footer Rows: '@ Right Column: ‘_m

Body Rows: [[None] | %]

[ Preview ( Cancel ) oK )

Keep in mind a few notes about creating table and cell styles — in the
General pane of the New Table Style and New Cell Style dialog boxes — that
you should know before getting too far into them:

v You give each style its own name. Choose names that will make sense a
week or a month later so that you know what they’re meant to be used for!

» You can base a new table style on an existing one, so changes to the
parent style are automatically reflected in the children styles based on it.

» You can assign a keyboard shortcut to styles you use frequently.
When creating table styles, you can also have the table style automatically

apply the cell styles of your choosing to the following table elements: header
rows, footer rows, body rows, the leftmost column, and the rightmost column.

When creating cell styles, you can choose a paragraph style to be automati-
cally applied to text in cells using the style.
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To apply styles to selected tables or cells, just choose the desired style from
the Table Style or Cell Style panel. To override existing formatting, use the
options indicated for paragraph and character styles described in Chapter 13.

Modifying and managing
table and cell styles

To modifying styles, just double-click the style name in the Table Styles or
Cell Styles panel to open the Table Style Options or Cell Style Options dialog
box, which is identical to the New Table Styles or New Cell Styles dialog box
explained in the previous section. Make your changes, click OK, and your
styles and all tables and cells using them are instantly updated!

InDesign also lets you manage your styles, such as creating groups of styles
to keep them better organized, and bringing in styles from other documents.
Because these features work the same for paragraph and character styles as
well, I cover them in Chapter 13.

Converting Tabs to Tables (and Back)

Often, you'll have a table done using tabs — whether imported from a word
processor or originally created in InDesign with tabs — that you want to con-
vert to a real InDesign table. All you have to do is select the tabbed text you
want to convert using the Type tool and choose Tablex>Convert Text to Table.

In the Convert Text to Table dialog box, you can choose a Column Separator
(Tab, Comma, Paragraph, or a text string you type in the field) or a Row
Separator (same options). Although most textual data uses tabs to separate
columns and paragraphs to separate rows, you may encounter other data
that uses something else. For example, spreadsheets and databases often
save data so that commas, rather than tabs, separate columns. That’s why
InDesign lets you choose the separator characters before conversion.

During the conversion, InDesign formats the table using the standard set-
tings, using the current text formatting and the default cell insets and
stroke types. You can then adjust the table using the tools covered in the
“Formatting tables” section, earlier in this chapter. Note that the conversion
treats all rows as body rows.

You can also convert a table to text by selecting multiple cells or an entire
table and choosing Tablew>Convert Table to Text. InDesign presents the same
options as it does in the Convert Text to Table dialog box so that you can
determine how the converted data appears.
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Chapter 20

Working with Footnotes,
Indexes, and TOCs

In This Chapter

Keeping track of details with footnotes
Adding indexes

Generating tables of contents

M any business documents — books, reports, white papers, and so
on — use features traditionally associated with academic book pub-

lishing: footnotes to cite sources, indexes to provide a map to specific con-
tent’s location in the document, and tables of contents (TOCs) to provide an
overview of the document’s structure and contents.

When you’re working on any type of document — a report, a magazine, a
textbook — you can easily spend more time manually creating tables of con-
tents, keeping footnotes updates, and laboriously managing indexes than you
spend designing the publication. InDesign helps reduce this labor while also
ensuring that your footnotes, indexes, and tables of content stay automati-
cally updated as your document is revised.

<MBER .
You can extend the power of these tools to book-length projects composed of

multiple InDesign documents (see Chapter 22), creating consistent indexing

and tables of contents in one fell swoop.

Adding Footnotes

Many documents, including academic and technical documents, use foot-
notes. InDesign lets you add footnotes to your document with very little fuss.
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Figure 20-1:
Inserting

a footnote
(shown
below the
table).
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You can import footnotes from Microsoft Word files (see Chapter 11), or you
can add footnotes directly in InDesign. With the text-insertion cursor in your
text where you want the footnote marker to appear, choose TyperInsert
Footnote to add a footnote to the bottom of the column that contains the
footnote marker, as shown in Figure 20-1. You need to manually enter the text
that will go with each numbered footnote, but InDesign updates the footnote
numbering as you add and delete footnotes.

You can’t insert footnotes into tables. But you can simulate footnotes by
adding a superscripted footnote character in the table text and typing your
footnote text below the table — note this “footnote” isn’t linked to the text,
doesn’t renumber automatically as a real footnote would, and can’t be format-
ted with InDesign’s footnote formatting controls.
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You can control much of the appearance of footnotes by choosing
Type=>Document Footnote Options to open the Footnote Options dialog box,
shown in Figure 20-2.

The Numbering and Formatting pane controls the formatting of the footnote text
and footnote character in the current InDesign document. The Layout pane con-
trols the placement of the footnote relative to the rest of the document.
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Among the features you should note in the Numbering and Formatting pane are

v Choose the numbering style — such as 1, 2, 3, 4 ... or I, i, iii, iv ... — via
the Style pop-up menu.

v Control whether the footnote numbers start anew (such as at the begin-
ning of a section) or continue from the previous number via the Start At
field.

v Control whether numbering automatically resets every page, spread, or
section via the Restart Numbering Every pop-up menu.

v Add a prefix and/or suffix to your footnote numbers via the Prefix and
Suffix fields. Note the unnamed pop-up menus that let you add special
characters such as a thin space or bracket.

v Use the Position and Character Style options in the Footnote Reference
Number in Text subsection to determine how the footnote characters
appear in text.

v~ Similarly, use the Paragraph Style and Separator options in the Footnote
Formatting subsection to determine how the footnote text appears.
(Note that any Separator options will display after any Suffix options
chosen.)

Among the features to note in the Layout pane are

v Set the preferred spacing for the footnote text in the Spacing Options
section.

Chapter 20: Working with Footnotes, Indexes, and TOCs 3 ’ 9
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v Convert Word’s endnotes (which appear at the end of a story) to
InDesign footnotes (which appear in the column or page that the foot-

note reference occurs in) by checking the Place End of Story Footnotes
at Bottom of Text option.

v Control whether footnotes can break across columns via the Allow Split
Footnotes option. Enabling this option can improve the layout when you
have long footnotes that otherwise eat up a column of text.

v Control the ruling line above footnotes using the Rule Above options.
They work like the paragraph rules (see Chapter 14).

To change these settings for future documents, open the dialog box while no
document is open and set your new defaults.

Creating Indexes

When trying to locate information in a book, nothing is as wonderful as a
good index. Once upon a time, book indexing was a labor-intensive process
involving piles of index cards. InDesign makes indexing much easier, while
still allowing you to make key decisions about how the index is formatted.

But be warned: Indexing is complicated business and is, by and large, an
expert feature. I cover just the basics here.

Choosing an indexing style
Before you begin indexing your document, ask yourself the following questions:

v+ Do you want to initial-cap all levels of all entries, or do you just want
sentence case?

v+ Should index headings appear in boldface?
v What type of punctuation will you use in your index?
v Will you capitalize secondary entries in the index?

v Should the index be nested or run-in style? (A nested index is an
indented list, with each entry on its own line. A run-in index puts all
related entries in one paragraph, separated by semicolons.)

After you make these decisions, making a small dummy index is a good idea.
From the dummy, create a master page for index pages, paragraph styles

for index headings (the letters A, B, C, and so on), paragraph styles for each
level of the index (including indents as appropriate), and character styles for
any special formatting you want on page numbers or cross-reference text.
InDesign doesn’t do any of these tasks for you.
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Figure 20-3:
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Index panel
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flyout menu.
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Inside the Index panel

When you want to index a chapter or document, open the Index panel by
choosing Window=>Type & Tables=>Index (Shift+F8). Use this panel to add
words to the index in up to four indent levels, edit or delete index entries, or
create cross-references. The Index panel is shown in Figure 20-3.
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Two radio buttons appear at the top of the Index panel: Reference and
Topic. You use Reference mode to add and edit entries from selected text.
(Although it’s a well-intentioned feature meant to help standardize index
entries, the Topic mode’s use isn’t intuitive, and most indexers simply ignore
it and add entries manually from selected text or type phrases into the Index
panel in Reference mode. You should ignore it, too.)

Select the Book check box if you're creating an index for multiple chapters in a
book (see Chapter 22). You must have a book open for this option to be avail-
able. If you have a book open and don’t select the Book check box, the index is
saved with the current document and not opened when you open other chap-
ters of the book.

Adding index items via the Index panel

To add entries to the index, be sure the Type tool is active and then choose
New Page Reference from the Index panel’s flyout menu (38+7 or Ctrl+7) to
get the dialog box shown in Figure 20-3.

The shortcut for New Page Reference has changed in InDesign CS4 to 8+7
or Ctrl+7. The previous shortcut, 8+U or Ctrl+U, now toggles smart guides,
which Chapter 10 covers.
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& option is called New Cross-Reference instead, letting you add a cross-
reference entry to the index. The resulting New Cross-Reference dialog box
is identical to the New Page Reference dialog box, except the various options
default to ones appropriate for a cross-reference.

Here’s how the controls work:

v If you selected text first in your document, the text is entered automati-
cally into Topic Level 1. Otherwise, type the text that you want to add
to the index. In Figure 20-3, you can see that I typed Colors. The text is
added to the Topic list and to the list of index entries.

»* You can enter text that controls how the entry is sorted in the Sort By
column. For example, if the selected text you're indexing is The X-Files,
but you want it sorted as if it were X-Files, The (so it appears with the X
entries in the index), enter X-Files, The in the Sorted By column. This
technique is also handy for names, such as indexing Barack Obama as
Obama, Barack by entering Obama, Barack in the Sorted By column.

v If you want a more complex index, you may want to use some or all of
the four possible entry levels. You may want an index entry to appear
under a higher-level topic. For example, you may want Border Collies
to appear in the index under Herding Dogs, in which case you’d enter
Herding Dogs in the Topic Level 1 field and Border Collies in the Topic
Level 2 field. Or you may want Collies in the Topic Level 1 field and then
Border in the Topic Level 2 field, because you plan on listing the differ-
ent varieties of collies under one Level 1 index entry, with the varieties
listed within that entry as Level 2 subentries. In Figure 20-3, I entered
subtractive in the Topic Level 2 field.

v Use the Type pop-up menu to determine the page entries for the index
entry. For example, if you select To End of Section, the page numbers for
the selected text in the index cover the range from the index entry to the
end of the section it’s in.

v To add just the selected text as an index entry, click Add. (If no text is
selected, the text is added to the Topic list, but no index entry appears
for it.) To add all occurrences of the text in the book, click Add All.

v To change previously defined index entries, select an entry and then
choose Page Reference Options in the Index panel’s flyout menu.

v~ At the bottom of the New Page Reference dialog box is a list of letters as
well as the entry Symbols (where entries that begin with numbers and
other nonletter characters will be grouped in the index). You can scroll
through this list of headings to see what is already in the index under
each letter. Although you may think clicking a letter would force the
current index entry to appear in that letter’s section of the index, it
doesn’t.
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To quickly add a word or text selection to an index, highlight the text and
press 38+7 or Ctrl+7 to add the text to the New Page Reference dialog box. To
index a word without opening that dialog box, just press Option+Shift+88+[

or Ctrl+Alt+Shift+[. This shortcut adds the text to the index using the index’s
default settings. (You can always edit them later.) And to enter an index entry
such as Barack Obama as a proper name (last name, first name, or Obama,
Barack in this example), use the shortcut Option+Shift+88+] or Ctrl+Alt+Shift+].

Polishing and generating the index

The Index panel’s flyout menu has several options useful for generating and
fine-tuning an index:

+* Duplicate Topic lets you duplicate a topic entry so that you can use the
settings from one entry without having to re-enter those settings in a
new entry.

v+ Delete Topic removes a topic (and any associated entries) from the index.
v+~ Import Topics lets you import topic lists from other InDesign documents.

” Go to Selected Marker causes InDesign to jump to the text that contains
the selected index entry in the Index panel.

v Topic Options lets you edit the Level and Sort By settings for topic
entries; these settings affect all index entries that use them.

v~ Capitalize lets you standardize the capitalization of topic entries — you
can choose Selected Topic, Selected Topic and All Subtopics, All Level 1
Topics, and All Topics.

v+~ Update Preview updates the index entries in the Index panel to reflect
page-number changes, new occurrences of index text occurrences, and
deleted occurrences of indexed text.

” Generate Index creates the index via the dialog box shown in Figure
20-4. In this dialog box, you specify the following: a title for the index,
the paragraph style for that title, whether a selected index is replaced
with the new one, whether an entire book is indexed, whether text on
hidden layers is indexed, whether the index is nested or run-in, whether
empty index headings and sections are included, what paragraph
styles are applied to each level of index entry, what character styles
are applied to different portions of index entries, and which characters
will be used as separators within index entries. (Click the More Options
button to see the nested/run-in and later options.)

After you generate an index, you get the standard InDesign loaded-text
icon (the paragraph icon); click an existing text frame into which you
want to flow the index, or click anywhere else in a document to have
InDesign create the text frame for you and flow the index text into it.
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Figure 20-4:
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Creating Tables of Contents

A table of contents (TOC) is useful in a long document because it helps read-
ers locate information quickly. A TOC is simply a list of paragraphs that are
formatted with the same styles. This dependence on styles means that if
you want to use the table of contents feature, you have to use paragraph
styles. Not only do styles guarantee consistent formatting, but they also tell
InDesign what text you want to include in your TOC.

After you create a book (or even a single document), InDesign can build a
table of contents by scanning pages for the paragraph styles you specify. For
example, if you create a book, you might use paragraph styles named Chapter
Title, Section, and Subsection. Using the table of contents feature, InDesign
can generate a table of contents that includes all three levels.

TOC styles manage the text that you want in a table of contents, the order in
which it appears, how page numbers are added, and how the various TOC
elements are formatted. To create a TOC style, choose Layout>Table of
Contents Styles.

In the Table of Contents Styles dialog box, click New to create a new TOC
style. You can also edit an existing TOC style via the Edit button, delete one
via the Delete button, and import one from another InDesign document via
the Load button.

Here’s how to create a TOC style after clicking the New button:

1. Enter a name for the TOC style in the TOC Style field (shown in
Figure 20-5).

The default is TOC Style 1.
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Figure 20-5:
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. In the Title field, enter a heading for the TOC.
This text appears in your table of contents.

If you don’t want a title, leave the Title field blank, but note that you still
get an empty paragraph at the top of your TOC for this title. You can
always delete that paragraph.

. Use the Style pop-up menu to choose the paragraph style that this title
will have.

. In the Styles in Table of Contents section, click a paragraph style that
you want to appear in your TOC from the Other Styles list at right.

For example, you might click Chapter Title.
. Click Add to add it to the Include Paragraph Styles list at left.

Select a style from the Include Paragraph Styles section and click
Remove to remove any paragraph styles you don’t want to be used in
the TOC.

. Repeat Steps 4 and 5 until you have added all the paragraph styles
that you want to include in the TOC.

. Use the Entry Style pop-up menu to select a TOC level and then choose
the paragraph formatting for that style.

If the Entry Style, Page Number, and other options don’t display, click
the More Options button to see them.

e Use the Page Number pop-up menu to determine how page num-
bers are handled: After Entry, Before Entry, and No Page Number.
If you want the page numbers to have a character style applied,
choose that style from the Style pop-up menu to the right of the
Page Number pop-up menu.
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¢ Use the Between Entry and Number field and pop-up menu to
choose what appears between the TOC text and the page number.
You can enter any characters you want; use the pop-up menu to
select special characters such as bullets and tabs. In most cases,
you should select a tab; the paragraph style selected earlier for
the TOC entry includes leader information, such as having a string
of periods between the text and the number. You can also apply
a character style to the characters between the text and the page
numbers via the Style pop-up menu at right.

¢ To sort entries at this level alphabetically, such as for a list of
products in a brochure, select the Sort Entries in Alphabetical
Order check box.

¢ To change the level of the current TOC entry, use the Level pop-up
menu. If you change the level of entries, InDesign correctly sorts
them when it creates the TOC, even if the levels seem out of order
in the Include Paragraph Styles list.

In the Options section of the dialog box, choose the appropri-

ate options. Check Create PDF Bookmarks if you're exporting the
document to PDF format and want the PDF TOC file to have book-
marks (a clickable set of TOC links). Check Run-in if you want all
entries at the same level to be in one paragraph. (This option isn’t
common for TOCs, but it’s used in indexes and lists of figures.)
Check Replace Existing Table of Contents if you want InDesign to
automatically replace an existing TOC if the TOC style is changed.
Check Include Text on Hidden Layers if you want text on hidden
layers to be included in the TOC. Check Include Book Documents
if you have a book open and want InDesign to generate a TOC
based on all chapters in that book. (InDesign shows the current
open book’s name.) Finally, control whether numbers are included
in the table of contents for numbered paragraphs using the new
Numbered Paragraphs pop-up menu.

8. Continue this process for each paragraph style whose text should be
in the TOC.

Note that the order in which you add these styles determines the initial
levels: The first paragraph style added is level 1; the second is level 2,
and so on. But you can change the order by changing the Level setting,
as described in Step 7.

You can also reorder the paragraph styles by dragging them up and down
in the list — but this doesn’t change their levels and thus won’t change
the order in which they are sorted in the TOC. All it does is change the
order you see them in the dialog box.
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To make changes to a TOC style, go to the Edit Table of Contents Style dialog
box. Choose Layout~>Table of Contents Styles, select the TOC style to edit,
and click Edit.

With a TOC style in place and your document properly formatted with the
paragraph styles that the TOC style will look for when generating a TOC,
you're ready to have InDesign create the actual TOC for you.

To generate a TOC, choose Layoutr>Table of Contents. You get a dialog box
that is identical to the New Table of Contents Style dialog box, shown in
Figure 20-5. In this dialog box, you can make changes to the TOC style set-
tings. (If you want to save those TOC style changes, be sure to click the Save
Style button.) Then click OK to have InDesign generate the TOC. You might
also get a dialog box asking whether you want to include items in overset text
(text that didn’t fit in your document after you placed it) in your TOC. It may
take a minute or two for the program to generate the TOC. (See Chapter 12
for more details on overset text.)

Be sure you allow enough space (a single text frame, a series of linked text
frames, or one or more empty pages) for the TOC before generating a final
TOC because if you end up adding or deleting pages based on the TOC length,
the TOC will display the old page numbers. To update page numbering after
flowing a TOC, simply rebuild the TOC by selecting the text frame holding the
TOC and then choosing Layout=>Update Table of Contents.

If you select a text frame, InDesign places the TOC text in it when you gener-
ate the TOC. If you don’t select a text frame, you see the familiar loaded-text
icon (the paragraph pointer) that you see when you place a text file. Click

a text frame to insert the TOC text in that frame or click in an empty part of
your document to create a text frame in which the TOC text will flow.

The feature that creates a TOC is actually a list generator, and you can use

it to create other kinds of lists. Basically, anything that is tagged with a para-
graph style can be used to create a list. For example, if your figure captions all
use their own paragraph style (called Caption Title in this example), you can
generate a list of figures by creating a TOC style that includes just the Caption
Title paragraph style. An InDesign document can have more than one TOC so
that you can include multiple lists in your document.
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A key area of improvement over the years in InDesign is the increased use
of automated text. From the very beginning, InDesign offered automatic
page numbers so that your folios and cross-references would reflect the cur-
rent pages as your layout changed. Later versions enhanced this capability
with section markers, which let you create variable names in folios for your
section titles. Still later came the ability to use data files and merge their con-
tents into a layout to customize your output, similar to how word processors
let you customize labels with their mail-merge feature. The newest version of
InDesign adds to this mix a new option: variable text, which gives you more
flexibility in where and how you can have InDesign update text automatically
throughout a document based on your specifications.

Altogether, these features have helped InDesign stake significant ground
in reducing the labor and time of manual processes, such as searching and
replacing for text that changes predictably throughout the document.

Another type of text variable is the cross-reference, which can insert the page
number or other text for you (such as See page 227 or Learn how color works
in the “All about Color” chapter). InDesign CS4 now supports such automated
cross-references. It also retains those cross-references imported from Word
files. Because InDesign’s cross-references capability uses the hyperlinks func-
tionality, I cover this type of automated text in Chapter 24.
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Automating Page Numbers
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You'll often want page references in text — the current page number in a
folio, for example, or the target page number for a “continued on” reference.
You can type a page number manually on each page of a multipage docu-
ment, but that can get old fast. If you're working on a multipage document,
you should be using master pages (see Chapters 4 and 5). And if you're using
master pages, you should handle page numbers on document pages by
placing page-number characters on their master pages.

If you want to add the current page number to a page, you can choose
Typer>Insert Special Character~>Markers=>Current Page Number
(Option+Shift+8+N or Ctrl+Shift+Alt+N) whenever the Type tool is active and
the text-insertion cursor is flashing. If you move the page or the text frame,
the page-number character is automatically updated to reflect the new page
number.

To create “continued on” and “continued from” lines, choose Typer>Insert
Special Characterm>Markerst>Next Page Number to have the next

page’s number inserted in your text, or choose Typer>Insert Special
Characterz>Markers>Previous Page Number to have the previous page’s
number inserted. (There are no shortcuts for these complex menu
sequences.) That next or previous page will be the next or previous page in
the story, not the next page in the document.

One flaw in InDesign’s continued-line approach is that the text frames must
be linked for InDesign to know what the next and previous pages are. Thus,
you're likely to place your continued lines in the middle of your text. But if the
text reflows, so do the continued lines. Here’s a way to avoid that problem:
Create separate text frames for your continued-on and continued-from text
frames. Now link just those two frames, not the story text. This way, the story
text can reflow as needed without affecting your continued lines.

Using Section Markers

InDesign offers another marker called the section marker, which lets you
insert specific text into your document and update it by just changing the
marker text.

The section marker is defined as part of a section start (see Chapter 4), and
it’s meant to be used in folios to put in the section name or chapter name.
But you can use it anywhere you want — and for anything you want, not just
for section or chapter labels.
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To define a section marker (you can have only one per section, of course),
open the Pages panel (Window=>Pages, [8+F12 or Ctrl+F12]) and choose
Numbering & Section Options from the panel’s flyout menu. In the resulting
dialog box, type a text string in the Section Marker field. Then click OK.

To use the marker, have the text insertion point active in whatever
text frame you want to insert it and then choose Type=Insert Special
Character->Markers=>Section Marker. That’s it!

Using Text Variables

With InDesign text variables, you can define an unlimited number of text vari-
ables that InDesign will happily update across your documents whenever you
change them or your layout does.

To create a text variable, choose Typer>Text Variablese>Define. You see get
the Text Variables dialog box, shown in Figure 21-1. It lists existing text vari-
ables — including the eight predefined ones in InDesign: Chapter Number,
Creation Date, File Name, Last Page Number, Modification Date, Output Date,
and the two types of Running Header. Any of them that you create are added
to this list.

@"&N\BER . . .
& The source of the number used in the Chapter Number text variable is
something you define as part of a book. Chapter 22 explains books and how
to set the chapter number.

To create a new text variable, click New. The New Text Variable dialog box
appears, as shown in Figure 21-1. Give the variable a name in the Name field,
and choose the type of variable you want from the Type pop-up menu. Your
choices are the seven predefined types plus Custom Text, which lets you put
in any text of your choosing. (This means you can create more than one vari-
able for, say, File Name or Modification Date. You might do this because you
want them formatted differently in different usage scenarios.)

The options for formatting the chosen type of variable varies based on the
type of variable it is. Three options are available for more than one type of
text variable:

v Text Before and Text After: These two fields — available for all Type
pop-up menu options except Custom Text — let you add any text you
want before or after the variable. For example, you might enter the word
Chapter in the Text Before field for a Chapter Number variable. Note
that both fields have an unnamed pop-up menu to their right from which
you can select a variety of common symbols and spaces.
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v Style: This pop-up menu lets you select the style to apply in the Chapter
Number, Running Header (Character Style), and Running Header
(Paragraph Style) text variables.

v~ Date Format: This field and its associated pop-up menu lets you choose
the desired date and time formats for the Creation Date, Modification
Date, and Output Date text variables. Examples include MM/dd/yy to get
a date like 05/08/62 and MMMM d, yyyy to get a date like August 15, 1962.
Don’t worry about memorizing codes — just pick the desired options
from the pop-up menu instead.

Several other variables have unique options:

v Custom Text: This variable has the fewest options. Just enter the
desired text, including choosing special characters, such as spaces and
dashes, from the unnamed pop-up menu to the right of the Text field.
That’s the only field to adjust for this text variable.

1 Last Page Number: In addition to the Text Before, Text After, and Style
formatting controls, this type includes one unique control: the Scope
pop-up menu. Here, you choose between Section and Document to tell
InDesign what you mean by last page number: the section’s last page or
the document’s.

v~ File Name: In addition to Text Before and Text After formatting
controls, this type has two unique check boxes — Include Entire Folder
Path and Include File Extension — to tell InDesign exactly how much of
the filename to include. If both are unchecked, InDesign includes just
the core filename, such as Jun 07 TOC. Checking the Include Entire
Folder Path adds the file location before the core filename, such as
MacintoshHD:Projects:Jun 07 TOCor C:\Projects\Jun 07
TOC. Checking the Include File Extension appends the filename
extension, such as June 07 TOC.indd.

+ Running Header: The formatting options for these two types —
Paragraph Style and Character Style — are the most complex, as shown
in Figure 21-1. The two Running Header menu options have two options
not available to other Type pop-up menu options:

¢ Use: This option determines which text to use: First on Page uses
the first text on the page that has the specific style applied, while
Last on Page uses the last text on the page that has the specific
style applied.

e Options: Here, you can control whether the punctuation of the
source text is retained in the running header (check Delete End
Punctuation to remove it) and whether the running header over-
rides the text of the source text’s capitalization (check Change
Case and then choose the appropriate capitalization option: Upper
Case, Lower Case, Title Case, or Sentence Case).
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é‘,\“ Title case means that the first letter of each word is capitalized, while Sentence
Case means that only the first letter of the first word in each sentence is
capitalized.
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Editing and managing text variables

Editing text variables is very much like creating them: Just select the variable
to change and click Edit in the Text Variables dialog box. You get the Edit
Text Variable dialog box, which is identical (except for its name) to the New
Text Variable dialog box covered in the previous section.

You can also import text variables from other documents by clicking Load in
the Text Variables dialog box and then choosing the document to import the
variables from. After choosing a document, you get the Load Text Variables
dialog box, where you can select which variables are imported and handle
name conflicts.

To get rid of a text variable, select it from the list in the Text Variables dialog
box and click Delete.

To convert a text variable in your document to the actual text, highlight it
and either choose Type=>Text Variablesm>Convert Variable to Text or, if you
happen to be in the Text Variables dialog box, click Convert to Text.
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Inserting text variables

Inserting text variables in your document uses the same essential process
as inserting a special character such as a section marker, except you use the
Text Variables menu option: Choose Type=>Text Variables=>Insert Variable
and then choose the desired variable from the submenu. If you happen to be
in the Text Variables dialog box, click Insert.

Using Conditional Text

CATURE
&*

Ng,

Have you ever worked on a document that has variations, forcing you to
create separate copies that you must then ensure have any changes applied
to all copies? Perhaps you used the layers feature (see Chapter 5) to restrict
the unique content to its own layer so that you could make visible each ver-
sion’s layer when you wanted to print that specific version. But you realized
this technique doesn’t work well for text inside paragraphs, because changes
to the text mean whatever you placed in layers won’t be at the right location
if your text changes move the text’s locations in the “main” layer.

InDesign CS4 offers a new way to have multiple versions of text in a
document that gets around these issues: conditional text. You can think of
conditional text as sort of a layer that works within text, so if the text moves,
the conditional “layers” do, too.

For example, say you have a publication that is distributed in Canada,
Ireland, and the U.K., where pricing is different (dollars, euros, and pounds,
respectively). You can’t really duplicate the main “dollars” layer and dupli-
cate all the text in it for the “euros” and “pounds” layers. Why? The reason

is that if you changed the text in the main layer that includes the dollar
prices, the pounds and euros layers would have the old text and need to be
changed also (a management nightmare). You may think that you can avoid
this problem by having a main layer for the text, and then separate layers for
the dollar, euro, and pound pricing. Unless your pricing wouldn’t move ever
(such as if it’s in an independent table), if the main text is edited and reflows,
those text frames would get out of place — an even worse situation.

With conditional text, you instead have just one layer for your text, and where
the text may need to change (such as for pricing), you insert conditional text.
Then, if you want to display the price in dollars, you enable the dollars condi-
tion, and the right text appears, no matter how the text is flowing. When you
want to display the price in euros, you enable the euros condition. Ditto for
pounds.
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Here’s how it works:

1. In your text, enter each of the text variations you want.

For example, as you can see in Figure 21-2, if you have three prices,
enter all three in sequence as if they were one piece of text. Apply any
formatting desired. Don’t worry for the moment that you don’t want
them all to display or print at the same time.
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2. Open the Conditional Text panel (Window=>Type & Tables~>
Conditional Text) and choose New Condition from the flyout menu.

3. In the New Conditions dialog box, give the condition a name and
determine how you want it to be highlighted (using the Appearance,

Method, and Color pop-up menus) in the layout, as shown in
Figure 21-2.

Your highlighting options are Underline and Highlight (which puts a
colored background behind conditional text), either of which you can
apply a color to. If you choose Underline, you can select a line type in
the Appearance pop-up menu. (It’s unavailable if you choose Highlight.)
This highlighting doesn’t print; it’s just lets you know in InDesign where
and what conditions are applied to text.

You can modify conditions later by choosing Condition Options from the
Conditional Text panel’s flyout menu. The dialog box is identical to the
New Conditions dialog box.
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4. In the text, highlight a piece of text (such as the euro price) and then
click the related condition to apply that condition to the selected text.

A check mark appears to the immediate left of the active condition for
whatever text is selected or in which your text cursor is active. In your
layout, the text also has whatever line type in whatever color you speci-
fied in the New Conditions dialog box so that you have a visual guide as
to what conditions are applied to what text.

Add as many conditions using Steps 3 and 4 as you need. The figure’s
example has three: one for each price. (Note that the [Unconditional]
condition is just your regular text, which always displays and prints.)

5. Now, click the squares in the Conditional Text panels to the far left of
the various conditions.

If the square shows an eye, any text tagged with that condition is vis-
ible. If the square is empty, any text tagged with that condition isn’t
displayed. By controlling which conditions are active (eye icons), you
determine what displays and prints in your document. (This process is
exactly how you make layers visible and invisible in the Layers panel, as
Chapter 5 explains.) Figure 21-3 shows the same text as in Figure 21-2,
but with just the [Unconditional] and the euros text visible.

Pretty easy, isn’t it? Just turn off and on the text you want to display and
print by hiding and showing the appropriate conditions.
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Chapter 22

Publishing Books

In This Chapter

Creating books
Tackling chapters
Printing your masterpieces

Numbering pages and sections

N ot only is InDesign useful for short documents like ads and newslet-
ters, but it also can comfortably handle longer, multichapter docu-
ments, such as books and manuals. The most common and easiest way to
build longer documents, especially those created by more than one author
or contributor, is to create multiple InDesign documents and then assemble
them into a larger book.

InDesign’s book feature lets you
v See who is working on each chapter (that is, on each document in the
book) and when.
v Update styles and swatches across documents for consistency.
v Update page numbers across multiple documents.

v Create a unified table of contents and a unified index for multiple
documents, using the techniques in Chapter 20.

v Easily print or create a PDF file from all the chapters of a book.

Creating a Book

In InDesign, a book is a specific type of file that you create to track chapters
or multiple documents that make up the book. Using InDesign’s book panel,
you can add, open and edit, rearrange, and print chapters of the book. The
book panel is nice for workgroups because multiple users can open the same
book and access different chapters; it also works well if you are a single user
working on a multichapter book.
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To create a new book, choose FilewoNewr>Book. The New Book dialog box
lets you specify a location for the book and give it a name. Click Save to
create and open the book.

You can open an existing book by using the Filem>Open command (88+0

or Ctrl+O). When viewing folder and disk contents via the Mac’s Finder or
Windows’s Explorer, you can also double-click a book’s icon or filename to
open it.

ATURE If multiple books are open, they now each appear in a separate tabbed
pane in a floating panel. If you want them to appear in individual panels,
as in previous versions of InDesign, you can just drag their tab out of the
panel, and InDesign will create a new panel for each dragged-out pane. To
always have InDesign open or create books in separate panels, disable the
Open Documents as Tabs option in the Interface pane of the Preferences
dialog box (choose InDesign=>Preferences=Interface [+K] on the Mac or
Edit=>Preferences=Interface [Ctrl+K] in Windows). Note that changing this
option also means that any documents created or opened also appear in
separate windows.

To close a book’s pane and any book documents that are in it, click the
book’s tab to select it and choose Close Book from the flyout menu. If a book
displays alone in a panel, simply click its close box. And if you click the close
box in a panel with multiple book panes, all the panes are closed along with
the panel.

Working with Book Chapters

A new book pane (or panel) is empty — you need to add chapter docu-
ments to fill it up. To do so, click the Add Document iconic button — the +
icon on the bottom right of the book panel (see Figure 22-1) — or use the
Add Document option in the book panel’s flyout menu. Use the Add Chapter
dialog box to locate and select the first chapter you want to add. Click the
Add button to make this the first chapter in the book. Repeat this process
to add to the book all the chapters you have ready. (You can also add more
chapters later.)

MBER Chapters are listed in the book pane in the order in which you add them. You
may want to rearrange them to match the actual order of the book project —
especially if you're numbering the book automatically from start to finish, since
InDesign will number them based on their order in the book pane. To rear-
range the relative position of chapters, just click and drag chapter names up or
down within the pane to put them in the desired order.



Chapter 22: Publishing Books 339

Style source  Active pane  Locked (in use)

Inactive pane Modified | Open

Book pane | Available Missing
73688 BOOK'| + NIK TUTORIAL Add Document...
3 [l nik cnos 2-31 Replace Document...
[ [ v choz 32-45 Remove Document
[ riccnoa 46-117
W r‘ Nikk Cho4 118-181 F—o Save Book
— Save Book As...
T i ik chos 182-225 (F—— 0 Book
Il m Mik ChO6 226-235 ig———— bt
— Preflight Book...
Package Selected Documents For Print...
Figure 22-1: Export Book for Digital Editions...
T B ® $ F o ExportSelected Documents to PDF...
A book | Print Selected Documents...
panel and ) :
its flyout Synchronize Styles and Swatches Racumen Informistion..
menu, as Save Book Synchronize Options...
well as Update All Cross-References
_the_ status Print Book Update Numbering >
indicators Book Page Numbering Options...
for Add Document Document Numbering Opticons...
“ " Automatic Document Conversion
chapter Remove Document
documents.
Small Panel Rows
|

To work on a chapter in a book, first open the book and then double-click the
chapter name in the book’s pane. The chapter opens in InDesign just like any
other InDesign document. For a chapter to be opened, it must be marked as
Available, as explained in the next section. When you finish editing a chapter,
save and close it as usual.

You can replace and delete chapters using the controls in the book panel’s
flyout menu for whatever book pane is selected:

v Replace an existing chapter with another document by selecting the
chapter in the book panel and choosing Replace Document from the
flyout menu. Navigate to a new document, select it, and click the Open
button. InDesign replaces the selected chapter with the new document.

v Delete chapters from a book by choosing Remove Document from the
flyout menu or by clicking the Remove Document iconic button (the -
icon) at the bottom of the panel.
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InDesign offers three other menu options in the flyout menu that come in
handy for managing a book: You can save a book by choosing Save Book, save
it to a new name by choosing Save Book As, and close a book by choosing
Close Book. (With the latter option, any changes to the book are not saved,
although a warning box gives you the chance to save any unsaved changes.)

Finding out about chapter status

When you use the book panel in a workgroup, it provides helpful status
reports about each chapter. (Figure 22-1 shows the icons used to indicate a
chapter’s status.) The statuses are

v Available: You can open, edit, or print the chapter. Only one user at a
time can open a chapter.

v Open: You have the chapter open and can edit it or print it. Nobody else
can open the chapter at this time.

v+ In Use: Another user has the chapter open. In this case, you can’t edit or
open the chapter.

v Modified: The chapter has been changed since the last time you opened
the book panel. Simply click the chapter name to update it.

v Missing: The chapter’s file has been moved since it was added to the
book. Double-click the chapter name to open the Find File dialog box
and locate it.

The Document Information menu option in the book panel’s flyout menu pro-
vides useful information. When you select a chapter and choose this option,
you can see the file’s modification date, location, and page range, and you
can replace the chapter with a different document.

Taking advantage of style sources

The first chapter you add to the book is, by default, the style source. You can
tell which chapter is the style source by the icon to the left of the chapter
name. In most cases, you want the styles, swatches, and so on to remain the
same from chapter to chapter. The style source in an InDesign book defines
the styles and swatches that are common to all the chapters in the book.

If you decide to make a different chapter the style source, all you need to do
is (in the book pane) click in the column to the left of that chapter’s filename.
The icon indicating the style source moves to that chapter. But note that
indicating a style source isn’t the end of the story; to ensure formatting con-
sistency, you need to synchronize all the book’s chapters to that source, as
explained in the next section.
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Synchronizing formatting

When you use the Synchronize feature, InDesign makes sure that the para-
graph styles, character styles, table styles, cell styles, object styles, trap pre-
sets, TOC styles, master pages, and color swatches in each chapter in the book
match those in the style source. This synchronization enforces consistency,
but also means you have to make sure that you choose the correct chapter as
the standard, because its settings will override the other chapters’ settings.

The book panel includes a Synchronize iconic button (the two facing arrows),
as well as a Synchronize Selected Documents or Synchronize Book menu item
in the flyout menu. Before you synchronize, make sure that you’'re happy
with the styles, master pages, and other settings you’ve established in the
style source and then follow these steps to synchronize:

1. Be sure that all chapters are available for editing.

2. Choose the style source by clicking the box to the left of the source
chapter so that the style-source icon appears.

3. Choose Synchronize Options from the book panel’s flyout menu, which
opens the — wait for it now! — Synchronize Options dialog box.

Make sure that every type of item you want to synchronize — Object Styles,
TOC Style, Character Styles, Paragraph Styles, Table Styles, Cell Styles,
Master Pages, Numbered Lists, Text Variables, Conditional Text Settings,
Cross-Reference Formats, Trap Presets, and Swatches — is checked.

InDesign CS4 adds the ability to synchronize the new cross-references
and conditional text attributes.

4. Select the chapters you want to synchronize and either click the
Synchronize button or choose Synchronize Selected Documents from
the flyout menu.

If no chapters are selected, InDesign assumes that you want to synchro-
nize all chapters; the menu option Synchronize Book appears in the
flyout menu rather than Synchronize Selected Documents in that case.

5. Compare the styles (character, paragraph, object, table, cell, and
TOC), swatches (color, tint, and gradient), text variables, numbered
lists, master pages, and trap presets in the style source to those in
each chapter.

If anything is different, the information in each chapter is updated to
match the style source. If someone changed the typeface in a style sheet
in a chapter, it reverts to the typeface specified in the style source. If
anything is missing from a chapter — for example, if you just added a
swatch to the style source but not to other chapters — that information
is added to each chapter. If a chapter uses its own style or swatch not
defined in the source style, that unique style or swatch is not changed or
removed — these local additions are retained.

341
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By using the synchronize feature, you give each chapter the same basic set
of styles and swatches as the style source, although you can still add more of
these specifications to individual chapters. Keep in mind that synchronizing
doesn’t repair the formatting fiascos that can happen when multiple users
work on the same book. Be sure everyone who needs to know the standards
for the design has access, ahead of time, to that information.

Printing Chapters and Books

A\

Using the book panel, you can print any chapters with the status of Available
or Open. Here’s how:

1. To print the entire book, make sure that no chapters are selected.

To print a contiguous range of chapters, Shift+click the first and last
chapters that you want to print. To print noncontiguous chapters,
& +click or Ctrl+click the chapters to select them.

2. Click the Print Book iconic button or choose Print Book or Print
Selected Documents in the book panel’s flyout menu.

The option you see depends on whether chapters are selected in the

book panel. Either way, the standard InDesign Print dialog box opens.
Note that the option to choose all pages or a range of pages is grayed
out — you must print all chapters in the selected chapters.

3. Make any adjustments in the Print dialog box.
4. Click Print to print the chapters.

You can also output a book to PDF by using the Export Book to PDF or Export
Selected Documents to PDF menu items in the flyout menu. Similar Digital
Editions options let you export to the eBook format. These menu items

work like their equivalent Print versions. (Chapter 24 covers PDF and eBook
options.) And you can collect all the chapters, images, and fonts into one
place using the Package Book for Print or Package Selected Documents for
Print options (see Chapter 23).

Working with Sections in Chapters

Section-based page numbering is fairly common in book-length documents
because it lets you, for example, restart page numbering in each new sec-
tion, such as 4.1, 4.2, and so on. Creating a section start is also the only way
to start a document on a left-facing page. InDesign gives you two choices for
numbering book pages: You can let the book panel number pages consecu-
tively from one chapter to the next, or you can add sections of page numbers,
which carry through the book until you start a new section.
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Numbering pages consecutively

If your book chapters don’t have sections, use consecutive page numbering,
in which the first page number of a chapter follows the last page number of
the previous chapter (for example, one chapter ends on page 224, and the
next chapter starts on page 225).

Consecutive page numbering is applied by default in InDesign. If, for some
reason, a document resets its numbering, go to that document, open the
Section dialog box (choose Numbering & Section Options in the Pages panel’s
flyout menu), and select Automatic Page Numbering.

Consecutive page numbering works as follows:

» Whenever you add a chapter that contains no sections or that has
section numbering set to Automatic Page Numbering, InDesign numbers
pages consecutively throughout the book.

v As you add and delete pages from chapters, InDesign updates all the
page numbers in the chapters that follow.

» You can force InDesign to renumber all the pages by choosing Repaginate
from the book panel’s flyout menu — handy if you changed section
options in some chapters and want the book to see those changes.

Numbering pages with sections

When chapters you add to books already contain sections of page numbers
(implemented through the Section dialog box, which you access via the
Numbering & Section Options menu option in the Pages panel’s flyout menu),
section page numbering overrides the book’s consecutive page number-

ing. The section page numbering carries through chapters of the book until
InDesign encounters a new section start. So if one chapter ends on page iv, the
next chapter starts on page v unless you start a new section for that chapter.

For more in-depth information about section numbering, see Chapter 4.

Setting chapter numbers

You can also see and modify any chapter’s page numbering settings by
selecting the chapter in the book panel and then choosing Document
Numbering Options from the flyout menu. Figure 22-2 shows the Document
Numbering Options dialog box. The top half of the dialog box is the same
as the Pages panel’s Section dialog box, whereas the bottom half — the
Document Chapter Numbering area — lets you control the chapter number-
ing style and the chapter number itself.
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You can force a chapter to have a specific number by selecting the Chapter
Number option, have the chapter use the same chapter number as the previ-
ous document (such as when you break a chapter into two documents), and
have InDesign automatically number the current document by incrementing
from the previous document’s chapter number.

The chapter number defined here — whether manually overridden or auto-
matically adjusted — is what is used by the Chapter Number text variable,
explained in Chapter 21.

Document Numbering Options

-V Start Section ( OK )
(®) Automatic Page Numbering (" cancel )

() Start Page Numbering at: 32

— Page Numbering
Section Prefix:
Style: [1,2,3,4.. |3

Section Marker: m

"l include Prefix when Numbering Pages

— Document Chapter Numbering

Style: [ 1,2,3,4...

() Automatic Chapter Numbering

(® Start Chapter Numbering at: |2

() Same as Previous Document in the Book

Book Name: Nik Tutorial.indb




Part VI

Printing and
Multimedia
Essentials

The Sth Wave By Rich Tennant
(O]

{ENNANT

“T've used several spreadsheet programs, but
this is the best one for designing quilt patterns.”



In this part . . .

Fnally, your layout is done. It’s beautiful, it’s well-
written, and you're eager to share it with your

readers. This part shows you how to take the final step

to print or create a PDF version of your layout. InDesign
gives you a lot of control over output, so you can optimize
the results based on what you're printing it to, such as
ensuring color fidelity and the best possible image resolu-
tion. Then you can start the whole creation, refinement,
and output process over again with your next layout!

Plus, this part explains how to go beyond print into the
brave new world of the multimedia by exporting files in
the Web’s HTML format, creating interactive PDF files
with effects such as buttons and embedded movies, and
even creating Flash animation files from your InDesign
layout. Can 3D be far behind?




Chapter 23

Printing Your Work

In This Chapter

Previewing your files before you print

Creating booklets

Setting colors for accurate reproduction

Printing your layouts to printers and other devices

Collecting files for service bureaus

ou've finished your document, and you want to share it with the whole
world, or at least your audience. So you reach for your mouse and
choose Filew>Print or quickly press O+P or Ctrl+P so that you can print.

Stop. Cancel. If this print job is your first with InDesign, you need to make
sure that you've properly set up your printer to get the results you need. The
process for doing so varies based on your operating system, and you can find
instructions at the author’s Web site at www. InDesignCentral .com.

Printing is more complex than just choosing File>Print (88+P or Ctrl+P). At least
it can be, depending on what you're printing and on what printing device you're
using. For example, printing a full-color brochure involves more settings and
steps than printing a proof copy to your laser printer or inkjet printer. So as you
go through this chapter, keep in mind that many steps aren’t relevant every time
you print — but understanding the basics of printing ensures that you follow the
right steps for each type of project. When you know the steps for printing one
document, the process for printing every other document takes little effort.

Checking Vour Document before Printing

3

Before you print, you should do a visual proof of your layout. It’s amazing
what you don’t notice when you’re focused on specific elements as you lay out
a page. Change your view setting so that the entire page or spread fits in the
window (choose View>Fit Page in Window [8+0 or Ctrl+0 — note the use of
the numeral zero in the shortcut] or Viewr>Fit Spread in Window [Option+3+0
or Ctrl+Alt+0], as desired) and then review your pages.
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This visual check is a critical step before printing, but you should also use
InDesign’s preflight tool to examine your document. The preflighting capabil-
ity examines your document for any issues of concern and gives you a report
on what you may need to fix.

You may wonder why you need a preflighting capability to check for things
such as missing fonts and images: After all, InDesign lists any missing fonts
and graphics when you open a document. The answer is that sometimes
fonts and graphics files are moved after you open a file, in which case you
won’t get the alerts from InDesign. This mistake is more likely to happen if
you work with files and fonts on a network drive, rather than with local fonts
and graphics. Preflighting also checks for other problematic issues, such as
the use of RGB files and TrueType fonts.

Identifying and fixing ervors

InDesign CS4 preflights your document as you're working on it so that you can
deal with surprises before the end of the project when you're likely on a tight
deadline. At the bottom of the document window, InDesign reveals whether it
has found any errors and lets you access the Preflight panel and other options
to both specify what the preflighting should be checking before and show you
the issues it has found. Figure 23-1 shows this alert and its options. This new
preflighting approach has also changed all the dialog boxes and most related
settings compared to previous versions of InDesign.

If you're working with the InDesign book feature (see Chapter 22), you can pre-
flight the book’s chapters from an open book’s panel by using the Preflight Book
option in its flyout menu. (If one or more documents in the book are selected

in the panel, the menu option changes to Preflight Selected Documents.) The
options are the same as for preflighting individual documents.

Preflight Panel
Define Profiles...

N{reF

o, 1 can hone
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You can turn preflighting on or off using either of these methods:

v In the Preflight pop-up menu at the bottom of the document window,
choose Preflight Document to toggle between off and on. If the menu option
is checked, preflighting is turned on. You can also toggle off and on Enable
Preflight for All Documents, which sets the default action for all documents.

v In the Preflight panel (Filec>Preflight [Shift+Option+3+F or Ctrl+Alt+
Shift+F]), enable the On option to turn preflighting on; disable it to
turn preflighting off. The flyout menu has the Enable Preflight for All
Documents option.

The Preflight panel shows all errors that InDesign has found in the Error
pane, as Figure 23-2 shows. The errors are grouped by type; to see the indi-
vidual errors, click the right-facing triangle to expand the group’s informa-
tion. In the list of issues that appears, you'll get a brief description and a
hyperlink to the page that has the error. Each list may have several occur-
rences, in which case you’ll see another right-facing triangle that if clicked
expands the list to show them all. And to get even more detail on a selected
item, expand the Info pane by clicking its right-facing triangle (unless it’s
already expanded, of course).

To “collapse” any lists (such as to get them out of the way as you look at other
items), click the down-pointing triangles.
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To get rid of the error notices, go to each page that has an issue and correct
it. InDesign updates the preflight errors status as you do.

Telling InDesign what to check for

InDesign has its default set of issues to look for when preflighting. But you can
set up your own options based on your specific needs. Although the process is
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Figure 23-3:
The Preflight
Options
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InDesign
looks for
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simple, you'll likely need to consult with your production manager or service
bureau to determine what settings you want to enable in your profile — these
settings are typically expert decisions.

Even

if the choices require expertise to make, the process for setting up your

preflight options is easy:

1.

In the Preflight pop-up menu at the bottom of the document window
or in the Preflight panel’s flyout menu, choose Define Profiles.

. In the Preflight Profiles dialog box, shown in Figure 23-3, click the +

iconic button to add a new profile.

Use the — iconic button to delete a selected profile.

. Give your profile a name and go through the options and select the

ones you want InDesign to preflight for as you work.

A triangle to the left of an option means that you can select from subop-
tions; click the triangle (it then points down) to get those suboptions.
(Click it again to “collapse” the suboptions so that they’re not in view.)

4. Click Save when done.

5. Use the + and - iconic buttons at left to add more profiles or remove

existing profiles.

6. Click OK when done to exit the Preflight Profiles dialog box.

7. In the Preflight panel, choose the desired profile for the current

document from the Profile pop-up menu.

If the Preflight panel isn’t open, choose Filew>Preflight (Shift+Option+3+F
or Ctrl+Alt+Shift+F) to open it.
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Setting Up Booklets

Figure 23-4:
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for a folded
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|

One of the trickiest types of documents to print is a folded booklet: You can’t
simply print the pages in sequence and have them end up on the right loca-
tion on the final sheets of paper — when you fold them, you’ll find the page
order is rearranged due to the folding, especially in two-sided documents.

The tried-and-true approach is to use a booklet template that essentially
provides a map of where pages should be so that when they’re printed and
folded, they end up in the right place — and then arrange your pages in that
order via the Pages panel. Figure 23-4 shows the natural order (1-8) that you
typically think a booklet has, as well as the actual page order (8,1; 2,7; 6,3;
and 4,5) in which it must be printed to appear as a sequence of 1 through 8.
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To simplify this approach, use the Print Booklet dialog box (File=>Print
Booklet). Here, you arrange your pages in the Pages panel in sequential order
(1-8, in this case) and let the InDesign software figure out how to rearrange
them for printing. Much easier! Figure 23-5 shows the Print Booklet dialog
box’s Setup pane.

Here are the key controls:
v Booklet Type: This pop-up menu is the key control. Here, you choose the

type of booklet, which tells InDesign how to arrange the pages when print-
ing so that they’re in the right sequence after folding. Your options are
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Figure 23-5:
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¢ 2-up Saddle Stitch: A folded sheet that contains two pages on
each side, with the staples in the centerfold, between the pages.
Newsletters, smaller magazines, and many office documents use
this option.

¢ 2-up Perfect Bound: A folded sheet that contains two pages on each
side, where the pages are stacked and folded and then cut and held
together with a glued backing or spine-based binding. This option is
typically used in books, larger magazines, and catalogs (because the
square binding holds more pages than saddle-stitching does).

¢ 2-up Consecutive: A sheet that contains two pages on one side,
with each page then cut and bound. This setup is essentially
normal printing except that it uses a two-page sheet to print two
pages at a time rather than a separate sheet for each page.

3-up Consecutive: Like 2-up Consecutive, except three pages are
on a sheet.

4-up Consecutive: Like 2-up Consecutive, except four pages appear
on a sheet.

Space Between Pages (not available for 2-up Saddle Stitch) and Bleed
Between Pages (available for 2-up Perfect Bound only): These options
let you adjust the relative spacing among pages and objects, typically to
provide additional white space around the folds.

Creep (not available for the Consecutive options): This option shifts
pages’ contents away from the spine in increasing amounts as pages fall
from the center of the booklet to the outside of the booklet. Because out-
side pages have to fold over many inside pages, their content can end up
obscured in the inside margins because their gutter is eaten up by
folding over those other pages. The Creep option corrects this problem.
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v~ Signature Size (available only for 2-up Perfect Bound): This option spec-
ifies how many pages are printed on each side of a sheet: 4, 8, 16, or 32.

v Automatically Adjust to Fit Marks and Bleeds: This option ensures
that crop marks, bleeds, and other content that appears outside the
page boundary are properly handled for the chosen booklet type. If not
checked, you can manually adjust these settings using the Top, Bottom,
Left, and Right fields.

When using these features, consult with your professional printer or service
bureau for the appropriate settings. If you're printing the documents yourself, do
a test run, then fold, cut, and/or staple the sample document to make sure that

it works as expected before printing lots of copies. The Preview pane shows the
results of your choices, but doing a dry run is always the safest option.

When you're happy with your settings, choose Print to get the standard Print
dialog box (covered in the “Choosing Print Options” section, later in this chapter).
You can also choose Print Settings to set up printer-specific controls (also
covered in that section).

Calibrating Color

If you're producing color documents for printing on a printing press, you may
want to use InDesign’s built-in color calibration tools. In a sense, you have

to, because InDesign’s color calibration is always on. But color calibration

is something you don’t do in a vacuum — you have to do it in your graphics
programs as well so that every piece of software that handles your graphics
is working from the same color assumptions.

If you use Adobe Creative Suite 4, you can use a consistent color management
system (CMS) in all print-oriented CS4 programs, ensuring consistent color.
For scanned images, digital camera photos, and the like, you can also tell
InDesign the source device so that InDesign knows the color assumptions
that the device makes and can use that information to adjust the colors
during printing accordingly.

You can set the CMS settings in InDesign by choosing Edit=>Color Settings to
get the Color Settings dialog box shown in Figure 23-6.

Many of Adobe’s Creative Suite 4 applications have the same dialog box,
although sometimes you access it in different ways:

v Bridge CS4: Choose Edite>Creative Suite Color Settings (Shift+38+K
or Ctrl+Shift+K). This action sets the defaults for all CS4 applications,
although you can modify individual applications, as described in the
next three bullets. Note that if individual applications’ color settings
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differ from the CS4-wide settings, you see a note to that effect at the top
of the affected applications’ Color Settings dialog boxes.

1 Acrobat Professional 9: Choose Acrobat= Preferences (38+K) on the
Mac or choose Edit=>Preferences (Ctrl+K) in Windows. Then go to the
Color Management pane. Note that this pane’s appearance differs from
the appearance of the Color Settings dialog boxes in the other Creative
Suite 4 applications.

v Illustrator CS4: Choose Edit=>Color Settings (Shift+3+K or Ctrl+Shift+K).
v+~ Photoshop CS4: Choose Edit=>Color Settings (Shift+8+K or Ctrl+Shift+K).

Note that the following CS4 applications have no CMS controls: Adobe Device
Manager, Dreamweaver, and Flash Professional.
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When you place a bitmapped image into InDesign, the CMS applies the default
settings defined in the Color Settings dialog box. (Choose Edit>Color Settings.)
If the document has no embedded color profile, a dialog box appears with a list
of color profiles, as well as options to apply the default you’ve set up in InDesign
or to apply no profile. (If you choose not to apply a profile, the color won’t be
adjusted during printing.)
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Whether or not the document has embedded profiles, you can change the
color settings for specific images as follows:

v As you import each file, select Show Import Options in the Place dialog
box (choose Filer>Place [88+D or Ctrl+D]) when you place a graphic into
InDesign. In the resulting Image Import Options dialog box, go to the
Color pane and select the appropriate profile from the Profile menu.

v Any time after you place an image, select it and choose Objectr>Image
Color Settings to apply a different profile. (You can also choose
Graphics>Image Color Settings from the contextual menu that appears
when you Control+click or right-click a graphic in InDesign.)

You can save and use color management settings in other documents. The
process is simple: Click Save in the Color Settings dialog box to save the cur-
rent dialog box’s settings to a file. If you want to use the saved color-settings
information in another document, open that document, click Load in the Color
Settings dialog box, and then browse for and select the color settings file.
That’s it! This technique is a handy way to ensure consistency in a workgroup.

If you put together a document with specific color settings, but then decide
you want to apply a new profile across your pictures or replace a specific
profile globally in your document, you have a couple of options:

v Choose Edit=>Assign Profiles to replace the color management settings
globally for the document, setting the target color settings for output.

v Choose Edit~>Convert to Profile to change the document’s working color
workspace. It also lets you change the CMS engine, rendering intent, and
black-point compensation settings. This does not change your output
color settings but instead changes the source profiles assigned to the
images so you can test different color settings in on-screen preview
mode (View=>Proof Colors).

Be sure to consult with a production manager or service bureau manager if
you change these expert settings.

When you're ready to output your document to a printer or other device,
set the profile and rendering intent for that destination device in the Color
Management pane of the Print dialog box (choose File>Print [8+P or
Ctrl+P]), which has an Options section with the Color Handling and Printer
Profile pop-up menus. Here, you select the appropriate option for your
output device. (If you don’t know, ask an expert.)
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Choosing Print Options

When your document is ready to print, go to the Print dialog box. (Choose
File>Print [88+P or Ctrl+P].) The Print dialog box has eight panes as well

as several options common to all the panes. (I cover just the essential ones
here.) Change any options and click Print, and InDesign sends your document
to the printer. Figure 23-7 shows the dialog box.

<P If you’re working with the InDesign book feature (see Chapter 22), you can
print the book’s chapters from an open book’s panel by using the Print Book
option in its flyout menu. (If one or more documents in the book are selected
in the panel, the menu option changes to Print Selected Documents.) The
setup options are the same as for printing individual documents.
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The common options available in the dialog box, no matter what pane is
selected, are as follows:

+* Print Preset pop-up menu: This pop-up menu lets you choose a previ-
ously defined set of printer settings, which makes it easy to switch
between, say, a proofing printer and a final output device.

v Printer pop-up menu: This pop-up menu lets you select the printer to use.
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v+ PPD pop-up menu: This pop-up menu lets you select PostScript Printer
Descriptions, which are files that contain configuration and feature
information specific to a brand and model of printer. You usually install
these files into your operating system by using software that comes
from your printer manufacturer. If InDesign finds no compatible PPDs, it
uses generic options. If InDesign finds just one compatible PPD, it uses
that automatically; otherwise, it lets you select a PPD.

1~ Save Preset button: Clicking this button saves any settings that you
change in the Print dialog box and lets you choose a name for those
saved settings for reuse. If you change the dialog box’s settings but don’t
save these changes as a print preset, InDesign changes the name of the
current settings in the Print Preset pop-up menu to [Custom] to remind
you that the settings are changed and unsaved.

You can also create print presets by choosing Filec>Print Presets=>Define
or edit an existing preset by choosing File=>Print Presetst>preset name.
When you click New or Edit in the resulting dialog box, a dialog box
identical to the Print dialog box appears, except that the Print button
becomes the OK button.

1 Setup button (Windows); Page Setup and Printer buttons (Mac): These
buttons give you access to printer-specific controls. You use these
dialog boxes to specify options such as printing to file, paper sources,
and printer resolution. Note that if you add a printer, you may need to
quit InDesign and restart it for it to see the new printer.

v Cancel button: Clicking this button closes the Print dialog box without
printing. Use this button if you've clicked Save Preset but don’t want to
print, as well when you have any reason not to print.

v Print button: Clicking this button prints the document based on the
current settings.

1 Page preview subpane: This subpane at the lower left shows the cur-
rent settings graphically. The page is indicated by the blue rectangle,
and the direction of the large P indicates the printing orientation; in
Figure 23-7 the P is unrotated. The figure’s subpane shows that the
paper itself is the same size as the page (the page is shown in white, and
if the paper were larger than the page, you'd see a light gray area around
the page indicating the excess paper). This preview changes as you
adjust settings in the dialog box.

The General pane

The General pane contains the basic settings for your print job. Most are self-
explanatory, but note the following:
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v When specifying a range of pages in the Pages Range option, you can
type nonconsecutive ranges, such as 1-4, 7, 10-13, 15, 18, 20. If you
want to print from a specific page to the end of the document, just type
the hyphen after the initial page number, such as 4-. InDesign figures
out what the last page is. Similarly, to start from the first page and end
on a specified page, just start with the hyphen, as in -11. InDesign lets
you type absolute page numbers in the Range field. For example, typing
+6—+12 would print the document’s 6th through 12th pages, no matter
what their page numbers are.

v Selecting the Spreads option prints facing pages on the same sheet of
paper, such as putting two letter-size pages on one 11-x-17-inch sheet.
This option is handy when showing clients proposed designs, but make
sure that you have a printer that can handle a large paper size or that
you scale the output down to fit (through the Setup pane, which I cover
in the following section).

v The Options section lets you print various layout components that you
typically don’t want in final output but may be useful when sharing
comps and other in-progress printouts with others, such as baseline
grids and nonprinting objects such as formatting notes.

+* A handy control in the Options section is the Print Layers pop-up menu,
which gives you additional control over how layers are marked as non-
printing print. The default option, Visible & Printable Layers, honors
your layers’ printing status. Visible Layers prints all visible layers,
including those marked as nonprinting. All Layers prints both visible
and hidden layers, including those marked as nonprinting. (See Chapter
5 for more on layers.)

The Setup pane

The Setup pane is where you tell InDesign how to work with the paper (or
other media, such as film negatives) to which you’re printing. The options
are straightforward, so I just highlight a few notes and tips:

v Custom paper size: Choosing some printer models will in turn let you
choose a Custom option in the Paper Size pop-up menu, in which case
you type the dimensions in the Width and Height fields, as well as posi-
tion the output through the Offset and Gap fields. These latter two
options are usually used when printing to a roll, such as in an image-
setter using photo paper (called RC paper, a resin-coated paper that
keeps details extremely sharp), so that you can make sure that a space
appears between the left edge of the roll and the page boundary (the
offsef), as well as between pages (the gap). Most printers can’t print
right to the edge, thus the Offset setting. You also want a gap between
pages for crop and registration marks, as well as to have room to
physically cut the pages.
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v Transverse option: Don’t use the Transverse option, which rotates the
output 90 degrees, unless your service bureau or production depart-
ment tells you to. Otherwise, you may have your pages cut off on the
final negatives.

v~ Tile options: Use the Tile options to print oversized documents. InDesign
breaks the document into separate pages — called tiles — that you later
can assemble together. To enable tiling, select the Tile check box and
then choose the appropriate option from the adjoining pop-up menu:

e Manual: This option lets you specify the tiles yourself. To specify a
tile, you change the origin point on the document ruler, and the new
origin point becomes the upper-left corner of the current tile. (To
change the origin point, just drag the upper-left corner of the rulers
to a new position in your document.) To print multiple tiles this
way, you need to adjust the origin point and print, adjust the origin
point to the next location and print, and so on, until you're done.

Auto: This option lets InDesign figure out where to divide the
pages into tiles. You can change the default amount of overlap
between tiles of 1.5 inches by using the Overlap field. The overlap
lets you easily align tiles by having enough overlap for you to see
where each should be placed relative to the others.

Auto Justified: This option is similar to Auto except that it makes
each tile the same size, adjusting the overlap if needed to do that.
(The Auto option, by contrast, simply starts at the origin point and
then does as much of the page as will fit in the tile, which means
the last tile may be a different width than the others.) You can see
the difference between the two by watching how the page preview
window at left changes as you select each option.

The Marks and Bleed pane

The Bleed and Slug area of the Marks and Bleed pane controls how materi-
als print past the page boundary. A bleed is used when you want a picture,
color, or text to go right to the edge of the paper. Because there is slight
variation on positioning when you print because the paper moves mechani-
cally through rollers and might move slightly during transit, publishers have
any to-the-edge materials actually print beyond the edge so that gaps never
appear. It’s essentially a safety margin. A normal bleed margin is 0p9 (4 inch),
although you can make it larger if you want.

A slug is an area beyond the bleed area in which you want printer’s marks to
appear. The reader never sees this area, but the workers at the commercial
printer do, and it helps them make sure that they have the right pages, colors,
and so on. Like the bleed, the slug area is trimmed off when the pages are
bound into a magazine, newspaper, or whatever. (The word slug is an old news-
paper term for this identifying information, based on the lead slug once used
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for this purpose on old printing presses.) The purpose of the slug is to ensure
that you have enough room for all the printer’s marks to appear between the
bleed area and the edges of the page. Otherwise, InDesign does the best it can.

It’s best to define your bleed and slug areas in your document itself

when you create the document in the New Document dialog box (choose
File>Newr=>Document [38+N or Ctrl+N]), as covered in Chapter 3. You can
also use the Document Setup dialog box. (Choose File>’Document Setup
[Option+38+P or Ctrl+Alt+P].) The two dialog boxes have the same options; if
they don’t show the Bleed and Slug section, click More Options to see it.

But if you didn’t define your bleeds previously, you can do so in the Print
dialog box’s Marks and Bleed pane. You can also override those New
Document or Document Setup document settings here. To use the document
settings, select the Use Document Bleed Settings option. Otherwise, type in

a bleed area by using the Top, Bottom, Left, and Right fields. If you want the
four fields to be the same, click the broken-chain iconic button to the right of
the Top field; it becomes a solid chain, indicating that all four fields will have
the same value if any are modified. Any bleed area is indicated in red in the
preview pane at the bottom left.

If you want to set the slug area, select the Include Slug Area option. InDesign
then reserves any slug area defined in the New Document or Document Setup
dialog box. You can’t set up the slug area in the Print dialog box.

The Output pane

The next pane is the Output pane, which controls the processing of colors
and inks on imagesetters, platesetters, and commercial printing equipment.
For proof printing, such as to a laser printer or an inkjet printer, the only
option that you need to worry about is on the Color pop-up menu, which
controls whether the colors print as color or as grayscale.

The options in the Output pane are for experts and should be specified in
coordination with your service bureau and commercial printer — these
options can really mess up your printing if set incorrectly.

One area that you should set is in the Ink Manager dialog box. Accessed by
clicking Ink Manager, the Ink Manager dialog box, shown in Figure 23-8, gives
you finer controls over how color negatives output. If any colors should have
been converted to process color but weren’t, you have three choices:

v Click the spot color iconic button. You can override the spot color in
the Ink Manager dialog box by clicking this button (a circle icon) to the
left of the color’s name. That action converts the spot color to a process
color. (Clicking the process color button, a four-color box icon, converts
a color back to a spot color.) This is the way to go for a quick fix.
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1 Make the spot color a process color instead. Do so by closing

Chapter 23: Printing Your Work 36 ’

the Ink Manager and Print dialog boxes and editing the color that

was incorrectly set as a spot color in the Swatches panel (choose
Windowr>Swatches [F5]), as I cover in Chapter 6. Using the Swatches
panel instead of fixing this color setting at output time in the Print dialog
box ensures that the color is permanently changed to a process color
for future print jobs.

1 Convert all spot colors to CMYK process equivalents. Do so by select-
ing the All Spots to Process option. This method is the easiest way
to make sure that you don’t accidentally print spot-color plates for a
CMYK-only document.

The other Ink Manager options are for experts and should be changed only
in consultation with your service bureau, production department, and/or

commercial printer.
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The Graphics pane

By using the Graphics pane, you control how graphics are printed and how
fonts are downloaded. The options here are meant for professional printing,
such as to imagesetters, in situations where you’re working with a service
bureau or in-house printing department. This pane is also an expert area, so
change these settings only after consulting with an experienced pro.
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The Color Management pane

The Color Management pane is where you manage color output (apply color
calibration). Most options should be changed only in consultation with your
service bureau or production department.

One option you should be able to change on your own is Printer Profile. Use
this pop-up menu to select the device to which the document will ultimately
be printed. This printer is by default the same as the profile selected in the
Edit Color Settings dialog box, which I cover earlier in this chapter, in the
section “Calibrating Color.”

The Advanced pane

The options in the Advanced pane let you control graphics file substitutions
in an Open Prepress Interface (OPI) workflow and also set transparency flat-
tening, which controls how transparent and semitransparent objects are
handled during output. Again, you should change these expert options only
in consultation with your service bureau or production department.

The Summary pane

The final Print dialog box pane is the Summary pane. It simply lists your settings
all in one place for easy review. The only option — Save Summary — saves the
settings to a file so that you can include it with your files when delivering them
to a service bureau or for distribution to other staff members so that they know
the preferred settings.

Creating a Document Package

Have you ever given a page-layout document to a service bureau only to be
called several hours later because some of the files necessary to output your
document are missing? If so, you’ll love the Package feature in InDesign.

This command, which you access by choosing Filem>Package (Option+Shift+
88+P or Ctrl+Alt+Shift+P), copies into a folder all the font, color-output, and
graphics files necessary to output your document. It also generates a report
that contains all the information about your document that a service bureau

is ever likely to need, including the document’s fonts, dimensions, and trap-
ping information. You can also create an instructions file that has your contact
information and any particulars you want to say about the document.
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When you run the Package command, InDesign preflights your document
automatically and gives you the option of viewing any problems it encoun-
ters. If you elect to view that information, the Preflight dialog box appears.
You can continue to package your document from that dialog box by clicking
Package after you assure yourself that none of the problems will affect the
document’s output. If it finds no problems during the automatic preflighting,
InDesign doesn’t display the Preflight dialog box.

Although InDesign CS4 preflights your document automatically by default, as
the “Checking Your Document before Printing” section, earlier in this chapter
explains, the Package command still does its own preflighting, using a core

set of issues that Adobe has decided need to be handled even if you let them
slide in your own preflighting. You can of course ignore them, but don’t expect
great output results if you do.

Before you can actually package the document, InDesign asks you to save
the current document and then fill in the Printing Instructions form. You can
change the default filename from Instructions. txt to something more
suitable, such as the name of your print job. Often, you’ll leave the printing
instructions blank — use the form only if you have special instructions.

If you don’t want to create an instructions form when packaging a docu-

ment, don’t click Cancel — it cancels the entire package operation. Just click
Continue, leaving the form blank. Similarly, you must click Save at the request
to save the document; clicking Cancel stops the package operation as well.

The next step is to create the package folder. You do so in the dialog box
that follows the Printing Instructions form, which on the Mac is called Create
Package Folder and in Windows is called Package Publication. Figure 23-9
shows the Mac version, which, except for the name at the top, is the same as
the Windows version.

In the dialog box, you can select what is copied: the fonts, color-output
profiles, and linked graphics (graphics pasted into an InDesign document
rather than imported are automatically included). You can also tell InDesign
to update the graphics links for those that were modified or moved; if this
Update Graphic Links in Package option isn’t selected, any missing or modi-
fied graphics files won’t be copied with the document.

You can tell InDesign to include fonts and links from hidden layers (which
you’d do only if you want the service bureau to print those hidden layers
or if you were giving the document’s files to a colleague to do further work).

You also can specify whether the document should use only the hyphen-
ation exceptions defined within it. This option often makes sense because it
ensures that the printer’s hyphenation dictionary — which may differ from
yours — doesn’t cause text to flow differently.
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Figure 23-9:
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Finally, you can choose to view the report after the package is created — on
the Mac, InDesign launches TextEdit and displays the report file, and on
Windows it launches Notepad and displays the report file.

Click Save (on the Mac) or Package (in Windows) when everything is ready to
go. Your document is placed in the folder you specify, as is the instructions
file (the report). Inside that folder, InDesign also creates a folder called Fonts
that includes the fonts, a folder called Links that has the graphics files, and a
folder called Output Profiles that has the color output profiles.

Don’t panic when you see a dialog box appear that warns you that sharing
fonts could be illegal. If you’re working with a reputable service bureau,
they’ll use the packaged fonts only for your job and then delete them. A font
license typically allows you to share fonts for such temporary usage, but of
course not to give away fonts to others for other uses. Anyone who needs the
fonts on an ongoing basis should buy them.

[ strongly recommend using the Package feature. It ensures that your service
bureau has all the necessary files and information to output your document
correctly.
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In This Chapter

Taking advantage of hyperlinks and cross-references

Going the extra mile with sounds and video

Getting fancy with buttons, rollovers, and other actions
Exporting Flash files, PDFs, and eBook files

Getting your work to the Web

p ublishing is no longer about just print. Documents exist in electronic
form as well, delivered on CD, from file servers, and over the Web. And
the definition of “document” has changed, going from static text and images
to a wider palette of media types, including sound and video, and a host of
new actions — think hyperlinks, animated rollovers based on your louse
movement, and buttons that initiate actions like turning a page or playing a
movie.

Over the years, InDesign has steadily added to its dynamic repertoire.
InDesign CS4 adds a bunch more: slideshow-style page transitions, Flash file
export, and a cross-reference capability.

Using Hyperlinks

Web pages, Flash files, and PDF files can include hyperlinks, the clickable hot
spots that direct a browser to open a new file or page. It’s a whole new way
to deliver related contents through an active cross-reference. And InDesign
lets you add hyperlinks to your documents, so if they’re exported to the PDF
or Web formats, those links are clickable.

InDesign uses its Hyperlinks panel (Window=Interactive>Hyperlinks) to add,
edit, and delete hyperlinks. In a sense, a hyperlink is a character attribute —
it’s applied to selected text. Figure 24-1 shows the Hyperlinks panel and its
flyout menu.
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InDesign CS4 overhauls the Hyperlinks panel, with many new and changed
options.

Creating hyperlinks

Although the process is straightforward, InDesign’s terminology can make it a
very confusing on how to start. You first create a hyperlink destination — the
place a hyperlink goes to, or its target — by choosing New Hyperlink Destination
from the Hyperlinks panel’s flyout menu. Figure 24-2 shows the dialog box. You
give the destination a name in the Name field and then choose from one of the
three options in the Type menu:

v URL: This option is a Web page address (the official name is Uniform
Resource Locator), as shown in the New Hyperlink Destination dialog
box in Figure 24-2. If you select this option, InDesign displays the URL
field in which you type the Web address.

v Page: This option lets you specify a specific page in a selected docu-
ment. If you select this option, InDesign provides a Page field in which
you specify the page number to open in the selected document, as well
as the Zoom Setting pop-up menu, which lets you select how the page
is displayed. (Options are Fixed, meaning at the default size in Adobe
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Reader; Fit View; Fit in Window; Fit Width; Fit Height; Fit Visible; and
Inherit Zoom, which uses the current zoom setting in Adobe Reader.)

+* Text Anchor: This option lets you specify a specific piece of text (the
selected text) in the selected document.

l Page kperlink Destination
Text Anchor
Ty = ——1 (T
Name: Bar Harbor l (m
URL: ttp://www.barharborinfo.com/
New Hyperlink Destination
—Type:| Text Anchor [ | (T
| Name: Bar Harbor 3 (" Cancel )
Figure 24-2:
The New
Hyperlink
Destination
dialog box’s
three vari- New Hyperlink Destination
ants are | —type:/ page B e
(from tOp Name: |Page Secl:45 I( Cancel ‘1
to bOttom) "] Name with Page Number
URL, Text Page: [“lsec1:45
Anchor, and Zoom Setting: |ﬁ
Page. -
|

With the destinations defined, you can now create the hyperlinks to them
(the hyperlink sources).

To create a hyperlink source:

1. Select the text or frame you want to be a hyperlink’s source (what the
reader clicks to go to the link) and then choose New Hyperlink from
the Hyperlinks panel’s flyout menu.

The New Hyperlink dialog box, shown in Figure 24-3, appears.
2. Use the Link To pop-up menu to determine what you’re hyperlinking to.

You have the same three options as in the New Hyperlink Destination
dialog box’s Type menu — Page, Text Anchor, and URL — as well as
three new ones: Email, File, and Shared Destination.
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EATURE Email lets you enter an e-mail address, as well as a default subject for
§ that e-mail, if you like. File lets you point to any file and make that into a

link; of course, any file you link to this way needs to be something your
reader has the software to open. Shared Destination lets you select an
InDesign document, including the current one, and then select from any
destinations of any type defined in it.

With the URL, Email, and File options, you can enable the Shared
Destination check box, which makes the new hyperlink visible to other
users through the Shared Destination option in the Linked To pop-up
menu.

. In the Character Style section, you can tell InDesign to apply a specific

character style to the hyperlinked text.

. In the Appearance section, you can control how the hyperlink appears

on-screen:

¢ Use the Type pop-up menu to choose Invisible Rectangle or Visible
Rectangle. The Invisible Rectangle option gives no visual indica-
tion that the text contains a hyperlink, except that the mouse
pointer becomes a hand icon when the reader maneuvers through
the document. (You’d typically pick this option when you’ve
used blue underline as a character attribute for the hyperlink text
to mirror the standard Web way of indicating a hyperlink.) The
Visible Rectangle option puts a box around the text using the fol-
lowing four settings. (They’re grayed out if Invisible Rectangle is
selected.)
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* The Highlight pop-up menu lets you choose how the source text
or frame is highlighted: None, Invert (reserve the foreground and
background colors), Outline (places a line around the source), and
Inset (places a line around the source, but inside any frame stroke;
for text, it’s the same as Outline).

® The Color pop-up menu displays Web-safe colors, as well as any
colors you defined in the document.

e The Width pop-up menu lets you choose the thickness of the line
used in the Outline and Inset options from the Highlight pop-up
menu. The choices are Thin, Medium, and Thick.

* You can choose the type of line in the Style pop-up menu: Solid or
Dashed.
5. When you’re done defining the hyperlink source, click OK.
¥ If your text includes a valid hyperlink, such as www. InDesignCentral . com,

you can select it and create a URL hyperlink automatically by choosing New
Hyperlink from URL in the Hyperlinks panel’s flyout menu.

After your hyperlink sources are defined, you can easily apply them by
selecting text and clicking an existing hyperlink source from the Hyperlinks
panel. You can also jump to the source or destination by selecting the
desired hyperlink in the Hyperlinks panel and choosing either Go to Source
or Go to Destination from the flyout menu or click the Go to Hyperlink Source
or Go to Hyperlink Destination iconic buttons at the bottom of the panel.
These “go to” options make a handy way to verify the links are correct.

Remember that [ said that InDesign’s hyperlinks feature is confusing? Well,
you may have noticed that when creating hyperlink sources, you see a sec-
tion in the dialog box where you indicate what kind of hyperlink you're creat-
ing. Hmmm. That means that when you’re creating hyperlink sources, you're
also creating hyperlink destinations — which you are. So what’s the point

of the New Hyperlink Destinations dialog box covered in the previous sec-
tion? It’s to create destinations before you have a place to link them from, at
least for the three types of links supported by the New Hyperlink Destination
dialog box: URLs, text anchors, and pages in the current document. So, when
you want to add hyperlinks to existing text and objects, use New Hyperlink.
When you want to create hyperlinks to be applied later, use New Hyperlink
Destination.

While we’re at it, also keep in mind one more intricacy of using InDesign’s
hyperlink destinations: The Shared Destination option in the Link To pop-up
menu in the New Hyperlink dialog box lets you choose any previously cre-
ated hyperlink destinations in the document selected in the Document
pop-up menu — both those created via the New Hyperlink Destination dialog
box and those created via the New Hyperlinks dialog box.
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Where hyperlinks will work

Being able to create hyperlinks in InDesign is
great. But be aware that not all links will be
preserved in your exported documents. Here's
what is kept for each type of Web or multimedia
file you can export:

v~ PDFfiles: All hyperlinks are retained except
those that specify a specific page in an
external document.

v+~ eBook files: No hyperlinks are retained for
objects (such as frames). For hyperlinks
applied to text selections, hyperlinks to files,
to anchored text in the current document,
to Web addresses, and to e-mail addresses
are retained.

v~ Flash files: All hyperlinks are retained
except those that specify a specific page

in an external document and those to
an e-mail address. Also, any hyperlinks
that appear in or over objects that have
transparency applied will not be retained.

v Web pages: Only hyperlinks applied to text
selections (not to objects such as frames or
graphics) are retained, and even then only
hyperlinks to files, to anchored text in the
current document, to Web addresses, and
to e-mail addresses are retained. Also, text
anchor destination links in the document
(including bookmarks) are retained.

As you can see, InDesign’s Hyperlinks panel
lets you create more kinds of links than you can
actually use in exported documents. That's a

pity.

Modifying and deleting hyperlinks

To modify hyperlink sources: Choose Hyperlink Options from the Hyperlinks
panel’s flyout menu to open the Hyperlink Options dialog box, which has
the same options as the New Hyperlink dialog box, shown in Figure 24-3,
to modify the source. Similarly, to modify hyperlink destinations, choose
Hyperlink Destination Options from the palette menu to open the Hyperlink
Destination Options dialog box and then select the target from the Name

pop-up menu. The Hyperlink Destination Options dialog box’s options are the

same as the New Hyperlink Destination dialog box, shown in Figure 24-2.

You can change the source text or frame by selecting it, clicking the hyper-

link name in the Hyperlinks panel, and finally choosing Reset Hyperlink from
the panel’s flyout menu. To change the target for a hyperlink to an InDesign
document, choose Update Hyperlink from the flyout menu (press and hold
Option or Alt to select a file that is not open).

To delete a hyperlink target, choose it in the Hyperlink Destination Options
dialog box and then click Delete. (Click Delete All to delete all targets defined
in the document.)

To delete a hypertext source, select it in the Hyperlinks panel and then
choose Delete Hyperlink from the flyout menu or click the Delete Selected
Hyperlinks iconic button at the bottom of the panel.
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When you export your InDesign files to PDF files (choose Filem>Export [38+E
or Ctrl+E], and choose Adobe PDF from the Format pop-up menu), be sure

to select the Hyperlinks option in the Include section of the General pane

in the Export PDF dialog box. If you export to the XHTML format to create a
Web page from your InDesign document (File> Export for Dreamweaver), the
hyperlinks are included automatically. (And note that you don’t need to use
Adobe’s Dreamweaver Web-editing software to work on these exported Web
pages; any HTML editor or text editor will do.)

Working with cross-references

InDesign CS4 uses the Hyperlinks panel to add a related capability: cross-
references. Automated cross-references are used just for text, such as to
automatically keep page numbers and chapter titles updated in text such as
see page 227 and Learn more about color in the chapter “All about Color.”

To work with cross-references, you have two choices for their “to” locations.
You can specify specific locations by adding text anchors in your documents
using the hyperlinks destination feature described in the previous section.
Then you select that text anchor in the New Cross-Reference dialog box. Or
you can just choose from a list of paragraphs and make the cross-reference
link to that selected paragraph in the New Cross-Reference dialog box.

You open the New Cross-Reference dialog box, shown in Figure 24-4, by
choosing Insert Cross-Reference from the Hyperlink s panel’s flyout menu or
by clicking its Create New Cross-Reference iconic button.

In the Linked To pop-up menu, choose Text Anchor if your “to” destination
is a text anchor. If you want to select a specific paragraph instead, choose
Paragraph; InDesign shows all the first words of each paragraph in the docu-
ment so that you can scroll through the list and choose the desired one. You
can also filter that list by choosing from the styles at left; only paragraphs
with the selected style appear (so, for example, you can see just headings by
choosing the paragraph style for your headings).

Use the Cross-Reference Format section of the New Cross-Reference dialog
box to control what text displays for that cross-reference. You can be as
basic as the page number (note that the word page appears with it automati-
cally) or as complex as, for example, showing the full paragraph text (such as
a heading) and the page number.

371



372 Partvi: Printing and Multimedia Essentials

Figure 24-4:
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You can create your own cross-reference formats and modify the existing ones
by using the Cross-Reference Formats dialog box shown in Figure 24-5. This is
an expert feature, so [ don’t cover it in detail, but feel free to experiment.

To open that dialog box, click the button to the right of the Format pop-up
menu in the New Cross-Reference dialog box (handy when you want to create
a new format as you are adding a cross-reference) or choose Define Cross-
Reference Formats from the Hyperlinks panel’s flyout menu. You can also
edit an existing format this way.

Cross-Reference Formats

Full Paragraph & Page Number
Full Paragraph

Name: [Full Paragraph & Page Number

Paragraph Text & Page Number
Paragrapn Text

Paragraph Number & Page Number
Paragraph Number

Text Anchor Name & Page Number
Text Anchor Name

Page Number

Definition:

“<fullPara {>" on page <pageNum />

[e]=]

¥ Character Style for Cross—Reference: | Index Cross-reference | 3]

Page Number
Paragraph Number
Paragraph Text
Full Paragraph
Partial Paragraph
Text Anchor Name
Chapter Number
File Name
Character Style

—_— ) €

Cancel

oK )
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The basic procedure for a cross-reference format is to add the text you want
to display for any cross-references using the format combined with the codes
for the text that is added and updated automatically. Use the iconic pop-up
menu (the + symbol) to the right of the Definition shown in Figure 24-5 to
select those codes. The iconic pop-up menu below it (the @ symbol) lets you
choose special characters, such as em spaces. You can also have a charac-
ter style applied to the cross-reference text as part of that format using the
Character Style for Cross-Reference option.

You can control how the cross-reference appears using the Appearance
section’s controls. They work just like the Appearance controls in the New

Hyperlinks dialog box, covered in the previous section.
CMBER . - ,
D To edit an existing cross-reference, choose Cross-Reference Options from the
Hyperlinks panel’s flyout menu; it’s identical to the New Cross-References

dialog box.

Adding bookmarks

PDF files use something called bookmarks to
help readers find information in the file. In a PDF
file, a bookmark list acts like a table-of-contents
list in a printed book, except that if you click

a bookmark item, Adobe Reader or Acrobat
brings you to the page the bookmark refers to
(see figure).

® Acrobat File Edit View
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|'__| Credits

E About the Author

v |‘_-| Introduction

m The Paint of All
This

¥ ®| Oh veah That

When you export to PDF, as explained in the
“Exporting PDF Files” section later in this chap-
ter, you can tell InDesign to take any table of
contents set for the document and create PDF
bookmarks from it. (Chapter 20 explains how to
set up tables of contents.)

But you can add your own independent book-
marks in addition to whatever is in the table

of contents. Open the Bookmarks panel
(Windowe>Interactivec>Bookmarks) and then
choose what you want to bookmark. To do so,
simply select some text or an object (frame or
line); if nothing is selected, the bookmark is to
the current page. Then choose New Bookmark
from the Bookmarks panel’s flyout menu or
click the Add Bookmarks iconic button — the

(continued)
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(continued)

page icon — at the bottom of the panel. After
you create the bookmark, choose the Rename
Bookmark option in the flyout menu to give it
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a meaningful name (see figure); this name
appears in the Bookmarks pane in Adobe
Reader or Acrobat.

New Bookmark
Delete Bookmark...

Rename Bookmark
Go to Selected Bookmark

Sort Bookmarks

If you want a bookmark to be a subentry of
another bookmark — the equivalent to a
second-level or third-level headline in a table of
contents — make sure that, before you create
the bookmark, you select a bookmark in the
Bookmarks panel. Any new bookmark is made
a child of the selected bookmark.

The other Bookmarks panel flyout menu options
are straightforward:

v Choose Delete Bookmark to delete any
bookmarks selected in the panel. (You can
also click the Delete Bookmarks iconic
button — the trashcan icon — at the bottom
of the panel.)

v Choose Go to Selected Bookmark to jump
to that page in your InDesign document.
An easier way is to simply double-click the
bookmark entry in the pane.

Choose Sort Benchmarks to sort bench-
mark subentries — this alphabetizes
second-level, third-level, and other page-
based subentries, and it sorts in order of
appearance on the page any text- and/
or object-based entries. It does not sort
the top-level bookmarks, which appear in
sequential order from the beginning of the
document.

Adding Sounds and Video

InDesign treats movies and sounds like any other file: You place them with
the Place command (Filer>Place [88+D or Ctrl+D]) into your layout. Movies
display as an image based on their first frame, while sounds display as a
speaker icon and print and export that way.

InDesign’s sound and movie format support is limited:

v InDesign can open QuickTime (MOV files) and Microsoft AVI movies, so
be sure your movies are in one of those formats. These movies can be
used only in exported PDF (Version 1.6 and later) files.

v InDesign also supports Adobe Flash animations (SWF files), though it
can export those only to PDF Version 1.6 and later files, as well as for
use in Flash files and HTML pages.
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v For sounds, it supports just the Apple AIFF and Microsoft WAV formats
and can export them only to PDF files.

To control how a movie behaves and what control the reader has, choose
Object=>Interactiver> Movie Options. For sounds, choose Objecte> Interactiver>
Sound Options. The Movie Options dialog box or Sound Options dialog box
appears, as appropriate. Figure 24-6 shows them both.

A faster way to set movie and sound settings is to double-click the frame
containing the movie or sound.

These movie and sound features are expert options, but ones that you should
play with to see what you can do with them.
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Adding Buttons, Rollovers,
and Other Actions

You've no doubt seen those cool Web pages where as your mouse passes over
an object, it changes color or makes something pop up on screen. Or clicking it
makes a movie play or other action occur. InDesign lets you add such capabili-
ties to your documents destined for export to the Web, Flash files, or PDF files.

You set up these actions and states in the Button panel (Windowr>Interactiver>
Button). Figure 24-7 shows the panel, with the Event pop-up menu, the flyout
menu, and the Actions pop-up menu all active (I composited this image; only
one can display at a time in real life).
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Figure 24-7:
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The Buttons panel replaces the States panel from previous versions of
InDesign and adds a few new states to match what Web browsers can support.
Also, InDesign CS4 no longer has a Button tool to create buttons; instead, you
convert any selected item to a button.

Although the Button panel and related controls are expert features, |
describe the basic principles here.

The first thing you need to do is create a button — something for a reader

to click. Any object can be a button, so choose the desired object with the
Selection tool and then click the Convert Object to Button iconic button at the
bottom of the Button panel or choose Object=>Interactiver>Convert to Button.
The object then appears in the Button panel with an initial [Normal] state
appearance, which is how it will appear unless the reader does something
with it. (You can also choose an existing button from a library that InDesign
includes; just choose Sample Buttons from the Button panel’s flyout menu.)

Each button has three possible state appearances: [Normal], [Click], and
[Rollover]. To add a [Click] state, choose On Click from the Event pop-up
menu and then select [Click] and enable its appearance. (Click the empty
box to its left; if the box displays an eye icon, the state will be visible when
the user clicks the button.) You can change the button’s color in its [Click]
state by just clicking a swatch from the Swatches panel (Windows=>Swatches,
[F5]) when the [Click] state is selected in the Button panel. You can also use
the Stroke panel (Windows=>Stroke [8+F10 or Ctrl+F10]) or the Effects panel
(Windowr>Effects [Shift+88+F10 or Ctrl+Shift+F10]) to adjust the button’s
[Click] state appearance.

Use the same technique to adjust the appearance of the [Rollover] state
(used with the On Rollover option in the Event pop-up menu. You can use
any (or several) of the states with the other Event pop-up menu options;
whatever has the eye icon displayed for that option is what the button will
display when the user takes the designated action.
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Most of the events are self-explanatory — On Click, On Rollover, On Roll Off,
and On Release — but two are not: On Blur and On Focus. These rarely used
events essentially let you highlight (focus) specific frames on a Web page or
dehighlight (blur) them. All these terms are used by Web-editing programs,
such as Adobe Dreamweaver, that expert users typically use.

In addition, each event can have one or more actions assigned to it, using
the + iconic button below the Event pop-up menu. (Use the — iconic button to
remove a selected action.) Clicking the + button displays the Actions pop-up
menu, shown in Figure 24-7. You choose the desired action for the current
event and then set up its specifics in the dialog box that appears.

By combining state appearances, events, and actions, you can create a truly
interactive document. Once done, the next step is to export the document to
the desired electronic format.

Exporting Flash Files

ATUR: InDesign CS4 now lets you export documents, or specific pages, as Flash files.

§ When you choose Filer>Export (88+E or Ctrl+E), you get a dialog box, where
among the various Format pop-up menu (Mac) or Save as Type pop-up menu

(Windows) options are two Flash options: Adobe Flash CS4 Pro (XFL) and SWF.

v An XFL file is one that Adobe Flash Professional CS4 can open for further
work, and is the option you should pick if the InDesign-exported file is
meant to be the starting point for your Flash file.

1 A SWF file is a ready-to-play file that can contain animations or, in the
case of those generated from InDesign, rollovers and actions; you can’t
edit a SWF file. SWF files are playable by the Adobe Flash Player, either
directly on a computer or via a Web browser.

Figure 24-8 shows the Export dialog boxes for each Flash option. The options
let you control the size of the exported file, which pages are exported, how text
is handled (kept as Flash text, meaning it’s editable in Flash Pro and embeds
the fonts, or converted either to vector images or to bitmapped images), and
whether pages are rasterized (converted to bitmapped images). The XFL export
has additional controls over which interactive effects, such as buttons and
hyperlinks, are exported, as well as how images are compressed.
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Exporting PDF Files

a\\J

Sometimes you want to create a PDF file for distribution on the Web, on

a CD, on a corporate intranet, or even by e-mail. PDF creation is a simple
task in InDesign. First choose FilewExport (8+E or Ctrl+E) and then choose
Adobe PDF in the Format pop-up menu (Mac) or Save as Type pop-up menu
(Windows).

If you’re working with the InDesign book feature (see Chapter 22), you can
export all of the book’s chapters to a single PDF file from an open book’s panel
by using the Export Book to PDF option in its flyout menu. (If one or more
documents in the book are selected in the panel, the menu option changes to
Export Selected Documents to PDF.) The setup options are the same as for
exporting individual documents.

After you select Adobe PDF in the Export dialog box’s Formats pop-up menu
and give the file a name and location in the File Name and Save in areas,
click Save to get the Export Adobe PDF dialog box, shown in Figure 24-9. The
dialog box has six panes; the General pane is displayed when you open the
dialog box. Several options are accessible from all six panes.

If you know how to use Acrobat Professional, you know how to set up your
PDF export. If not, consult with a local expert because PDF export options are
as complex and job-specific as the print options I cover in Chapter 23.

Some basic options are available in all the panes, and you should feel com-
fortable setting them on your own:
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v Adobe PDF Preset pop-up menu: This pop-up menu lets you select from
both predefined sets of PDF-export settings (similar to the printer pre-
sets covered earlier in this chapter), as well as any presets you or some-
one else may have created.

v+ Compatibility pop-up menu: This pop-up menu lets you choose which
PDF file version to save the file as. Your options are Acrobat 4 (PDF 1.3),
Acrobat 5 (PDF 1.4), Acrobat 6 (PDF 1.5), Acrobat 7 (PDF 1.6), Acrobat 8
(PDF 1.7), and Acrobat 9 (PDF 1.8).

Choosing Acrobat 4 (PDF 1.3) is the best option for plain documents that
you want to distribute on CD or over the Web because it ensures the
broadest number of people will be able to view the file. But it also limits
the ability to use some features, particularly those that protect the doc-
ument from unauthorized usage such as copying its contents.

Choose a later version if you need specific features. For example, choose
Acrobat 6 (PDF 1.5) or later if your document uses transparency or high-
level security settings. Use Acrobat 7 (PDF 1.6) or later for files with
video, audio, and other multimedia features.

v Save Preset button: Click this option to save any settings made in the
Export Adobe PDF dialog box as a new preset. (You can also define new
PDF presets by choosing File=>PDF Export Presetse>Define.)

v Export button: Click this option to create the PDF file based on the
settings that you selected in the various panes.

Export Adobe PDF

Adobe PDF Preset: | [High Quality Print] (modified) A
Standard: | None v C ibility: | Acrobat 8 (PDF 1.7) %

General

Description: |[Based on '[High Quality Print]'] Use these settings to create
Adobe PDF documents for quality printing on desktop
printers and proofers. Created PDF documents can be
opened with Acrobat and Adobe Reader 5.0 and later.
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The General pane

Use the General pane, shown in Figure 24-9, to determine what is exported.
The Pages option gives you the same flexibility as the Print dialog box’s Pages
option, which I cover in Chapter 23. Similarly, the Spread option works like the
same-name option in the Print dialog box, also covered in that chapter.

In the Options section, you can select the following options:

+ Embed Page Thumbnails: Select this option if you're creating a PDF file
to be viewed on-screen. Thumbnails help people to more easily navigate
your document in the Adobe Reader program. However, if you're send-
ing the PDF files to a service bureau or commercial printer for printing,
you don’t need to generate the thumbnails.

v Optimize for Fast Web View: Always select this option. It minimizes file
size without compromising the output.

v Create Tagged PDF: Select this option to embed XML tag information into
the PDF file. It’s useful for XML-based workflows and Adobe eBooks. If you
don’t know what XML or eBooks are, you don’t need to select this option.

v View PDF after Exporting: Select this option if you want to see the
results of the PDF export as soon as the export is complete. Typically,
however, you shouldn’t select this option because you’ll likely have
other things you want to do before launching Adobe Reader (or the full
Acrobat program, if you own it) to proof your files.

v Create Acrobat Layers: If you selected Acrobat 6 (PDF 1.5) or later in
the Compatibility pop-up menu, you can select this option, which out-
puts any InDesign layers to separate layers in Acrobat. (Acrobat 6 was
the first version of Acrobat to support layers.) If you choose an earlier
version in the Compatibility option, Create Acrobat Layers is grayed out.

CATURE v Export Layers: This new pop-up menu gives you additional control over
how layers marked as nonprinting are exported to the PDF file. It used

to be that if you marked a layer as nonprinting, you’d have to leave the
Export Adobe PDF dialog box to open the Layers panel to make it export-
able. Now, you can skip that step and override layers’ nonprinting status
using this pop-up menu. The default option, Visible & Printable Layers,
honors your layers’ printing status. Visible Layers exports all visible
layers, including those marked as nonprinting. All Layers exports both
visible and hidden layers, including those marked as nonprinting. (See
Chapter 5 for more on layers.)

In the Include section, you set what elements of the document are included in
the PDF file. You can select the following options:

+ Bookmarks: This option takes InDesign table-of-contents (TOC) information
and preserves it as bookmarks in the exported PDF file. (See Chapter 20 for
details on TOCs.)
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v+ Hyperlinks: This choice preserves any hyperlinks added in InDesign.
Otherwise, the hyperlinks are converted to standard text in the PDF file.
(Chapter 22 explains how to create hyperlinks in InDesign.)

v Visible Guides and Grids: This setting includes the on-screen guides and
grids in the output version — an option you’d use only when creating PDF
files meant to be used as designer examples, not for readers or for prepress.

+* Non-Printing Objects: This option includes any objects marked as
Nonprinting through the Attributes pane. (Choose Windowr>Attributes.)

+~ Interactive Elements: This option preserves interactive objects, such as
buttons, rather than convert them to static graphics.

v Multimedia: This pop-up menu lets you control how embedded sound
and video are handled. This option is available only if you choose Acrobat
6 (PDF 1.5) or later in the Compatibility pop-up menu. The options are
Use Object Settings, Link All, or Embed All. In InDesign, you can embed a
sound or movie file, or link to one. This option lets you override the indi-
vidual settings and make all such objects embedded or linked.

Security pane

The Security pane is used to protect your documents from unauthorized
usage or copying — something you should strongly consider doing for PDF
files distributed on the Web or in other electronic media.

To enable such protections, be sure the Require a Password to Open the
Document and the Use a Password to Restrict Printing, Editing, and Other
Tasks options are enabled. Here’s how their settings work:

v Encryption Level: This section’s options depend on the option set in
the Compatibility pop-up menu; Acrobat 5 (PDF 1.4) and higher use High
(128-Bit RC4) encryption, while earlier versions use 40-bit RC4.

v Document Open Password: In this section of the Security pane, you
can require a password to open the exported PDF file by selecting this
option and typing a password in the associated text field. If you don’t
type a password here, you're forced to type one in a dialog box that
appears later. To access protected content, recipients must use the
Security pane in Acrobat. (Choose Filec>’Document Properties [88+D or
Ctrl+D] in Acrobat.)

+ Permissions: Here, you determine what restrictions to place on the PDF
file. Note that the following options vary based on what version of the
PDF format you selected in the General pane.

¢ Use a Password to Restrict Printing, Editing, and Other Tasks: You
can restrict recipients’ actions by selecting this option and then
specifying permissible actions by using the Printing Allowed and
Changes Allowed pop-up menus, as well as selecting from among the
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options that follow. (The number of options displayed varies based
on the preset chosen.) You can also require a password to allow
editing of the file in another application.

Printing Allowed: You can select None, Low-Resolution (150 dpi),
or High Resolution. You would disable printing to ensure that the
material can be read only on-screen.

Changes Allowed: You can select None; Inserting, Deleting and
Rotating Pages; Filling in Form Fields and Signing; Commenting,
Filling in Form Fields, and Signing; or Any Except Extracting Pages.
(Signing means using digital signatures to verify sender and recipi-
ent identities.)

Enable Copying of Text, Images, and Other Content: If it’s okay
for recipients to use the PDF file’s objects, select this option.

Enable Text Access of Screen Reader Devices for the Visually
Impaired: If you want the file to be accessible to visually impaired
recipients who use text-reader applications, select this option.
This option is available only if you’re exporting to Acrobat 5 (PDF
1.4) or later.

Enable Plaintext Metadata: For documents with metadata — author-
ing information associated with XML documents and Web pages —
you can make that metadata visible to Web-based search engines and
similar applications by selecting this option. This option is available
only if you're exporting to Acrobat 6 (PDF 1.5) or later.

Exporting to eBook Format

Adobe has created a hybrid document format that combines some PDF and
some Web capabilities, Called an eBook, it’s meant to be a way to deliver
books in a rich-media way for electronic readers and via Adobe’s own Digital
Editions software. Not many people use this format, so I don’t dwell on it.

To export a layout to eBook format, simply choose Filem>Export for Digital
Editions. You get the Save As dialog box, where you choose the disk and
folder to store the exported Web page, as well as the page’s filename. After
you click Save, you get the Digital Editions Export Options dialog box, shown
in Figure 24-10, in which you specify how InDesign converts the layout to the
eBook format. Unless you're eBook-savvy, ask your boss what settings to use.
Here are the basics:

v In the General pane, you choose how to handle bulleted and numbered
lists are handled (see the next section on exporting to the Web), as well
as how styles are converted to the Web’s CSS format (also in the next
section).
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Figure 24-10:
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v+ In the Images pane, you choose how your images are converted to the
Web’s GIF and JPEG formats, selecting options such as image quality and
color palette.

v+ In the Advanced pane, you choose which flavor of the eBook format is
used. (It’s called EPUB here because eBooks have the filename extension
.epub.) You also choose whether the InDesign layout’s table of contents
is exported — because . epub files are typically used for electronic
books, it’s likely you would export the TOC, as books typically have
TOCs.

Click Export when done with your settings.
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Exporting to the Web

InDesign lets you export your layouts to the XHTML format that Web editors
such as Adobe’s Dreamweaver can open for further work. (Note that you'll
usually want to do further work in a Web editor both to take advantage of
Web-specific formatting options and to rework the layout to better fit the
horizontal “page” size of a Web browser.)

To export a layout to XHTML format, simply choose File=>Export for
Dreamweaver. (And despite the name, your files aren’t limited to use by
Adobe’s Dreamweaver software; any Web editor should be able to open the
files.) If you want to export just specific items on a page, select them with one
of the selection tools before choosing this menu option.
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Figure 24-11:
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You get the Save As dialog box, where you choose the disk and folder to
store the exported Web page, as well as the page’s filename. After you click
Save, you get the XHTML Export Options dialog box, shown in Figure 24-11,
in which you specify how InDesign converts the layout to the Web format.
Unless you're Web-savvy, ask your Web master what settings to use:

v In the General pane, you choose whether to export the currently
selected objects or the entire document, as well as how to handle bul-
leted and numbered lists. The default mappings — Map to Unordered
Lists for bullets and Map to Ordered Lists for numbers — work for most
sites. But you can also have InDesign convert either or both such lists
into plain text rather than using the Web’s list functions.

v+ In the Images pane, you choose how your images are converted to the
Web’s GIF and JPEG formats, selecting options such as image quality and
color palette.

| XHTML Export Options
General Images
Images : - _
™ Formatted

Image Conversion: | Automatic | $
GIF Options
’7 Palette: | Adaptive (no dither) |

Interlace

— JPEG Options
Image Quality: | Medium }
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‘ Cancel Export )

ar

ar

v In the Advanced pane, you set how text formatting is converted to the
Web’s version of styles, called cascading style sheets, or CSS. It’s prefer-
able to choose External CSS as the export option, because that choice
has the Web pages use a single style file that all Web pages can refer
to, ensuring consistency (much like InDesign’s styles offer). Note that
InDesign doesn’t create a CSS file for you; you or your Web designer
must create it in a Web-editing program. Also in this pane, you can spec-
ify an external JavaScript file to link to — again, something your Web
designer or programmer will have created separately.

Click Export when done with your settings.

The export process is simple, so it’s easy to forget that converting print lay-
outs to the Web’s format is rarely a “point-and-shoot” activity. Expect your
Web designer to do major work on those exported pages in his Web editing
program, to optimize them for the Web environment. That’s no reflection on
you or InDesign — just the reality of working in different media.



Part VIII
The Part of Tens

The 5th Wave By Rich Tennant

CRAUTENNANT

the charts?”



In this part . . .

Tlis part of the book was what inspired David
Letterman’s Top 10 lists. (Well, it could have!) Forget
about slogging through the details. Here, you get the
quick hits on everything from the coolest new features to
the best resources to augment your InDesign. Plus, you
get a handy cheat sheet of the keyboard shortcuts you’ll
use every day. Think of it as popcorn from a book!




Chapter 25

Top Ten New Features in
InDesign CS4

In This Chapter
Taking a look at finishing touches
Getting the scoop on fancy features

A dmit it — you came here before looking at the rest of the book. I can’t
blame you — everyone loves to know what’s new. Well, InDesign C54

has some really cool new stuff. Much of it falls into the category of nice little
touches that make something that much easier to use.

But InDesign also added a bunch of “Hey, let’s see what the users can do with
this” kind of new thing just to keep everyone’s brain sharp. You’'ll have your
favorite new features, of course, but because I'm writing the book, I get to tell
you mine!

Smart Guides, Spacing, and Dimensions

Smart guides, spacing, and dimensions — three related features — are hands-
down the best addition to InDesign in this version. As Chapter 10 explains,
these features give you visual feedback as you work with objects — create,
resize, move, and rotate them — so that they snap to the locations, sizes,
rotations, and so on of nearby objects. The theory is that most objects are
related to the nearby ones, so it makes sense for, say, a new frame’s left

side to align to the frame nearest it if your mouse gets close to that existing
frame’s horizontal coordinate.

InDesign has always allowed precise positioning with the Transform panel
and later the Control panel — which you still have — but the truth is that
most layout artists are mouse-based, and those controls had no effect on
mouse-driven design work. Now InDesign has solved that issue.
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Cross-References

Programs from more than a decade ago — including Adobe’s own
FrameMaker technical publishing tool — let you add cross-references in
your documents to text on other pages, so the page numbers and even head-
lines references were updated automatically in all the places referring to
them. Now InDesign finally lets you do the same thing, using new controls in
the Hyperlinks panel to provide cross-referencing capabilities. Chapter 24
explains how this tool works.

Flash Export

Sure, Adobe has a vested interest in promoting its Flash Professional anima-
tion tool for the Web, but the truth is that lines separating print, the Web,
and computer-based documents are blurring away. It makes sense for a
layout tool to support all three types of presentation approaches, so the
ability to export InDesign files to Flash format is very welcome.

The Flash export capability gives you a new venue to use existing InDesign
capabilities, including hyperlinks, rollovers, embedded audio, embedded
video, and the new page transitions. Chapter 24 explains the new Flash
export feature.

Nested Lines

I've been whining for this feature ever since Adobe introduced the nested
styles feature in the CS version. (See — they do listen!) Nested styles are a
great way to apply formatting based on regular patterns, such as making the
first sentence always bold or the text through an em space use a specific
character style (such as for lists).

But many designers like to make the first line or two of a paragraph — typi-
cally at the beginning of a story or section — all small caps or have a char-
acter style applied. Nested styles can’t do that, as they didn’t know how to
count lines. As Chapter 13 explains, InDesign now knows how to count lines
so that you can apply a desired style to however many lines in arrow that
you want.
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Dynamic Autoflow

Although InDesign already had an option to add pages as needed to your
layout as you placed text files, the CS4 version makes the process easier and
gives you more control over such autoflow, as Chapter 11 explains.

Pointer Information

This feature is one of those subtle improvements that you wonder how no
one thought of it before. You can now have InDesign display near your mouse
pointer the current coordinates, so when you're drawing, rotating, or resizing
something, you can see exactly where the mouse is, what size the object is,
and what the new rotation is.

You're focused on that mouse pointer while you're working, so it makes per-
fect sense to display that key information — what InDesign calls transformation
values — where your attention is. Chapter 8 shows what [ mean.

Spread Rotation

Spread rotation also falls in the “Why didn’t they think of it before?” depart-
ment. When you use rotated text, it’s hard to edit! After all, you can’t turn
your head at those angles (at least I can’t!). So now InDesign lets you rotate
specific spreads so that you can work with the text straight on. Of course,
these rotated spreads are just for viewing; they print the normal way, as
Chapter 8 explains.

Conditional Text

Some people work on documents, such as catalogs and price sheets, that
have multiple versions with regional or other minor differences, requiring
several versions of the document with just slight differences. Imagine a price
sheet that has prices in euros, U.S. dollars, yen, Canadian dollars, and British
pounds — except for the prices, everything’s the same, yet you need to make
them into separate documents and then update any description changes
across them all. That’s a management fiasco waiting to happen.

InDesign CS4’s conditional text feature solves that, letting you have one docu-
ment with all the variants in it. You then have the ability to toggle among
each of the variants. Chapter 21 explains how to use this new feature.
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Automatic Preflighting

Preflighting is something we all should do, but often don’t: Review the layout
for the little gotchas that can ruin the printed version. One example is not
noticing that a photo is RGB so that when it prints in CMYK on a high-end
printer, its colors are off. Another example is a low-res preview file that you
forgot to replace before printing with the high-res version. Or a TrueType
font that you used by accident on an imagesetter that supports only
PostScript fonts. You get the idea.

Now, InDesign is always checking your document as you work on it, display-
ing the number of current errors at the bottom of the document window.
(Boy, is that scary to watch!) This double-check means that you can see that
you have issues early enough to fix them, before a crisis ensues.

Even better, InDesign lets you create your own preflight profiles so that you
can define exactly what issues to be on the hunt for. Chapter 23 explains how
preflighting works.

PDF Page Rotations

Okay, this feature is an eye-candy pick; most documents will never use it. But
if you're creating PDF or Flash files from your InDesign document, you can
now set page transitions — those animated wipes, fades, and corner peels
common to PowerPoint presentations — so as someone moves from one
page to another in a PDF or Flash file, they get those same transition effects.
Dorky but cool. Chapter 24 explains how to apply them.
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Top Ten Resources for
InDesign Users

In This Chapter
Discovering useful Web sites
Using Adobe Web resources
Finding books to read

Wlen you'’re ready to expand your horizons beyond what I can squeeze
into the pages of this book, check out this chapter. No matter what

type of information you’re looking for, you can find it here among this handy
list of InDesign resources.

Web Sites

Web sites are a great ongoing resource because they let you keep up with
news, techniques, and product versions. Here are four sites that belong in
your bookmarks.

InDesignCentral

www.indesigncentral . com

To help you keep up with the dynamic field of publishing, I've created an
independent Web site that helps InDesign users stay current on tools and
techniques. InDesignCentral provides the following resources:

v Tools: Links to plug-ins, scripts, utilities, and Adobe downloads.

v~ Tips: My favorite tips, as well as reader tips.

v Resources: Print publishing links, Web publishing links, Mac OS X links,
and Windows links.
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v Adobe InDesign Bible series and QuarkXPress to InDesign: Face to
Face: Excerpts from the books, including updates from after the books’
releases and color versions of the screen images from the chapters that
cover color.

The Adobe Web site

www . adobe . com

The friendly people at Adobe, who gave the world InDesign, recognize the
value in providing useful information for users of their software solutions.
The Adobe Web site offers InDesign tips and tricks, guides, interactive tutori-
als, and lists of user groups. It’s worth your while to visit the site now and
then to see what’s new. Be sure to check out the InDesign community area
for pro tips and help from users just like you.

InDesign User Group

www . indesignusergroup.com
Seeking to help InDesign users share skills and tips, Adobe is supporting
local user groups in many cities. Here’s your chance to extend your InDesign
knowledge and enlarge your personal network of graphics and layout
experts.

You can also find links to several how-to guides from Adobe.

Creativepro

www.Ccreativepro.com

Looking for the latest product and industry news? Go to Creativepro.com, an
online magazine that also functions as a resource and reviews center.

Magazine Resources

The Web has revolutionized content delivery, but a good old-fashioned maga-
zine is hard to beat for the richness of its information and the ability to take
advantage of its knowledge almost anywhere you happen to be.
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InDesign Magazine

www . indesignmag.com

This PDF-delivered bimonthly magazine takes the expertise of a whole bunch
of InDesign power users and puts it into one place, giving you a regular flow
of great ideas, tips, and tricks. While it’s not as convenient as a print maga-
zine, the PDF format does have the advantage of being easy to store and keep
with you wherever your computer happens to be. Plus, you can always print
an article and take it with you if you want.

Layers magazine

www.layersmagazine.com

A great resource for tips and tricks specific to the Adobe universe of prod-
ucts is Layers magazine, which produces six glossy issues each year, chock-
full of tips and how-to advice.

Macworld magazine

www . macworld.com

Macworld magazine remains a spectacular resource for publishers of all skill
levels, providing graphics guidance as well as general news and advice about
the Mac platform that most designers use.

Recommended Books

Wiley Publishing, Inc., the publisher of this book, also offers a wide range
of books to help layout artists and publication designers exploit publishing
tools to the fullest. The following four books — the first two [ wrote — can
help you expand your InDesign knowledge and related areas of expertise:

v My Adobe InDesign CS4 Bible gives you extensive insight and tips on
using the newest versions of InDesign in professional publishing
environments.

v My QuarkXPress to InDesign: Face to Face shows you how to make the
move from QuarkXPress to InDesign. You'll be running at full speed in
no time, leveraging your knowledge of QuarkXPress and translating it
into InDesign’s approach. Although this book was written using the CS2
version, its techniques apply to the CS4 edition as well.
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v Adobe Creative Suite 4 Bible, by Ted Padova, Kelly L. Murdock, and
Wendy Halderman, provides an all-in-one resource for users of Adobe’s
cornerstone tools (Photoshop, Illustrator, Acrobat Professional, and
InDesign).

v Digital Photography: Top 100 Simplified Tips & Tricks, by Gregory
Georges, provides clear, illustrated instructions for 100 tasks that reveal
cool secrets, teach timesaving tricks, and explain great tips to make
you a better digital photographer. To help you understand the implica-
tions of digital photography on the production process, Total Digital
Photography: The Shoot to Print Workflow Handbook, by Serge Timacheff
and David Karlins, offers complete, end-to-end workflow advice from
shoot to print in a full-color presentation.
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absolute page numbers, 18, 70
Acrobat Professional, CSM settings for, 354
active panel, 26
Adobe Creative Suite 4 Bible (Padova,
Murdock, and Halderman), 394
Adobe Dreamweaver, exporting to, 59
Adobe Flash formats
exporting in, 59, 377-378, 388
hyperlinks in files, 370
Adobe Illustrator, 281, 354
Adobe InDesign CS54 Bible (Gruman), 129,
393
Adobe Paragraph Composer, 248
Adobe Single-Line Composer, 248
Adobe Web site, 392
agates, specifying, 12, 40
Align panel, 177-178
aligning. See arranging and aligning;
justification
Alspach, Ted (lllustrator CS4 For Dummies),
129
anchor points
overview, 125, 127
selecting, 139
anchored frames
adjusting, 187
caveats for, 186
converting existing frames to, 186-187
creating, 183-185
deleting, 188
described, 180
inline frames versus, 183
object style options, 161
releasing the anchor, 188
application bar, 17
application frame, 16-17
arranging and aligning. See also
justification; stacking order
aligning objects to each other, 177-178
aligning paragraphs, 239-240

layers, 83

objects using coordinates, 167-168

optical margin alignment, 44, 273-274

Snap to Document Grid option, 175

Snap to Guides option, 172

tabs for text, 305-307

windows, 19-20
arrow key preferences, 41
Autocorrect feature, 221-222
autoflow feature, 194-195, 205, 389
automatic recovery feature, 60
automatic text

conditional text, 334-336, 389

improvements for, 329

page numbers, 330

section markers for, 330-331

text variables for, 331-334

ol e

baseline, defined, 42
baseline grid
changing settings for, 176
described, 169
frame-based grid versus, 177
showing and hiding, 46, 176
baseline shift, 41, 257
bevel effect, 153-154
bitmap graphics
file formats, 282
import options for, 287-288
bleed area, 53
Bleed mode, 25
blending modes, 150-151
blends. See gradients
BMP format, 282, 287
booklets, printing setup for, 351-353
bookmarks in PDF files, 373-374, 380
books (InDesign)
chapter numbers, 343-344
closing, 338, 340
creating, 337-338
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books (InDesign) (continued)
defined, 337
deleting chapters, 339
indexes, 320-324
opening, 338
page numbers, 342-343
printing chapters and books, 342, 356
replacing chapters, 339
saving, 340
status reports for chapters, 340
style sources, 340
synchronizing formatting, 341-342
table of contents, 324-327
working with chapters, 338-342
Bridge CS4, CSM settings for, 353-354
bulleted lists, 265-268
buttons and button actions, 375-377

oo

calculations in panel fields, 28
calibrating color, 353-355
capitalization controls, 255-256, 258-259
capitalization of index topics, 323
cell styles, 47, 313-315
Cell Styles panel, 314-315
centimeters, specifying, 12, 41
Character panel
changing font size using, 254-255
changing fonts using, 254
kerning controls, 262
overview, 251
on smallish monitors, 253
strikethrough or underline styles, 275
tracking controls, 262
character styles
applying to text, 234-236, 252
Basic Character Formats, 255-256
creating, 229
defaults, 47
font selection, 254
font size, 254-255
managing, 234
paragraph styles using, 230
paragraph styles versus, 228
Quick Apply panel for, 236
sharing, 233
style groups, 233-234
updating, 232

Character Styles panel, 229, 253
characters. See also fonts; glyphs
applying formats to, 251-253
baseline shift, 41, 257
Basic Character Formats, 255-256
capitalization controls, 255-256, 258-259
fractions, 271-273
kerning, 261, 262
leading applied to, 262, 263
ligature controls, 255-256, 260-261
preventing hyphenation, 261
scaling, 256-257
skewing (artificial italics), 257-258
strikethrough controls, 255-256, 259-260
stroke adjustments, 276
superscript and subscript controls,
255-256, 259
tracking, 261, 262-263
underlining controls, 255-256, 259-260
checking documents before printing
identifying and fixing errors, 348-349
preflight options, 349-350
visual check, 347-348
ciceros, specifying, 12, 41
clicking
defined, 2
triple clicking to select line, 35
Clipping Path command, 299-301
clipping paths
converting to frames, 297, 301
creating, 298-301
default attributes, 45
defined, 297
for imported graphics, 287, 297-298
for masking out graphics, 294
removing, 301
for text wrap, 208
closed paths, creating, 129
CMS (color management system), 353-355
CMYK color model, 100, 102, 103
color management system (CMS), 353-355
color swatches. See also Swatches panel
applying, 115
copying, 111
creating, 99-103
defaults, 47
deleting, 112
exporting, 114
importing, 47, 112-113
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Kuler colors, 104
libraries of, 102-103
mixed-ink, 105-106
modifying, 111
spot versus process colors, 100
tints, 106-107
colors. See also color swatches
applying, 115
calibrating, 353-355
color models available, 102
duotone, 105
gradients, 107-111
importing, 47, 112-113
Kuler panel for, 104
for layers, 79
mixed-ink, 105-106
predefined, 99
process, 100
sampling, 113-114
spot, 100
for strokes, 132
themes, 104
tints, 106-107
unnamed, 103
column guides. See margin and column
guides
columns
changing in text frames, 207-208
changing location of guides, 18
default settings, 42
defined, 18
for master pages, 89
for new document, 53
readability impacted by, 206
specifying in master text frames, 207

text wrap options for objects splitting,

210
combining layers, 83
Composition preferences, 37-39
conditional text, 334-336, 389
contextual menus, 26
Control panel
applying character formats with, 252
applying paragraph formats with, 238
changing font size using, 255
changing fonts using, 254
kerning controls, 262
positioning objects using, 167-168
rotating objects using, 143

selecting objects using, 138

shearing objects using, 145

strikethrough or underline styles, 275

tracking controls, 262
control point, 11
Control+clicking. See right-clicking
converting

bulleted or numbered lists to paragraphs,

267

clipping paths to frames, 297, 301

frames to anchored frames, 186-187

shape to different shape, 122

tabs to and from tables, 315

text into shapes, 276-277

text variables to text, 333

Word endnotes to footnotes, 320
copying

before adjusting layouts, 76

color swatches, 111

to different layer, 82

graphics into InDesign, 292

to hidden or locked layer, 82

index topics, 323

library items, 98

master pages, 90

object styles, 161

opening document copy, 57

pages among documents, 65

pages within documents, 65

saving document copy, 57

text from InDesign, 203

text into InDesign, 203

text styles, 234
Corner Options feature, 148-149
corner points

corner options, 148-149

defined, 125

object style options, 160

working with, 127
crash, recovering from, 60
Creativepro Web site, 392
cropping graphics, 23, 293-294
cross-references, hyperlink, 371-373, 388
customizing InDesign. See preferences
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defaults. See also preferences

colors, 47

document, 42

master page, 88

measurement unit, 12

object, 44-45

styles, 47

text, 44

views, 45-46
deleting or removing

anchored frames, 188

bullets from lists, 267

chapters, 339

clipping path from graphic, 301

color swatches, 112

horizontal rules, 250

hyperlink target or source, 370

index topics, 323

inline frames, 182

layers, 84

library items, 97

local overrides, 93

master pages, 91, 93

numbers from lists, 267

object from a group, 156

object styles, 161

objects, 141

pages, 65

ruler guides, 172

section start, 70-71

tabs, 307

text styles, 234

text variables, 333

unused layers, 84
deselecting objects, 138
dictionary for spell-checker, 224-226
Digital Photography: Top 100 Simplified Tips

& Tricks (Georges), 394

Direct Selection tool, 22, 122, 123
directional feathering, 153, 154
disaster recovery, 60
docks and docking, 27, 28-29
document grid, 46, 169, 174-175

document preferences
accessing, 34
Composition, 37-39
defaults, 42
Measurement, 39—41
Type, 35-37
document windows
application bar, 17
application frame, 16-17
displaying multiple, 19-20
guides, 18
overview, 14
page controls, 18-19
pages, 18
pasteboard, 16
rulers, 15
zero point, 15-16
documents. See also multimedia projects;
pages; spreads
applying master pages to, 92
checking before printing, 347-350
closing, 57
creating and choosing settings for, 51-54
creating from templates, 87
creating with most recent settings, 54
defaults, 42
disaster recovery, 60
dividing into sections, 69-70
exporting content, 58-59
opening, 51, 54-56
Package feature, 362-364
preferences, 34-41
removing section start, 70-71
reverting to saved version, 57
saving, 57-58
starting on left page, 67-68
double-click, defined, 3
dragging. See also copying; moving items
defined, 3
graphics into InDesign, 292
items into library, 96
navigator feature, using, 73
objects to different layer, 82
objects to new location, 140
pages among documents, 65
pages within documents, 65



panels, 27

resizing objects, 139

text editing preferences, 36

text into InDesign, 203
drawings, 281. See also graphics
Dreamweaver, exporting to, 59
drop caps, 11, 243-244
drop shadows, 151-153
duotone colors, 105
duplicating. See copying

oF o

eBooks, 59, 370, 382-383

Edit menu, 30

editing text
basic capabilities, 213
highlighting, 214
navigating, 214
replacing formatting, 218-219
replacing glyphs, 219-220
replacing missing fonts, 221
replacing text, 217-218
saved queries for, 220
searching, 216-217
spell-check feature, 220-226
Story Editor for, 215-216
Type tool for, 213
undoing edits, 215
zooming for, 214

Effects panel, 150-153

em, defined, 261

embedding links, 165

emboss effect, 153-154

end points, 125

Enhanced Metafile (EMF) format, 281
EPS (Encapsulated PostScript) format

clipping paths, 297

exporting in, 59

for graphics, 281, 282, 287

import options for, 289, 290
Excel files, importing, 201-202
exporting

color swatches, 114

copying text from InDesign, 203

document content, 58-59

eBooks, 59, 382-383

Flash files, 59, 377-378, 388

format options for, 58-59

layers, controlling which are exported, 80
PDF files, 59, 371, 378-382

in XHTML format, 371, 383-384

ofFe

faces, 253. See also fonts
facing-pages layout. See spreads
feathering, 153-154
File menu, 30
fills
adding to shapes, 132
defined, 125
object style options, 159
in tables, formatting, 312-313
transparency for, 150
finding. See searching
fitting commands for graphics, 294-296
Flash formats. See Adobe Flash formats
flattening layers, 83
flipping objects, 145
floating panels, 27
flush-left/flush-right text. See justification
folios, 77
font family, 253. See also fonts
fonts
changing between, 253-254
changing size of, 254-255
defaults, 44
fraction typefaces, 271-272
label formatting, 269
packaging with documents, 363, 364
preview preferences, 36
replacing missing, 221
substitutions, highlight preferences, 38
terminology, 253
footnotes, 317-320
fractions, formatting, 271-273
frame-based grid, 169, 177
frames. See also objects; shapes; text
frames
adding fills, 132
anchored, 161, 180, 183-188

Index 399
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frames (continued)
converting clipping paths to, 297, 301
converting to anchored frames, 186-187
corner style, 45
creating, 23, 24, 120-121
cropping graphics by adjusting, 23, 294
defined, 13
editing manually, 122
fitting, 295
inline, 161, 180, 181-183
Miter Limit, 130
object defaults, 44-45
object style options, 160, 161
as placeholders, 119
placing imported graphics in, 284-285
resizing, 23, 140
selecting, 122
shapes versus, 119
showing links between text frames, 46
on templates, 85
text defaults, 44
text wrapping options, 208
text wrapping preferences, 38-39
tools for creating, 119-120
Free Transform tool, 146

oG o

Georges, Gregory (Digital Photography: Top

100 Simplified Tips & Tricks), 394
GIF format, 282, 287
global tools, 10, 11
glyphs
defined, 38
scaling, 248
searching and replacing, 219-220
substitutions, highlight preferences, 38
Gradient Feather tool, 110, 111
gradient feathering, 153, 154
Gradient panel, 109-111
gradients
adding stop points for, 109
applying, 115
changing transition rates for, 109
creating swatches, 107-109
defined, 107
Gradient Feather tool for, 110, 111
Gradient panel for, 109-111

naming, 107
rotating, 110
unnamed, 109

graduated fills. See gradients

graphics. See also objects
adjusting layouts, 74-76
clipping paths, 287, 294, 297-301
copying and pasting into InDesign, 292
cropping, 23, 293-294
dragging and dropping into InDesign, 292
file formats, 281-283
fitting commands for, 294-296
import options for, 286-291, 292
importing using Place command, 283-286
InDesign file import options, 291
irregular shapes, 296-301
layers, handling after import, 292
layers, handling during import, 291-292
links to, 283
masking out, 294
moving frame separately from, 22
moving within a frame, 22, 23
packaging with documents, 363
preparing for importing, 281-283
resizing, 295
scaling, 295
terminology, 281
text wrap using “holes” in, 210

grids
baseline, 46, 169, 176-177
document, 46, 169, 174-175
frame-based, 169, 177

groups
creating, 156
knockout group, 151
removing an object from, 156
restricting transparency to, 151
selecting objects in, 138, 156
for text styles, 233-234
transforming, 156
ungrouping, 156
uses for, 155

Gruman, Galen (author)
Adobe InDesign CS4 Bible, 129, 393
QuarkXPress to InDesign, 393

guides. See margin and column guides;

ruler guides; smart guides
gutter, 53, 89
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Halderman, Wendy (Adobe Creative Suite 4
Bible), 394
Hand tool, 25, 73
hanging punctuation, 273-274
Help menu, 31
hidden characters, showing, 44
hidden layers
copying objects to, 82
moving objects to, 82
text wrap on, 80, 208
hiding. See showing or hiding
highlighting
problems, preferences for, 38
text, 214
horizontal rules, 249-250
hyperlinks
creating, 366-369
cross-references, 371-373, 388
defined, 365
deleting target or source for, 370
document types and retention of, 370
modifying, 370
Hyperlinks panel, 365-366
hyphenation
automatic, settings for, 245-246
defined, 244
highlight preferences, 38
manual, 244-245
preventing, 261
single-line or paragraph composition, 248
spell-check customization, 226

o]e
illustrations, 281. See also graphics
Illustrator (Adobe), 281, 354
Hlustrator CS4 For Dummies (Alspach), 129
images, 281. See also graphics
importing
autoflow feature for, 194-195, 205
color swatches, 47, 112-113
footnotes from Word, 318
graphics, alternative methods, 292
graphics import options, 286-291
graphics, preparing files for, 281-283

graphics using Place command, 283-286
index topic lists, 323
master pages, 91
Microsoft Excel files, 201-202
object styles, 161
PageMaker documents, 55, 56
placing imported text, 197-198
preferences, 43
QuarkXPress documents, 55, 56
styles, 47
tables, 307
text by copying and pasting, 203
text by dragging, 203
text variables, 333
Word or RTF files, 198-200
inches, specifying, 12, 40
indenting paragraphs, 240, 307
InDesign Interchange format, 59
InDesign Magazine, 393
InDesign Markup (IDML) format, 59
InDesign menu, 30
InDesign Tagged Text format, 59
InDesign User Group, 392
InDesignCentral Web site, 4, 6, 391-392
Index panel, 321-324
indexes
adding entries to, 321-323
caveat for creating, 320
Index panel overview, 321
polishing and generating, 323-324
style choices for, 320
usefulness of, 320
inline frames
adjusting, 182-183
anchored frames versus, 183
creating, 181-182, 186
deleting, 182
described, 180, 181
leading issues with, 181
object style options, 161
inner glow effect, 153-154
intercaps, 220
Internet resources, 391-392
italics, artificial (skewing), 257-258
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JPEG format
for graphics, 282
import options for, 287-288
saving page, spread, or text as, 59
scaling when importing files, 285
justification
alignment controls, 239
controlling, 247-248
defined, 244
highlight preferences, 38
single-line or paragraph composition, 248
text wrapping preferences, 39

o o

kerning
arrow key preferences, 41
controlling, 255-256, 262
defined, 42, 261
highlight preferences, 38
increments for, 261
tracking versus, 263
key combination conventions
in this book, 2
knockout group with blending modes, 151
Kuler panel, 104

o/ o

Lab color model, 102
label formatting, 268-269
layers
Acrobat, 380
colors for, 79
combining (flattening), 83
creating, 78-79
customizing, 79-80
cutting and pasting to, 82
deleting, 84
entire document encompassed by, 78
guides for, 80
hiding, 76
image, handling after import, 292

image, handling during import, 291-292
locking guides on, 80
locking layers, 79-80
moving objects among, 82
overlays compared to, 76, 77-78
overview, 77-78
placing objects on, 81-82
printing or preventing from printing, 80
rearranging, 83
selecting multiple, 82
selecting objects on, 81
showing, 79
stacking order for, 77, 83
for template annotation, 86
unused, deleting, 84
uses for, 76-77
Layers magazine, 393
Layers panel
creating a layer, 78
deleting layers, 84
merging layers, 83
rearranging layers, 83
selecting objects on layers, 81
Layout menu, 30
layouts. See also master pages; templates
adjusting, 74-76
default settings, 42
visual proof before printing, 347-348
leaders for tabs, 306-307
leading
arrow key preferences, 41
character-by-character basis for, 262, 263
controlling, 241, 263
defined, 42, 241, 263
inline frame issues for, 181
preferences, 35
text wrap based on, 211
text wrapping preferences, 39
letter spacing in justified text, 247
letters for page numbers, 68
libraries
adding items to, 96
copying items onto document pages, 98
creating, 94-95
defined, 94
deleting items from, 97
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panels, managing, 98
searching for items, 97
snippets versus, 95
tagging items, 96-97
ligatures, 255-256, 260-261
lighting effects, 152-154
line art, 281. See also graphics
line spacing. See leading
Line tool, 24, 123
linear gradients, 110
lines. See also paths
changing bounding box for, 123
changing length and angle of, 123
characteristics set in Stroke panel, 124
drawing, 123
horizontal rules, 249-250
Line tool for, 122
links. See also hyperlinks
defined, 13
editing the original file, 166
embedding, 165
finding the source file, 166
to graphics, 283
navigating to, 165
packaging graphics with documents, 363
reestablishing, 164-165, 166
showing between text frames, 46
to source text files, 163
threading text frames, 204-205
unlinking, 166
updating, 165
Links panel
controlling what appears in, 166
options, 164-166
overview, 163-164
loading. See importing
local overrides, 93
local tools, 10-11
locking or unlocking
column guides, 172
copying objects to locked layer, 82
guides for layers, 80
layers, 79-80
moving objects to locked layer, 82
object to page, 80, 157
ruler guides, 171
zero point, 16

ol o

Macworld magazine, 393
magazine resources, 392-393
margin and column guides
changes when adjusting layouts, 75, 76
changing location of, 18
created for active layer, 80
described, 18, 169
hiding, 46
moving, 172
unlocking, 172
margins
adjusting layouts, 74-76
changing location of guides, 18
default settings, 42
defined, 18
for master pages, 89
for new document, 53
optical alignment, 44, 273-274
marquee for selecting objects, 136
master objects
applying text wrap to, 211
changing on document pages, 93
defined, 90
local override for, 93
modifying on master page, 90
releasing from parent master, 90
selecting, 93
showing and hiding, 46, 93
master pages
adding pages to document, 64
applying to document pages, 92
basing on a document spread, 90
basing on another master page, 90
changing attributes of, 89
columns, 89
copying, 90
creating new, 88-89
default, 88
defined, 87
deleting from documents, 91
displaying, 71
importing, 91
layers with, 81
margins, 89
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master pages (continued)
for new documents, 52-53
page numbers on, 89
Pages panel location for, 89
removing from document page, 91, 93
ruler guides for, 170
selecting objects on, 136
for spreads, 89
templates versus, 87
master text frames
adding for repeating elements, 193, 194
applying text wrap to, 211
autoflow feature, 194-195, 205, 389
changing settings for, 195-196
creating, 192
creating with new document, 192
specifying columns, 207
types of, 192
uses for, 191
measurement values
codes for specifying, 12
default measurement unit, 12
preferences, 39-41
for rulers, 15
menus
contextual, 26
conventions in this book, 2
flyout, for libraries, 95
flyout, on Tools panels, 26
navigating with, 72
overview, 30-31
Preview Mode button, 25
showing all options, 10
merging layers, 83
Microsoft Excel files, importing, 201-202
Microsoft Word files
converting endnotes to footnotes, 320
importing footnotes from, 318
importing text from, 198-200
millimeters, specifying, 12, 40
mixed-ink colors, creating, 105-106
monitors, small
Character panel on, 253
table-related panels on, 309
mouse terminology, 2-3
movie files, 374-375
moving around. See navigating

moving items

anchored frames, 187

arrow key preferences for, 41
column guides, 172

to different layer, 82

Direct Selection tool for, 22
frame without moving graphic, 22
graphic within its frame, 22, 23
to hidden or locked layer, 82
inline frames, 182—-183

mouse for, 140

pages among documents, 66-67
pages within documents, 65-66
placing on layers, 81-82
Position tool for, 23

ruler guides, 171

Selection tool for, 22

X and Y coordinates for, 141

multimedia projects

bookmarks in PDF files for, 373-374, 380
buttons and button actions for, 375-377
exporting eBooks, 59, 382-383
exporting Flash files, 59, 377-378
exporting PDF files, 59, 378-382
exporting to the Web, 383-384
hyperlinks for, 365-373

sound files for, 374-375

video files for, 374-375

multipage documents. See also pages;

spreads
adjusting layouts, 74-76
dividing into sections, 69-70
numbering pages, 68
removing section start, 70-71
single-sided, 62
starting on left page, 67-68

multiple text versions (conditional text),

334-336, 389

multiwindow feature, 19-20
Murdock, Kelly L. (Adobe Creative Suite 4

Bible), 394

o\ o

navigating

jumping to a page, 18-19, 72
keyboard shortcuts for, 72
to links, 165
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menu commands for, 72

navigator feature for, 73

page controls for, 18

Pages panel for, 71-72

text, 214

tools for, 24-25
nested paragraph styles, 230-232, 388
New Feature icon, 5
Normal mode, 25
Normal Mode button, 25
numbered lists, 265-268
numbering book chapters, 343-344
numbering footnotes, 318-319
numbering pages. See page numbers

o () o

object defaults, 44-45
Object menu

flipping commands, 145

overview, 31

Select submenu, 137-138
object styles

applying, 147-148, 162-163

Basic Attributes panes, 159-161

creating, 157-161

defaults, 47

deleting, 161

duplicating, 161

families of, 159

loading, 161

managing, 161, 163

modifying, 161

predefined, 162

previewing, 158

redefining, 161

usefulness of, 157

viewing current settings, 159

objects. See also frames; master objects;

shapes
aligning to each other, 177-178

copying to hidden or locked layers, 82

Corner Options feature, 148-149
defaults, 44-45

defined, 119

deleting, 141

deselecting, 138

flipping, 145
grouping, 156
locking to page, 80, 157
object-creation tools, 24
placing on layers, 81-82
positioning with coordinates, 167-168
preventing from printing, 141
removing from a group, 156
repeating transformations, 146
replacing attributes, 146-148
resizing, 139-140
rotating, 142-144
selecting anchor points on, 139
selecting contents of, 137
selecting objects, 81, 135-138, 179
shearing, 145
stacking order for, 179
styles, 47, 147-148, 157-163
ungrouping, 156
unrotating, 143
unshearing, 145
optical margin alignment, 44, 273-274
orphans, controlling, 242-243
outer glow effect, 153-154
outlines, converting text into, 276-277
overlays, layers versus, 76, 77-78
overset text, 204

oo

Package feature, 362-364
packages, defined, 13
Padova, Ted (Adobe Creative Suite 4 Bible),
394
page controls, 18-19
page layouts. See layouts
page numbers
absolute, 18, 70
automating, 330
changing the starting number, 68
layers for folios, 77
letters for, 68
on master pages, 89
navigating with page controls, 18
removing section start, 70-71
Roman numerals for, 68
section-based, 69-70, 343-344
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new in CS4, 27
selecting options, 28

PageMaker documents, opening, 55, 56
pages. See also master pages; spreads

adding to document, 63-64

adjusting layouts, 74-76

applying master pages to, 92

changing master objects on, 93

copying, 65

copying library items onto, 98

deleting, 65

fitting in window, 72

hyperlinks to, 366-367

inserting uneven number in spreads, 64

locking objects to, 80, 157

moving among documents, 66-67

moving within documents, 65-66

navigating, 18-19, 71-73

overview, 18

saving as JPEG files, 59

selecting, 64-65

specifying for new document, 52

starting documents on left page, 67-68

switching between master and document
pages, 71

Pages panel

absolute page numbers in, 70

adding pages, 63-64

copying pages, 65

deleting pages, 65

master pages on, 89

moving pages among documents, 66-67

moving pages within documents, 65-66

navigating with, 71-72

opening, 62

overview, 61-62

selecting pages, 64-65

starting documents on left page, 67-68

panels. See also specific panels

access via Window menu, 26

active, defined, 26

calculations in fields, 28

changing values in fields, 28

closing, 26

collapsing and expanding, 27

controls typically found on, 26-27

dragging to and from docks, 27

floating, 27

library, 98

showing and hiding, 28

switching between, 26
Pantone colors, 100, 102-103
Pantone Matching System (PMS), 102
Pantone Process Coated library, 102
Pantone Solid Coated library, 102
Pantone Solid Matte library, 103
Pantone Solid Uncoated library, 103
paragraph composition, 248
Paragraph panel, 237, 238, 252
paragraph styles

alignment controls, 239-240

applying different style to next

paragraph, 230

applying to text, 234-236

Basic Paragraph, 44, 230

character styles versus, 228

creating, 228, 229-230

defaults, 44, 47

drop cap controls, 243

horizontal rule controls, 249-250

hyphenation controls, 246

indent controls, 240

justification controls, 247-248

managing, 234

nested, 230-232, 388

object style options, 160

Quick Apply panel for, 236

sharing, 233

style groups, 233-234

for table of contents, 324-326

updating, 232

using character styles, 230

widow and orphan controls, 242-243
Paragraph Styles panel, 228
paragraphs

aligning, 239-240

applying formats to, 237-238

bulleted lists, 265-268

controlling breaks, 242-243

drop caps, 11, 243-244

horizontal rules for, 249-250

hyphenation, 38, 226, 238, 244-246, 248,

261
indent controls, 240, 307
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inserting space between, 241
justification, 38, 39, 239, 247-248
labeling, 268-269
numbered lists, 265-268
pasteboard, 16
paths
anchor points, 125
applying strokes to, 124
closed, creating, 129
closed, defined, 129
closure property, 124
contents of, 125
defined, 123, 124
direction lines, 125
drawing curves, 127-128
drawing zigzags, 126-127
fills for, 125
joining, 128-129
segments, 125
text following, 278
of text outlines, 277
tools for creating, 123
PCX format, 282, 287
PDF (Portable Document Format)
bookmarks, 373-374, 380
controlling layers exporting to, 80
defined, 13
exporting in, 59, 371, 378-382
for graphics, 281, 282
hyperlinks in, 370, 371, 381
import options for, 289, 290
rotating pages, 382, 390
security settings for, 381-382
Pen tool, 24, 126-128
Pencil tool, 126
Photoshop CS4, CSM settings for, 354
Photoshop file format, 282, 283, 287, 297
Photoshop For Dummies series (Wiley
Publishing), 297
picas, specifying, 12, 40
PICT format, 282, 283, 287
pictures. See graphics
Place command, 283-285
placeholders. See frames
plug-ins, 13
PMS (Pantone Matching System), 102
PNG format, 282, 283, 287, 288

pointer, defined, 2
pointer information, 389
points, specifying, 12, 40
Portable Document Format. See PDF
Position tool, 23
positioning. See arranging and aligning;
moving items
power failure, recovering from, 60
preferences
color defaults, 47
Composition, 37-39
defined, 33, 34
document defaults, 42
importing or loading, 43
Measurement, 39-41
methods for changing, 34
object defaults, 44-45
presets, 43
reversing changes, 34
stored, 43
style defaults, 47
text defaults, 44
text wrap, 38-39, 211
Type, 35-37
view defaults, 45-46
Preflight panel, 349
preflighting capability
defined, 348, 390
of Package command, 363
setting options for, 349-350
using, 348-349
presets, 43
Preview mode, 25
Preview Mode button, 25
printing
booklets setup for, 351-353
books, 342, 356
chapters, 342
checking documents before, 347-350
creating a document package, 362-364
layer uses for, 76-77, 80
preventing objects from, 141
Print dialog box options, 356-362
using a service bureau, 362-364
process colors, 100
publishing books. See books (InDesign)
pull-quotes, 271
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QuarkXPress documents, opening, 55, 56
QuarkXPress to InDesign (Gruman), 393
Quick Apply panel, 28, 236

QuickTime movie format, 283, 287
quotation mark preferences, 35

o R o

radial gradients, creating, 111
raster formats, 282
rearranging. See arranging and aligning
recovery from power failure or crash, 60
redoing actions, 12, 215
reference points, 11, 139, 141
Remember icon, 6
removing. See deleting or removing
replacing. See searching
resizing. See also scaling
docks, 28
fonts, 254-255
frames, 23, 140
Free Transform tool for, 146
graphics, 295
objects, 139-140
scaling objects, 140
reverse type, 269, 270
reverting to saved document version, 57
RGB color model, 102
right-clicking
defined, 3
displaying hidden tools, 21
opening contextual menus, 26
rollovers for buttons, 376-377
Roman numerals for page numbers, 68
Rotate tool, 142-143
rotating
Control panel for, 143
Free Transform tool for, 146
gradients, 110
PDF pages, 382, 390
preparing for, 142
Rotate tool for, 142-143
shearing, 142, 145
spreads, 144, 389
unrotating objects, 143

RTF (Rich Text Format)
exporting in, 59
importing text files, 198-200

ruler guides
changes when adjusting layouts, 75, 76
created for active layer, 80
creating automatically, 170-171
creating manually, 169-170
default settings, 42
described, 169
working with, 171-172

rulers
changes when adjusting layouts, 75, 76
changing measurement system for, 15
measurement preferences, 40-41
overview, 15
showing and hiding, 15, 46
zero point, 15-16, 170

rules, horizontal, 249-250

running headings, layers for, 77

oS e

sampling colors, 113-114
satin effect, 153-154
saving
before adjusting layouts, 76
books, 340
document as template, 86
documents, 57-58
presets, 43
queries, 220
reverting to saved version, 57
workspaces, 29
Scalable Vector Graphics (SVG) format, 58
scaling. See also resizing
characters, 256-257
Free Transform tool for, 146
glyphs, 248
graphics, 295
of JPEG files during import, 285
label text, 269
objects, 140
Scitex Continuous Tone (SCT) format, 282,
283, 287
searching
Find/Change feature for, 216-217
for library items, 97
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and replacing formatting, 218-219
and replacing glyphs, 219-220
and replacing text, 217-218
saving queries, 220
text, 216-217
section markers, 330-331
sections
in book chapters, 342-344
defined, 69
dividing documents into, 69
removing section start, 70-71
security settings for PDF files, 381-382
selecting
anchor points and direction handles, 139
deselecting objects, 138
frames, 122
master objects, 93
multiple layers, 82
multiple objects, 136
object contents, 137
objects in groups, 138, 156
objects individually, 135-136
objects on layers, 81
objects on master pages, 136
objects using Control panel, 138
overlapping objects, 136-137, 179
pages, 64-65
ruler guides, 171
unused text styles, 234
Selection tool
changing line bounding box with, 123
selecting multiple objects, 136
selecting objects individually, 135-136
selecting objects on master pages, 136
switching to Direct Selection tool, 122
using, 22
sentence case, 333
service bureaus, document package for,
362-364
shapes. See also frames; objects
adding fills, 132
converting, 122
converting text into, 276-277
creating, 120-121
defined, 119
editing manually, 122
frames versus, 119

free-form, Pencil tool for, 126
selecting direction handles, 139
text wrap options, 210
tools for creating, 119-120
Shear tool, 145
shearing, 142, 145
showing or hiding
application frame, 17
baseline grid, 46, 176
document grid, 46, 175
frame edges, 46
full menus, 15
guides, 46, 80
hidden characters, 44
layers, 76, 79
links between text frames, 46
master objects, 46, 93
multiple document windows, 19-20
panels, 28
ruler guides, 171
rulers, 15, 46
smart guides, 46
sidebars, 271
single-line composition, 248
sizing. See resizing
skewing text (artificial italics), 257-258
slug area, 53
Slug mode, 25
small caps
capitalization controls, 255-256, 258-259
label formatting, 269
preferences, 37
smart guides
described, 169, 387
hiding, 46
working with, 173-174
smart spacing, 173
Smart Text Reflow preferences, 36
smooth points, 125, 127
snippets, 95
sound files, 374-375
spacing features, 387
special characters. See glyphs
spell-check feature
Autocorrect, 221-222
checking as you type, 221
customizing the dictionary, 224-226
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spell-check feature (continued)
customizing hyphenation points, 226
described, 220
sharing the dictionary, 224
using the dialog box, 222-224
spot colors, 100
spreads. See also pages
adjusting layouts, 74-76
defined, 18
duplicating within document, 65
fitting in window, 72
inserting uneven number of pages, 64
master pages for, 89
rotating, 144, 389
saving as JPEG files, 59
shuffling when moving pages, 66
specifying for new document, 52
starting documents on left page, 67-68
stacking order
defined, 77
for layers, 77
for overlapping objects, 179
rearranging layers in, 83
stored preferences, 43
Story Editor, using, 215-216
Story panel, object style options, 160
strikethrough
controlling, 255-256, 259-260
custom options for, 274-276
Stroke panel
adjusting character strokes, 276
line characteristics specified in, 124
opening, 130
setting stroke attributes, 130-132
strokes
applying to paths, 124
character, 276
colors for, 132
dashed lines, 131, 132-133
default properties, 45
defined, 13
fitting graphics with, 295
object style options, 160
setting attributes for, 130-132
styles for, 132-134
in tables, formatting, 311, 313
transparency for, 150

styles
cell, 47, 313-315
defaults, 47
importing, 47
object, 47, 147-148, 157-163
stroke, 132-134
synchronizing for books, 341-342
table, 47, 308, 313-315
text, 44, 47, 227-236
TOC, 324-327
subscript and superscript characters
controlling, 255-256, 259
preferences, 36-37
SVG (Scalable Vector Graphics) format, 58
swatch-based color models, 102
Swatches panel. See also color swatches
adding unnamed colors to, 103
adding unnamed gradients to, 109
applying swatches, 115
copying swatches, 112
creating gradients, 107-109
creating mixed-ink colors, 105-106
creating swatches, 99-103
creating tints, 106
default color palette, 100
deleting swatches, 112
editing swatches, 111
exporting swatches, 114
importing swatches, 47, 112-113
opening, 99
sampling colors, 113-114
setting stroke color, 132
SWF format, exporting in, 59, 377-378

oJ e

Table menu, 31
table of contents (TOC), 324-327
Table Styles panel, 314-315
tables
adding items to, 309
adjusting, 310
cell styles, 47, 313-315
converting to and from tabs, 315
creating, 308-309
footnote simulation for, 318
formatting, 310-313
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importing, 307
inserting tabs in, 309
keyboard shortcuts for editing, 310
limitations of tabs for, 307
styles, 47, 308, 313-315
tabs
converting to and from tables, 315
deleting or clearing, 307
inserting in tables, 309
leaders (repeating characters), 306-307
repeating, 307
resetting indents, 307
setting with Tabs panel, 305-307
Tabs panel, 305-307
tagging library items, 96-97
Technical Stuff icon, 6
templates
annotating, 86
for booklets, 351
creating documents from, 87
creating templates, 86
defined, 85
master pages versus, 87
modifying, 86-87
opening for editing, 54, 86-87
text. See also characters; editing text;
paragraphs
bulleted lists, 265-268
conditional, 334-336, 389
converting into shapes, 276-277
defaults, 44
drag-and-drop preferences, 36
following paths, 278
hyperlink to anchor in, 366
imported, placing, 197-198
importing, 196, 198-203
as layout element, 191
navigating, 214
numbered lists, 265-268
reverse type, 269, 270
saving as JPEG file, 59
searching, 216-217
section markers for automating, 330-331
sidebars and pull-quotes, 271
styles, 44, 47, 160, 227-236
in tables, formatting, 312

tabs for, 305-307
variables, 331-334
text files
importing, 198-200
links to, 163
unlinking, 166
text frames. See also frames; master text
frames
adding fills, 132
autoflow feature, 194-195, 205, 389
breaking threads, 206
changing columns in, 207-208
changing settings for, 195-196
converting text into shapes, 276-277
creating individually, 193-194
creating with Type tool, 23, 24, 120-121
defaults, 44
inserting in a threaded chain, 206
object style options, 160
out port, 204
overset text, 204
in port, 204
reflow when adjusting layouts, 76
rerouting threads, 206
saving in XML format, 59
showing links between, 46
threading, 204-205
text styles. See character styles; paragraph
styles
text variables, 331-334
text wrap
clipping paths for, 208
on hidden layers, 80, 208
for master items, 211
object defaults, 45
object style options, 160
options for, 208
overriding settings, 209
preferences, 38-39, 211
Text Wrap panel settings, 209-211
Text Wrap panel, 209-211, 298-299
themes, 104
threads, 13, 204-206
TIFF format, 282, 283, 297
tints, 106-107, 115
Tip icon, 6
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title case, 333
TOC (table of contents), 324-327
Tool Tips, 20, 28
Tools panel
collapsing and expanding, 27
creating colors from, avoiding, 103
displaying hidden tools, 21
flyout menu on, 26
frame- and shape-creation tools, 119-120
navigation tools, 24-25
object-creation tools, 24
overview, 20-21
sampling colors, 113-114
Selection tools, 22-23
setting stroke color, 132
Tool Tips for, 20
Type tool, 23
Toyo colors, 100
tracking
controlling, 255-256, 262
defined, 42, 261, 262
highlight preferences, 38
increments for, 261
kerning versus, 263
Transform panel, 146
transforming objects
flipping, 145
Free Transform tool for, 146
groups, 156
preparing for, 142
repeating transformations, 146
rotating, 142-144
shearing, 145
transition rates for gradients, 109
translations, layers for, 77
transparency, 77, 150-151, 282
Type menu, 30
Type on a Path tool, 278
Type preferences, 35-37
type styles, 253. See also fonts
Type tool
creating text frames, 23, 24, 120-121
described, 23
for editing text, 213
using, 23
typefaces, 253. See also fonts

typesetting problems, highlight
preferences, 38

typographic quotes preferences, 35

typographic terminology, 42

olf o

underlining
controlling, 255-256, 259-260
custom options for, 274-276
label formatting, 269
undoing actions, 12, 215
ungrouping objects, 156
unlinking text files, 166
unlocking. See locking or unlocking
unnamed colors, 103
unnamed gradients, 109
unrotating objects, 143
unshearing objects, 145
updating. See also automatic text
index preview, 323
links, 165
text styles, 232

oo

variables, text, 331-334
vector graphics
file formats, 281
import options for, 289-290
Version Cue pop-up menu, 15
video files, 374-375
View buttons, 25
View menu
Fit Page and Fit Spread commands, 72
overview, 31
settings, 46
visual proof of layout, 347-348

o ([ o

Warning! icon, 6

Web pages. See also multimedia projects
buttons and button actions for, 375-377
exporting to, 383-384
hyperlinks in, 370
hyperlinks to, 366
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Web site resources, 391-393 x height, defined, 37
white space, 261. See also kerning; leading; = XFL format, exporting in, 59, 377-378
tracking XHTML format, exporting in, 59, 371,
widows, controlling, 242-243, 262 383-384
Window menu, 26, 31 XML format, exporting in, 59
Windows Metafile (WMF) format, 281, 283
Word files. See Microsoft Word files Py Z PY
word spacing in justified text, 247
workspaces, 29 zero point (ruler intersection point), 15-16,
wrapping text. See text wrap 170
Zoom tool, 25
o X [ ) zooming
for editing text, 214
X and Y coordinates fitting pages or spreads in window, 72
control point for, 11 navigator feature, using, 73

moving objects using, 141
positioning objects using, 167-168
zero point for, 15-16
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